Autor Thema: CUL device - Can't open /dev/.....: Permission denied  (Gelesen 110 mal)

Offline JPP88

  • New Member
  • *
  • Beiträge: 17
CUL device - Can't open /dev/.....: Permission denied
« am: 06 März 2017, 21:39:45 »
Hallo,

ich habe leider folgendes Problem.

Ich habe laut dieser Anleitung https://waschto.eu/cul-433-mhz-gateway-zum-selber-bauen und folgendem Wiki Eintrag https://wiki.fhem.de/wiki/Selbstbau_CUL, um die neueste Version der culfw.

Die Installation und das Flashen (nach Neustart vom Raspberry) verlief reibungslos.

Danach wollte ich meinen CUL wie in der Anleitung beschrieben in FHEM einbinden, aber leider bekam ich im Logfile folgenden Eintrag:

2017.03.06 21:30:25 3: Probing CUL device /dev/ttyAMA0
2017.03.06 21:30:25 3: Can't open /dev/ttyAMA0: Permission denied
2017.03.06 21:30:25 1: usb create end

Und auch bei jedem get Befehl bekomme ich immer wieder No answer

Ich habe auch schon recherchiert aber leider noch keinen Ansatz gefunden, der mir half.

Daher hoffe ich, dass ihr mir helfen könnt.

Ich habe jetzt noch eine Sache gefunden in meiner Schlatung und wollte danach nochmals alles machen, aber jetzt bekomme ich den einfach nicht mehr geflasht und erhalte immer wieder folgende Fehlermeldung:

root@raspberrypi:/opt/culfw-code-562-trunk/culfw/Devices/nanoCUL# make program
#@if test ! -d /sys/class/gpio/gpio17; then echo 17 > /sys/class/gpio/export; fi
#@if test ! -d /sys/class/gpio/gpio18; then echo 18 > /sys/class/gpio/export; fi
#echo out > /sys/class/gpio/gpio17/direction
#echo out > /sys/class/gpio/gpio18/direction
#echo 0 > /sys/class/gpio/gpio17/value
#echo 0 > /sys/class/gpio/gpio18/value
#sleep 1
#echo 1 > /sys/class/gpio/gpio17/value
#sleep 1
#echo 1 > /sys/class/gpio/gpio18/value
avrdude -D -p atmega328p -P /dev/ttyUSB0 -b 57600 -c arduino    -U flash:w:nanoCUL.hex
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x0a
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x5b
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x4c
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x61
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x43
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x72
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x6f
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x73
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x73
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x65

avrdude done.  Thank you.

makefile:217: recipe for target 'program' failed
make: *** [program] Error 1

Auch wiederholtes neustarten brachte keinen Erfolg.

Vielen Dank schon einmal im Voraus
« Letzte Änderung: 06 März 2017, 22:21:37 von JPP88 »