Autor Thema: HM-LC-SW1-PCB pairing klappt, aber via FHEM nicht schaltbar  (Gelesen 401 mal)

Offline bart0190

  • New Member
  • *
  • Beiträge: 13
Hallo,
Nach dem Pairing des Aktors mit dem HM_LAN erscheint das neue Device in FHEM mit einem großen, eingekreisten Fragezeichen.
Das passiert mir zum ersten Mal, und ich frage mich, wie man das beheben kann (denn der Aktor hat auch Missing ACK).
Im FHEM verhält sich das Device auch anders als meine bisherigen devices, und wenn man reinklickt kann man mit "set ... virtual" einen virtuellen Kanal machen, aber ich habe nicht rausgefunden, wie ich einfach von FHEM aus schalten kann.
Da das Gerät nun so ist, kann ich den Aktor auch nicht von der Entfernung bedienen. Am Aktor selber kann ich den Taster drücken und das Relais schaltet.
Kann mir jemand bitte helfen, was ich probieren kann (oder als weitere Info geben soll)?

lg bart

Offline Wuppi68

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1350
  • Wuppertaler Wimpelbeauftragter
Antw:HM-LC-SW1-PCB pairing klappt, aber via FHEM nicht schaltbar
« Antwort #1 am: 07 März 2017, 07:08:30 »
Glaskugel polier
Kaffeesatz les


Gerät nicht gepairt sondern nur per autocreate in FHEM angelegt

noch einmal hmpair for sec durchführen mit anschließendem getconfig und dann die Einsteigerdoku
Jetzt auf nem I3 und primär Homematic

kein Support für cfg Editierer

Support heißt nicht wenn die Frau zu Ihrem Mann sagt: Geh mal bitte zum Frauenarzt, ich habe Bauchschmerzen

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 6268
    • Otto's Technik Blog
Antw:HM-LC-SW1-PCB pairing klappt, aber via FHEM nicht schaltbar
« Antwort #2 am: 07 März 2017, 19:12:30 »
Hi,

ein list vom gerät wäre nicht schlecht.

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline bart0190

  • New Member
  • *
  • Beiträge: 13
Antw:HM-LC-SW1-PCB pairing klappt, aber via FHEM nicht schaltbar
« Antwort #3 am: 08 März 2017, 07:02:53 »
danke für die schnellen Antworten.
ELV schreibt gestern:

-------------------
von ELV - Technische Kundenbetreuung » 07.03.2017, 11:21

Hallo bart0190,

bitte beachten Sie, dass sich die HomeMatic Konfigurationsadapter (LAN und USB) inkl. der zugehörigen Konfigurationssoftware und des BidCos Service seit Mitte 2015 im Status "Out of Support" befinden.

Neue HomeMatic Komponenten können daher nicht an die HomeMatic Konfigurationsadapter angelernt werden.
------------------------

Ich hab mir das HMLAN Ding erst letztes Jahr gekauft ... :-|

Hier die List, ich meine gepairt sollte das sein. getconfig hatte ich diesmal nicht gemacht.

 

Offline Wuppi68

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1350
  • Wuppertaler Wimpelbeauftragter
Antw:HM-LC-SW1-PCB pairing klappt, aber via FHEM nicht schaltbar
« Antwort #4 am: 08 März 2017, 08:52:38 »
gepait scheint er zu sein ....

setzt mal Burst auf Auto in den Attributen

Ist die Batterie frisch?
Jetzt auf nem I3 und primär Homematic

kein Support für cfg Editierer

Support heißt nicht wenn die Frau zu Ihrem Mann sagt: Geh mal bitte zum Frauenarzt, ich habe Bauchschmerzen

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 6268
    • Otto's Technik Blog
Antw:HM-LC-SW1-PCB pairing klappt, aber via FHEM nicht schaltbar
« Antwort #5 am: 08 März 2017, 08:58:12 »
Moin,

nach einem list kopiert man den Text einfach in die Zwischenablage und fügt ihn im Post in Code Tags ein. Die bekommst Du mit der # Taste über  :-X
Ich werde es irgendwann ablehnen Screenshots zu lesen  :-X

Ja das Gerät ist gepairt, die rssi Werte sind relativ schlecht: unter -80 kann gehen muss aber nicht. Also der Funkkontakt zum HMLAN ist nicht berauschend.

Die Aussage von elv ist hierfür irrelevant, Du wolltest doch nicht mit deren Software tun sondern mit FHEM oder?

Wenn das Gerät falsch angelegt wurde, würde ich wie folgt vorgehen.

Funkkontakt verbessern.
Bei Bedarf Raw definition des Gerätes und der Channels kopieren und sichern (unterste Zeile unter der Gerätedefinition)
Die Seriennummer des Gerätes kopieren -> D-serialNr!
Alle Definitionen die mit dem Gerät zu tun haben (also auch die Channels) einfach löschen -> delete this device (ganz unten neben Raw definition).
Mit einem set <io> hmPairSerial <D-serialNr> sollte das Gerät neu angelegt werden.
Eventuell noch ein set <Gerät> getConfig absetzen.
Je nach Gerät muss die Datenübertragung ausgelöst werden (Anlerntaste, Aktion)
Das Gerät bei Bedarf umbennen, alle HM Definitionen kennen den Befehl set <> deviceRename. Damit werden auch die Channels umbenannt.

Nicht das Gerät mit Werksreset zurücksetzen!

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline bart0190

  • New Member
  • *
  • Beiträge: 13
Antw:HM-LC-SW1-PCB pairing klappt, aber via FHEM nicht schaltbar
« Antwort #6 am: 16 März 2017, 22:30:49 »
Hallo,
Danke für die schnellen Rückmeldungen. Werde in Zukunft natürlich die Listings entsprechend kopieren, danke für den Hinweis.
Hab das von dir Otto vorgeschlagene probiert - gleiches Resultat, das eingekreiste ? ist weiterhin da. :-[
Jetzt hab ich mal einen anderen Aktor (HM-LC-Dim1PWM-CV) angelernt, wobei hier die Kanäle richtig aussehen (mit der kleinen Glühbirne bei einem Kanal). Aber auch hier kann ich nicht vom FHEM aus schalten (danach hab ich auch dort deinen Weg probiert - gleiches Resultat). Veilleicht mach ich prinzipiell etwas falsch. Bin zwar noch recht unerfahren, aber hab schon einige Jalousie-Aktoren und Lichtaktoren und Heizungsaktoren erfolgreich angelernt.

Hab nun auch schon probiert mein HM_LAN aus- und einzustecken. Gleiches wie vorher.
Ich glaub ich werd mir mal nen anderen Aktor suchen und schauen, ob es mit dem klappt.

Habt ihr sonst noch eine Idee?

lg bart

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 6268
    • Otto's Technik Blog
Antw:HM-LC-SW1-PCB pairing klappt, aber via FHEM nicht schaltbar
« Antwort #7 am: 16 März 2017, 22:42:38 »
Jetzt hab ich mal einen anderen Aktor (HM-LC-Dim1PWM-CV) angelernt, wobei hier die Kanäle richtig aussehen (mit der kleinen Glühbirne bei einem Kanal). Aber auch hier kann ich nicht vom FHEM aus schalten (danach hab ich auch dort deinen Weg probiert - gleiches Resultat).
Hi Bart,

was meinst Du damit? Beim Dimmer kannst Du im Hauptgerät nicht schalten, sondern in dem Kanal mit der "Birne" (wenn da mein Lehrer wüsste, der hat mal eine Birne aus der Tasche gezogen und gesagt: Wenn Sie das zum glühen bringen ist es eine Glühbirne, alles andere sind Glühlampen :))
Wenn Du auf die Birne klickst sollte was passieren.

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline bart0190

  • New Member
  • *
  • Beiträge: 13
Antw:HM-LC-SW1-PCB pairing klappt, aber via FHEM nicht schaltbar
« Antwort #8 am: 17 März 2017, 06:38:56 »
Hallo Otto,
Ja, das hatte ich mir gedacht, dass wer bzgl. der Birne bemerkt.  ;D
Beim Dimmer hab ich nun den Taster gedrückt, Glühlämpchen in FHEM erscheint als "leuchtend", dann hab ich den HM_LAN auf
set HM_LAN hmPairForSec 60gesetzt und dann (im Lämpchen-ein-Status) 4 sec den Taster auf dem Dimmer gedrückt. Jetzt klappts mit dem Dimmer schalten (Kanal) vom FHEM aus. Anscheinend war es vorher nicht richtig gepairt. :)

Das mit dem HM-LC-SW1-PCB, da komm ich noch immer nicht auf einen grünen Zweig. Wobei es hier weiterhin leicht sein kann, dass es was Ähnliches ist. (z.B. bei der Pairingabfolge - zuerst einschalten, dann nochmal pairing, ...).
Ich werde dieses WoE nochmal probieren.

Für weitere Hinweise, auch wenn man erwartet, dass ich sie gemacht hätte ;) , bin ich dankbar.

lg
bart

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 6268
    • Otto's Technik Blog
Antw:HM-LC-SW1-PCB pairing klappt, aber via FHEM nicht schaltbar
« Antwort #9 am: 17 März 2017, 09:47:13 »
Hi,

Zeichen für gepairt sind eigentlich die Readings PairedTo und R-pairCentral - dort muss sauber nur Deine hmId drin stehen 0x3224CD ohne set_ davor oder so.

Wie gesagt dein HM-LC-SW1-PCB HM_5194DD hat schlechten Empfang, der bekommt seinen state nicht gemeldet. Das geht sogar ohne pairing. Wenn bei rssi unter -80 noch ein paar Störungen durch anderen Funk dazu kommen, geht eventuell nichts mehr.

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline bart0190

  • New Member
  • *
  • Beiträge: 13
Antw:HM-LC-SW1-PCB pairing klappt, aber via FHEM nicht schaltbar
« Antwort #10 am: 18 März 2017, 10:41:11 »
Danke für die schnelle Rückmeldung.
Hab das Device nun näher an das HM_LAN gelegt. RSSI ist nun besser. Das eingekreiste Fragezeichen ist noch immer da (und somit kein gewohntes Glühlampchen, das man schalten kann). Vielleicht klappt das Teil ja wirklich nicht mit dem HM_LAN oder es ist beim Löten was schiefgegangen.
Hab hier nochmal eine List angehängt, aber da scheinen (mit meinem Laien-Wissen) die wichtigen Punkte ok.
lg
bart

Internals:
   CFGFN
   DEF        5194DD
   HM_LAN_MSGCNT 9
   HM_LAN_RAWMSG RE0C18E73,0001,07E2BE80,FF,FFD3,0AA0105194DD3224CD0202010A320B240CCD15FF18000000
   HM_LAN_RSSI -45
   HM_LAN_TIME 2017-03-18 10:31:05
   IODev      HM_LAN
   LASTInputDev HM_LAN
   MSGCNT     9
   NAME       HM_5194DD
   NR         534
   STATE      ???
   TYPE       CUL_HM
   lastMsg    No:0A - t:10 s:5194DD d:3224CD 0202010A320B240CCD15FF18000000
   protLastRcv 2017-03-18 10:31:05
   protSnd    7 last_at:2017-03-18 10:31:05
   protState  CMDs_done
   rssi_at_HM_LAN avg:-50.77 min:-58 max:-45 lst:-45 cnt:9
   Readings:
     2017-03-18 10:31:02   CommandAccepted yes
     2017-03-18 10:31:01   D-firmware      2.8
     2017-03-18 10:31:01   D-serialNr      NEQ1632285
     2017-03-18 10:31:05   PairedTo        0x3224CD
     2017-03-18 10:31:05   R-pairCentral   0x3224CD
     2017-03-18 10:31:05   RegL_00.          02:01 0A:32 0B:24 0C:CD 15:FF 18:00 00:00
   Helper:
     HM_CMDNR   10
     cSnd       013224CD5194DD0006,013224CD5194DD00040000000000
     Expert:
       def        1
       det        0
       raw        1
       tpl        0
     Io:
       newChn     +5194DD,00,00,00
       nextSend   1489829465.63164
       prefIO
       rxt        0
       vccu
       p:
         5194DD
         00
         00
         00
     Mrssi:
       mNo        0A
       Io:
         HM_LAN     -43
     Prt:
       bErr       0
       sProc      0
       Rspwait:
     Q:
       qReqConf
       qReqStat
     Role:
       chn        1
       dev        1
     Rpt:
       IO         HM_LAN
       flg        A
       ts         1489829465.55227
       ack:
         HASH(0x13107e0)
         0A80023224CD5194DD00
     Rssi:
       At_hm_lan:
         avg        -50.7777777777778
         cnt        9
         lst        -45
         max        -45
         min        -58
     Shadowreg:
Attributes:
   IODev      HM_LAN
   autoReadReg 4_reqStatus
   expert     2_raw
   firmware   2.8
   model      unknown
   room       CUL_HM
   serialNr   NEQ1632285
   subType

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 6268
    • Otto's Technik Blog
Antw:HM-LC-SW1-PCB pairing klappt, aber via FHEM nicht schaltbar
« Antwort #11 am: 18 März 2017, 13:03:57 »
Hi,

also hmInfo liefert mir unter models
 switch           HM-LC-Sw1-PCB            0103 normal                         1,3   
Heißt also wird von FHEM unterstützt

Dein list liefert aber   model      unknown
Heißt also nicht richtig erkannt. Dein FHEM ist aktuell?

Wenn ja löschst du die def, kopiert aber vorher deine Seriennummer    serialNr   NEQ1632285 und gibts in der Kommandozeile ein:
set HM_LAN hmPairSerial NEQ1632285
Mal schauen was dann angelegt wird.

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline bart0190

  • New Member
  • *
  • Beiträge: 13
Antw:HM-LC-SW1-PCB pairing klappt, aber via FHEM nicht schaltbar
« Antwort #12 am: 18 März 2017, 19:26:03 »
Hi,
Das könnte es sein. FHEM is definitiv alt.   ::)
Dachte nicht dran, weil ja alles andere funktioniert. Bei einem neu eingeführten Device is es natürlich was anderes.
Danke für deine Geduld, werde das morgen probieren.

lg
bart

Offline bart0190

  • New Member
  • *
  • Beiträge: 13
Antw:HM-LC-SW1-PCB pairing klappt, aber via FHEM nicht schaltbar
« Antwort #13 am: 20 März 2017, 06:45:15 »
Hi Otto,
Nochmal vielen, vielen Dank!
Jetzt klappt es.  :D :D :D  FHEM update durchgeführt:
updatedanach
shutdown restartund dann direkt angelernt.

Also, das Problem war die alte FHEM-Software Version.

lg
bart