Autor Thema: Raspi wird nicht angesprochen  (Gelesen 461 mal)

Offline Wasserwerk33

  • Full Member
  • ***
  • Beiträge: 192
Raspi wird nicht angesprochen
« am: 19 März 2017, 15:51:34 »
Hi
vielleicht könnt ihr mir ja hier helfen? Ich könnte meinen Fhem server nicht mehr erreichen. Habe meine PI dann neu aufgesetzt. soweit alles gut. Nur nun kann ich fhem immer noch nicht erreichen. und ich kann ihn auch nicht per Putty erreichen obwohl ich SSH aktiviert habe. Wenn ich über meine PI sudo service ssh status eingebe schreibt dieser auch active running.

Wo ist den nun mein fehler??
danke für die Hilfe schon mal.

Offline helmut

  • New Member
  • *
  • Beiträge: 34
Antw:Raspi wird nicht angesprochen
« Antwort #1 am: 19 März 2017, 20:17:37 »
Ich vermute, Du hast ein normales raspbian auf Deinem PI.
Was sagen denn "sudo ifconfig -a", "sudo netstat -rn" und "sudo netstat -anp|grep -i sshd|grep -i listen"?
Dann kannst Du auch ein "sudo ls -lrt /var/lib/dhcp/" absetzen und ein "sudo cat /var/lib/dhcp/<dateiname>" fuer die letzte ausgegebene Datei (bei mir ist das dhclient.wlan0.leases) ausfuehren.
Intelligenz ist die Fähigkeit, Arbeit zu vermeiden, aber dafür zu sorgen, daß die Arbeit gemacht wird.
(Linus Torvalds)

Offline Wasserwerk33

  • Full Member
  • ***
  • Beiträge: 192
Antw:Raspi wird nicht angesprochen
« Antwort #2 am: 19 März 2017, 20:57:00 »
Hier meine Antworten
sudo ifconfig -a
eth0      Link encap:Ethernet  Hardware Adresse b8:27:eb:8c:83:14
          inet6-Adresse: fe80::5d13:1c57:ceae:55fd/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST MULTICAST  MTU:1500  Metrik:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Lokale Schleife
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:65536  Metrik:1
          RX packets:5101 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5101 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1
          RX bytes:713311 (696.5 KiB)  TX bytes:713311 (696.5 KiB)

wlan0     Link encap:Ethernet  Hardware Adresse b8:27:eb:d9:d6:41
          inet Adresse:192.168.33.47  Bcast:192.168.33.255  Maske:255.255.255.0
          inet6-Adresse: fe80::9191:fff1:3ca9:813d/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:69258 errors:0 dropped:6853 overruns:0 frame:0
          TX packets:64853 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:34031052 (32.4 MiB)  TX bytes:23707609 (22.6 MiB)

sudo netstat -rn
Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags   MSS Fenster irtt Iface
0.0.0.0         192.168.33.1    0.0.0.0         UG        0 0          0 wlan0
192.168.33.0    0.0.0.0         255.255.255.0   U         0 0          0 wlan0

sudo netstat -anp|grep -i sshd|grep -i listen
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      541/sshd
tcp6       0      0 :::22                   :::*                    LISTEN      541/sshd

sudo ls -lrt /var/lib/dhcp/
^[[6~insgesamt 0
-rw-r--r-- 1 root root 0 Mär  3 16:25 dhclient.leases

kannst du damit was anfangen??

ich kann da nicht viel raus lesen.

Offline Wasserwerk33

  • Full Member
  • ***
  • Beiträge: 192
Antw:Raspi wird nicht angesprochen
« Antwort #3 am: 19 März 2017, 21:59:00 »
Habe noch herausgefunden das ich über mein Ipad auf Fhem zugreifen kann. Auch wenn ich es per Notebook nicht mehr kann.

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 3260
Antw:Raspi wird nicht angesprochen
« Antwort #4 am: 20 März 2017, 10:20:30 »
was sagt den ein ping auf die ip?
- Bitte um Input für Output
- When there is a Shell, there is a Way

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline helmut

  • New Member
  • *
  • Beiträge: 34
Antw:Raspi wird nicht angesprochen
« Antwort #5 am: 20 März 2017, 10:37:10 »
Eigentlich sieht das alles gut aus. Da Du IPv6 nicht konfiguriert hast, wuerde ich das auch abschalten.
https://www.thomas-krenn.com/de/wiki/IPv6_deaktivieren

Also
sudo echo "net.ipv6.conf.all.disable_ipv6 = 1" >  /etc/sysctl.d/01-disable-ipv6.conf
eingeben und das System neu starten.

Falls das nicht geholfen hat, waeren die Inhalte der Dateien /var/lib/dhcp/dhclient.leases und /etc/resolv.conf interessant:
sudo cat /var/lib/dhcp/dhclient.leases
sudo cat /etc/resolv.conf
Ausserdem die Kontrolle, ob das Deaktivieren funktioniert hat:
sudo ip addr show | grep inet
"inet6" sollte in der Ausgabe nicht mehr vorkommen.

Gruss Helmut
Intelligenz ist die Fähigkeit, Arbeit zu vermeiden, aber dafür zu sorgen, daß die Arbeit gemacht wird.
(Linus Torvalds)

Offline Wasserwerk33

  • Full Member
  • ***
  • Beiträge: 192
Antw:Raspi wird nicht angesprochen
« Antwort #6 am: 20 März 2017, 14:53:34 »
sudo echo "net.ipv6.conf.all.disable_ipv6 = 1" >  /etc/sysctl.d/01-disable-ipv6.conf
schreibt mir das Programm das ich da keine Berechtigung für habe.

das komische ist ja auch, erst funktoniert es und nach einem Tag bricht dieses zusammen, nach einem neustart funktoniert es wieder.


Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 3260
Antw:Raspi wird nicht angesprochen
« Antwort #7 am: 20 März 2017, 18:13:07 »
Nochnmals:
- Rufst Du mit Namen oder mit IP auf?
- Funktioniert dann "ping"?

Ohne Input kein Output

und an IPv6 sollte es nicht liegen ...
- Bitte um Input für Output
- When there is a Shell, there is a Way

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 6844
    • Otto's Technik Blog
Antw:Raspi wird nicht angesprochen
« Antwort #8 am: 20 März 2017, 18:19:20 »
Hi,

Windows überlegt sich in letzer Zeit immer mal, dass es jetzt an der Zeit wäre nur noch ipv6 zum machen. Zumindest die Namensauflösung. Und für ipv6 macht zu Hause wahrscheinlich gar keiner Namensauflösung und Broadcast macht auch keiner mehr.

Muss irgendeins der letzten Patches gewesen sein.

Also versuch es doch einfach über die ipv4 Adresse. Es liegt nicht an der fhem Maschine es liegt am Windows PC - denke ich.

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline helmut

  • New Member
  • *
  • Beiträge: 34
Antw:Raspi wird nicht angesprochen
« Antwort #9 am: 20 März 2017, 19:44:57 »
sudo echo "net.ipv6.conf.all.disable_ipv6 = 1" >  /etc/sysctl.d/01-disable-ipv6.conf
schreibt mir das Programm das ich da keine Berechtigung für habe.

Mit dem sudo-Konzept von Debian und Co. kann ich mich bis auf den heutigen Tag nicht anfreunden.
Versuche es mit "sudo su -" um root zu werden. Dann sollte auch
echo "net.ipv6.conf.all.disable_ipv6 = 1" >  /etc/sysctl.d/01-disable-ipv6.conf
funktionieren.

Hast Du es mit der v4-Adresse probiert? putty -v (increase verbosity) koennte Dir weiterhelfen oder, um IPv4 zu erzwingen, putty -4
https://www.eisscholle.net/spickzettel/windows/putty_parameter

Gruss Helmut
Intelligenz ist die Fähigkeit, Arbeit zu vermeiden, aber dafür zu sorgen, daß die Arbeit gemacht wird.
(Linus Torvalds)

 

decade-submarginal