Autor Thema: Firmware auf Nano schreiben Error  (Gelesen 1202 mal)

Offline jonjuergens

  • New Member
  • *
  • Beiträge: 7
Firmware auf Nano schreiben Error
« am: 19 März 2017, 18:47:14 »
Hallo, habe mich genau an diese Anleitung gehalten aber leider erhalte ich immer folgende Fehlermeldung:



Ich hoffe mir kann jemand helfen.
LG
Jon

Online Otto123

  • Hero Member
  • *****
  • Beiträge: 6809
    • Otto's Technik Blog
Antw:Firmware auf Nano schreiben Error
« Antwort #1 am: 19 März 2017, 18:58:20 »
Hi Jon,

was sagt denn ls -l /dev/ttyUSB*
ls -l /dev/serial/by-path/

Gruß Otto
« Letzte Änderung: 19 März 2017, 19:04:40 von Otto123 »
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline jonjuergens

  • New Member
  • *
  • Beiträge: 7
Antw:Firmware auf Nano schreiben Error
« Antwort #2 am: 19 März 2017, 19:14:08 »
Hi Jon,

was sagt denn ls -l /dev/ttyUSB*
ls -l /dev/serial/by-path/

Gruß Otto

Hi Otto,
folgendes:

pi@raspberrypi:~ $ ls -l /dev/ttyUSB*
crw-rw---- 1 root dialout 188, 0 Mär 19 18:41 /dev/ttyUSB0
pi@raspberrypi:~ $ ls -l /dev/serial/by-path/
insgesamt 0
lrwxrwxrwx 1 root root 13 Mär 15 20:17 platform-20980000.usb-usb-0:1.2:1.0-port0 -> ../../ttyUSB0
Bei der Anleitung aus dem Wiki erhalte ich die gleiche Fehlermeldung.

Online Otto123

  • Hero Member
  • *****
  • Beiträge: 6809
    • Otto's Technik Blog
Antw:Firmware auf Nano schreiben Error
« Antwort #3 am: 19 März 2017, 19:23:50 »
Sorry tut mir leid, da kann ich nicht helfen. Ich wollte bloß abklären ob wirklich was am USB0 steckt, weil laut avrdude kann er da nichts tun.
Kenne ansonsten nanocul nicht.

Weiß aber auch nicht ob Du den Post im richtigen Forum gemacht hast. Ich denke Du hast kein Problem mit der Entwicklung sondern mit dem Handling.

Vielleicht besser hier hin verschieben -> https://forum.fhem.de/index.php/board,6.0.html

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 1583
  • Hausaufgaben schon gemacht?
    • Perpetual beta
Antw:Firmware auf Nano schreiben Error
« Antwort #4 am: 19 März 2017, 19:27:04 »
Kann auch sein, dass der USB-Wandler sich aufgehängt hat, ab- und wiederanstecken hilft manchmal (!Port ändert sich uU.!).

ansonsten noch zur Identifizierung des Wandlers: ls -l /dev/serial/by-id
jessie-lite@PI2 | ConfigDB | VCCU | MySensors seriell (2.2.0-beta, RS485+nRF24) | DS18B20@MySensors | Milight@ESP-GW | SIGNALduino | MapleCUN
Bitte beachten: https://forum.fhem.de/index.php/topic,71806.0.html

Offline jonjuergens

  • New Member
  • *
  • Beiträge: 7
Antw:Firmware auf Nano schreiben Error
« Antwort #5 am: 19 März 2017, 20:06:37 »
Hallo,
leider trotz ab und anstecken die gleiche Fehlermeldung ;-(

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 1118
  • Es begann alles so klein ;-)
Firmware auf Nano schreiben Error
« Antwort #6 am: 19 März 2017, 20:32:01 »
Hi,
Hast Du wirklich nur ein USB Gerät dran?

Evtl. Brauchst du ein
sudo make program

Ansonsten mal die Ausgaben von folgenden Befehlen hier posten
lsusb -t
dmesg | grep usb
ls -l /dev/serial/by-id

Gruß Arnd


Raspi2 mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, Bravia, ...
« Letzte Änderung: 19 März 2017, 20:36:38 von RaspiLED »
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline micky0867

  • Full Member
  • ***
  • Beiträge: 163
Antw:Firmware auf Nano schreiben Error
« Antwort #7 am: 19 März 2017, 20:34:57 »
Die Meldung von avrdude deutet darauf hin, dass was am USBport hängt, er aber nicht damit kommunizieren kann.
Ein nicht vorhandenes ttyUSB0 sieht so aus:
avrdude: ser_open(): can't open device "/dev/ttyUSB0": No such file or directory
Könnte ein Problem mit dem Bootloader sein.
Manchmal hilft es, den Bootloader neu zu flashen:
http://torsten-traenkner.de/linux/raspberry/arduino.php

Micky

Offline jonjuergens

  • New Member
  • *
  • Beiträge: 7
Antw:Firmware auf Nano schreiben Error
« Antwort #8 am: 19 März 2017, 22:22:13 »
Hi,
Hast Du wirklich nur ein USB Gerät dran?

Evtl. Brauchst du ein
sudo make program

Ansonsten mal die Ausgaben von folgenden Befehlen hier posten
lsusb -t
dmesg | grep usb
ls -l /dev/serial/by-id

Gruß Arnd


Raspi2 mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, Bravia, ...

Hallo, erstmal vielen Dank für die schnelle und große Unterstützung!
Ich habe noch einen Wlan Stick an meinem Pi aber auch ohne funktioniert es nicht.
Anbei der Auszug (ohne WLAN Stick nur Mit dem Nano)
pi@raspberrypi:~ $ lsusb -t
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/3p, 480M
        |__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=smsc95xx, 4                                                                                                                                                             80M
        |__ Port 2: Dev 4, If 0, Class=Vendor Specific Class, Driver=ch341, 12M
pi@raspberrypi:~ $ dmesg | grep usb
[    0.636803] usbcore: registered new interface driver usbfs
[    0.642536] usbcore: registered new interface driver hub
[    0.648062] usbcore: registered new device driver usb
[    1.104411] usbcore: registered new interface driver smsc95xx
[    1.656747] dwc_otg 20980000.usb: DWC OTG Controller
[    1.664438] dwc_otg 20980000.usb: new USB bus registered, assigned bus number                                                                                                                                                              1
[    1.674516] dwc_otg 20980000.usb: irq 56, io mem 0x00000000
[    1.695399] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    1.704897] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=                                                                                                                                                             1
[    1.714799] usb usb1: Product: DWC OTG Controller
[    1.722101] usb usb1: Manufacturer: Linux 4.4.50+ dwc_otg_hcd
[    1.730475] usb usb1: SerialNumber: 20980000.usb
[    1.753374] usbcore: registered new interface driver usb-storage
[    1.916236] usbcore: registered new interface driver usbhid
[    1.924505] usbhid: USB HID core driver
[    2.199362] usb 1-1: new high-speed USB device number 2 using dwc_otg
[    2.409855] usb 1-1: New USB device found, idVendor=0424, idProduct=9512
[    2.419931] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    2.729356] usb 1-1.1: new high-speed USB device number 3 using dwc_otg
[    2.839878] usb 1-1.1: New USB device found, idVendor=0424, idProduct=ec00
[    2.850217] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber                                                                                                                                                             =0
[    2.975793] smsc95xx 1-1.1:1.0 eth0: register 'smsc95xx' at usb-20980000.usb-                                                                                                                                                             1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:5d:56:cd
[    3.092472] usb 1-1.2: new full-speed USB device number 4 using dwc_otg
[    3.203249] usb 1-1.2: New USB device found, idVendor=1a86, idProduct=7523
[    3.213395] usb 1-1.2: New USB device strings: Mfr=0, Product=2, SerialNumber                                                                                                                                                             =0
[    3.223936] usb 1-1.2: Product: USB2.0-Serial
[   13.294945] usbcore: registered new interface driver usbserial
[   13.301989] usbcore: registered new interface driver usbserial_generic
[   13.302168] usbserial: USB Serial support registered for generic
[   13.355178] usbcore: registered new interface driver ch341
[   13.355358] usbserial: USB Serial support registered for ch341-uart
[   13.400569] usb 1-1.2: ch341-uart converter now attached to ttyUSB0
pi@raspberrypi:~ $ ls -l /dev/serial/by-id
insgesamt 0
lrwxrwxrwx 1 root root 13 Mär 19 22:19 usb-1a86_USB2.0-Serial-if00-port0 -> ../.                                                                                                                                                             ./ttyUSB0

Offline micky0867

  • Full Member
  • ***
  • Beiträge: 163
Antw:Firmware auf Nano schreiben Error
« Antwort #9 am: 20 März 2017, 06:39:50 »
Alternativ kannst du es auch mal mit einer anderen Baudrate probieren....falls der Bootloader doch OK sein sollte.

 

decade-submarginal