FHEM - Hausautomations-Systeme > MQTT

Dauernd disconnected - reconnected

(1/2) > >>

fstefan1960:
Hallo,

nach einem Neustart von FHEM spinnt bei mir MQTT. Ich bekomme dauernd:

--- Code: ---2017.04.14 23:34:38 1: 192.168.1.19:1883 disconnected, waiting to reappear (Mosquitto)
2017.04.14 23:34:38 1: 192.168.1.19:1883 reappeared (Mosquitto)
2017.04.14 23:34:39 1: 192.168.1.19:1883 disconnected, waiting to reappear (Mosquitto)
2017.04.14 23:34:39 1: 192.168.1.19:1883 reappeared (Mosquitto)
2017.04.14 23:34:40 1: 192.168.1.19:1883 disconnected, waiting to reappear (Mosquitto)
2017.04.14 23:34:40 1: 192.168.1.19:1883 reappeared (Mosquitto)
2017.04.14 23:34:40 1: 192.168.1.19:1883 disconnected, waiting to reappear (Mosquitto)

--- Ende Code ---

Das Ganze ad infinitum. Abhilfe schafft, das Device zu löschen und wieder anzulegen mit Username und Passwort.

Ist nur blöd nach jedem Neustart ...

eisler:
Hallo fstefan1960,

das sieht nach fehlendem Username und Passwort aus.
Username und Passwort werden in $modpath/FHEM/FhemUtils/uniqueID gespeichert
und werden beim einem Neustart von FHEM von dort gelesen.

Grüße
Stephan


fstefan1960:
Hallo Stephan,

vielen Dank. In der Datei stehen die beiden Angaben drin. Ich habe sie jetzt mal weiter nach oben genommen, da sie erst ganz am Ende standen hinter dem Token für den Telegram-Bot. Das ist sehr lang und enthält auch Zeichen, die beim Parsen der Datei vielleicht Stress machen. Mal sehen, ob das nun stabil läuft.

Wichtig ist auch, dass in der fhem.cfg die Reihenfolge von Broker-Definition, Bridges usw. richtig ist ... (Als Erfahrung an andere).

Dlay:
Bei mir trat der gleiche Mist auf als ich mit den Attributen qos und retain rumgespielt habe.

Hab die dann wieder gelöscht und fhem neu gestartet. Danach war es weg.

PatrickR:

--- Zitat von: Dlay am 20 Juni 2017, 23:39:18 ---Bei mir trat der gleiche Mist auf als ich mit den Attributen qos und retain rumgespielt habe.

Hab die dann wieder gelöscht und fhem neu gestartet. Danach war es weg.

--- Ende Zitat ---

Wohl eher: https://svn.fhem.de/trac/changeset?old_path=%2F&old=14534&new_path=%2F&new=14534

Also User/Password noch einmal setzen und das Problem sollte nachhaltig Geschichte sein.


Von unterwegs gesendet.

Navigation

[0] Themen-Index

[#] Nächste Seite

Zur normalen Ansicht wechseln