Autor Thema: Neues Modul: Signalbot (Integration für den Signal Messenger) via signal-cli  (Gelesen 76138 mal)

Offline holoarts

  • New Member
  • *
  • Beiträge: 4
Hi Chris,

freut mich, dass du meine Erweiterung brauchen kannst.

Da das original fhem/fhem Image x86 kann, ist vermutlich nur in meinem Dockerfile der Link https://github.com/bublath/FHEM-Signalbot/raw/main/armhf-glibc2.31-0.10.9/libsignal_jni.so durch https://github.com/bublath/FHEM-Signalbot/raw/main/amd64-glibc2.28-0.10.9/libsignal_jni.so. Das hast du vermutlich ohnehin schon gemacht.

Ich habe leider kein Testenvironment dafür zur Verfügung.

Zu Truenas Scale kann ich leider nichts beitrage.

LG Michael
FHEM Nutzer seit 2007

Offline Flachzange

  • Full Member
  • ***
  • Beiträge: 159
Ja, genau ich habe nur die Library getauscht (auch wenn ich natürlich erstmal die falsche Version gegriffen hatte). Der Container läuft jetzt auch und Signal sendet auch fleißig. Mir war nur erstmal gar nicht klar, wie ich da jetzt meinen eigenen Container bauen muss, aber das war eine vergleichsweise flache Lernkurve!

Danke nochmal. Das hat meinen Umstieg auf Docker massiv erleichert.

Danke natürlich an dieser Stelle nochmal an Jörg für das super Plugin, was hier seit Monaten gute Dienste verrichtet.

Offline Adimarantis

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 708
Ich hab das auch gerade mal probiert und testweise ein "addDevice" in Signalbot eingebaut.
...
- Die gelinkte Instanz kann nur senden aber nicht empfangen
Das scheint bei mir nach einem sauberen reinit jetzt doch zu funktionieren. Gruppeninfos ist wohl ein bekanntes Problem.
Raspberry 4 + HM-MOD-RPI-PCB (pivCCU) + RfxTrx433XL + 2xRaspberry 1
Module: 50_Signalbot, 52_I2C_ADS1x1x , 58_RPI_1Wire, (50_SPI_MAX31865)