Autor Thema: Probleme beim Anlernen von FS20 DCLED  (Gelesen 246 mal)

Offline uli69

  • New Member
  • *
  • Beiträge: 13
    • Ulis Homepage
Probleme beim Anlernen von FS20 DCLED
« am: 07 Mai 2017, 17:44:28 »
Hallo,

ich versuche gerade ein LED Dimmer FS20 DCLED anzulernen. Ich habe den Dimmer folgendermaßen definiert:
define WOHNZIMMER_dimmer1 FS20 1801 01
attr WOHNZIMMER_dimmer1 IODev CUL1
attr WOHNZIMMER_dimmer1 eventMap /on:Ein/off:Aus/
attr WOHNZIMMER_dimmer1 model dummyDimmer
attr WOHNZIMMER_dimmer1 webCmd Ein:dim:Aus
Der CUL-Stick ist wie folgt definiert:
define CUL1 CUL /dev/ttyACM0@38400 0000
attr CUL1 connectCommand Nr1
attr CUL1 devStateIcon .*:it_wireless_dcf77
attr CUL1 icon cul_868
attr CUL1 rfmode SlowRF
Zum Anlernen habe ich dann den Schalter am Dimmer gute 15 Sekunden gedrückt, bis die LED blinkt. Dann habe ich ein "set WOHNZIMMER_dimmer1 on" abgeschickt. Das Pairing scheint dann nicht funktioniert zu haben, da der Dimmer auf keine Befehle reagiert.

Die Logeinträge sehen unverdächtig aus:
2017.05.07 17:31:34 3: FS20 set WOHNZIMMER_dimmer1 on
2017.05.07 17:31:34 5: CUL1 sending F18010111
2017.05.07 17:31:34 5: SW: F18010111
2017.05.07 17:31:45 3: FS20 set WOHNZIMMER_dimmer1 off
2017.05.07 17:31:45 5: CUL1 sending F18010100
2017.05.07 17:31:45 5: SW: F18010100
Ist da der Dimmer kaputt oder ist da doch noch was in der Konfiguration falsch, da dass mein einziges FS20 Gerät ist?

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 16620
Antw:Probleme beim Anlernen von FS20 DCLED
« Antwort #1 am: 07 Mai 2017, 18:13:20 »
attr CUL1 connectCommand Nr1kommt mir komisch vor, was genau soll man damit erreichen?
Ich wuerde das Attribut loeschen, den Stick entfernen, wieder einstecken, und dann das FS20 Geraet anlernen.

Offline uli69

  • New Member
  • *
  • Beiträge: 13
    • Ulis Homepage
Antw:Probleme beim Anlernen von FS20 DCLED
« Antwort #2 am: 07 Mai 2017, 19:13:06 »
attr CUL1 connectCommand Nr1kommt mir komisch vor, was genau soll man damit erreichen?
Ja danke für den Hinweis, das macht das Problem.

Ich empfange eine TFA Stratos 35.1077 (https://forum.fhem.de/index.php/topic,66253.msg575353.html#msg575353). Mit dem Kommando schalte ich die dazu notwendigen Datagramme ein:
N<func>

    Native RF mode.
    This mode does not use any packet or CRC features of CC1101. It just looks for preamble and given sync word and returns a fixed amount of received data. This is meant for compatibility to RFM12B-based protocols. Checking, decoding and processing of this raw received data is up to a higher software level.

    <func> is one of:
        r<mode>
        enables reception of datagrams. The following modes are known:
            1 - LaCrosse/IT+ 17.241 kbps
Das scheint dann leider den Empfang von FS20 zu verhindern  >:( Mal schauen, ob ich die N-Kommandos eventuell vorm Senden von FS20 Kommandos abschalten kann.

 

decade-submarginal