Autor Thema: iPhone stellt FTUI nicht korrekt dar  (Gelesen 117 mal)

Offline Himi

  • Jr. Member
  • **
  • Beiträge: 53
iPhone stellt FTUI nicht korrekt dar
« am: 30 Mai 2020, 17:03:48 »
Hallo zusammen,

seit Jahren lief Fhem-Tablet UI korrekt auf meinem Smartphon S9.

Nach einem jetzigen Umstieg auf eine iPhon wird das Tablet UI nicht mehr korrekt dargestellt.

Es wird nur noch ein Hintergrund mit grauen und schwarzen Streifen sowie die Header-Überschriften dargestellt.

Fehlt da in der index.htm im <head> noch ein Eintrag?

Ich rufe Fhem FTUI über die Chrome-App auf.

Wer hat einen Tipp?

Besten Dank im Voraus

Offline amenomade

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5591
Antw:iPhone stellt FTUI nicht korrekt dar
« Antwort #1 am: Gestern um 00:06:51 »
Zitat
Fehlt da in der index.htm im <head> noch ein Eintrag?
Um festzustellen, ob da was fehlt, muss man zuerst wissen, was da steht...

Folgende metas können einen Einfluss haben:
        <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
        <meta name="mobile-web-app-capable" content="yes">
        <meta name="apple-mobile-web-app-capable" content="yes">
FHEM 5.9 Pi 3, EchoDot, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, Debmatic und HM / HmIP Komponenten, Rademacher Duofern Jalousien, Fritz!Dect Thermostaten, Proteus

Offline Himi

  • Jr. Member
  • **
  • Beiträge: 53
Antw:iPhone stellt FTUI nicht korrekt dar
« Antwort #2 am: Gestern um 09:19:11 »
Bei mir steht folgendes in der index .html

<title>FHEM-Tablet-UI</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
<meta name="widget_base_width" content="127">
<meta name="widget_base_height" content="100">
<meta name="mobile-web-app-capable" content="yes">
<meta name="apple-mobile-web-app-capable" content="yes">
        <meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="longpoll" content="1"> <!-- 1=longpoll;0=shortpoll every 30sec -->
<meta name="debug" content="0"> <!-- 1=output to console;0=not output -->

Offline amenomade

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5591
Antw:iPhone stellt FTUI nicht korrekt dar
« Antwort #3 am: Heute um 02:58:20 »
Sieht gut aus.
Passiert das gleiche in Chrome auf einem PC, wenn Du ein iPhone emulierst (in den Dev Tools)? (es wäre einfacher zum Debuggen...)
FHEM 5.9 Pi 3, EchoDot, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, Debmatic und HM / HmIP Komponenten, Rademacher Duofern Jalousien, Fritz!Dect Thermostaten, Proteus