Autor Thema: [Gelöst] TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab  (Gelesen 1077 mal)

Offline TimoWer

  • New Member
  • *
  • Beiträge: 13
Hallo zusammen, ich muss mich mit meinem Problem nach langer Recherche und nach langem hin und her doch ans Forum wenden und euer Wissen nutzen  :-X

Ich hatte mir den BUS-Ankoppler von Busware.de besorgt und die diesen direkt am USB Port meines Raspberry Pi 3 angeschlossen. Soweit so gut...

Per Define nach der Anleitung auf https://wiki.fhem.de/wiki/EIB_/_KNX habe ich den Stick in Fhem eingebunden. Anschließend habe ich von EIB auf KNXD umgestellt. Als Orientierungshilfe habe ich mich an die Anleitungen aus dem FHEM Wiki sowie die der Github Seite gehalten
https://wiki.fhem.de/wiki/Knxd
https://github.com/knxd/knxd

Nun zu meinem Problem...

Anfangs lief die Einbindung der KNX-Geräte (Lampen / Rolläden) Problemlos alles ließ sich schalten bzw. steuern. Dazu habe ich mich an der autocreate Funktion vergriffen. Nach einem Update Befehl in FHEM ging nichtsmehr bei Versuch eine Lampe zu schalten hat sich FHEM aufgehängt (CPU) Auslastung bei 100% - Nur Neustart hat geholfen...

Nun habe ich den RaPi neu aufgesetzt FHEM neu aufgespielt und stehe vor dem gleichen Problem:

FHEM Läuft
TUL-Stick eingebunden (definde EIB...)
autocreate aktiv
KNX Geräte werden erkannt
Aber die CPU Auslastung wieder bei 100%

Sobald ich die Busleitung vom Stick entferne normalisiert sich die CPU Auslastung wieder und ist gegen 0

Ich weiß an dieser Stelle leider nicht mehr weiter und hoffe ihr konnt mir helfen...

Grüße
Timo
« Letzte Änderung: 12 Juni 2017, 12:11:02 von TimoWer »
Keep Calm and solve that Problem togehter!

Offline Jensmaier2

  • Jr. Member
  • **
  • Beiträge: 90
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #1 am: 06 Juni 2017, 16:45:38 »
Du hast vermutlich die Geräte noch angelegt wie bei EIB.

define testgeraet EIB 1/2/3
attr testgeraet IODEV ...

richtig ist nun
define testgeraet KNX 1/2/3:dpt1 z.B.

LG

Offline TimoWer

  • New Member
  • *
  • Beiträge: 13
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #2 am: 06 Juni 2017, 17:17:01 »
Okay gleich mal schauen... denke mal die autocreate zu deaktivieren ist an dieser stelle sinnvoll oder?
Keep Calm and solve that Problem togehter!

Offline Jensmaier2

  • Jr. Member
  • **
  • Beiträge: 90
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #3 am: 06 Juni 2017, 17:29:05 »
Keine Ahnung habe ich nie benutzt :)

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 840
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #4 am: 06 Juni 2017, 18:28:41 »
Kann mich Jens nur anschließen. Wenn EIB Geräte angelegt sind, aber nur knx aktiv ist, werden die eib-nachrichten nie aus der queue geholt. Die läuft dann voll...

Offline Elgardo

  • New Member
  • *
  • Beiträge: 5
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #5 am: 08 Juni 2017, 13:53:29 »
Ich habe das selbe Problem. Nach einem Update steigt die CPU Auslastung auf 100% sobald ich versuche eine Lampe einzuschalten.
Sämtliche Geräte habe ich als KNX Devices wie folgt angelegt:

define Licht KNX 0/0/5:dpt1
attr Licht IODev tul

Den TUL selbst:

define tul TUL tul:/dev/ttyACM0 1.1.249
attr tul useEIB 0

Parallel dazu ist für meine Homematic Rauchmelder in meine FHEM-Installation ein CUL eingebunden.

Mit den "alten" 00_tul.pm und 10_KNX.pm Dateien funktioniert alles einwandfrei.

Die FHEM Installation läuft auf einem Raspberry 2 mit Raspbian Jessie.

Stimmt irgendetwas an meinen Gerätedefinitionen nicht?
Für Tipps die mir zur Problemlösung weiterhelfen bin ich sehr dankbar.

LG
Martin

Offline TimoWer

  • New Member
  • *
  • Beiträge: 13
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #6 am: 08 Juni 2017, 14:17:16 »
Ich habe das selbe Problem. Nach einem Update steigt die CPU Auslastung auf 100% sobald ich versuche eine Lampe einzuschalten.
Sämtliche Geräte habe ich als KNX Devices wie folgt angelegt:

define Licht KNX 0/0/5:dpt1
attr Licht IODev tul

Den TUL selbst:

define tul TUL tul:/dev/ttyACM0 1.1.249
attr tul useEIB 0

Parallel dazu ist für meine Homematic Rauchmelder in meine FHEM-Installation ein CUL eingebunden.

Mit den "alten" 00_tul.pm und 10_KNX.pm Dateien funktioniert alles einwandfrei.

Die FHEM Installation läuft auf einem Raspberry 2 mit Raspbian Jessie.

Stimmt irgendetwas an meinen Gerätedefinitionen nicht?
Für Tipps die mir zur Problemlösung weiterhelfen bin ich sehr dankbar.

LG
Martin

Wie stelle ich den auf die ""alten" 00_tul.pm und 10_KNX.pm Dateien" um? Kannst du mir das erklären? Das wäre super  :D

Noch eine Anmerkung zu meinem Problem: Kann es sein das es mit den Schreibrechten der "fhem.cfg" Zusammenhängt hatte diese nach der Installation von Fhem nicht für die WEB-Oberfläche eingetragen. Weil in den KNX Geräten welche ich angelegt habe ist nach wie vor das model attr hinterlegt so z.B. auch "Blink" das sollte ja mit der Umstellung auf KNX nicht mehr vorhanden sein...
Keep Calm and solve that Problem togehter!

Offline TimoWer

  • New Member
  • *
  • Beiträge: 13
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #7 am: 08 Juni 2017, 14:30:29 »
Im übrigen habe ich meinen TUL wie folgt in FHEM eingebunden:

define EIB TUL tul:/dev/ttyACM0@57600 1.1.251

Da es wie bereits geschrieben eine Anfangs (Bis zum update Befehl in FHEM) funktionierte gehe ich nicht davon aus das sich hier ein Fehler eingeschlichen hat... Oder liege ich da flasch ?!

Bin echt am verzweifeln  :o
Keep Calm and solve that Problem togehter!

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 840
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #8 am: 08 Juni 2017, 18:49:11 »
Servus!

An einen systematischen Fehler glaube ich nicht. Ich würde auch Dir empfehlen, den knxd zu verwenden...

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 840
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #9 am: 08 Juni 2017, 19:14:17 »
Zwei Ansätze hab ich:

1. in der fhem.cfg darf KEIN EINZIGES define mit EIB stehen, wenn in der TUL useEIB auf 0 steht. Wenn in der TUL useEIB auf 1 steht, muss mindestens ein EIB-Define vorhanden sein. Sonst müllt es den Speicher voll.
2. 10_knx und 00_tul müssen zueinander passen. Seit Umstellung auf den erweiterten Adressbereich verträgt es hier keine Inkompatibilitäten mehr.

Was ich nicht sicher auschließen kann, ist dass das Modul 10_eib mit der TUL nicht mehr sauber kann - wegen der erweiterten Gruppenadressen...

Grüße, Andi

P.S.: Besser als raten und hilfreicher als Orakeln sind meist Logs mit Level 5 zum Fehlerzeitpunkt...

Offline CQuadrat

  • Sr. Member
  • ****
  • Beiträge: 502
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #10 am: 08 Juni 2017, 19:17:48 »
Ich hatte nach dem letzten Update ein ähnliches Problem.

Eine Konkretisierung von dpt1 auf dpt1.008 half bei mir.
Musst Du ggf. natürlich an den Device-Typ anpassen.

« Letzte Änderung: 08 Juni 2017, 19:19:20 von CQuadrat »
FHEM auf Mini-ITX-Server mit Intel Quad-Core J1900:
+ HM: HM-LAN, HM-USB, HM-MOD-UART mit div. HM-Komponenten
+ RFXtrx: Funkwetterstation Bresser mit ext. Thermometer, Regenmesser und Windmesser
+ TUL (KNX-Anbindung), KM271 (per ser2net), SONOS (div. Gimmicks), OneWire, Hue

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 840
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #11 am: 08 Juni 2017, 19:31:35 »
DAS kann ich mir nicht erklären - das darf keinen Unterschied machen. Ich selbst habe etliche dpt1 im Einsatz.

Code:
"dpt1" => {CODE=>"dpt1", UNIT=>"", FACTOR=>undef, OFFSET=>undef, PATTERN=>qr/([oO][nN])|([oO][fF][fF])|(0?1)|(0?0)/, MIN=>"off", MAX=>"on"}, 
"dpt1.001" => {CODE=>"dpt1", UNIT=>"", FACTOR=>undef, OFFSET=>undef, PATTERN=>qr/([oO][nN])|([oO][fF][fF])|(0?1)|(0?0)/, MIN=>"off", MAX=>"on"},

Offline CQuadrat

  • Sr. Member
  • ****
  • Beiträge: 502
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #12 am: 08 Juni 2017, 19:56:44 »
Und .008?

War aber definitiv ein Problem bei mir. Ich benutze aber auch noch den eibd, falls das hier überhaupt eine Rolle spielt.
FHEM auf Mini-ITX-Server mit Intel Quad-Core J1900:
+ HM: HM-LAN, HM-USB, HM-MOD-UART mit div. HM-Komponenten
+ RFXtrx: Funkwetterstation Bresser mit ext. Thermometer, Regenmesser und Windmesser
+ TUL (KNX-Anbindung), KM271 (per ser2net), SONOS (div. Gimmicks), OneWire, Hue

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 840
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #13 am: 08 Juni 2017, 20:36:58 »
Syntaktisch das gleiche...das KANN nichts machen. Da muss der Hund woanders begraben gewesen sein.

Offline CQuadrat

  • Sr. Member
  • ****
  • Beiträge: 502
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #14 am: 09 Juni 2017, 01:20:44 »
Syntaktisch das gleiche...das KANN nichts machen. Da muss der Hund woanders begraben gewesen sein.

Vielleicht drehe ich es am Wochenende nochmal zurück, um den Freeze/Absturz zu provozieren.
FHEM auf Mini-ITX-Server mit Intel Quad-Core J1900:
+ HM: HM-LAN, HM-USB, HM-MOD-UART mit div. HM-Komponenten
+ RFXtrx: Funkwetterstation Bresser mit ext. Thermometer, Regenmesser und Windmesser
+ TUL (KNX-Anbindung), KM271 (per ser2net), SONOS (div. Gimmicks), OneWire, Hue

Offline TimoWer

  • New Member
  • *
  • Beiträge: 13
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #15 am: 09 Juni 2017, 09:57:46 »
Also zunächst mal danke für eure Lösungsansätze und die Beteiligung an meinem Problem...  :D

Ich habe mich gestern dazu entschieden nochmals von vorne zu beginnen und eine dataillierte Dokumentation zu erstellen.

Diese werde ich dann hier hochladen...

Mich stört einfach das es zuvor ging und ohne erklärbaren Grund einfach nicht mehr...
Keep Calm and solve that Problem togehter!

Offline TimoWer

  • New Member
  • *
  • Beiträge: 13
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #16 am: 12 Juni 2017, 09:45:29 »
Also nach einigen neuinstallationen bin ich immer wieder am gleichen Problem gescheitert... Letzlich war ich soweit das beim Schalten einer Lampe zumindest das reading in FHEM funktioniert hatte. Beim Schalten über FHEM alleridngs gab er mir immer "BAD EIB Adress" im Log als Fehler.

Letzlich hat mir Elgardo den Lösungsweg per PM gebracht... Er hat mir gestern die alten Module als Link per PM geschickt.

Neue Module rausgeschmissen - Alte Module rein - Reboot siehe da es funktioniert!

Stand Januar 17
https://github.com/mhop/fhem-mirror/blob/5302025a8d5db4d8f1b5e56767b131e87799b36e/fhem/FHEM/10_KNX.pm

https://github.com/mhop/fhem-mirror/blob/49e4bb2dd4f61968dae814c0abf9e49c907d169a/fhem/FHEM/00_TUL.pm

An dieser stelle nochmal danke an alle die sich an meinem Problem beteiligt haben!

Das Ganze hat mich in Punkte "Wissen über FHEM" um einiges weiter gebracht  8)

Grüße
Timo
Keep Calm and solve that Problem togehter!

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 840
Naja, so ne richtige Lösung ist das ja grad nicht. Ich hätte mal Interesse an EUren fhem.cfg's...

Offline websta911

  • Newbie
  • Beiträge: 1
Hi,

Vielen Vielen Dank für den Workaround, was ich mich nun frage ist, ist das ein BUG und wird im nächsten Release gefixt oder ist meine Config (EIB) so alt dass ich auf KNX umstellen muss damit das wieder funktioniert?

Vielen Dank für die Infos
lg

Offline pole23

  • Full Member
  • ***
  • Beiträge: 106
Ich hatte das Problem anfangs auch, allerdings hatte ich da noch eib und knx gemischt.
Ich habe dann alles auf KNX umgestellt, den useEIB Parameter rausgenommen und das Update laufen lassen. Seid dem steigt die CPU nicht mehr auf 100%. Habe in der Config auch ein Mix aus dpt1, dpt1.001, dpt1.008 usw.

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 840
@Websta911:

weder - noch. Das Modul EIB warte ich nicht mehr - wie mehrfach empfohlen solltest Du komplett auf KNX umsteigen oder die TUL nie wieder updaten.

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 840
An alle, die die letzen 1,5 Jahre den Hinweis auf das "deprecated" Modul 10_EIB im Log sowie die diversen Threads dazu übersehen haben:
Probiert mal die Version im Anhang. Eventuell reichen die paar Handgriffe bereits.

Dennoch - das mache ich nicht mehr beliebig oft - BITTE auf 10_KNX umstellen!!!

Grüße Andi

...mit der Bitte um Rückmeldung...

Offline TimoWer

  • New Member
  • *
  • Beiträge: 13
Mein Problem war die Umstellung auf 10_KNX... Das hatte ich in meiner Installation nicht bedacht. Ich habe auch die Dateien von jeglichen Updates ausgeschlossen... Wenn ich mal wieder ein Update fahre mache ich vorher ein Backup...

Habe aus meinem Fehler gelernt da dieser einiges an Zeit gekostet hat...

Grüße
Timo
Keep Calm and solve that Problem togehter!