Autor Thema: [Gelöst] TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab  (Gelesen 1321 mal)

Offline TimoWer

  • New Member
  • *
  • Beiträge: 16
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #15 am: 09 Juni 2017, 09:57:46 »
Also zunächst mal danke für eure Lösungsansätze und die Beteiligung an meinem Problem...  :D

Ich habe mich gestern dazu entschieden nochmals von vorne zu beginnen und eine dataillierte Dokumentation zu erstellen.

Diese werde ich dann hier hochladen...

Mich stört einfach das es zuvor ging und ohne erklärbaren Grund einfach nicht mehr...
Keep Calm and solve that Problem togehter!

Offline TimoWer

  • New Member
  • *
  • Beiträge: 16
Antw:TPUART USB Modul KNX/EIB - Hohe CPU Auslastung - FHEM stürzt ab
« Antwort #16 am: 12 Juni 2017, 09:45:29 »
Also nach einigen neuinstallationen bin ich immer wieder am gleichen Problem gescheitert... Letzlich war ich soweit das beim Schalten einer Lampe zumindest das reading in FHEM funktioniert hatte. Beim Schalten über FHEM alleridngs gab er mir immer "BAD EIB Adress" im Log als Fehler.

Letzlich hat mir Elgardo den Lösungsweg per PM gebracht... Er hat mir gestern die alten Module als Link per PM geschickt.

Neue Module rausgeschmissen - Alte Module rein - Reboot siehe da es funktioniert!

Stand Januar 17
https://github.com/mhop/fhem-mirror/blob/5302025a8d5db4d8f1b5e56767b131e87799b36e/fhem/FHEM/10_KNX.pm

https://github.com/mhop/fhem-mirror/blob/49e4bb2dd4f61968dae814c0abf9e49c907d169a/fhem/FHEM/00_TUL.pm

An dieser stelle nochmal danke an alle die sich an meinem Problem beteiligt haben!

Das Ganze hat mich in Punkte "Wissen über FHEM" um einiges weiter gebracht  8)

Grüße
Timo
Keep Calm and solve that Problem togehter!

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 853
Naja, so ne richtige Lösung ist das ja grad nicht. Ich hätte mal Interesse an EUren fhem.cfg's...

Offline websta911

  • Newbie
  • Beiträge: 1
Hi,

Vielen Vielen Dank für den Workaround, was ich mich nun frage ist, ist das ein BUG und wird im nächsten Release gefixt oder ist meine Config (EIB) so alt dass ich auf KNX umstellen muss damit das wieder funktioniert?

Vielen Dank für die Infos
lg

Offline pole23

  • Full Member
  • ***
  • Beiträge: 108
Ich hatte das Problem anfangs auch, allerdings hatte ich da noch eib und knx gemischt.
Ich habe dann alles auf KNX umgestellt, den useEIB Parameter rausgenommen und das Update laufen lassen. Seid dem steigt die CPU nicht mehr auf 100%. Habe in der Config auch ein Mix aus dpt1, dpt1.001, dpt1.008 usw.

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 853
@Websta911:

weder - noch. Das Modul EIB warte ich nicht mehr - wie mehrfach empfohlen solltest Du komplett auf KNX umsteigen oder die TUL nie wieder updaten.

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 853
An alle, die die letzen 1,5 Jahre den Hinweis auf das "deprecated" Modul 10_EIB im Log sowie die diversen Threads dazu übersehen haben:
Probiert mal die Version im Anhang. Eventuell reichen die paar Handgriffe bereits.

Dennoch - das mache ich nicht mehr beliebig oft - BITTE auf 10_KNX umstellen!!!

Grüße Andi

...mit der Bitte um Rückmeldung...

Offline TimoWer

  • New Member
  • *
  • Beiträge: 16
Mein Problem war die Umstellung auf 10_KNX... Das hatte ich in meiner Installation nicht bedacht. Ich habe auch die Dateien von jeglichen Updates ausgeschlossen... Wenn ich mal wieder ein Update fahre mache ich vorher ein Backup...

Habe aus meinem Fehler gelernt da dieser einiges an Zeit gekostet hat...

Grüße
Timo
Keep Calm and solve that Problem togehter!

 

decade-submarginal