Autor Thema: Raspberry Pi2, KNXD mit FHEM und enertex KNXnet/IP Interface  (Gelesen 648 mal)

Offline schorge

  • New Member
  • *
  • Beiträge: 3
Hallo erstmal allerseits hier!

Ich kämpfe mich nun seit einigen Tagen durch den smarhome-Dschungel.

Mein Ziel: FHEM mit knxd und smartvisu, einfache Logiken und bei Bedarf Erweiterungen. 

Jetzt meine Hürde wo ich nach vielen Beiträgen hier und anderswo nicht mehr weiterkomme:

/etc/init.d/knxd status
spukt mir das aus:
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: activating (auto-restart) (Result: exit-code) since Mon 2017-06-12 11:29:28 CEST; 1s ago
  Process: 4706 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=2)
 Main PID: 4706 (code=exited, status=2)

geändert habe ich folgendes:/etc/knxd.conf

KNXD_OPTS="-e 0.0.0 -c --no-tunnel-client-queuing -b ipt:192.168.1.38 -D -R -T -S"
/etc/default/knxd

START_KNXD=YES


Meine ETS5 hat eine Verbindung zu dem IP Interface.
Neustart etc. bringt keine Hilfe...



Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 853
Antw:Raspberry Pi2, KNXD mit FHEM und enertex KNXnet/IP Interface
« Antwort #1 am: 12 Juni 2017, 12:30:33 »
Bitte nutz erstmal die suche. Dazu gibt es bereits ein dutzend threads.

Offline schorge

  • New Member
  • *
  • Beiträge: 3
Antw:Raspberry Pi2, KNXD mit FHEM und enertex KNXnet/IP Interface
« Antwort #2 am: 12 Juni 2017, 13:27:30 »
Ja ich weis, allerdings finde ich keinen mit diesem IP Interface bzw. habe alle bekannten KNXD_OPTS ausprobiert...  :(

Suche ich hier nach "Status=2" Threads, bekomme ich keine Ergebnisse....
« Letzte Änderung: 12 Juni 2017, 13:30:41 von schorge »

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 853
Antw:Raspberry Pi2, KNXD mit FHEM und enertex KNXnet/IP Interface
« Antwort #3 am: 12 Juni 2017, 18:37:23 »
Welches Interface ist zunächst völlig wurscht (sollte zumindest so sein).
Deine aktuellen Parameter zeigen mir, dass Du bisher nicht wirklich intensiv recherchiert hast - sonst stünden beispielsweise DTRS VOR dem -b und nicht danach.
Auch ist es nicht allzu clever, zusätzlich zu einem Multicast-taugliches Interface einen zweiten Multicast-Server einrichten zu wollen.

Anyhow - folgendes hab ich aus einem alten Thread rauskopiert. Ich würd mal per Kommandozeile anfangen und erst wenn alles läuft, den Dienst einrichten.

Zudem würde ich mal mit einer HelloWorld Parametrierung anfangen - DAS klappt in 99% der Fälle:

sudo knxd -c -u /run/knx-b ipt:192.168.1.38

Offline schorge

  • New Member
  • *
  • Beiträge: 3
Antw:Raspberry Pi2, KNXD mit FHEM und enertex KNXnet/IP Interface
« Antwort #4 am: 13 Juni 2017, 08:24:51 »
HelloWorld sagt folgendes:

E00000055: [ 1:main] There is no KNX addr= in section 'main'.
F00000000: [ 1:main] Error setting up the KNX router.

Scheint aber ganz aktuelle zu sein:
https://knx-user-forum.de/forum/projektforen/knxd/1070988-test-v0-14-ist-so-weit

jedoch komme ich mit diesen .ini Dateien jetzt ganz durcheinander  :(

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 853
Antw:Raspberry Pi2, KNXD mit FHEM und enertex KNXnet/IP Interface
« Antwort #5 am: 13 Juni 2017, 18:09:16 »
Naja, mach halt ein Leerzeichen rein :-)

sudo knxd -c -u /run/knx -b ipt:192.168.1.38