Autor Thema: Chrome 59.x macht Ärger bei geschütztem Kamerabild  (Gelesen 610 mal)

Offline accessburn

  • Sr. Member
  • ****
  • Beiträge: 645
  • Lecker Raspberry-Cocktail!
    • TRcoding
Chrome 59.x macht Ärger bei geschütztem Kamerabild
« am: 14 Juni 2017, 14:46:25 »
Huhu,
seit dem heutigen Update laden die Kamerabilder nicht mehr. Mit etwas nachforschung habe ich folgendes gefunden: https://www.chromestatus.com/feature/5669008342777856

Bin mir nicht sicher ob es einen wirklichen Zusammenhang gibt, vielleicht kann das mal jemand lesen oder erforschen der da mehr Ahnung hat.


Die Kamera-URL (http://xxx:xxx@dyndns:irgendwas/snapshot.cgi?user=xxx&pwd=xxx&resolution=64&rate=0&_=1497444292557) ist wohl das Problem:

Zitat
[Deprecation] Subresource requests whose URLs contain embedded credentials (e.g. `https://user:pass@host/`) are blocked. See https://www.chromestatus.com/feature/5669008342777856 for more details.
« Letzte Änderung: 14 Juni 2017, 14:51:57 von accessburn »
Wezzy Rpi2b> FHEM, Elro, Intenso, FTUI, Jeelink v3, Max!Cube, Fire5, Foscam, NAS, Fritz!Box + Fon, Max!Wandthermostat, Amazon Echo
Wezzy Rpi2> Kettenfahrzeug
Jessie Rp3b> UPNP, NAS, Pi-Hole, ownCloud

Offline amenomade

  • Sr. Member
  • ****
  • Beiträge: 909
Antw:Chrome 59.x macht Ärger bei geschütztem Kamerabild
« Antwort #1 am: 14 Juni 2017, 15:11:26 »
Ich weiss nicht wie Du die Url in FHEM aufrufst, aber es ist schon lange angekündigt für Chrome. IE unterstützt es schon lange nicht mehr. Safari auch nicht. Es ist nur eine Frage der Zeit, bis kein Browser mehr es akzeptiert.
 
FHEM 5.8 Pi 3, EchoDot, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, und HM Komponenten

F:"Schatz? Mach aus bitte"
M: "Alexa? Licht aus"-"Ich bin mir leider nicht sicher"  M:"Alexa? aus Licht"-"Das weiss ich leider nicht" M:"Alexa? Schalte...
F: "Drück mal auf den blöden Knopf!

Offline accessburn

  • Sr. Member
  • ****
  • Beiträge: 645
  • Lecker Raspberry-Cocktail!
    • TRcoding
Antw:Chrome 59.x macht Ärger bei geschütztem Kamerabild
« Antwort #2 am: 14 Juni 2017, 15:37:13 »
Na supi...
Wie schütze ich eine URL die ich trotz allem von außen aufrufen kann denn dann?
Wezzy Rpi2b> FHEM, Elro, Intenso, FTUI, Jeelink v3, Max!Cube, Fire5, Foscam, NAS, Fritz!Box + Fon, Max!Wandthermostat, Amazon Echo
Wezzy Rpi2> Kettenfahrzeug
Jessie Rp3b> UPNP, NAS, Pi-Hole, ownCloud

Offline amenomade

  • Sr. Member
  • ****
  • Beiträge: 909
Antw:Chrome 59.x macht Ärger bei geschütztem Kamerabild
« Antwort #3 am: 14 Juni 2017, 16:23:41 »
http://xxx:xxx@dyndns:irgendwas/snapshot.cgi?user=xxx&pwd=xxx&resolution=64&rate=0&_=1497444292557
Meines Achtens ist so wie so in http dein Passwort nicht geschützt, da die alle Daten unverschlüsselt im Netz wandern.
FHEM 5.8 Pi 3, EchoDot, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, und HM Komponenten

F:"Schatz? Mach aus bitte"
M: "Alexa? Licht aus"-"Ich bin mir leider nicht sicher"  M:"Alexa? aus Licht"-"Das weiss ich leider nicht" M:"Alexa? Schalte...
F: "Drück mal auf den blöden Knopf!

Offline accessburn

  • Sr. Member
  • ****
  • Beiträge: 645
  • Lecker Raspberry-Cocktail!
    • TRcoding
Antw:Chrome 59.x macht Ärger bei geschütztem Kamerabild
« Antwort #4 am: 14 Juni 2017, 16:37:54 »
Ja aber ohne das Passwort ist die Kamera für jeden offen.
Wezzy Rpi2b> FHEM, Elro, Intenso, FTUI, Jeelink v3, Max!Cube, Fire5, Foscam, NAS, Fritz!Box + Fon, Max!Wandthermostat, Amazon Echo
Wezzy Rpi2> Kettenfahrzeug
Jessie Rp3b> UPNP, NAS, Pi-Hole, ownCloud

Offline amenomade

  • Sr. Member
  • ****
  • Beiträge: 909
Antw:Chrome 59.x macht Ärger bei geschütztem Kamerabild
« Antwort #5 am: 14 Juni 2017, 17:01:37 »
Dann musst Du das BasicAuth user:passwort als data und nicht in der URL mitgeben. Wie gesagt: da ich nicht weiss, was du genau in FHEM damit machen willst, kann ich nicht weiter sagen wie.
FHEM 5.8 Pi 3, EchoDot, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, und HM Komponenten

F:"Schatz? Mach aus bitte"
M: "Alexa? Licht aus"-"Ich bin mir leider nicht sicher"  M:"Alexa? aus Licht"-"Das weiss ich leider nicht" M:"Alexa? Schalte...
F: "Drück mal auf den blöden Knopf!

Offline accessburn

  • Sr. Member
  • ****
  • Beiträge: 645
  • Lecker Raspberry-Cocktail!
    • TRcoding
Antw:Chrome 59.x macht Ärger bei geschütztem Kamerabild
« Antwort #6 am: 14 Juni 2017, 18:13:59 »
Das musst du mir mal genauer erklären  :D

Der Link ist einfach nur ein Image in FTUI, dort bleibt das Image einfach leer, wenn ich die URL in einem leeren Tab öffne gehts aber.
Wezzy Rpi2b> FHEM, Elro, Intenso, FTUI, Jeelink v3, Max!Cube, Fire5, Foscam, NAS, Fritz!Box + Fon, Max!Wandthermostat, Amazon Echo
Wezzy Rpi2> Kettenfahrzeug
Jessie Rp3b> UPNP, NAS, Pi-Hole, ownCloud

Offline amenomade

  • Sr. Member
  • ****
  • Beiträge: 909
Antw:Chrome 59.x macht Ärger bei geschütztem Kamerabild
« Antwort #7 am: 15 Juni 2017, 02:53:38 »
Schau mal das IPCAM Modul. Vielleicht wird es einfacher als etwas direkt im html Code der TabletUI zu basteln.
https://fhem.de/commandref.html#IPCAM

Beispiel:
https://forum.fhem.de/index.php/topic,47799.msg394663.html#msg394663
FHEM 5.8 Pi 3, EchoDot, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, und HM Komponenten

F:"Schatz? Mach aus bitte"
M: "Alexa? Licht aus"-"Ich bin mir leider nicht sicher"  M:"Alexa? aus Licht"-"Das weiss ich leider nicht" M:"Alexa? Schalte...
F: "Drück mal auf den blöden Knopf!

Offline accessburn

  • Sr. Member
  • ****
  • Beiträge: 645
  • Lecker Raspberry-Cocktail!
    • TRcoding
Antw:Chrome 59.x macht Ärger bei geschütztem Kamerabild
« Antwort #8 am: 15 Juni 2017, 10:05:25 »
Okay, das hab ich und scheint zu funktionieren, jedoch wie bekomme ich das bild ohne zwischenspeichern in FTUI?
Wezzy Rpi2b> FHEM, Elro, Intenso, FTUI, Jeelink v3, Max!Cube, Fire5, Foscam, NAS, Fritz!Box + Fon, Max!Wandthermostat, Amazon Echo
Wezzy Rpi2> Kettenfahrzeug
Jessie Rp3b> UPNP, NAS, Pi-Hole, ownCloud

 

decade-submarginal