Autor Thema: KNXD mit Berker IOS Server  (Gelesen 1291 mal)

Offline Sirel

  • Full Member
  • ***
  • Beiträge: 152
KNXD mit Berker IOS Server
« am: 19 Juni 2017, 22:17:56 »
Hallo zusammen,
ich probiere seit ein paar Stunden meinen Pi mit dem o.g. Server sprechen zu lassen.
KNXD habe ich installiert. Anfangs erhielt ich keine Fehlermeldung, nun startet der Service nicht mehr. Bei der Installation habe ich ich an diese Anleitung gehalten. https://wiki.fhem.de/wiki/Knxd.

Hat schon mal jemand knxd mit diesem Server verbunden, bzw. kann mir jemand sagen, was ich in unter /etc/default/knxd eintragen muss? Derzeit habe ich KNXD_OPTS="-u /tmp/eib -u /var/run/knx  -b ipt:192.168.2.106"
dort eingetragen.

Vielen Dank vorab,

Max

PS:
Hier noch ein Auszug aus dem Journal
-- Logs begin at Mo 2017-06-19 21:53:18 CEST, end at Mo 2017-06-19 22:27:49 CEST. --
Jun 19 22:27:32 raspberrypi systemd[1]: Unit knxd.service entered failed state.
Jun 19 22:27:42 raspberrypi systemd[1]: knxd.service holdoff time over, scheduling restart.
Jun 19 22:27:42 raspberrypi systemd[1]: Stopping KNX Daemon...
-- Subject: Unit knxd.service has begun shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit knxd.service has begun shutting down.
Jun 19 22:27:42 raspberrypi systemd[1]: Starting KNX Daemon...
-- Subject: Unit knxd.service has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit knxd.service has begun starting up.
Jun 19 22:27:42 raspberrypi knxd[3183]: knxd requires a bus address (option -e)!: Connection refused
Jun 19 22:27:42 raspberrypi systemd[1]: knxd.service: main process exited, code=exited, status=1/FAILURE
Jun 19 22:27:42 raspberrypi systemd[1]: Failed to start KNX Daemon.
-- Subject: Unit knxd.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit knxd.service has failed.
--
-- The result is failed.
Jun 19 22:27:42 raspberrypi systemd[1]: Unit knxd.service entered failed state.
Jun 19 22:27:49 raspberrypi sudo[3185]: pi : TTY=pts/0 ; PWD=/home/pi ; USER=root ; COMMAND=/bin/journalctl -xn
Jun 19 22:27:49 raspberrypi sudo[3185]: pam_unix(sudo:session): session opened for user root by pi(uid=0)
« Letzte Änderung: 19 Juni 2017, 22:29:24 von Sirel »

Offline pole23

  • Full Member
  • ***
  • Beiträge: 108
KNXD mit Berker IOS Server
« Antwort #1 am: 20 Juni 2017, 10:04:50 »
Hallo, du hast die Busadresse mit dem Parameter -e vergessen, wie in der Fehlermeldung beschrieben. Schau dir mal folgenden WikiEintrag an https://wiki.fhem.de/wiki/Einrichten_knxd_mit_MDT_SCN-IP000.02


Gesendet von iPhone mit Tapatalk

Offline Sirel

  • Full Member
  • ***
  • Beiträge: 152
Antw:KNXD mit Berker IOS Server
« Antwort #2 am: 20 Juni 2017, 17:32:14 »
Hi Pole23,
besten Dank, werden es nachher oder morgen ausprobieren.
Für mich zum Verständnis: "-e" definiert die die Busadresse von RPi, mit welcher er sich im KNX-Netz anmeldet, oder? Im den Beispiel wäre es dann das Gerät mit der Nummer 240 in der 1. Linie, richtig?

Viele Grüße und besten Dank,

Max

Offline Sirel

  • Full Member
  • ***
  • Beiträge: 152
Antw:KNXD mit Berker IOS Server
« Antwort #3 am: 03 Juli 2017, 20:41:55 »
Hallo zusammen,
ich habe jetzt das -e hinzugefügt und nun erscheint auch keine Fehlermeldung mehr.
In der Conf steht jetzt
KNXD_OPTS="-e 1.0.240  ipt:192.168.2.106"

Wenn ich jetzt über groupswrite eine Lampe schalten möchte, passiert allerdings nichts. Auch FHEM erkennt keine Geräte. Scheint, das der PI nicht richtig verbunden ist.
Kann mir jemand bitte bei der parametisierung helfen?

Besten Dank vorab,
Max

Offline svenson08

  • Developer
  • Full Member
  • ****
  • Beiträge: 489
Antw:KNXD mit Berker IOS Server
« Antwort #4 am: 04 Juli 2017, 07:14:06 »
Funktioniert deine knxd Installation, kannst du über knxd dein Lampe schalten?
Wie ist dein KNX Device in fhem definiert?
Raspberry PI, Cubietruck, Fhem 5.8, COC & CUL, FS20, HomeMatic, KNX, mySensors

Offline Sirel

  • Full Member
  • ***
  • Beiträge: 152
Antw:KNXD mit Berker IOS Server
« Antwort #5 am: 04 Juli 2017, 21:49:30 »
Hi Svenson,
das geht alles. Die Installation wurde von einem Fachbetrieb durchgeführt. Ich kann mit der Berker Software Szenen erstellen, Lampen testen usw. Gleiches natürlich auch über die Schalter im Haus.

Kann es sein das -b ip: fehlt - also anstelle von ipt: ? Das Ding ist ja ein Server/Router(?)... oder muss ich den pi noch anlernen?
Bin ratlos....

Thx und Grüße,

Max


Offline svenson08

  • Developer
  • Full Member
  • ****
  • Beiträge: 489
Antw:KNXD mit Berker IOS Server
« Antwort #6 am: 05 Juli 2017, 05:42:24 »
Also kannst du über knxd, auf der Konsole dein Lampe schalten?
Wie ist dein KNX Device in fhem definiert?
Raspberry PI, Cubietruck, Fhem 5.8, COC & CUL, FS20, HomeMatic, KNX, mySensors

Offline Sirel

  • Full Member
  • ***
  • Beiträge: 152
Antw:KNXD mit Berker IOS Server
« Antwort #7 am: 05 Juli 2017, 13:43:39 »
Hi Svenson,

also über die Berker Software und über die Wandtaster geht alles.
Über knxd geht es nicht, jedenfalls habe ich es nicht hinbekommen.
In Fhem ist das Modul so eingerichtet
define tul TUL eibd:localhost 1.1.249 Status initialized, es werden aber keine Geräte angelegt.

Kann ich Dir sonst noch weitere Infos liefern?

VG,
Max

Offline svenson08

  • Developer
  • Full Member
  • ****
  • Beiträge: 489
Antw:KNXD mit Berker IOS Server
« Antwort #8 am: 05 Juli 2017, 13:55:33 »
Wenn es über knxd nicht geht, wird es über fhem nicht gehen können. Du musst also bei der knxd Konfiguration ansetzen.
Wie ist den dein knxd konfiguriert?
Raspberry PI, Cubietruck, Fhem 5.8, COC & CUL, FS20, HomeMatic, KNX, mySensors

Offline Sirel

  • Full Member
  • ***
  • Beiträge: 152
Antw:KNXD mit Berker IOS Server
« Antwort #9 am: 05 Juli 2017, 13:57:19 »
Genau, das denke ich auch.

Ich habe in der knx Conf nur
KNXD_OPTS="-e 1.0.240  ipt:192.168.2.106"eingefügt.

Max

Offline svenson08

  • Developer
  • Full Member
  • ****
  • Beiträge: 489
Antw:KNXD mit Berker IOS Server
« Antwort #10 am: 05 Juli 2017, 17:42:33 »

Du hast dir die Doku zur knxd Konfiguration aber auch schon angelesen? Ich meine das https://github.com/knxd/knxd/wiki oder auch die aus dem Wiki https://wiki.fhem.de/wiki/Knxd
Und du setzt auch die aktuelle knx Version ein, zumindest setze ich das vorraus.

Nur mal als Beispiel, meine Konfig

KNXD_OPTS="-f9 -t1023 -e 0.0.1 -E 0.0.10:8 -i -DTRS -u /tmp/eib -b ipt:192.168.103.101"
Aber die jetzt einfach blind übernehmen wäre nicht so doll, du solltest schon wissen und verstehen was die Parameter bedeuten. Was aber in der verlinkten Doku beschrieben ist.

Raspberry PI, Cubietruck, Fhem 5.8, COC & CUL, FS20, HomeMatic, KNX, mySensors

Offline Sirel

  • Full Member
  • ***
  • Beiträge: 152
Antw:KNXD mit Berker IOS Server
« Antwort #11 am: 05 Juli 2017, 18:14:45 »
Danke für Deine Konfig. Ja, die Version etc. ist aktuell. System ist frisch installiert.

Deine Links kenne ich, geschaut habe ich aber u.a. auch hier https://knx-user-forum.de/forum/projektforen/knxd/1049547-grundlagen-zum-knxd-mit-installationsanleitung-vor-dem-schreiben-lesen. Stammt vom selben Autor.

Du lässt, wenn ich das richtig sehe, knxd einen Server bereitstellen (-DTRS). Da ich ja bereits einen Server/Router habe,  brauche ich die Features doch nicht mal bereitstellen, oder?
Mein Verstädnis ist, dass sich der Pi in so einem Fall als Device am Bus ausgibt und dann die Geräte entsprechend anspricht - so, wie der Rauchmelder direkt mit dem Licht sprechen kann.

Wie sieht Deine Installation denn aus?

Max

Offline svenson08

  • Developer
  • Full Member
  • ****
  • Beiträge: 489
Antw:KNXD mit Berker IOS Server
« Antwort #12 am: 05 Juli 2017, 18:36:34 »
Der knxd verhält sich wie ein Teilnehmer im Bus. Nur das er über das IP Gateway mit dem Bus kommuniziert.
Die genaue Konfig ist von deinem KNX IP Device abhängig. Das scheint auch etwas Hersteller abhängig zu sein.
Am Ende hab ich auch etwas experimentiert. Bei mir tut es nicht ohne -DTRS und ohne -b.
Ich habe aber kein IP Router sondern ein einfaches IP Interface, was bisher erfolgreich und zuverlässig seinen Dienst tut.
Raspberry PI, Cubietruck, Fhem 5.8, COC & CUL, FS20, HomeMatic, KNX, mySensors

Offline Sirel

  • Full Member
  • ***
  • Beiträge: 152
Antw:KNXD mit Berker IOS Server
« Antwort #13 am: 05 Juli 2017, 18:43:27 »
Thx für die schnelle Antwort.
Ich probiere dann noch weiter rum... meine Vermutung ist, dass -b gehört noch rein.
Der Server ist auch nicht wirklich gut dokumentiert. Jendfalls habe ich trotz Recherche nicht viel gefunden.

Max

Offline svenson08

  • Developer
  • Full Member
  • ****
  • Beiträge: 489
Antw:KNXD mit Berker IOS Server
« Antwort #14 am: 05 Juli 2017, 18:46:22 »
-b wird bei Multicast client (-b ip:) und bei Non-Multicast client (-b ipt:) benötigt. Dein Device müsste ein Mutlicast client sein.
Raspberry PI, Cubietruck, Fhem 5.8, COC & CUL, FS20, HomeMatic, KNX, mySensors

 

decade-submarginal