Autor Thema: Neuinstallation smartvisu 2.8  (Gelesen 1358 mal)

Offline stratege-0815

  • Full Member
  • ***
  • Beiträge: 143
Neuinstallation smartvisu 2.8
« am: 28 Juni 2017, 21:23:26 »
Hallo zusammen,
ich bin etwas verloren oder sehe den Wald vor Bäumen nicht, wie kann ich am besten eine saubere Neuinstallation von smartvisu 2.8 vornehmen. Gehe ich da jetzt nach dem Wiki vor? Oder hier nach Foren Einträgen, was ist hier best practice? Ich erwarte jetzt keine vorgekaute Lösung und bin auch durchaus in der Lage mir hier Informationen zusammen zu suchen, nur ist es eben so das ich völlig den Überblick verloren habe.
Beste Grüße
Jan

Offline dev0

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3306
    • _.:|:._
Antw: Neuinstallation smartvisu 2.8
« Antwort #1 am: 29 Juni 2017, 09:08:38 »
Bei der Fronthem Installation gibt es keine Unterscheide. SmartVisu 2.8 würde ich erst einmal ohne die Multi-Client-Modifikationen von herrmannj installieren und schauen, dass es grundlegend funktioniert. Danach kannst Du immer noch die Patches von Jörg einspielen, wenn Du sie benötigst und die config.php nach config.ini umbenennen. Durch die Änderung der Dateiendung ist der Inhalt für jeden einsehbar, der Zugriff auf sv hat. Daher kann es ratsam sein, den Zugriff auf diese Datei im Webserver zu sperren.

Offline StefanSH

  • Newbie
  • Beiträge: 2
Antw: Neuinstallation smartvisu 2.8
« Antwort #2 am: 06 Januar 2018, 13:38:25 »
Hallo zusammen,
ich habe smartvisu 2.8 auch vor ein paar Tage installiert (nach Anleitung im Fhem Wiki)
leider bekomme ich das Smartvisu nicht gestartet.
wenn ich die IP/smartvisu eingebe, kommt im Browser die Meldung 403 Forbidden. also keine Berechtigung

muss ich irgendwo was eintragen, damit ich auf smartvisu zugreifen kann?
ich gerade irgendwie auf dem Schlauch

Gruß
Stefan


-- hat sich erledigt, es liefen zwei Webserver auf meinem System. nachdem ich einen deinstalliert hab gings.
« Letzte Änderung: 07 Januar 2018, 13:22:09 von StefanSH »

Offline Gerhard

  • Full Member
  • ***
  • Beiträge: 333
Antw: Neuinstallation smartvisu 2.8
« Antwort #3 am: 08 Januar 2018, 11:54:25 »
statt  IP/smartvisu ->  IP/sv?
3 x FB7(3/4)90, 1 x cubietruck 1 x  raspberry 2B, CUL V3 (HMLAN, FS20, HMS, CUL_WS, FBAHA, FBDECT, IPCAM, STV, IT, SecvestIP, ebusd, SecvestIP, etc.)

Offline buchner51

  • Full Member
  • ***
  • Beiträge: 107
Antw: Neuinstallation smartvisu 2.8
« Antwort #4 am: 10 Februar 2018, 13:02:16 »
Hallo zusammen,

ich bin ein Neuling bei sv, aber ich wollte die alternative zu ftui mal testen.

die Installation ist OK Etagen und Räume hab ich angelegt, aber bei den Räumen beziehungsweise de html Seiten dazu.

Ich bin nach folgender Anleitung vorgegangen:

http://www.meintechblog.de/2015/06/smartvisu-mit-fhem-die-perfekte-visualisierung-teil-1-basics/

Aber sobald ich den Code einfüge kommt keine Seite mehr... wo liegt mein Fehler?

{% extends "rooms.html" %}

{% block content %}
<h1><img class="icon" src='{{ icon0 }}scene_livingroom.png'/>Wohnzimmer</h1>
  <div class="preblock">
  </div>
  <div class="block">
    <div class="set-2" data-role="collapsible-set" data-theme="c" data-content-theme="a" data-mini="true">
      <div data-role="collapsible" data-collapsed="false" >
        <h3>Licht</h3>
          <table width="90%">
            <tr><td align="left" width="100px"> {{ basic.switch('Lavalampen', 'wz_Deko', icon1~'light_floor_lamp.png', icon0~'light_floor_lamp.png') }}</td>
              <td>Lavalampen</td>
            </tr>
          </table>
        </div>
      </div>
   </div>

{% endblock %}

Danke
BananaPi
KNX mit Cul FHEM mit Tablet UI

Offline buchner51

  • Full Member
  • ***
  • Beiträge: 107
Antw: Neuinstallation smartvisu 2.8
« Antwort #5 am: 10 Februar 2018, 14:05:24 »
Ich erhalte folgende Fehlermeldung:

                                                                      smartVISU
                                                              14:04, 10.02, v2.8
--------------------------------------------------------------------------------

Error occurred in twig-template engine!

error: A template that extends another one cannot have a body but a byte order mark (BOM) has been detected; it must be removed.
file:  room_Esszimmer.html
line:  1

--------------------------------------------------------------------------------

BananaPi
KNX mit Cul FHEM mit Tablet UI

Offline buchner51

  • Full Member
  • ***
  • Beiträge: 107
Antw: Neuinstallation smartvisu 2.8
« Antwort #6 am: 10 Februar 2018, 21:42:56 »
Hallo für alle die das selbe Problem haben, hier nachmal mein Fehler:

A template that extends another one cannot have a body but a byte order mark (BOM) has been detected; it must be removed.
die Lösung:

https://software-lupe.de/tipp/utf-8-ohne-bom-mit-notepad/
BananaPi
KNX mit Cul FHEM mit Tablet UI

 

decade-submarginal