Verschiedenes > ESP8266

[Project] NeopixelBusFX - WS2812 Effekt-Plugin für ESPEasy

<< < (87/89) > >>

kleinericebear:

--- Zitat von: retro1 am 13 Juni 2021, 07:08:32 ---seit etwa 3 Wochen bekomme ich folgende Fehlermeldung beim Kompilieren:

--- Ende Zitat ---

Hallo Roland, hast Du hier schon eine Lösung gefunden.
Ich bekomme es nach Stunden leider nicht zum laufen :-(

Danke & Grüße
 Marc

kleinericebear:
Läuft :-)

Mit der aktuellen ESP Version "20210802" läuft es bei mir nicht!
Die ESP Version "20210503" funktioniert hingegen einwandfrei - strange.

retro1:
Hallo Forum,

temporäre Lösung bei mir:

src/src/Helpers/StringConverter.h editieren bei Zeile 71:

--- Code: ---const __FlashStringHelper * prefix);

--- Ende Code ---
ersetzen durch

--- Code: ---const String& prefix);

--- Ende Code ---

und

src/src/Helpers/StringConverter.cpp editieren bei Zeile 172:

--- Code: ---String formatToHex(unsigned long value, const __FlashStringHelper * prefix) {

--- Ende Code ---
ersetzen durch

--- Code: ---String formatToHex(unsigned long value, const String& prefix) {

--- Ende Code ---

EDIT: Zeilen angepasst

Grüsse
Roland

Klaus0815:
Könnte es mir evtl jemand als fertiges bin zur Verfügung stellen?

Ich habe schon ewig kein ESPEasy mehr selbst kompiliert - wird sicher nicht auf Anhieb funktionieren :-)

Ich bräuchte sowohl eine Version für den ESP8266 als auch ESP32


Viele Grüße

Klaus

chrisse111179:
Hallo,

nach viel ausprobieren und basteln habe ich das auch am Laufen. Super! Danke dafür!
Ist es gewollt, dass Mode und Lastmode nur aktualisiert werden, wenn ich im Device NeoPixelBusFX einen Intervall angebe?
Oder ist da bei mir irgendetwas falsch?

Viele Grüße,
Christian

Navigation

[0] Themen-Index

[#] Nächste Seite

[*] Vorherige Sete

Zur normalen Ansicht wechseln