Autor Thema: Max Thermostat immer wieder im auto-Modus  (Gelesen 625 mal)

Offline HansDampfHH

  • Full Member
  • ***
  • Beiträge: 275
Max Thermostat immer wieder im auto-Modus
« am: 13 Juli 2017, 17:04:40 »
Ich habe meinen Max Cube erfolgreich mit culfw geflashed.
Grundsätzlich funktionieren die Wochenprogramme.

Ich kann nun mit nachfolgendem Befehl die Temperatur manuell ändern:
set MAX_14a78b desiredTemperature 18.0

Im Device steht dann auch "mode manuell". Aber anscheinend greift dann trotzdem wieder das Wochenprogramm und der Modus wechselt nach einer Zeit wieder auf auto.
Wie kann ich denn dauerhaft die Temperatur auf manuell stellen?

Hier mal ein List eines meiner Thermostate:
Internals:
   CULMax_MSGCNT 130
   CULMax_TIME 2017-07-13 17:00:31
   DEF        HeatingThermostatPlus 08b9d2
   IODev      CULMax
   LASTInputDev CULMax
   MSGCNT     130
   NAME       MAX_08b9d2
   NR         834
   RSSI       -47
   STATE      21.0 °C
   TYPE       MAX
   addr       08b9d2
   backend    CULMax
   dstsetting 1
   mode       0
   rferror    0
   type       HeatingThermostatPlus
   READINGS:
     2017-07-13 17:00:31   RSSI            -47
     2017-07-10 22:33:40   TimeInformationHour 1
     2017-07-13 17:00:31   battery         ok
     2017-07-13 17:00:31   desiredTemperature 21.0
     2017-07-10 21:48:15   firmware        1.0
     2017-07-11 09:49:50   groupid         0
     2017-07-13 17:00:31   mode            auto
     2017-07-13 16:54:14   msgcnt          83
     2017-07-13 17:00:31   state           21.0 °C
     2017-07-13 17:00:31   temperature     24.5
     2017-07-10 21:48:15   testresult      0
     2017-07-13 17:00:31   valveposition   0
     2017-07-11 10:12:03   weekprofile-0-Sat-temp 17.0 °C  /  21.0 °C  /  17.0 °C  /  17.0 °C
     2017-07-11 10:12:03   weekprofile-0-Sat-time 00:00-06:00  /  06:00-22:00  /  22:00-23:55  /  23:55-00:00
     2017-07-11 10:12:03   weekprofile-1-Sun-temp 17.0 °C  /  21.0 °C  /  17.0 °C  /  17.0 °C
     2017-07-11 10:12:03   weekprofile-1-Sun-time 00:00-06:00  /  06:00-22:00  /  22:00-23:55  /  23:55-00:00
     2017-07-11 10:12:03   weekprofile-2-Mon-temp 17.0 °C  /  21.0 °C  /  17.0 °C  /  21.0 °C  /  17.0 °C  /  17.0 °C
     2017-07-11 10:12:03   weekprofile-2-Mon-time 00:00-06:00  /  06:00-09:00  /  09:00-17:00  /  17:00-23:00  /  23:00-23:55  /  23:55-00:00
     2017-07-11 10:12:03   weekprofile-3-Tue-temp 17.0 °C  /  21.0 °C  /  17.0 °C  /  21.0 °C  /  17.0 °C  /  17.0 °C
     2017-07-11 10:12:03   weekprofile-3-Tue-time 00:00-06:00  /  06:00-09:00  /  09:00-17:00  /  17:00-23:00  /  23:00-23:55  /  23:55-00:00
     2017-07-11 10:12:03   weekprofile-4-Wed-temp 17.0 °C  /  21.0 °C  /  17.0 °C  /  21.0 °C  /  17.0 °C  /  17.0 °C
     2017-07-11 10:12:03   weekprofile-4-Wed-time 00:00-06:00  /  06:00-09:00  /  09:00-17:00  /  17:00-23:00  /  23:00-23:55  /  23:55-00:00
     2017-07-11 10:12:03   weekprofile-5-Thu-temp 17.0 °C  /  21.0 °C  /  17.0 °C  /  21.0 °C  /  17.0 °C  /  17.0 °C
     2017-07-11 10:12:03   weekprofile-5-Thu-time 00:00-06:00  /  06:00-09:00  /  09:00-17:00  /  17:00-23:00  /  23:00-23:55  /  23:55-00:00
     2017-07-11 10:12:03   weekprofile-6-Fri-temp 17.0 °C  /  21.0 °C  /  17.0 °C  /  21.0 °C  /  17.0 °C  /  17.0 °C
     2017-07-11 10:12:03   weekprofile-6-Fri-time 00:00-06:00  /  06:00-09:00  /  09:00-17:00  /  17:00-23:00  /  23:00-23:55  /  23:55-00:00
   helper:
     DesiTime   1499866051
     LastCmdDate 1499957654.64822
     NextScan   1499959274
     NextScanTimestamp 2017-07-13 17:21:14
     TempBeforeWindOpen 21.0
     TemperatureTime 1499958031
     WinWasOpen 0
     desiredOffset 0
     gotTempTS  1
     leadDesiTemp 21.0
     switchDate 1499979600
   internals:
     interfaces thermostat;battery;temperature
Attributes:
   IODev      CULMax
   alias      Wohnzimmer links
   icon       hc_wht_regler
   room       MAX,Wohnzimmer
   scanTemp   1
   scnProcessByDesiChange 0
   userattr   scnProcessByDesiChange:0,1 scnShutterList scnModeHandling:NOCHANGE,AUTO,MANUAL
FHEM auf einem Intel NUC mit Debian Jessie, Selbstbau-CUL433

Offline Peter Kappelt

  • New Member
  • *
  • Beiträge: 45
Antw:Max Thermostat immer wieder im auto-Modus
« Antwort #1 am: 14 Juli 2017, 23:25:45 »
Hallo,

probiere mal
set Max-Geraet desiredTemperature manual 18.0
Sollte funktionieren.

Schönen Abend,
Peter

Offline HansDampfHH

  • Full Member
  • ***
  • Beiträge: 275
Antw:Max Thermostat immer wieder im auto-Modus
« Antwort #2 am: 16 Juli 2017, 10:24:36 »
Ne, leider auch nicht. Das Thermostat schaltet zwar auf 18 Grad.
Aber beim nächsten Schaltpunkt des Wochenprofils ist wieder die Automatik am Zug.

Wenn ich die Temperatur setze auf einen bestimmten Wert wechselt am Thermostat zwar auch der Modus von "Auto" nach "Manuell".
Aber das hindert das Wochenprogramm dennoch nicht wieder anzuspringen wenn der nächste Wechsel erreicht ist.
FHEM auf einem Intel NUC mit Debian Jessie, Selbstbau-CUL433

Offline Jackson

  • New Member
  • *
  • Beiträge: 39
Antw:Max Thermostat immer wieder im auto-Modus
« Antwort #3 am: 24 Juli 2017, 17:08:46 »

Wenn ich die Temperatur setze auf einen bestimmten Wert wechselt am Thermostat zwar auch der Modus von "Auto" nach "Manuell".
Aber das hindert das Wochenprogramm dennoch nicht wieder anzuspringen wenn der nächste Wechsel erreicht ist.

Ja, das ist das Wochenprogramm was da schaltet. Und das kannst meines Wissens auch nicht umgehen, außer das Wochenprogramm entsprechend auf die Temperaturen anzupassen.

Fhem 5.8 auf RPI3
MAXLAN - 7 Max HT basic - 2 Max WT
Jeelink - TX 29 DTH

Offline HansDampfHH

  • Full Member
  • ***
  • Beiträge: 275
Antw:Max Thermostat immer wieder im auto-Modus
« Antwort #4 am: 26 Juli 2017, 22:53:18 »
Hm, wenn ich also im Herbst 2 Wochen Urlaub mache muss ich das Wochenprogramm für 10 Thermostate anpassen und nach dem Urlaub wieder alle alten Wochenprogramme einspielen? Wie blöd ist das denn? Oder wenn ich Commandref richtig verstehe sollte doch auch ein OFF oder ECO funktionieren, oder?
Klingt nach einer dauerhaften Einstellung.
FHEM auf einem Intel NUC mit Debian Jessie, Selbstbau-CUL433

Offline SibbeH

  • New Member
  • *
  • Beiträge: 21
Antw:Max Thermostat immer wieder im auto-Modus
« Antwort #5 am: 29 Juli 2017, 12:14:10 »
Auch mir ist es nicht gelungen um für eine längere zeit mit

set Max_Geraet desiredTemperature manual 15.0

eine gewünschten Temperatur einzustellen.

Mit einen MAX Wandthermostat ist es mit wohl gelungen. Darum habe ich in allen Räume, in denen ein oder mehrere MAX Heizkörperthermostats verwendet werden ein MAX Wandthermostat WT+ montiert. (Dieses erhöht auch die WAF-Faktor :) :) ).

Wenn ich nun mit Urlaub gehe, stelle ich für jede Wandthermostat die Temperatur ein mit:

set MAX_Wandthermostat desiredTemperature 15 until dd.mm.yyyy HH:MM

und nach dem Urlaub rennt das Wochenprogramm schon wirder.

Sibbe
Raspberry Pi, CULV3, MAX Thermostat, MAX Wandthermostat, FS20AS1-2, FS20UE1-2, FS20PIRA, FS20DT, FS20UWS
MaxScanner, UtilsMaxProf, UWZ

Offline HansDampfHH

  • Full Member
  • ***
  • Beiträge: 275
Antw:Max Thermostat immer wieder im auto-Modus
« Antwort #6 am: 29 Juli 2017, 18:16:00 »
Hm, okay. Das wäre mir aber zu teuer. Wir haben einige Räume.
Kann man nicht auch ein Wandthermostat als Dummy anlegen?
Also ohne eine echtes zu kaufen und an die Wand zu nageln?
FHEM auf einem Intel NUC mit Debian Jessie, Selbstbau-CUL433

Offline Jackson

  • New Member
  • *
  • Beiträge: 39
Fhem 5.8 auf RPI3
MAXLAN - 7 Max HT basic - 2 Max WT
Jeelink - TX 29 DTH

Offline HansDampfHH

  • Full Member
  • ***
  • Beiträge: 275
Antw:Max Thermostat immer wieder im auto-Modus
« Antwort #8 am: 07 August 2017, 14:49:49 »
Okay, danke.
Es sind halt 10 Thermostate in 9 Räumen, die tagsüber grundsätzlich unterschiedliche Programme haben.
Der Gedanke jetzt 9 imaginäre Wandthermostate zu haben und darüber die Thermostate zu steuern scheint mir auch etwas umständlich.

Ich muss noch mal die Commandref studieren und mit den Optionen spielen.
Vielen Dank vorerst !
FHEM auf einem Intel NUC mit Debian Jessie, Selbstbau-CUL433

Offline Jackson

  • New Member
  • *
  • Beiträge: 39
Antw:Max Thermostat immer wieder im auto-Modus
« Antwort #9 am: 08 August 2017, 16:17:40 »
Mir ist noch was eingefallen...

Hast du Parameter den KeepAuto bei deinen Thermostaten gesetzt? Wenn ja, könnte das der Grund, warum das Wochenprogramm den Vorrang bekommt.

https://fhem.de/commandref_DE.html#MAX

... und dann bei den Attributes

keepAuto
Standardwert: 0. Wenn der Wert auf 1 gesetzt wird, bleibt das Gerät im Wochenprogramm auch wenn eine desiredTemperature gesendet wird.
Fhem 5.8 auf RPI3
MAXLAN - 7 Max HT basic - 2 Max WT
Jeelink - TX 29 DTH

Offline HansDampfHH

  • Full Member
  • ***
  • Beiträge: 275
Antw:Max Thermostat immer wieder im auto-Modus
« Antwort #10 am: 08 August 2017, 16:33:48 »
Das attr ist nicht gesetzt.
Ich habe es aber noch mal auf 0 gesetzt und die Temperatur geändert.
Mal sehen, ob beim nächsten Schaltpunkt des Wochenprogramms das Thermostat doch wieder umspringt.

Was funktioniert, ist das stellen auf OFF.
Dann springt das Wochenprogramm nicht wieder an.

Edit:
Wie vermutet hat das keine Änderung gebracht, dass attr keepAuto ist ja per Default auf 0.
Springt also nach wie vor zurück in das Wochenprogramm.
Die Thermostate auf OFF setzen ist zumindest in den wärmeren Monaten eine Option.
Im Winter wohl nicht ganz das Wahre ;-)
« Letzte Änderung: 10 August 2017, 10:54:05 von HansDampfHH »
FHEM auf einem Intel NUC mit Debian Jessie, Selbstbau-CUL433

Offline John

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1388
  • LOGO, PID20, HourCounter, KostalPiko, MaxScanner
Antw:Max Thermostat immer wieder im auto-Modus
« Antwort #11 am: 13 August 2017, 17:53:30 »
das Attribut "scanTemp" ist aktiv.

Wenn also der MaxScanner läuft wird er immer wieder den Mode umschalten AUTO<=>MANU.

Genau das ist seine Aufgabe.


CubieTruck/ CULV3
MAX Thermostat, MAX Thermostat+, MAX Fensterkontakt, MAX ECO-Taster
HMS100-TF, Sonos, PID20, HourCounter, MaxScanner

Offline HansDampfHH

  • Full Member
  • ***
  • Beiträge: 275
Antw:Max Thermostat immer wieder im auto-Modus
« Antwort #12 am: 13 August 2017, 19:22:21 »
Oh man, den hatte ich diesbezüglich nicht auf dem Zettel.
Das wird des Rätsels Lösung sein !
FHEM auf einem Intel NUC mit Debian Jessie, Selbstbau-CUL433