Autor Thema: [Gelöst] Anfänger hängt fest - Sonoff Konfiguration  (Gelesen 1837 mal)

Offline j_a_p1

  • New Member
  • *
  • Beiträge: 6
[Gelöst] Anfänger hängt fest - Sonoff Konfiguration
« am: 01 August 2017, 22:17:26 »
Hallo zusammen,
ich bin der Jens und seit ca. 8 Wochen beschäftige ich mich mit Fhem. Läuft bei mir auf dem Raspi und bis jetzt hatte ich auch nur Intertechno Steckdosen mit zwei selbst gelöteten 433 MHz Culs geschaltet. Dann habe ich irgendwo was von Sonoff gelesen. Ich fand die Idee klasse und klar, der Preis war sehr ansprechend. Also bestellt und nach langem hin und her Tasmota geflasht. Nach langer Recherche habe ich nun zumindest die Möglichkeit zu schalten

Was ich aber vermisse ist die Anzeige des Status sowie eine optische Anzeige wie der derzeitige Status ist. Im Moment steht da "subscription acknowledged" und ich komme da einfach nicht weiter...vielleicht habt Ihr ja ne Idee? Ich hoffe, ich vergesse jetzt nichts...wenn ja, habt bitte Nachsicht...bin ein echter Anfänger

Also die Konfiguration des Sonoff sieht wie folgt aus

define 1_sch_sq MQTT_DEVICE
attr 1_sch_sq IODev myBroker
attr 1_sch_sq devStateIcon ON:rc_GREEN:OFF OFF:rc_RED:ON
attr 1_sch_sq icon hue_filled_br30
attr 1_sch_sq publishSet ON OFF cmnd/1_sch_sq/POWER
attr 1_sch_sq room 01_Schlafzimmer,MQTT
attr 1_sch_sq stateFormat transmission-state
attr 1_sch_sq subscribeReading_Licht stat/1_sch_sq/POWER
attr 1_sch_sq subscribeReading_Status stat/1_sch_sq/STATUS
attr 1_sch_sq webCmd ON:OFF

wenn ich nun im Webfrontend des Sonoff schalte erhalte ich im Terminal diese Meldungen

Client mosqsub/2911-FHEM received PUBLISH (d0, q0, r0, m0, 'stat/1_sch_sq/RESULT', ... (15 bytes))
stat/1_sch_sq/RESULT {"POWER":"OFF"}
Client mosqsub/2911-FHEM received PUBLISH (d0, q0, r0, m0, 'stat/1_sch_sq/POWER', ... (3 bytes))
stat/1_sch_sq/POWER OFF
Client mosqsub/2911-FHEM received PUBLISH (d0, q0, r0, m0, 'stat/1_sch_sq/RESULT', ... (14 bytes))
stat/1_sch_sq/RESULT {"POWER":"ON"}
Client mosqsub/2911-FHEM received PUBLISH (d0, q0, r0, m0, 'stat/1_sch_sq/POWER', ... (2 bytes))
stat/1_sch_sq/POWER ON
Client mosqsub/2911-FHEM sending PINGREQ
Client mosqsub/2911-FHEM received PINGRESP

Die MQTT Parameter des Sonoff

Client ID = DVES_%06X
User = DVES_USER
Password = (habe ich nicht eingetragen ist aber vorausgefüllt)
Topic = 1_sch_sq


Ich hoffe, ich habe nicht vergessen.
Ciao
Jens
« Letzte Änderung: 22 August 2017, 23:11:38 von j_a_p1 »

Offline Tedious

  • Hero Member
  • *****
  • Beiträge: 1436
  • Indocti discant et ament meminisse periti
Antw:Anfänger hängt fest - Sonoff Konfiguration
« Antwort #1 am: 02 August 2017, 09:22:14 »
Bin da jetzt nicht so der Spezialist... aber Du abonnierst STATUS

attr 1_sch_sq subscribeReading_Status stat/1_sch_sq/STATUS
und der Sonoff meldet an den Broker POWER

Client mosqsub/2911-FHEM received PUBLISH (d0, q0, r0, m0, 'stat/1_sch_sq/POWER', ... (2 bytes))
stat/1_sch_sq/POWER ON

Abonniere statt STATUS mal POWER, denn sollten Werte übergeben werden - IMHO, wie gesagt - bin da kein Spezialist...
FHEM auf Proxmox-VM (Intel NUC) mit 4xMapleCUN (433,3x868) und Jeelink, HUE, MiLight, Max!, SonOff, Zigbee, Alexa, uvm...

Offline j_a_p1

  • New Member
  • *
  • Beiträge: 6
Antw:Anfänger hängt fest - Sonoff Konfiguration
« Antwort #2 am: 02 August 2017, 18:19:23 »
Danke, habe ich gerade gemacht und das alte Attribut gelöscht. Stettdessen nun attr 1_sch_sq subscribeReading_Status stat/1_sch_sq/POWERleider ohne Erfolg.
Ciao
Jens

Offline j_a_p1

  • New Member
  • *
  • Beiträge: 6
Antw:Anfänger hängt fest - Sonoff Konfiguration
« Antwort #3 am: 03 August 2017, 23:04:23 »
so, nach etwas überlegen und recherchieren habe ich jetzt ne funktionierende Lösung ;)
define 1_sch_sq MQTT_DEVICE
attr 1_sch_sq IODev Mosquitto
attr 1_sch_sq devStateIcon OFF:FS20.off:ON ON:FS20.on:OFF
attr 1_sch_sq icon ge_wht_steckdose
attr 1_sch_sq publishSet ON OFF cmnd/1_sch_sq/POWER
attr 1_sch_sq room MQTT
attr 1_sch_sq stateFormat state
attr 1_sch_sq subscribeReading_state cmnd/1_sch_sq/POWER
attr 1_sch_sq webCmd ON:OFF
Gefällt mir Gefällt mir x 1 Liste anzeigen

 

decade-submarginal