Autor Thema: [73_GardenaSmartBridge, 74_GardenaSmartDevice] - Module für Gardena Smart System  (Gelesen 201077 mal)

Offline Spook112

  • Full Member
  • ***
  • Beiträge: 129
Das mit dem Status-Code 204 ist vielleicht nicht besonders "sprechend" aber etwas was ich noch verstehe.

Was ich allerdings nicht verstehe, warum danach dann noch einmal der alte Status "parked_timer" wieder gesetzt wird, bevor dann der richtige, neue Status "ok_cutting_timer_overridden" gesetzt wird.

Kommt das auch von Gardena so?
Das ergibt doch gar keinen Sinn - oder?
Raspberry PI / RaZberry ZWAVE Modul / RFXTRX433E / 13 Fibaro FGS-222-EN-A-v1.00 / 17 VISION ZD2102-5 / 10 Somfy RTS / 4 Greenwave GWRENS310-F / Onkyo TX-NR616 / 2 devolo Home Control Funkschalter / 8 FIBARO System FGSD002 Smoke Sensoren

Offline BOFH

  • Full Member
  • ***
  • Beiträge: 211
@All die testen mögen.
https://git.cooltux.net/FHEM/mod-GardenaSmart/raw/branch/patch-token_expired/controls_GardenaSmartDevice.txt

@Spool112.
der 204er sollte eigentlich nicht im status stehen. stattdessen ein "the command is processed".
passiert das immer? oder hat sich hier das senden des mähens mit dem intervall pull übershcnitten ?


RasPi 4
ZWave.me ZME_UZB (Fibaro Auge Gen.2)/ HM-USB2 (Thermostat | Hutschienen Relais | 1-/2fach Schalter) / Enigma2 / PhilipsTV / Philips HUE (GO|Bulb|Stripe (plus)) / Somfy IO Rollos / BOSCH HSG636XS6 / SONOS (P1, P3, P5 2.Gen, SUB, Bar)
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline Spook112

  • Full Member
  • ***
  • Beiträge: 129
Hi,
also bei mir ist das zwischen dem 13.07. (erstmalig) und dem 28.07. (vorerst letztmalig) insgesamt dreimal aufgetreten.
Hier ein Beispiel für die Einträge im Log-File:
2021-07-18_10:29:36 SILENO___Tobi device_info-last_time_online: 2021-07-18 10:28:42
2021-07-18_11:12:46 SILENO___Tobi send command to gardena cloud
2021-07-18_11:12:46 SILENO___Tobi previousState: parked_timer
2021-07-18_11:12:49 SILENO___Tobi 204
2021-07-18_11:12:49 SILENO___Tobi the command is processed
2021-07-18_11:12:49 SILENO___Tobi previousState: 204
2021-07-18_11:13:03 SILENO___Tobi mower_timer-mower_timer: 10800
2021-07-18_11:13:03 SILENO___Tobi mower_timer-mower_timer_timestamp: 1626606768
2021-07-18_11:13:03 SILENO___Tobi device_info-last_time_online: 2021-07-18 11:12:52
2021-07-18_11:13:03 SILENO___Tobi parked_timer
2021-07-18_11:13:03 SILENO___Tobi previousState: the command is processed
2021-07-18_11:14:04 SILENO___Tobi mower-status: ok_leaving
2021-07-18_11:14:04 SILENO___Tobi battery-level: 99
2021-07-18_11:14:04 SILENO___Tobi device_info-last_time_online: 2021-07-18 11:13:15
2021-07-18_11:14:04 SILENO___Tobi ok_leaving
2021-07-18_11:14:04 SILENO___Tobi user_spec_reading_mower: 99
2021-07-18_11:14:04 SILENO___Tobi user_spec_reading_mower_stat: 99
2021-07-18_11:14:04 SILENO___Tobi previousState: parked_timer

Dazu muss man sagen, dass ich den vorangegangenen Status immer in das userReading previousState "wegspeichere", einfach um sehen zu können was vorher war.
Darüber hinaus nutze ich das manuelle Intervenieren in den Zeitplan meines Mähers eher selten, da er ja üblicherweise nach Zeitplan mäht/mähen soll.

Von daher würde ich sagen, dass das in dem Zeitraum vermutlich immer aufgetreten ist,, wenn ich ein Kommando aus FHEM an den Mäher gesendet habe.
Seltsam ist, dass er laut Log-File sowohl den Status 204 annimmt, als sofort danach dann auch den Status "the command is processed".
Ich meine aber, dass im Reading nur die 204 aufgetaucht ist. Sonst wäre mir das ja gar nicht aufgefallen.

Ich schaue mir das die nächsten Tage noch mal näher an - versuche zu simulieren.

Soll ich dazu vorher updaten ?
Raspberry PI / RaZberry ZWAVE Modul / RFXTRX433E / 13 Fibaro FGS-222-EN-A-v1.00 / 17 VISION ZD2102-5 / 10 Somfy RTS / 4 Greenwave GWRENS310-F / Onkyo TX-NR616 / 2 devolo Home Control Funkschalter / 8 FIBARO System FGSD002 Smoke Sensoren

Offline SouzA

  • Sr. Member
  • ****
  • Beiträge: 825
  • Nein! Doch!! Ohhh....
Glaub die haben das Token handling geändert…. Alle 10 Tage könnten die Probleme auftauchen. Ich beobachte es mal mit.
Moin,
is mal wieder ausgestiegen. Diesmal allerdings ohne Fehlermeldung.
Zeitraum solange es funktionierte: 28.07. ca. 7.30h bis 07.08. ca. 7.30h. Danach wieder tot.

Bis denn
SouzA

Edit:
Dieses Mal war auch ein Neustart notwendig um die Sensoren und co wieder zum Leben zu erwecken...
« Letzte Änderung: 09 August 2021, 10:05:30 von SouzA »
Raspi 4, EnOcean TCM310 USB, HM-MOD-UART-USB, Jeelink, hue, AMAD, fully, FRITZBOX, TelegramBot, VIERA, Presence BT/Mac, TPLink, Gassistant, Shelly, fhempy

Offline Bob83

  • New Member
  • *
  • Beiträge: 13
@All die testen mögen.
https://git.cooltux.net/FHEM/mod-GardenaSmart/raw/branch/patch-token_expired/controls_GardenaSmartDevice.txt

@Spool112.
der 204er sollte eigentlich nicht im status stehen. stattdessen ein "the command is processed".
passiert das immer? oder hat sich hier das senden des mähens mit dem intervall pull übershcnitten ?




@BOFH: Danke für deine Hilfe. Ich habe das gleiche Problem seit ein paar Wochen und wollte gerade schauen ob noch andere das Problem haben. Update habe ich eingespielt und hoffe, dass der Mäher jetzt keine Proleme mehr macht. Werde dann nochmal ein Feedback schreiben.

Offline Spook112

  • Full Member
  • ***
  • Beiträge: 129
Jetzt bin ich nach einem Update auf die neue Version zum Testen gekommen:
Der Mäher war im Status "parked timer" und ich habe dann manuell, aus fhem heraus, das Kommando "startOverrideTimer 180" aus dem WEB Interface gesendet.
Unten die daraus resultierenden Logfile Einträge:
2021-08-12_09:59:41 SILENO___Tobi device_info-last_time_online: 2021-08-12 09:58:34
2021-08-12_10:16:28 SILENO___Tobi send command to gardena cloud
2021-08-12_10:16:28 SILENO___Tobi previousState: parked_timer
2021-08-12_10:16:30 SILENO___Tobi 204
2021-08-12_10:16:30 SILENO___Tobi the command is processed
2021-08-12_10:16:30 SILENO___Tobi previousState: 204
2021-08-12_10:16:44 SILENO___Tobi mower_timer-mower_timer: 10800
2021-08-12_10:16:44 SILENO___Tobi mower_timer-mower_timer_timestamp: 1628763389
2021-08-12_10:16:44 SILENO___Tobi device_info-last_time_online: 2021-08-12 10:16:33
2021-08-12_10:16:44 SILENO___Tobi parked_timer
2021-08-12_10:16:44 SILENO___Tobi previousState: the command is processed
2021-08-12_10:17:55 SILENO___Tobi mower-status: ok_leaving
2021-08-12_10:17:55 SILENO___Tobi battery-level: 99
2021-08-12_10:17:55 SILENO___Tobi device_info-last_time_online: 2021-08-12 10:16:57
2021-08-12_10:17:55 SILENO___Tobi ok_leaving
2021-08-12_10:17:55 SILENO___Tobi user_spec_reading_mower: 99
2021-08-12_10:17:55 SILENO___Tobi user_spec_reading_mower_stat: 99
2021-08-12_10:17:55 SILENO___Tobi previousState: parked_timer
2021-08-12_10:17:55 SILENO___Tobi battery_0_date: 99
2021-08-12_10:17:55 SILENO___Tobi battery_previous: 100
2021-08-12_10:24:15 SILENO___Tobi mower-status: ok_cutting_timer_overridden
2021-08-12_10:24:15 SILENO___Tobi mower-source_for_next_start: no_source
2021-08-12_10:24:15 SILENO___Tobi mower-timestamp_next_start: temporarily unavailable
2021-08-12_10:24:15 SILENO___Tobi device_info-last_time_online: 2021-08-12 10:23:34
2021-08-12_10:24:15 SILENO___Tobi ok_cutting_timer_overridden
2021-08-12_10:24:15 SILENO___Tobi previousState: ok_leaving


Im Web Interface wurden nacheinander die folgenden Status angezeigt:
1) send command to gardena cloud
2) the command is processed
3) parked_timer
4) ok_leaving
5) ok_cutting_timer_overridden

Jetzt mäht er munter vor sich hin :-)

Die "204" die im Logfile zu sehen ist habe ich im Web Interface nicht gesehen.
Entweder, sie ist nur extrem kurz aufgetaucht und ich habe es übersehen oder sie ist gar nicht aufgetaucht, was wir ja eigentlich erreichen wollten.

Was ich immer noch nicht verstehe - und auch nicht für korrekt halte - ist die Tatsache, dass nach dem Senden (1) und Verarbeiten (2) des Kommandos der Status wieder zurück auf "parked_timer" (3) geht.
Soll/muss das so sein?
So richtig logisch ist das ja nicht, denn nach dem Verarbeiten des Kommandos sollte ja eigentlich der neue Status "ok leaving" sein, denn der Mäher soll ja die Garage verlassen.

Hängt das vielleicht damit zusammen, dass es etwa eine Minute dauert bis der Status dann auf "ok leaving" wechselt?
Woran liegt das eigentlich?
Raspberry PI / RaZberry ZWAVE Modul / RFXTRX433E / 13 Fibaro FGS-222-EN-A-v1.00 / 17 VISION ZD2102-5 / 10 Somfy RTS / 4 Greenwave GWRENS310-F / Onkyo TX-NR616 / 2 devolo Home Control Funkschalter / 8 FIBARO System FGSD002 Smoke Sensoren

Offline SebastianStorb

  • Jr. Member
  • **
  • Beiträge: 71
Update funktioniert nicht
Nachdem ich update all durchgeführt habe kommt

2021.08.22 09:27:38 1 : UPD FHEM/73_GardenaSmartBridge.pm
2021.08.22 09:27:38 1 : UPD FHEM/74_GardenaSmartDevice.pm
2021.08.22 09:27:38 1 : saving fhem.cfg
2021.08.22 09:27:38 1 : saving ./log/fhem.save

beim Update Check kommt aber wieder:

List of new / modified files since last update:
UPD FHEM/73_GardenaSmartBridge.pm
UPD FHEM/74_GardenaSmartDevice.pm
Downloading https://raw.githubusercontent.com/knowthelist/fhem-tablet-ui/master/controls_fhemtabletui.txt

Im Logfile steht dann:
2021.08.22 09:27:38 1: GardenaSmartDevice
2021.08.22 09:27:39 1: UPD FHEM/73_GardenaSmartBridge.pm
2021.08.22 09:27:39 1: UPD FHEM/74_GardenaSmartDevice.pm
2021.08.22 09:27:39 1: saving fhem.cfg
2021.08.22 09:27:39 1: saving ./log/fhem.save
2021.08.22 09:27:39 1:
2021.08.22 09:27:39 1: New entries in the CHANGED file:
2021.08.22 09:27:39 1: <!DOCTYPE html>
2021.08.22 09:27:39 1: <html lang="en-US" class="theme-">
2021.08.22 09:27:39 1: <head data-suburl="">
2021.08.22 09:27:39 1: <meta charset="utf-8">
2021.08.22 09:27:39 1: <meta name="viewport" content="width=device-width, initial-scale=1">
2021.08.22 09:27:39 1: <meta http-equiv="x-ua-compatible" content="ie=edge">
2021.08.22 09:27:39 1: <title>Page Not Found -  mod-GardenaSmart - Gitea: Git with a cup of tea </title>
2021.08.22 09:27:39 1: <link rel="manifest" href="data:application/json;base64,eyJuYW1lIjoiR2l0ZWE6IEdpdCB3aXRoIGEgY3VwIG9mIHRlYSIsInNob3J0X25hbWUiOiJHaXRlYTogR2l0IHdpdGggYSBjdXAgb2YgdGVhIiwic3RhcnRfdXJsIjoiaHR0cHM6Ly9naXQuY29vbHR1eC5uZXQvIiwiaWNvbnMiOlt7InNyYyI6Imh0dHBzOi8vZ2l0LmNvb2x0dXgubmV0L2ltZy9sb2dvLnBuZyIsInR5cGUiOiJpbWFnZS9wbmciLCJzaXplcyI6IjUxMng1MTIifSx7InNyYyI6Imh0dHBzOi8vZ2l0LmNvb2x0dXgubmV0L2ltZy9sb2dvLnN2ZyIsInR5cGUiOiJpbWFnZS9zdmcreG1sIiwic2l6ZXMiOiI1MTJ4NTEyIn1dfQ=="/>
2021.08.22 09:27:39 1: <meta name="theme-color" content="#6cc644">
2021.08.22 09:27:39 1: <meta name="default-theme" content="gitea" />
2021.08.22 09:27:39 1: <meta name="author" content="FHEM" />
2021.08.22 09:27:39 1: <meta name="description" content="mod-GardenaSmart" />
2021.08.22 09:27:39 1: <meta name="keywords" content="go,git,self-hosted,gitea">
2021.08.22 09:27:39 1: <meta name="referrer" content="no-referrer" />
2021.08.22 09:27:39 1: <meta name="_csrf" content="EaQAppjvR6-WOJJsoDXeJc_Ds846MTYyOTYxNzI1OTAwNTcwMDA2Ng" />
2021.08.22 09:27:39 1:
2021.08.22 09:27:39 1:
2021.08.22 09:27:39 1:
2021.08.22 09:27:39 1: Calling /usr/bin/perl ./contrib/commandref_join.pl -noWarnings, this may take a while
2021.08.22 09:27:43 1:
2021.08.22 09:27:43 1: update finished, "shutdown restart" is needed to activate the changes.

Was mache ich falsch?

Offline Bob83

  • New Member
  • *
  • Beiträge: 13
@BOFH: Danke für deine Hilfe. Ich habe das gleiche Problem seit ein paar Wochen und wollte gerade schauen ob noch andere das Problem haben. Update habe ich eingespielt und hoffe, dass der Mäher jetzt keine Proleme mehr macht. Werde dann nochmal ein Feedback schreiben.

@BOFH: Seit dem ich das Update von dir eingespielt habe, bekomme ich den beschriebenen Fehler nicht mehr. Sollte sich daran was ändern, melde ich mich noch einmal.

Offline BOFH

  • Full Member
  • ***
  • Beiträge: 211
Jetzt bin ich nach einem Update auf die neue Version zum Testen gekommen:
Der Mäher war im Status "parked timer" und ich habe dann manuell, aus fhem heraus, das Kommando "startOverrideTimer 180" aus dem WEB Interface gesendet.
Unten die daraus resultierenden Logfile Einträge:
2021-08-12_09:59:41 SILENO___Tobi device_info-last_time_online: 2021-08-12 09:58:34
2021-08-12_10:16:28 SILENO___Tobi send command to gardena cloud
2021-08-12_10:16:28 SILENO___Tobi previousState: parked_timer
2021-08-12_10:16:30 SILENO___Tobi 204
2021-08-12_10:16:30 SILENO___Tobi the command is processed
2021-08-12_10:16:30 SILENO___Tobi previousState: 204
2021-08-12_10:16:44 SILENO___Tobi mower_timer-mower_timer: 10800
2021-08-12_10:16:44 SILENO___Tobi mower_timer-mower_timer_timestamp: 1628763389
2021-08-12_10:16:44 SILENO___Tobi device_info-last_time_online: 2021-08-12 10:16:33
2021-08-12_10:16:44 SILENO___Tobi parked_timer
2021-08-12_10:16:44 SILENO___Tobi previousState: the command is processed
2021-08-12_10:17:55 SILENO___Tobi mower-status: ok_leaving
2021-08-12_10:17:55 SILENO___Tobi battery-level: 99
2021-08-12_10:17:55 SILENO___Tobi device_info-last_time_online: 2021-08-12 10:16:57
2021-08-12_10:17:55 SILENO___Tobi ok_leaving
2021-08-12_10:17:55 SILENO___Tobi user_spec_reading_mower: 99
2021-08-12_10:17:55 SILENO___Tobi user_spec_reading_mower_stat: 99
2021-08-12_10:17:55 SILENO___Tobi previousState: parked_timer
2021-08-12_10:17:55 SILENO___Tobi battery_0_date: 99
2021-08-12_10:17:55 SILENO___Tobi battery_previous: 100
2021-08-12_10:24:15 SILENO___Tobi mower-status: ok_cutting_timer_overridden
2021-08-12_10:24:15 SILENO___Tobi mower-source_for_next_start: no_source
2021-08-12_10:24:15 SILENO___Tobi mower-timestamp_next_start: temporarily unavailable
2021-08-12_10:24:15 SILENO___Tobi device_info-last_time_online: 2021-08-12 10:23:34
2021-08-12_10:24:15 SILENO___Tobi ok_cutting_timer_overridden
2021-08-12_10:24:15 SILENO___Tobi previousState: ok_leaving


Im Web Interface wurden nacheinander die folgenden Status angezeigt:
1) send command to gardena cloud
2) the command is processed
3) parked_timer
4) ok_leaving
5) ok_cutting_timer_overridden

Jetzt mäht er munter vor sich hin :-)

Die "204" die im Logfile zu sehen ist habe ich im Web Interface nicht gesehen.
Entweder, sie ist nur extrem kurz aufgetaucht und ich habe es übersehen oder sie ist gar nicht aufgetaucht, was wir ja eigentlich erreichen wollten.

Was ich immer noch nicht verstehe - und auch nicht für korrekt halte - ist die Tatsache, dass nach dem Senden (1) und Verarbeiten (2) des Kommandos der Status wieder zurück auf "parked_timer" (3) geht.
Soll/muss das so sein?
So richtig logisch ist das ja nicht, denn nach dem Verarbeiten des Kommandos sollte ja eigentlich der neue Status "ok leaving" sein, denn der Mäher soll ja die Garage verlassen.

Hängt das vielleicht damit zusammen, dass es etwa eine Minute dauert bis der Status dann auf "ok leaving" wechselt?
Woran liegt das eigentlich?

Guck ich mir noch mal genauer an


Update funktioniert nicht
Nachdem ich update all durchgeführt habe kommt

2021.08.22 09:27:38 1 : UPD FHEM/73_GardenaSmartBridge.pm
2021.08.22 09:27:38 1 : UPD FHEM/74_GardenaSmartDevice.pm
2021.08.22 09:27:38 1 : saving fhem.cfg
2021.08.22 09:27:38 1 : saving ./log/fhem.save

beim Update Check kommt aber wieder:

List of new / modified files since last update:
UPD FHEM/73_GardenaSmartBridge.pm
UPD FHEM/74_GardenaSmartDevice.pm
Downloading https://raw.githubusercontent.com/knowthelist/fhem-tablet-ui/master/controls_fhemtabletui.txt

Im Logfile steht dann:
2021.08.22 09:27:38 1: GardenaSmartDevice
2021.08.22 09:27:39 1: UPD FHEM/73_GardenaSmartBridge.pm
2021.08.22 09:27:39 1: UPD FHEM/74_GardenaSmartDevice.pm
2021.08.22 09:27:39 1: saving fhem.cfg
2021.08.22 09:27:39 1: saving ./log/fhem.save
2021.08.22 09:27:39 1:
2021.08.22 09:27:39 1: New entries in the CHANGED file:
2021.08.22 09:27:39 1: <!DOCTYPE html>
2021.08.22 09:27:39 1: <html lang="en-US" class="theme-">
2021.08.22 09:27:39 1: <head data-suburl="">
2021.08.22 09:27:39 1: <meta charset="utf-8">
2021.08.22 09:27:39 1: <meta name="viewport" content="width=device-width, initial-scale=1">
2021.08.22 09:27:39 1: <meta http-equiv="x-ua-compatible" content="ie=edge">
2021.08.22 09:27:39 1: <title>Page Not Found -  mod-GardenaSmart - Gitea: Git with a cup of tea </title>
2021.08.22 09:27:39 1: <link rel="manifest" href="data:application/json;base64,eyJuYW1lIjoiR2l0ZWE6IEdpdCB3aXRoIGEgY3VwIG9mIHRlYSIsInNob3J0X25hbWUiOiJHaXRlYTogR2l0IHdpdGggYSBjdXAgb2YgdGVhIiwic3RhcnRfdXJsIjoiaHR0cHM6Ly9naXQuY29vbHR1eC5uZXQvIiwiaWNvbnMiOlt7InNyYyI6Imh0dHBzOi8vZ2l0LmNvb2x0dXgubmV0L2ltZy9sb2dvLnBuZyIsInR5cGUiOiJpbWFnZS9wbmciLCJzaXplcyI6IjUxMng1MTIifSx7InNyYyI6Imh0dHBzOi8vZ2l0LmNvb2x0dXgubmV0L2ltZy9sb2dvLnN2ZyIsInR5cGUiOiJpbWFnZS9zdmcreG1sIiwic2l6ZXMiOiI1MTJ4NTEyIn1dfQ=="/>
2021.08.22 09:27:39 1: <meta name="theme-color" content="#6cc644">
2021.08.22 09:27:39 1: <meta name="default-theme" content="gitea" />
2021.08.22 09:27:39 1: <meta name="author" content="FHEM" />
2021.08.22 09:27:39 1: <meta name="description" content="mod-GardenaSmart" />
2021.08.22 09:27:39 1: <meta name="keywords" content="go,git,self-hosted,gitea">
2021.08.22 09:27:39 1: <meta name="referrer" content="no-referrer" />
2021.08.22 09:27:39 1: <meta name="_csrf" content="EaQAppjvR6-WOJJsoDXeJc_Ds846MTYyOTYxNzI1OTAwNTcwMDA2Ng" />
2021.08.22 09:27:39 1:
2021.08.22 09:27:39 1:
2021.08.22 09:27:39 1:
2021.08.22 09:27:39 1: Calling /usr/bin/perl ./contrib/commandref_join.pl -noWarnings, this may take a while
2021.08.22 09:27:43 1:
2021.08.22 09:27:43 1: update finished, "shutdown restart" is needed to activate the changes.

Was mache ich falsch?


denke du hast dich vertippt. Steht ja. Page Not found
Eventuell noch eine alte Quelle drin? Dann lässt sich die neue nicht hinzufügen


update list


Guck mal nach
@BOFH: Seit dem ich das Update von dir eingespielt habe, bekomme ich den beschriebenen Fehler nicht mehr. Sollte sich daran was ändern, melde ich mich noch einmal.

Top.
RasPi 4
ZWave.me ZME_UZB (Fibaro Auge Gen.2)/ HM-USB2 (Thermostat | Hutschienen Relais | 1-/2fach Schalter) / Enigma2 / PhilipsTV / Philips HUE (GO|Bulb|Stripe (plus)) / Somfy IO Rollos / BOSCH HSG636XS6 / SONOS (P1, P3, P5 2.Gen, SUB, Bar)


Offline BOFH

  • Full Member
  • ***
  • Beiträge: 211
Du könntest Testung löschen.

update delete https://git.cooltux.net/FHEM/mod-GardenaSmart/raw/branch/testing/controls_GardenaSmartDevice.txt

Danach das

update add https://git.cooltux.net/FHEM/mod-GardenaSmart/raw/branch/patch-token_expired/controls_GardenaSmartDevice.txt


Obwohl der testing Zweig existiert… und relativ aktuell ist
De Verlauf sieht so aus.
Patch x -> devel -> testing -> svn (fhem)

Also sollte Testung gehen allerdings den 10tage Fehler haben…. Wenn keiner sich beschwert würde ich das zum we Richtung svn anstoßen via cooltux
« Letzte Änderung: 24 August 2021, 21:05:58 von BOFH »
RasPi 4
ZWave.me ZME_UZB (Fibaro Auge Gen.2)/ HM-USB2 (Thermostat | Hutschienen Relais | 1-/2fach Schalter) / Enigma2 / PhilipsTV / Philips HUE (GO|Bulb|Stripe (plus)) / Somfy IO Rollos / BOSCH HSG636XS6 / SONOS (P1, P3, P5 2.Gen, SUB, Bar)

Offline SebastianStorb

  • Jr. Member
  • **
  • Beiträge: 71
Vielen herzlichen Dank für die Unterstützung!

Ich habe es genau so gemacht, leider kommt immer noch:
2021.08.26 21:32:17 1 : fhem
2021.08.26 21:32:17 1 : UPD FHEM/73_GardenaSmartBridge.pm
2021.08.26 21:32:17 1 : UPD FHEM/74_GardenaSmartDevice.pm
2021.08.26 21:32:17 1 : saving fhem.cfg
2021.08.26 21:32:17 1 : saving ./log/fhem.save

update list ergibt jetzt:
http://fhem.de/fhemupdate/controls_fhem.txt
...
https://raw.githubusercontent.com/jowiemann/DBPlan-for-Fhem/master/controls_dbplan.txt
https://git.cooltux.net/FHEM/mod-GardenaSmart/raw/branch/patch-token_expired/controls_GardenaSmartDevice.txt

Im Logfile steht:
2021.08.26 21:32:17 1: GardenaSmartDevice
2021.08.26 21:32:18 1: UPD FHEM/73_GardenaSmartBridge.pm
2021.08.26 21:32:18 1: UPD FHEM/74_GardenaSmartDevice.pm
2021.08.26 21:32:18 1: saving fhem.cfg
2021.08.26 21:32:18 1: saving ./log/fhem.save
2021.08.26 21:32:18 1:
2021.08.26 21:32:18 1: New entries in the CHANGED file:
2021.08.26 21:32:18 1: <!DOCTYPE html>
2021.08.26 21:32:18 1: <html lang="en-US" class="theme-">
2021.08.26 21:32:18 1: <head data-suburl="">
2021.08.26 21:32:18 1: <meta charset="utf-8">
2021.08.26 21:32:18 1: <meta name="viewport" content="width=device-width, initial-scale=1">
2021.08.26 21:32:18 1: <meta http-equiv="x-ua-compatible" content="ie=edge">
2021.08.26 21:32:18 1: <title>Page Not Found -  mod-GardenaSmart - Gitea: Git with a cup of tea </title>
2021.08.26 21:32:18 1: <link rel="manifest" href="data:application/json;base64,eyJuYW1lIjoiR2l0ZWE6IEdpdCB3aXRoIGEgY3VwIG9mIHRlYSIsInNob3J0X25hbWUiOiJHaXRlYTogR2l0IHdpdGggYSBjdXAgb2YgdGVhIiwic3RhcnRfdXJsIjoiaHR0cHM6Ly9naXQuY29vbHR1eC5uZXQvIiwiaWNvbnMiOlt7InNyYyI6Imh0dHBzOi8vZ2l0LmNvb2x0dXgubmV0L2ltZy9sb2dvLnBuZyIsInR5cGUiOiJpbWFnZS9wbmciLCJzaXplcyI6IjUxMng1MTIifSx7InNyYyI6Imh0dHBzOi8vZ2l0LmNvb2x0dXgubmV0L2ltZy9sb2dvLnN2ZyIsInR5cGUiOiJpbWFnZS9zdmcreG1sIiwic2l6ZXMiOiI1MTJ4NTEyIn1dfQ=="/>
2021.08.26 21:32:18 1: <meta name="theme-color" content="#6cc644">
2021.08.26 21:32:18 1: <meta name="default-theme" content="gitea" />
2021.08.26 21:32:18 1: <meta name="author" content="FHEM" />
2021.08.26 21:32:18 1: <meta name="description" content="mod-GardenaSmart" />
2021.08.26 21:32:18 1: <meta name="keywords" content="go,git,self-hosted,gitea">
2021.08.26 21:32:18 1: <meta name="referrer" content="no-referrer" />
2021.08.26 21:32:18 1: <meta name="_csrf" content="QlY2e1U3Il-YZvexlhjcTwn33cc6MTYzMDAwNjMzODA5MDE0MjI2Mw" />
2021.08.26 21:32:18 1:
2021.08.26 21:32:18 1:
2021.08.26 21:32:18 1:
2021.08.26 21:32:18 1: Calling /usr/bin/perl ./contrib/commandref_join.pl -noWarnings, this may take a while
2021.08.26 21:32:22 1:
2021.08.26 21:32:22 1: update finished, "shutdown restart" is needed to activate the changes.

Mehrfach Update all und restart ohne Erfolg.

Offline BOFH

  • Full Member
  • ***
  • Beiträge: 211
schon verrückt.

versuch doch bitte mal wie es aussieht, wenn du die Dateien aus deinem FHEM Ordner löscht.

Und welche Version zeigt dir FHEM an ?
RasPi 4
ZWave.me ZME_UZB (Fibaro Auge Gen.2)/ HM-USB2 (Thermostat | Hutschienen Relais | 1-/2fach Schalter) / Enigma2 / PhilipsTV / Philips HUE (GO|Bulb|Stripe (plus)) / Somfy IO Rollos / BOSCH HSG636XS6 / SONOS (P1, P3, P5 2.Gen, SUB, Bar)

Offline SebastianStorb

  • Jr. Member
  • **
  • Beiträge: 71
Habe ich per ftp zuerst umgenannt in #.... dann beim 2. Versuch gelöscht.

Ergebnis ist unverändert:
fhem
List of new / modified files since last update:
UPD FHEM/73_GardenaSmartBridge.pm
UPD FHEM/74_GardenaSmartDevice.pm
Downloading https://raw.githubusercontent.com/knowthelist/fhem-tablet-ui/master/controls_fhemtabletui.txt
Latest Revision: 24883



Mmm das ist komisch: Warum wird denn keine Id gefunden:

Latest Revision: 24883


No Id found for 73_GardenaSmartBridge.pm
No Id found for 74_GardenaSmartDevice.pm





Offline CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 27892
Das mit dem no Id ist korrekt da die Module aus dem Git ja keine SVN Id haben. Aber dennoch sollte nach einem Update keine weiteren Updates der Module angebten werden. Ich wüsste aber leider auch nicht wirklich wo das herkommen kann.
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://www.paypal.com/paypalme/MOldenburg
My FHEM Git: https://git.cooltux.net/FHEM/
Mein Dokuwiki:
https://www.cooltux.net

 

decade-submarginal