Autor Thema: [73_GardenaSmartBridge, 74_GardenaSmartDevice] - Module für Gardena Smart System  (Gelesen 207743 mal)

Offline BOFH

  • Full Member
  • ***
  • Beiträge: 229
Es gibt ein
readingValueLanguage
Der dann die Reading in deutsch absetzt
RasPi 4
ZWave.me ZME_UZB (Fibaro Auge Gen.2)/ HM-USB2 (Thermostat | Hutschienen Relais | 1-/2fach Schalter) / Enigma2 / PhilipsTV / Philips HUE (GO|Bulb|Stripe (plus)) / Somfy IO Rollos / BOSCH HSG636XS6 / SONOS (P1, P3, P5 2.Gen, SUB, Bar)

Offline sweetie-pie

  • Full Member
  • ***
  • Beiträge: 104
Hallo,

seit heute will mein Sileno nicht mehr so richtig.

Ich habe den Sileno wie auch die Bridge schon mal gelöscht und neu angelegt.
Das Bridge sieht aus wie zuvor. Leider wurde der Sileno nicht angelegt.
Autocreate war aktiv.

Weiterhin und vllt OT:
Auch kann ich seit heute in meiner Gardena App Zonen einzeichnen.
Nicht das Gardena da mal was an der API gebaut hat.  ::)

Bin ich alleine oder hat noch wer Probleme?

Edit:
2022.05.10 17:30:30 5: GardenaSmartBridge (Gardena_Bridge) - RequestERROR: received http code 200 receive Error after requesting gardena cloudGruß
  sweetie-pie
« Letzte Änderung: 10 Mai 2022, 17:40:33 von sweetie-pie »

Offline 10mamai

  • New Member
  • *
  • Beiträge: 13
Hi zusammen,

sorry, ich stehe auf dem Schlauch:
Habe beim sensor2 im Internal STATE neben der Temperatur T: 00 °C,  und Feuchtigkeit H: 00 % auch einen Wert D: 00.0 stehen.
Im Reading state stehen nur „T: 00 °C H: 00 %“, auch sonst finde ich diesen ominösen D-Wert in keinem Reading.
Kann der Wert doch etwas mit der Helligkeit zu tun haben? evtl. aus der Zuordnung bei Gardena zur Geolocation?

vg

Ergänzung: der D-Wert existiert erst seit kurzem. Evtl. seit dem Gardena-Update des Sensors.

OK, hat sich erledigt. D ist vermutlich Dewpoint also der Taupunkt. Vielleicht kann der noch als Reading ergänzt werden.
« Letzte Änderung: 15 Mai 2022, 10:20:30 von 10mamai »
fhem 6.1 auf Raspberry PI4 mit HM-MOD-UART, Signalduino, EnOcean,ezControl XS1 mit Warema-Lizenz, viel Tasmota, viele 868 HM, weniger 433.

Offline sweetie-pie

  • Full Member
  • ***
  • Beiträge: 104
seit heute will mein Sileno nicht mehr so richtig.

Sorry, ich habe den Mäher immer noch nicht wieder am laufen:
Device gelöscht.
Bridge gelöscht.
Save gemacht.
fhem gestoppt.
fhem.save & fhem.cfg manuell geprüft und aufgeräumt.
fhem gestartet.
Bridge neuangelegt.

Autocreate ist an, aber es passiert nix.

Internals:
   BRIDGE     1
   CFGFN     
   FUUID      627ebe39-f33f-2e3f-30c7-fc74d811a945fc79
   FVERSION   73_GardenaSmartBridge.pm:v2.4.7-s25661/2022-02-09
   INTERVAL   60
   NAME       Gardena_Bridge
   NOTIFYDEV  global,Gardena_Bridge
   NR         1746
   NTFY_ORDER 50-Gardena_Bridge
   STATE      200
   TYPE       GardenaSmartBridge
   URL        https://smart.gardena.com/v1
   VERSION    v2.4.7
   READINGS:
     2022-05-13 22:24:14   address         xxxxxxxxxxxxxxxx, Deutschland
     2022-05-13 22:24:14   authorized_user_ids 0
     2022-05-13 22:24:14   city            xxxxxxxxxxxxxxx
     2022-05-13 22:24:14   devices         2
     2022-05-13 22:24:14   gateway_time_zone Europe/Zurich
     2022-05-13 22:24:14   gateway_time_zone_offset 7200000
     2022-05-13 22:24:14   id              xxxxxxxxxxxxxxxxxx
     2022-05-13 22:33:37   lastRequestState request_error
     2022-05-13 22:24:14   latitude        xxxxxxxxxxx
     2022-05-13 22:24:14   longitude       xxxxxxxxxxxx
     2022-05-13 22:24:14   name            My Garden
     2022-05-13 22:33:37   state           200
     2022-05-13 22:24:14   sun_data        HASH(0x5632dbcdd838)
     2022-05-13 22:24:14   time_zone       Europe/Berlin
     2022-05-13 22:24:14   time_zone_offset 7200000
     2022-05-13 22:24:14   token           xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
   helper:
     locations_id xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
     refresh_token fe6b0332-1cc3-422f-8428-0aac385d729e
     session_id XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
     token_expired 1653337451.83769
     user_id    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Attributes:
   debugDEVICE 1
   debugJSON  1
   gardenaAccountEmail gardena@xxxxxxxxxxxxxx
   room       GardenaSmart
   verbose    5

Im Debug sehe ich allerdings den Mäher, nur es wird kein Device mehr angelegt:
2022.05.13 22:37:43 4: GardenaSmartBridge (Gardena_Bridge) - Read password from file
2022.05.13 22:37:43 4: GardenaSmartBridge (Gardena_Bridge) - Send with URL: https://smart.gardena.com/v1/devices?locationId=1e0c2241-9f6a-4f17-b312-292451634c0b, HEADER: secret!, DATA: secret!, METHOD: GET
2022.05.13 22:37:43 4: GardenaSmartBridge (Gardena_Bridge) - fetch device list and device states
2022.05.13 22:37:45 4: GardenaSmartBridge (Gardena_Bridge) - Request: {"devices":[{

"id":"b77f0a35-7b9c-48c9-99ae-723344e024f8","name":"SILENO","category":"mower","configuration_synchronized":true,"abilities":[{
"id":"5f7cf564-61f3-3130-931d-fb3028d3ce77","name":"device_info","properties":[{
"id":"34cbe6f6-55ec-34d4-999c-861462d3aa2b","name":"manufacturer","value":"Gardena"},{
"id":"59a56e84-a74a-3cf9-8d70-e2b7ac5c03d2","name":"product","value":"10-DEVICE"},{
"id":"faf7cdf4-7c7c-3cd3-95e3-0a4581f32391","name":"serial_number","value":"999999999999"},{
"id":"ded0ec3e-6631-32a4-af7f-8f231d08004f","name":"version","value":"1.0.0-4.0.0-1.5.3-1.0.0"},{
"id":"e4e2cb41-22a5-38e6-aca0-7b03e0fe1ca6","name":"category","value":"mower"},{
"id":"e3861c39-0a52-37df-81fd-48023ac7f44c","name":"last_time_online","value":"2022-05-13T19:51:16.581Z"},{
"id":"a9b29124-9ae3-3951-888c-64e203da25a8","name":"sgtin","value":"xxxxxxxxxxxxxxxxxxxxxxx"},{
"id":"6e7d89e6-63c8-3c73-9b83-f86a906a1910","name":"connection_status","timestamp":"2022-05-13T20:37:44.678Z","value":"online"}],"type":"device_info"},{
"id":"3d7c3299-c59c-3919-b64a-a1b97a635458","name":"battery","properties":[{
"id":"d1bb65e5-fffb-3952-8da4-e2d45707db9d","name":"level","timestamp":"2022-05-13T14:56:58.564Z","unit":"%","value":100},{
"id":"76ebc851-98fa-3106-acb5-259709bc6ee4","name":"charging","timestamp":"2022-05-13T14:33:49.090Z","value":false}],"type":"battery_power"},{
"id":"e9f563f2-841a-3c99-993f-400c3ecd96ef","name":"firmware","properties":[{
"id":"ecbe0f54-5e02-30db-a8c1-6f5e13460969","name":"firmware_status","value":"up_to_date"},{
"id":"14a04766-35f5-362a-b1f5-98009400f41a","name":"firmware_upload_progress","value":0},{
"id":"91bdbbe5-39d3-3336-8b80-af38eebdcb3a","name":"firmware_available_version","value":""},{
"id":"5a6b215b-5c7b-3e63-9fe1-628fe6d699e4","name":"inclusion_status","value":"included"},{
"id":"affa9653-1908-381e-8350-980616a598c3","name":"firmware_command","value":"idle"}],"type":"firmware"},{
"id":"23305c6d-340b-335a-9b5b-941045b185ce","name":"mower_timer","properties":[{
"id":"10fb2c64-1566-387a-92bf-50dae7611c2a","name":"mower_timer","timestamp":"2022-05-13T14:30:05.293Z","unit":"seconds","value":"0"}],"type":"robotic_mower_timer"},{
"id":"b951bb5a-3567-3baa-a332-ac35aee96b1b","name":"mower","properties":[{
"id":"c69a30ae-409f-3e1d-b2b3-6c9313bed66e","name":"manual_operation","timestamp":"2022-05-10T22:07:20.116Z","value":false},{
"id":"15e6d6a7-f5d8-3eca-9e7e-3e418dbb2f99","name":"status","timestamp":"2022-05-13T14:33:49.090Z","value":"parked_timer"},{
"id":"6d3bc264-d3f9-3484-9549-493b3c03f416","name":"error","timestamp":"2022-05-13T14:33:49.090Z","value":"no_message"},{
"id":"676ded31-c3b7-3d1e-86ed-a774253cb4c7","name":"last_error_code","timestamp":"2022-05-10T22:07:20.280Z","value":"no_message"},{
"id":"6df7c7e7-ba63-3059-b289-5f6b906a3212","name":"timestamp_last_error_code","timestamp":"2022-05-10T22:07:20.300Z","value":"1970-01-01T00:00Z"},{
"id":"cf5d1409-b274-38aa-8383-4cca0f6490a8","name":"source_for_next_start","timestamp":"2022-05-13T14:30:04.535Z","value":"week_timer"},{
"id":"4f7370ba-f210-3646-a8f8-c5c4db46cabe","name":"timestamp_next_start","timestamp":"2022-05-13T14:30:04.511Z","value":"2022-05-16T05:30Z"}],"type":"robotic_mower"},{
"id":"5ed53fd6-7e7f-358a-a963-ff8c4222fb63","name":"mower_stats","properties":[{
"id":"02835e56-73cc-3c4c-8fe4-ebc05647682a","name":"cutting_time","timestamp":"2022-05-13T14:33:49.343Z","unit":"h","value":100},{
"id":"521cf15f-b8fc-38d8-b362-c575536cb58e","name":"charging_cycles","timestamp":"2022-05-13T13:54:48.847Z","value":83},{
"id":"f977e5f3-b9f3-3abc-a759-643071bf39a8","name":"collisions","timestamp":"2022-05-13T10:55:52.025Z","value":99},{
"id":"f1cdda49-e6fd-3292-a989-039087278e36","name":"running_time","timestamp":"2022-05-13T14:33:49.260Z","unit":"h","value":107}],"type":"robotic_mower_stats"},{
"id":"76256bb1-7e3a-3e31-ac05-abea676d5635","name":"mower_type","properties":[{
"id":"6b7ec03e-0695-3946-aa9b-ac56b9d55ac5","name":"base_software_up_to_date","timestamp":"2022-05-10T22:07:20.217Z","value":true},{
"id":"0c2ffc1b-7e39-33e5-a4e3-6e69d629990b","name":"mmi_version","timestamp":"2022-05-10T22:07:19.808Z","value":"35.8"},{
"id":"8c4cb340-52a2-3eda-9652-e9bd5fa49d6f","name":"mainboard_version","timestamp":"2022-05-10T22:07:20.217Z","value":"35.13"},{
"id":"12ccd8aa-d9e5-3700-bb6a-baac401cdc86","name":"device_type","timestamp":"2022-05-10T22:07:20.238Z","value":"18"},{
"id":"039098ea-b88d-3de2-a83c-d45b5dfd6224","name":"device_variant","timestamp":"2022-05-10T22:07:20.259Z","value":"4"},{
[-=GEKUERZT=-]
2022.05.13 22:37:45 5: GardenaSmartBridge (Gardena_Bridge) - RequestERROR: http error 200
2022.05.13 22:37:45 4: GardenaSmartBridge (Gardena_Bridge) - set internal timer function for recall getDevices sub
2022.05.13 22:37:45 5: GardenaSmartBridge (Gardena_Bridge) - RequestERROR: received http code 200 receive Error after requesting gardena cloud

Wie schon erwähnt vermutlich habe ich das Problem seit die LONA-Zonen verfügbar sind, kann aber auch Zufall sein.
Kann es sein, dass hier irgendwas in die Binsen geht? Gerne stelle ich das vollständige JASON-Log per PM zur Verfügung.

Gruß
 sweetie-pie

Offline BOFH

  • Full Member
  • ***
  • Beiträge: 229
Hi zusammen,

sorry, ich stehe auf dem Schlauch:
Habe beim sensor2 im Internal STATE neben der Temperatur T: 00 °C,  und Feuchtigkeit H: 00 % auch einen Wert D: 00.0 stehen.
Im Reading state stehen nur „T: 00 °C H: 00 %“, auch sonst finde ich diesen ominösen D-Wert in keinem Reading.
Kann der Wert doch etwas mit der Helligkeit zu tun haben? evtl. aus der Zuordnung bei Gardena zur Geolocation?

vg

Ergänzung: der D-Wert existiert erst seit kurzem. Evtl. seit dem Gardena-Update des Sensors.

OK, hat sich erledigt. D ist vermutlich Dewpoint also der Taupunkt. Vielleicht kann der noch als Reading ergänzt werden.

Interessant. Schick doch mal bitte ein list deines sensors!
Ich tippe ja eher, dass du dewpoint in fhem aktiviert hast und der dort den D: irgendwo her zaubert
RasPi 4
ZWave.me ZME_UZB (Fibaro Auge Gen.2)/ HM-USB2 (Thermostat | Hutschienen Relais | 1-/2fach Schalter) / Enigma2 / PhilipsTV / Philips HUE (GO|Bulb|Stripe (plus)) / Somfy IO Rollos / BOSCH HSG636XS6 / SONOS (P1, P3, P5 2.Gen, SUB, Bar)

Offline BOFH

  • Full Member
  • ***
  • Beiträge: 229
Sorry, ich habe den Mäher immer noch nicht wieder am laufen:
Device gelöscht.
...
Gruß
 sweetie-pie

Device wird noch immer nicht angelegt? bei einem getDevicesState ?
RasPi 4
ZWave.me ZME_UZB (Fibaro Auge Gen.2)/ HM-USB2 (Thermostat | Hutschienen Relais | 1-/2fach Schalter) / Enigma2 / PhilipsTV / Philips HUE (GO|Bulb|Stripe (plus)) / Somfy IO Rollos / BOSCH HSG636XS6 / SONOS (P1, P3, P5 2.Gen, SUB, Bar)

Offline sweetie-pie

  • Full Member
  • ***
  • Beiträge: 104
Device wird noch immer nicht angelegt? bei einem getDevicesState ?

Nein, in der Bridge steht "devices 2". Angelegt wird leider nichts...  :(

In dem JSON String scheinen auch alle Daten vorhanden (s.o.), aber irgendwie wird das Gerät nicht angelegt.

Gruß
  sweetie-pie

Offline BOFH

  • Full Member
  • ***
  • Beiträge: 229
Nein, in der Bridge steht "devices 2". Angelegt wird leider nichts...  :(

In dem JSON String scheinen auch alle Daten vorhanden (s.o.), aber irgendwie wird das Gerät nicht angelegt.

Gruß
  sweetie-pie

stell mal bitte die bridge auf verbose 5  und mach ein getdevicesstate und PM mir mal bitte alle ausgaben im fhem log die mit
(GardenaSmartDevice) und (GardenaSmartBridge) zu tun haben

RasPi 4
ZWave.me ZME_UZB (Fibaro Auge Gen.2)/ HM-USB2 (Thermostat | Hutschienen Relais | 1-/2fach Schalter) / Enigma2 / PhilipsTV / Philips HUE (GO|Bulb|Stripe (plus)) / Somfy IO Rollos / BOSCH HSG636XS6 / SONOS (P1, P3, P5 2.Gen, SUB, Bar)

Offline BOFH

  • Full Member
  • ***
  • Beiträge: 229
für alle lona luxus geräte ... update kommt die tage ...

@sweetie-pie: pn bitte teste das mal, denke es geht :)
RasPi 4
ZWave.me ZME_UZB (Fibaro Auge Gen.2)/ HM-USB2 (Thermostat | Hutschienen Relais | 1-/2fach Schalter) / Enigma2 / PhilipsTV / Philips HUE (GO|Bulb|Stripe (plus)) / Somfy IO Rollos / BOSCH HSG636XS6 / SONOS (P1, P3, P5 2.Gen, SUB, Bar)
Gefällt mir Gefällt mir x 1 Liste anzeigen

Online sig10680

  • Jr. Member
  • **
  • Beiträge: 99
Hallo in die Runde,

aktuell nutze ich das Modul (74_HusqvarnaAutomower.pm) um meinen Automower zu Steuern. Aber leider wird das Modul nicht weiterentwickelt! Jetzt zu meiner Frage wenn ich einen Gardena Bridge einsetzen würde, könnte ich mit den beiden Modulen (73_GardenaSmartBridge, 74_GardenaSmartDevice) meinen Rasenroboter von Husqvarna steuern und Auslesen? Oder sind diese Module ausschließlich für Gardena Produkte.

mfg sig10680

Offline hhhdg

  • New Member
  • *
  • Beiträge: 7
Ich habe seit einigen Tagen das gleiche Problem mit meinem Lona Mäher (kein Update mehr aus der cloud, JSON Paket kommt jedoch an). Konnte der Patch schon getestet werden? Würde mich sonst auch für einen Test anbieten.
« Letzte Änderung: 21 Mai 2022, 17:49:52 von hhhdg »

Offline sweetie-pie

  • Full Member
  • ***
  • Beiträge: 104
Konnte der Patch schon getestet werden?

Ja, läuft stabil mit einem 2022er smarten SILENO life... ist aber wohl noch nicht im SVN.



Offline hhhdg

  • New Member
  • *
  • Beiträge: 7
sweetie-pie hatte mir den Patch weitergeleitet
Großen Dank an BOFH! Läuft bei mir ebenfalls wieder

Offline BOFH

  • Full Member
  • ***
  • Beiträge: 229
Bin aktuell im Urlaub...
wenn ich wieder da bin Stoß ich , lassen anstoßen, das Update Richtung svn. Macht cooltux dann :)

@sig10680. Muss man mal testen. Man hat die Chance die baseurl über ein Attribut zu setzten. Ich weiß aber nicht ob die dort ähnlich arbeiten wie Gardena. Gardena ist grundlegend husqvana aber ob die api identisch arbeiten weiß ich nicht. Eventuell würde hier die „große“ api eher greifen; nutzen wir nur nicht :)

Also kurz um. Testen ^^
RasPi 4
ZWave.me ZME_UZB (Fibaro Auge Gen.2)/ HM-USB2 (Thermostat | Hutschienen Relais | 1-/2fach Schalter) / Enigma2 / PhilipsTV / Philips HUE (GO|Bulb|Stripe (plus)) / Somfy IO Rollos / BOSCH HSG636XS6 / SONOS (P1, P3, P5 2.Gen, SUB, Bar)

Offline sn0000py

  • Developer
  • Full Member
  • ****
  • Beiträge: 450
Hallo ne Frage in die Runde - suche gerade eine Bewässerungssteuerung - aber soviel ich jetzt rausgelesen habe, geht Gardena nur per Cloud die Steuerung oder?

Bind da leider von Somfy/tahoma etwas cloud verbelastet - will daher auf jeden fall was cloud loses