Autor Thema: [gelöst] SmartVISU Database Plot Widget - (Anfänger-) Problem  (Gelesen 353 mal)

Offline anstroe

  • New Member
  • *
  • Beiträge: 13
Hallo zusammen,

ich habe das Widget von https://github.com/ToGe3688/db_plot_widget eingebunden.
Allerdings bekomme ich in SV folgende Fehlermeldung angezeigt:
"dbPlot Error (Update)
[dbPlot.widget]: SQLSTATE[HY000]: General error: 1 no such table: history"

Die Tabelle existiert, über Terminal kann ich sie mir anzeigen lassen.
Ich vermute entweder ein Rechteproblem oder ich habe doch etwas nicht richtig eingerichtet?!

Kann mir von euch jemand weiterhelfen?

Viele Grüße
Anne
« Letzte Änderung: 10 August 2017, 12:54:29 von anstroe »
Neuling mit Raspberry Pi 3B, FHEM 5.8, smartVISU 2.8, 2x Wago 750-841

Offline dev0

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2898
    • _.:|:._
Antw:SmartVISU Database Plot Widget - (Anfänger-) Problem
« Antwort #1 am: 10 August 2017, 11:06:49 »
Zitat
Ich vermute entweder ein Rechteproblem oder ich habe doch etwas nicht richtig eingerichtet?!
Dann solltest Du das kontrollieren. Ohne weitere Fakten wird das hier nur ein (lustiges?) Ratespiel.

Offline herrmannj

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4193
Antw:SmartVISU Database Plot Widget - (Anfänger-) Problem
« Antwort #2 am: 10 August 2017, 11:09:57 »
Verbindung *zur* DB richtig ? vmtl nein ...

#Ohne weitere Fakten wird das hier nur ein (lustiges?) Ratespiel.
smartVisu mit fronthem, einiges an HM, RFXTRX, Oregon, CUL, Homeeasy, ganz viele LED + Diverse

Offline anstroe

  • New Member
  • *
  • Beiträge: 13
Antw:SmartVISU Database Plot Widget - (Anfänger-) Problem
« Antwort #3 am: 10 August 2017, 12:23:53 »
entschuldigt bitte, den Screenshot mit den Rechten habe ich vergessen anzuhängen  ::)
zusätzlich noch ein Screenshot der widget_dbplot.config.php, diese ist ja (soweit ich das verstanden habe) für die Datenbankverbindung zuständig?!

Anne
« Letzte Änderung: 10 August 2017, 12:26:51 von anstroe »
Neuling mit Raspberry Pi 3B, FHEM 5.8, smartVISU 2.8, 2x Wago 750-841

Offline herrmannj

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4193
Antw:SmartVISU Database Plot Widget - (Anfänger-) Problem
« Antwort #4 am: 10 August 2017, 12:31:50 »
Die dB Verbindung ist sicher falsch. Sqlite und MySQL widersprechen sich ja schon
smartVisu mit fronthem, einiges an HM, RFXTRX, Oregon, CUL, Homeeasy, ganz viele LED + Diverse

Offline anstroe

  • New Member
  • *
  • Beiträge: 13
Antw:SmartVISU Database Plot Widget - (Anfänger-) Problem
« Antwort #5 am: 10 August 2017, 12:45:10 »
hmm ok, dachte wenn man als Typ 'sqlite' angibt verwendet er die zugehörigen Einstellungen... :-[
hab den MySQL Teil rausgenommen und den Webserver neu gestartet, leider immer noch das gleiche Problem.
Der angegebene Standardpfad entspricht meinem verwendeten Pfad.
Neuling mit Raspberry Pi 3B, FHEM 5.8, smartVISU 2.8, 2x Wago 750-841

Offline herrmannj

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4193
Antw:SmartVISU Database Plot Widget - (Anfänger-) Problem
« Antwort #6 am: 10 August 2017, 12:49:26 »
der Pfad ist doch in Deinem Screenshot auskommentiert ? Wir reden schon über sqlite, oder ?
smartVisu mit fronthem, einiges an HM, RFXTRX, Oregon, CUL, Homeeasy, ganz viele LED + Diverse

Offline anstroe

  • New Member
  • *
  • Beiträge: 13
Antw:SmartVISU Database Plot Widget - (Anfänger-) Problem
« Antwort #7 am: 10 August 2017, 12:54:09 »
oh weh, wie peinlich... Danke für deine Mühe! Jetzt funktioniert's natürlich!
Neuling mit Raspberry Pi 3B, FHEM 5.8, smartVISU 2.8, 2x Wago 750-841

Offline herrmannj

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4193
Antw:[gelöst] SmartVISU Database Plot Widget - (Anfänger-) Problem
« Antwort #8 am: 10 August 2017, 13:02:54 »
büddeschön  :)

Schön einarbeiten und dann viele tolle neue widgets beisteuern. Dann passt das schon  8)
smartVisu mit fronthem, einiges an HM, RFXTRX, Oregon, CUL, Homeeasy, ganz viele LED + Diverse
Gefällt mir Gefällt mir x 2 Liste anzeigen

Offline anstroe

  • New Member
  • *
  • Beiträge: 13
Antw:[gelöst] SmartVISU Database Plot Widget - (Anfänger-) Problem
« Antwort #9 am: 10 August 2017, 13:12:44 »
da muss ich meine Programmierkenntnisse in pyhton/perl noch ein bisschen ausbauen ;-)
Aber, wer weiß...
Ein paar Sachen funktionieren noch nicht so wie ich mir das vorstelle, da muss ich mich aber erst noch ein bisschen durchs Forum lesen. (Liegt mit an unserer Haussteuerung über Wago die über Modbus ausgelesen wird)
Neuling mit Raspberry Pi 3B, FHEM 5.8, smartVISU 2.8, 2x Wago 750-841

Offline dev0

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2898
    • _.:|:._
Antw:[gelöst] SmartVISU Database Plot Widget - (Anfänger-) Problem
« Antwort #10 am: 10 August 2017, 14:36:50 »
Zitat
da muss ich meine Programmierkenntnisse in pyhton/perl noch ein bisschen ausbauen ;-)
Für die Widgets nur html/js ;)