Autor Thema: RenaultZE  (Gelesen 26255 mal)

Offline martin2day

  • Full Member
  • ***
  • Beiträge: 135
Antw:RenaultZE
« Antwort #210 am: 07 August 2022, 20:30:09 »
Guten Abend,

vielen Dank für die tolle Arbeit. Installiert und läuft auf Anhieb auf einer neuen ZOE!!! 8)
Gibt es noch weitere Werte die man auslesen könnte... gerade der Zustand vom Akku würde mich sehr interessieren :-)

Euch einen schönen Abend
Gruß Martin

Offline plin

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 868
    • FHEM-Landschaft von plin
Antw:RenaultZE
« Antwort #211 am: 09 August 2022, 16:45:18 »
Gibt es noch weitere Werte die man auslesen könnte... gerade der Zustand vom Akku würde mich sehr interessieren :-)

Alles was Renault anbietet ist drin. Hast Du schon die Readings
- batteryAvailableEnergy
- batteryLevel
gesehen?

VG Peter
FHEM1 (Main) Raspi3b mit CUL, Homematic, SDUINO 433/OOK, zentrale Steuerung
FHEM2 (Keller) x86 mit CUL/hmland, IP-basierte Module
FHEM3 (Erdgeschoss) Raspi2 mit SDUINO 868/GFSK
FHEM4 (Hausanschlussraum), USV und OBIS-Modul
FHEM5 (Docker) mit FHEM2FHEM, InfluxDB

Offline Wolle02

  • Sr. Member
  • ****
  • Beiträge: 654
Antw:RenaultZE
« Antwort #212 am: 07 September 2022, 17:14:15 »
Seit gestern vormittag habe ich folgende Fehlermeldungen im Logfile:

2022.09.07 09:22:21 3: ERROR: (2) RenaultZE_gData_Step2, error (data) while calling https://api-wired-prod-1-euw1.wrd-aws.com/commerce/v1/accounts/82eb8973-7222-4df8-81a6-da9e810b2cc6/kamereon/kca/car-adapter/v1/cars/xxxxxxxxxxxxxxxxx/charge-mode?country=DE - errorCode=err.tech.wired.kamereon-proxy, errorMessage=Failed to forward request to remote service.
2022.09.07 09:22:21 3: INFO: pretty printing error errorCode=err.tech.wired.kamereon-proxy, errorMessage=Failed to forward request to remote service.
2022.09.07 09:22:21 3: ERROR: (2) RenaultZE_gData_Step2, error (data) while calling https://api-wired-prod-1-euw1.wrd-aws.com/commerce/v1/accounts/82eb8973-7222-4df8-81a6-da9e810b2cc6/kamereon/kca/car-adapter/v2/cars/xxxxxxxxxxxxxxxxxx/battery-status?country=DE - errorCode=err.tech.wired.kamereon-proxy, errorMessage=Failed to forward request to remote service.
2022.09.07 09:22:21 3: INFO: pretty printing error errorCode=err.tech.wired.kamereon-proxy, errorMessage=Failed to forward request to remote service.
2022.09.07 09:22:21 3: ERROR: (2) RenaultZE_gData_Step2, error (data) while calling https://api-wired-prod-1-euw1.wrd-aws.com/commerce/v1/accounts/82eb8973-7222-4df8-81a6-da9e810b2cc6/kamereon/kca/car-adapter/v1/cars/xxxxxxxxxxxxxxxxxx/cockpit?country=DE - errorCode=err.tech.wired.kamereon-proxy, errorMessage=Failed to forward request to remote service.
2022.09.07 09:22:21 3: INFO: pretty printing error errorCode=err.tech.wired.kamereon-proxy, errorMessage=Failed to forward request to remote service.

Seit heute nachmittag hat sich die Fehlermeldung geändert und sieht jetzt so aus:

2022.09.07 14:52:23 3: ERROR: (2) RenaultZE_gData_Step2, error (data) while calling https://api-wired-prod-1-euw1.wrd-aws.com/commerce/v1/accounts/82eb8973-7222-4df8-81a6-da9e810b2cc6/kamereon/kca/car-adapter/v1/cars/xxxxxxxxxxxxxxxxxxxxxx/charge-mode?country=DE - errorCode=err.func.404, errorMessage={"errors":[{"status":"Not Found","code":"404","title":"Unexpected error","detail":"VIN pseudonymization Vehicle identities not found"}]}
2022.09.07 14:52:23 3: INFO: pretty printing error errorCode=err.func.404, errorMessage={"errors":[{"status":"Not Found","code":"404","title":"Unexpected error","detail":"VIN pseudonymization Vehicle identities not found"}]}
2022.09.07 14:52:23 3: ERROR: (2) RenaultZE_gData_Step2, error (data) while calling https://api-wired-prod-1-euw1.wrd-aws.com/commerce/v1/accounts/82eb8973-7222-4df8-81a6-da9e810b2cc6/kamereon/kca/car-adapter/v1/cars/xxxxxxxxxxxxxxxxxxxxxx/cockpit?country=DE - errorCode=err.func.404, errorMessage={"errors":[{"status":"Not Found","code":"404","title":"Unexpected error","detail":"VIN pseudonymization Vehicle identities not found"}]}
2022.09.07 14:52:23 3: INFO: pretty printing error errorCode=err.func.404, errorMessage={"errors":[{"status":"Not Found","code":"404","title":"Unexpected error","detail":"VIN pseudonymization Vehicle identities not found"}]}
2022.09.07 14:52:23 3: ERROR: (2) RenaultZE_gData_Step2, error (data) while calling https://api-wired-prod-1-euw1.wrd-aws.com/commerce/v1/accounts/82eb8973-7222-4df8-81a6-da9e810b2cc6/kamereon/kca/car-adapter/v2/cars/xxxxxxxxxxxxxxxxxxxxx/battery-status?country=DE - errorCode=err.func.404, errorMessage={"errors":[{"status":"Not Found","code":"404","title":"Unexpected error","detail":"VIN pseudonymization Vehicle identities not found"}]}
2022.09.07 14:52:23 3: INFO: pretty printing error errorCode=err.func.404, errorMessage={"errors":[{"status":"Not Found","code":"404","title":"Unexpected error","detail":"VIN pseudonymization Vehicle identities not found"}]}

Seit heute nachmittag wird auch der SoC nicht mehr aktualisiert.

Hat da Renault wieder was an der API bzw. irgendwelchen Schlüsseln geändert?

Offline DocCyber

  • Full Member
  • ***
  • Beiträge: 486
Antw:RenaultZE
« Antwort #213 am: 07 September 2022, 17:54:00 »
Hallo zusammen,

Ich habe die selben Probleme bzw Fehlermeldungen wie Wolle02

Behandle die Menschen so, als wären sie, was sie sein sollten. Dadurch hilfst du ihnen zu werden, was sie sein können. (Goethe)


RPi-3 mit HM-CFG-LAN und jede Menge HM Komponenten.

Offline Wolle02

  • Sr. Member
  • ****
  • Beiträge: 654
Antw:RenaultZE
« Antwort #214 am: 08 September 2022, 06:38:37 »
Gestern abend änderte sich die Fehlermeldung nochmal, allerdings nur einmalig:

2022.09.07 18:52:39 3: RenaultZE_gData_Step2 - DataError <html>
<head><title>502 Bad Gateway</title></head>
<body>
<center><h1>502 Bad Gateway</h1></center>
</body>
</html>

2022.09.07 18:52:39 3: RenaultZE_gData_Step2 - DataError <html>
<head><title>502 Bad Gateway</title></head>
<body>
<center><h1>502 Bad Gateway</h1></center>
</body>
</html>

2022.09.07 18:52:39 3: RenaultZE_gData_Step2 - DataError <html>
<head><title>502 Bad Gateway</title></head>
<body>
<center><h1>502 Bad Gateway</h1></center>
</body>
</html>

Seither sind aber keine Fehlermeldungen mehr im Log und auch der SoC wird wieder aktualisiert. Scheinbar doch nur ein temporäres Problem bei Renault.

Offline Wolle02

  • Sr. Member
  • ****
  • Beiträge: 654
Antw:RenaultZE
« Antwort #215 am: 08 September 2022, 09:03:30 »
Zu früh gefreut. Heute morgen beim Laden wieder folgende Fehlermeldung:

2022.09.08 08:52:41 3: ERROR: (2) RenaultZE_gData_Step2, error (data) while calling https://api-wired-prod-1-euw1.wrd-aws.com/commerce/v1/accounts/82eb8973-7222-4df8-81a6-da9e810b2cc6/kamereon/kca/car-adapter/v2/cars/xxxxxxxxxxxxxxxxxxx/battery-status?country=DE - errorCode=err.tech.wired.kamereon-proxy, errorMessage=Failed to forward request to remote service.
2022.09.08 08:52:41 3: INFO: pretty printing error errorCode=err.tech.wired.kamereon-proxy, errorMessage=Failed to forward request to remote service.

Offline plin

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 868
    • FHEM-Landschaft von plin
Antw:RenaultZE
« Antwort #216 am: 08 September 2022, 18:24:22 »
Zu früh gefreut. Heute morgen beim Laden wieder folgende Fehlermeldung:

2022.09.08 08:52:41 3: ERROR: (2) RenaultZE_gData_Step2, error (data) while calling https://api-wired-prod-1-euw1.wrd-aws.com/commerce/v1/accounts/82eb8973-7222-4df8-81a6-da9e810b2cc6/kamereon/kca/car-adapter/v2/cars/xxxxxxxxxxxxxxxxxxx/battery-status?country=DE - errorCode=err.tech.wired.kamereon-proxy, errorMessage=Failed to forward request to remote service.
2022.09.08 08:52:41 3: INFO: pretty printing error errorCode=err.tech.wired.kamereon-proxy, errorMessage=Failed to forward request to remote service.

Ist das ein permanenter Zustand oder tritt die Meldung nur hin und wieder auf? Die Daten meiner Zoe können aktuell abgerufen werden.
FHEM1 (Main) Raspi3b mit CUL, Homematic, SDUINO 433/OOK, zentrale Steuerung
FHEM2 (Keller) x86 mit CUL/hmland, IP-basierte Module
FHEM3 (Erdgeschoss) Raspi2 mit SDUINO 868/GFSK
FHEM4 (Hausanschlussraum), USV und OBIS-Modul
FHEM5 (Docker) mit FHEM2FHEM, InfluxDB

Offline Wolle02

  • Sr. Member
  • ****
  • Beiträge: 654
Antw:RenaultZE
« Antwort #217 am: 08 September 2022, 18:46:10 »
Ist das ein permanenter Zustand oder tritt die Meldung nur hin und wieder auf? Die Daten meiner Zoe können aktuell abgerufen werden.

Das war jetzt tatsächlich heute morgen nur einmalig. Über den Tag trat dann keine weitere Fehlermeldung auf und der SoC wurde weiterhin aktualisiert. Erst heute Abend kam wieder diese Meldung:

2022.09.08 18:22:34 3: RenaultZE_gData_Step2 - DataError <html>
<head><title>502 Bad Gateway</title></head>
<body>
<center><h1>502 Bad Gateway</h1></center>
</body>
</html>

2022.09.08 18:22:34 3: RenaultZE_gData_Step2 - DataError <html>
<head><title>502 Bad Gateway</title></head>
<body>
<center><h1>502 Bad Gateway</h1></center>
</body>
</html>

2022.09.08 18:22:34 3: RenaultZE_gData_Step2 - DataError <html>
<head><title>502 Bad Gateway</title></head>
<body>
<center><h1>502 Bad Gateway</h1></center>
</body>
</html>

Auch wieder wie gestern so um 18 Uhr irgendwas.

Ich habe jetzt nochmal das Laden gestartet und sobald ein Batterie Statusupdate kommt, also z.B. 1 Prozent geladen kommt wieder diese Fehlermeldung:

2022.09.08 18:41:54 3: ERROR: RenaultZE_gData_Step2, error while calling https://api-wired-prod-1-euw1.wrd-aws.com/commerce/v1/accounts/82eb8973-7222-4df8-81a6-da9e810b2cc6/kamereon/kca/car-adapter/v2/cars/xxxxxxxxxxxxxxxxxxx/battery-status?country=DE - read from https://api-wired-prod-1-euw1.wrd-aws.com:443 timed out
2022.09.08 18:41:54 3: INFO: pretty printing error read from https://api-wired-prod-1-euw1.wrd-aws.com:443 timed out
2022.09.08 18:41:54 3: ERROR: RenaultZE_gData_Step2, error while calling https://api-wired-prod-1-euw1.wrd-aws.com/commerce/v1/accounts/82eb8973-7222-4df8-81a6-da9e810b2cc6/kamereon/kca/car-adapter/v1/cars/xxxxxxxxxxxxxxxxxxx/charge-mode?country=DE - read from https://api-wired-prod-1-euw1.wrd-aws.com:443 timed out
2022.09.08 18:41:54 3: INFO: pretty printing error read from https://api-wired-prod-1-euw1.wrd-aws.com:443 timed out
2022.09.08 18:41:54 3: ERROR: RenaultZE_gData_Step2, error while calling https://api-wired-prod-1-euw1.wrd-aws.com/commerce/v1/accounts/82eb8973-7222-4df8-81a6-da9e810b2cc6/kamereon/kca/car-adapter/v1/cars/xxxxxxxxxxxxxxxxxxx/cockpit?country=DE - read from https://api-wired-prod-1-euw1.wrd-aws.com:443 timed out
2022.09.08 18:41:54 3: INFO: pretty printing error read from https://api-wired-prod-1-euw1.wrd-aws.com:443 timed out

Offline Blablubblaber

  • Full Member
  • ***
  • Beiträge: 118
Antw:RenaultZE
« Antwort #218 am: 16 September 2022, 14:45:01 »
Hallo,

ich habe eben auch das Modul bei mir integriert und versucht es zum laufen zu bekommen.
Leider habe ich ebenfalls das Problem das es sich nicht verbindet.

Meldung:

   
{
  "callId": "xxxxxxxxxx",
  "errorCode": 400093,
  "errorDetails": "Missing required parameter: ApiKey",
  "errorMessage": "Invalid ApiKey parameter",
  "apiVersion": 2,
  "statusCode": 400,
  "statusReason": "Bad Request",
  "time": "2022-09-16T12:37:38.606Z"
}

habe leider im bisherigen Text keine Lösung finden können.

Und eine Anmerkung es wäre noch gut das attr disable mit auf zu nehmen damit man es deaktivieren kann wenn man es nicht braucht oder wie bei mir bis eine Lösung für das Problem gefunden wurde.

LG Dennis

Offline plin

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 868
    • FHEM-Landschaft von plin
Antw:RenaultZE
« Antwort #219 am: 16 September 2022, 17:19:22 »
Kannst Du mal ein LIST des Devices posten.
FHEM1 (Main) Raspi3b mit CUL, Homematic, SDUINO 433/OOK, zentrale Steuerung
FHEM2 (Keller) x86 mit CUL/hmland, IP-basierte Module
FHEM3 (Erdgeschoss) Raspi2 mit SDUINO 868/GFSK
FHEM4 (Hausanschlussraum), USV und OBIS-Modul
FHEM5 (Docker) mit FHEM2FHEM, InfluxDB

Offline plin

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 868
    • FHEM-Landschaft von plin
Antw:RenaultZE
« Antwort #220 am: 16 September 2022, 17:21:52 »
Ich habe jetzt nochmal das Laden gestartet und sobald ein Batterie Statusupdate kommt, also z.B. 1 Prozent geladen kommt wieder diese Fehlermeldung:
Wurde der Batteriestatus denn korrekt ausgelesen/gesetzt (zzgl. Fehlermeldung) oder kam nur die Fehlermeldung?

Ich muss bei mir noch mal gezielt einen Ladevorgang starten und mit meiner Entwicklungs-Instanz den Vorgang beobachten. Bei mir werden alle Daten während des Ladens korrekt ausgelesen.
FHEM1 (Main) Raspi3b mit CUL, Homematic, SDUINO 433/OOK, zentrale Steuerung
FHEM2 (Keller) x86 mit CUL/hmland, IP-basierte Module
FHEM3 (Erdgeschoss) Raspi2 mit SDUINO 868/GFSK
FHEM4 (Hausanschlussraum), USV und OBIS-Modul
FHEM5 (Docker) mit FHEM2FHEM, InfluxDB

Offline Wolle02

  • Sr. Member
  • ****
  • Beiträge: 654
Antw:RenaultZE
« Antwort #221 am: 16 September 2022, 17:56:56 »
Wurde der Batteriestatus denn korrekt ausgelesen/gesetzt (zzgl. Fehlermeldung) oder kam nur die Fehlermeldung?

Es kam nur die Fehlermeldung. Zu dem Zeitpunkt wurde der SoC nicht aktualisiert. Erst nach Beendigung des Ladevorgangs wurde der SoC wieder aktualisiert.
Ich habe aber seither auch nicht mehr geladen. Ich werde beim nächsten Laden nochmal schauen.

Offline Blablubblaber

  • Full Member
  • ***
  • Beiträge: 118
Antw:RenaultZE
« Antwort #222 am: 16 September 2022, 18:34:02 »
Jetzt läuft es.

Ein Update von FHEM hat Abhilfe geschaffen.
« Letzte Änderung: 16 September 2022, 19:34:18 von Blablubblaber »

 

decade-submarginal