Autor Thema: Neue Versionen und Support zum Modbus-Modul  (Gelesen 12111 mal)

Offline StefanStrobel

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 995
Antw:Neue Versionen und Support zum Modbus-Modul
« Antwort #15 am: 30 September 2017, 13:58:22 »
Hallo der-Lolo,

das sieht nach einem reload des Moduls aus.

Gruss
   Stefan

Online der-Lolo

  • Hero Member
  • *****
  • Beiträge: 1483
Antw:Neue Versionen und Support zum Modbus-Modul
« Antwort #16 am: 30 September 2017, 14:10:37 »
Das sollte also bzgl. der funktion des Moduls keine rolle spielen?

Offline StefanStrobel

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 995
Antw:Neue Versionen und Support zum Modbus-Modul
« Antwort #17 am: 02 Oktober 2017, 21:09:46 »
ich würde mich schon fragen, wo das herkommt, aber die Funktion sollte es nicht stören.

Gruss
   Stefan

Online der-Lolo

  • Hero Member
  • *****
  • Beiträge: 1483
Antw:Neue Versionen und Support zum Modbus-Modul
« Antwort #18 am: 02 Oktober 2017, 22:10:25 »
Ich hab gestern testweise auf einem Raspi3B mit stretch aufgesetzt, das funktioniert tadellos - angeschlossen an der Synology DiskStation funktioniert es aber nicht. Sehr eigenartig...

Offline Marie

  • Full Member
  • ***
  • Beiträge: 237
    • Marie's Blog
Antw:Neue Versionen und Support zum Modbus-Modul
« Antwort #19 am: 26 Oktober 2017, 09:20:31 »
Moin Stefan,


ich habe da mal eine Frage bzgl. des SET Befehls ScanModbusIds..lt commander gibt es den, bei Eingabe bekomme ich die Meldung "Befehl nicht verfügbar"... oder so. FHEM ist aktuell...


Hast Du eine Idee?


LG


Marie
Banana Pi & FHEM2FHEM Raspberry,RS485 Modbus Stromzähler UMG96, diverse Schaltsteckdosen 433 MHz, 868 MHz, MYSENSORS Temperatursensoren , Smartvisu, Homekit & Siri, Geofency, Zwave Rauchmelder & Steckdosen & Garagensteuerung, TabletUi mit BananaPi M2Ultra im Wohnmobil, Homebridge usw.usw.

Online der-Lolo

  • Hero Member
  • *****
  • Beiträge: 1483
Antw:Neue Versionen und Support zum Modbus-Modul
« Antwort #20 am: 26 Oktober 2017, 09:28:18 »
Ich glaube Du musst noch ein enabelControlSet Attribut beim Device, also nicht am Controller setzen...

Offline Marie

  • Full Member
  • ***
  • Beiträge: 237
    • Marie's Blog
Antw:Neue Versionen und Support zum Modbus-Modul
« Antwort #21 am: 26 Oktober 2017, 09:36:13 »
Moin,


ja das habe ich ja gemacht, aber interessanterweise gibt es in der Set-Liste diesen Befehl nicht obwohl er in der CommandRef beschrieben wird....
 
Banana Pi & FHEM2FHEM Raspberry,RS485 Modbus Stromzähler UMG96, diverse Schaltsteckdosen 433 MHz, 868 MHz, MYSENSORS Temperatursensoren , Smartvisu, Homekit & Siri, Geofency, Zwave Rauchmelder & Steckdosen & Garagensteuerung, TabletUi mit BananaPi M2Ultra im Wohnmobil, Homebridge usw.usw.

Online der-Lolo

  • Hero Member
  • *****
  • Beiträge: 1483
Antw:Neue Versionen und Support zum Modbus-Modul
« Antwort #22 am: 26 Oktober 2017, 09:38:12 »
und wenn du ihn von Hand eingibst?

Offline Marie

  • Full Member
  • ***
  • Beiträge: 237
    • Marie's Blog
Antw:Neue Versionen und Support zum Modbus-Modul
« Antwort #23 am: 26 Oktober 2017, 10:00:34 »
und wenn du ihn von Hand eingibst?


... kommt die Meldung "geht nicht"...


aber ich sehe gerade das steht nur Scan nach RS485-Teilnehmer... ich habe Modus over TCP...demnach dürfte das nicht gehen denke ich mal..schade..


LG


Marie
Banana Pi & FHEM2FHEM Raspberry,RS485 Modbus Stromzähler UMG96, diverse Schaltsteckdosen 433 MHz, 868 MHz, MYSENSORS Temperatursensoren , Smartvisu, Homekit & Siri, Geofency, Zwave Rauchmelder & Steckdosen & Garagensteuerung, TabletUi mit BananaPi M2Ultra im Wohnmobil, Homebridge usw.usw.

Offline StefanStrobel

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 995
Antw:Neue Versionen und Support zum Modbus-Modul
« Antwort #24 am: 26 Oktober 2017, 10:38:29 »
Dafür könnetst Du mit NMAP o.ä. nach IP-Adressen mit offenem TCP-Port 502 suchen.

Das Modbus-Modul kann dann für ein gegebenes Gerät die Register scannen.

Gruss
   Stefan

Offline Marie

  • Full Member
  • ***
  • Beiträge: 237
    • Marie's Blog
Antw:Neue Versionen und Support zum Modbus-Modul
« Antwort #25 am: 26 Oktober 2017, 10:52:44 »
Hallo Stefan,


das Problem war folgendes : kommuniziere mit einem Victron gateway (Solaranlage Wohnmobil) per Modus TCP. Leider ist die Doku von Victron für das Gateway nicht aktuell und so war mir nicht klar, wo welches Devices (ID) arbeitet. Aber ich habe mich mittlerweile auf die Console des Gateways gehackt und dort die Zuordnung gefunden..arbeite mich voran, so das ich gerade aktuell diesen Scan nicht mehr brauche... aber trotzdem danke Euch!


LG


Marie
Banana Pi & FHEM2FHEM Raspberry,RS485 Modbus Stromzähler UMG96, diverse Schaltsteckdosen 433 MHz, 868 MHz, MYSENSORS Temperatursensoren , Smartvisu, Homekit & Siri, Geofency, Zwave Rauchmelder & Steckdosen & Garagensteuerung, TabletUi mit BananaPi M2Ultra im Wohnmobil, Homebridge usw.usw.

Offline crispyduck

  • Full Member
  • ***
  • Beiträge: 229
Antw:Neue Versionen und Support zum Modbus-Modul
« Antwort #26 am: 30 Oktober 2017, 22:26:22 »
Hallo,

kann mir wer einen guten USB Modbus Adapter empfehlen?

Habe momentan so einen China RS485 Adapter im Einsatz, welcher zwar gut funktionoert, aber nach ein paar Wochen bekomme ich folgende dmesg Meldung und das Modbus Modul hört auf Readings upzudaten.

[122157.169334] ch341-uart ttyUSB0: usb_serial_generic_read_bulk_callback - urb stopped: -32
Nach einem FHEM Neustart geht wieder alles, wo sich das Modul da genau aufhängt weiß ich nicht, hab zwar schon oft probiert das ganze mit verbose 5 zu loggen, aber dann lief lustigerweise alles.

Eventuell kann man dort wo das Modul hängen bleibt ja noch ein Reload einbauen.

Aber mein eigentliches Problem ist wohl der Adapter, dachte erst es ist ein Stromproblem, aber nachdem dann auch der extern versorgte USB Hub nicht half, tippe ich mal darauf das es an dem Adapter selbst liegt.

Danke,
Crispyduck
« Letzte Änderung: 01 November 2017, 08:42:52 von crispyduck »

Offline pontiac

  • New Member
  • *
  • Beiträge: 5
Antw:Neue Versionen und Support zum Modbus-Modul
« Antwort #27 am: 06 Dezember 2017, 12:26:56 »
Hallo, mein erstes Post hier und gleich eine Frage.

Ich krieg meinen SolarLogPro Zähler nicht dazu über Modbus mit FHEM zu reden. Seit Tagen hab ich alles was hier und im alten Thread  steht ausprobiert, komme aber zu keinem vernünftigen Ergebniss.

Mit folgender Konfig bokomme ich ein paar Daten, immer mal wieder angezeigt, kann sie aber noch nicht mal zuordnen.
Kappiere einfach nicht die Registerabfrage.

define ModbusRS485 Modbus /dev/serial/by-id/usb-CTI_GmbH_Serial_Converter_CT1EI9EF-if00-port0@9600
attr ModbusRS485 devStateIcon disconnected:usb@red open:usb@green opened:usb@green

define Power ModbusAttr 1 20
attr Power userattr IODev dev-h-combine dev-h-defPoll dev-i-defFormat obj-h100-reading obj-h101-reading obj-h102-reading obj-h106-reading obj-h107-reading obj-h108-reading obj-h109-reading obj-h110-reading obj-h111-reading obj-h200-expr obj-h200-len obj-h200-reading obj-h201-expr obj-h201-len obj-h201-reading obj-h202-expr obj-h202-len obj-h202-reading obj-h206-expr obj-h206-reading obj-h207-expr obj-h207-reading obj-h208-expr obj-h208-reading obj-h209-expr obj-h209-reading obj-h21-expr obj-h210-expr obj-h210-reading obj-h211-expr obj-h211-reading obj-h279-expr obj-h279-reading obj-h280-expr obj-h280-reading obj-h281-expr obj-h281-reading obj-h40101-reading verbose
attr Power dev-h-combine 20
attr Power dev-h-defPoll 5

attr Power obj-h206-expr ($val/100)*4
attr Power obj-h206-reading Strom_L1
attr Power obj-h207-expr ($val/100)*4
attr Power obj-h207-reading Strom_L2
attr Power obj-h208-expr ($val * 4) /1000
attr Power obj-h208-reading Strom_L3
attr Power obj-h209-expr ($val * 4) / 1000
attr Power obj-h209-reading W_Leistung_L1
attr Power obj-h210-expr ($val * 4) / 1000
attr Power obj-h210-reading W_Leistung_L2
attr Power obj-h211-expr ($val * 4) / 1000
attr Power obj-h211-reading W_Leistung_L3
attr Power obj-h279-expr ($val * 4) / 100
attr Power obj-h279-reading Wirkleistung_gesamt
attr Power verbose 5

------------------------------------------------------
Strom_L1 2109.44 2017-12-06 11:58:00
Strom_L2 68 2017-12-06 11:58:00
Strom_L3 56.32 2017-12-06 11:58:00                 Ausgabe in Fhem
W_Leistung_L1 0 2017-12-06 11:58:00
W_Leistung_L2 0 2017-12-06 11:49:52
----------------------------------------------

Ist aber schon 30min. alt. Keine Aktualisierung.

Register vom Zähler, laut Anleitung:
RegisterAdress: 2008 5002 L1 Voltage Read Datablocks:4 Float Big Endian
RegisterAdress: 2068 500CL1 Current Read Datablocks:4 Float Big Endian
RegisterAdress: 2088 5014 L1 Avtice Power Read Datablocks:4 Float Big Endian

Hab mit format N n usw. getestet. Wenn ich meine Adressen 2008 bzw. 2007 usw. eingebe kommt nichts mehr.

Würde gerne im von mir einstellbaren Intervall alles von L1 des Zählers abfragen.

Helft mir bitte auf die Sprünge, ich verzweifele langsam. Viele ander Dinge hab ich am laufen, das hier ist mir im Moment zu hoch.

Offline Heuberg

  • Jr. Member
  • **
  • Beiträge: 84
Antw:Neue Versionen und Support zum Modbus-Modul
« Antwort #28 am: 06 Dezember 2017, 20:09:52 »
Hallo pontiac,

wie hast Du denn den Zähler angeschlossen?

Viele Grüße
Rainer

Offline pontiac

  • New Member
  • *
  • Beiträge: 5
Antw:Neue Versionen und Support zum Modbus-Modul
« Antwort #29 am: 06 Dezember 2017, 23:13:00 »
Hallo Rainer,
am Raspi den USB RS485 Dongle, an A/B, hier auch den Abschlußwiderstand, Zweidraht zum Zähler auf A/B, von dort auf A/B zum Solarlog 300.
Länge ca. 30cm Dongle zum Zähler, ca. 8m zum Solarlog. Solarlog liest einwandfrei den Zähler aus. Den Widerstand am Dongle, da der Solarlog mein Master sein muß, so hab ich es verstanden.

LG Jann