Autor Thema: CPU Last bei SVG bei 99%  (Gelesen 381 mal)

Offline Christian72D

  • Full Member
  • ***
  • Beiträge: 327
CPU Last bei SVG bei 99%
« am: 31 August 2017, 16:53:25 »
Ich habe das Problem daß mein RasPi 3 beim Zeichnen eines SVGs auf fast 100% CPU Last ansteigt, auch wenn nur zwei Werte der letzten 24h gezeichnet werden müssen.
Das hatte ich bis vor einiger Zeit nicht.

Jemand eine Idee was es sein könnte?

Offline amenomade

  • Hero Member
  • *****
  • Beiträge: 2033
Antw:CPU Last bei SVG bei 99%
« Antwort #1 am: 31 August 2017, 21:49:22 »
Ja, ich habe sogar mehrere Ideen.
FHEM 5.8 Pi 3, EchoDot, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, und HM Komponenten

F:"Schatz? Mach aus bitte"
M: "Alexa? Licht aus"-"Ich bin mir leider nicht sicher"  M:"Alexa? aus Licht"-"Das weiss ich leider nicht" M:"Alexa? Schalte...
F: "Drück mal auf den blöden Knopf!

Offline Christian72D

  • Full Member
  • ***
  • Beiträge: 327
Antw:CPU Last bei SVG bei 99%
« Antwort #2 am: 13 September 2017, 11:18:04 »
Lässt du mich auch an denen teilhaben?

Offline amenomade

  • Hero Member
  • *****
  • Beiträge: 2033
Antw:CPU Last bei SVG bei 99%
« Antwort #3 am: 13 September 2017, 12:44:41 »
Ja gerne. Die sind aber zu viele, um alle in einem Post zu schreiben. Deswegen wäre es nicht schlecht, deine Frage ein bisschen zu präzisieren, um die Möglichkeiten einzugrenzen:

- welche Versionen von Modulen?
- wie sieht die Definition des SVGs aus? plot Datei, usw.
- was gibt es für Werte zu zeichnen?
- nutzt Du FileLog oder DbLog?
- taucht etwas in der Haupt Log?
- was für ein Device ist es? Evtl. "list" des Devices, und "list" der Log Definition.
- hast Du longpollSVG aktiv?
- was hast du schon gemacht, um das Problem zu analysieren? Sysmon, apptime?

Je mehr Informationen Du lieferst, desto genauer können wir antworten.
FHEM 5.8 Pi 3, EchoDot, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, und HM Komponenten

F:"Schatz? Mach aus bitte"
M: "Alexa? Licht aus"-"Ich bin mir leider nicht sicher"  M:"Alexa? aus Licht"-"Das weiss ich leider nicht" M:"Alexa? Schalte...
F: "Drück mal auf den blöden Knopf!

Online kadettilac89

  • Full Member
  • ***
  • Beiträge: 469
Antw:CPU Last bei SVG bei 99%
« Antwort #4 am: 13 September 2017, 16:04:06 »

Jemand eine Idee was es sein könnte?

Hört sich nach DBLog ohne Suchindex an.

https://forum.fhem.de/index.php/topic,76451.0.html relevant?
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline amenomade

  • Hero Member
  • *****
  • Beiträge: 2033
Antw:CPU Last bei SVG bei 99%
« Antwort #5 am: 13 September 2017, 16:31:33 »
Zitat
DBLog ohne Suchindex an
Das ist natürlich eine Möglichkeit. Ein configCheck könnte auch helfen, die Ursache zu finden, wenn tatsächlich DbLog genutzt wird.

Deswegen die Fragen hieroben.
FHEM 5.8 Pi 3, EchoDot, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, und HM Komponenten

F:"Schatz? Mach aus bitte"
M: "Alexa? Licht aus"-"Ich bin mir leider nicht sicher"  M:"Alexa? aus Licht"-"Das weiss ich leider nicht" M:"Alexa? Schalte...
F: "Drück mal auf den blöden Knopf!

Offline Christian72D

  • Full Member
  • ***
  • Beiträge: 327
Antw:CPU Last bei SVG bei 99%
« Antwort #6 am: 13 September 2017, 16:33:04 »
Hört sich nach DBLog ohne Suchindex an.

DANKE, das wars!

Komisch, ist wohl erst seit Kurzem im Wiki, ich weiß daß ich es vor einem Jahr definitiv nach dem Wiki erstellt hatte und dieses Problem NICHT hatte.

Online kadettilac89

  • Full Member
  • ***
  • Beiträge: 469
Antw:CPU Last bei SVG bei 99%
« Antwort #7 am: 13 September 2017, 17:31:03 »
Komisch, ist wohl erst seit Kurzem im Wiki, ich weiß daß ich es vor einem Jahr definitiv nach dem Wiki erstellt hatte und dieses Problem NICHT hatte.

Ist jetzt nur Raten ... entweder Index gab es und wurde durch irgend welche Aktionen entfernt, oder es gab ihn nicht und die DB hat durch Updates irgend etwas geändert.

Bei Tabellenzugriffen ohne Index ist irgendwann eine kritische Masse erreicht ab wann sich ein Zugriff extrem verlangsamt. Vielleicht hat sich die DB bei dir schnell vergrößert durch ungünstiges Loggen. Wie gesagt .. Rätselraten.

Offline Christian72D

  • Full Member
  • ***
  • Beiträge: 327
Antw:CPU Last bei SVG bei 99%
« Antwort #8 am: 14 September 2017, 12:32:22 »
Wie gesagt: der Eintrag mit dem INDEX ist ja erst vor Kurzem ins Wiki gekommen.
Vorher lief dbLog bestimmt schon ein Jahr auf dem alten Gerät, da ich es nach dem Wiki gemacht hatte kann das mit dem INDEX eigentlich nicht bei mir drin gewesen sein, trotzdem lief es super flott.

Online Deckoffizier

  • Full Member
  • ***
  • Beiträge: 179
Antw:CPU Last bei SVG bei 99%
« Antwort #9 am: 14 September 2017, 15:48:14 »
Hallo amenomade,

nochmal aus cmdref zu set <name> configCheck

Dieser Check prüft einige wichtige Einstellungen des DbLog-Devices und gibt Empfehlungen für potentielle Verbesserungen. (verfügbar für MySQL, PostgreSQL)

falls SQLite ?

Gruß
Hans-Jürgen


FHEM 5.8 auf RasPI B+ mit CUL 868MHz, CUL 433 MHZ,1 Wire USB Busmaster, diverse 1 Wire Sensoren

Offline amenomade

  • Hero Member
  • *****
  • Beiträge: 2033
Antw:CPU Last bei SVG bei 99%
« Antwort #10 am: 14 September 2017, 16:25:08 »
Ne, für SQlite geht es m.W. nicht. Aber wie soll ich wissen, dass du SQlite nutzt? Das ist der Sinn meiner ersten Antwort: um genaue Antworte und Hilfe zu bekommen, muss man mehr genauere Information liefern.
« Letzte Änderung: 14 September 2017, 16:27:30 von amenomade »
FHEM 5.8 Pi 3, EchoDot, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, und HM Komponenten

F:"Schatz? Mach aus bitte"
M: "Alexa? Licht aus"-"Ich bin mir leider nicht sicher"  M:"Alexa? aus Licht"-"Das weiss ich leider nicht" M:"Alexa? Schalte...
F: "Drück mal auf den blöden Knopf!

 

decade-submarginal