Autor Thema: ( gelöst ) Keine Icons mehr im WebIF  (Gelesen 1044 mal)

Offline Neuhier

  • Full Member
  • ***
  • Beiträge: 415
( gelöst ) Keine Icons mehr im WebIF
« am: 05 September 2017, 23:32:48 »
Habe seit ca. 2 Wochen das Problem, daß z.B. Icon on.png und off.png im Pfad ./www/images/default liegen, aber nicht angezeigt werden.
Stattdessen wird nur on.svg und off.svg verwendet.

Also getestet und den WebIF gesagt, daß es im Pfad nur noch den Ordner default gibt.
Jetzt werden ( logischer Weise ) gar keine Icon mehr angezeigt.

Nutze FF 55.0.3 und auch der Cache ist ausgekippt worden.

Es fehlen in der Übersicht auch z.B. die Windrosen aus dem weather-Ordner.
Im Explorer und auch per FTP sind alle Icons da, nur im WebIF nicht.

Ach so, das ist seit ich den Tip aus dem Wiki genutzt und im WebIF:
Zitat
attr WEB iconPath fhemSVG:openautomation:default:icons_small
eingetragen habe.
« Letzte Änderung: 05 September 2017, 23:56:39 von Neuhier »
Hilfreich Hilfreich x 1 Liste anzeigen

Offline Fixel2012

  • Hero Member
  • *****
  • Beiträge: 1218
Antw:Keine Icons mehr im WebIF
« Antwort #1 am: 05 September 2017, 23:36:13 »
Das erste was mir dazu einfällt:

Sind vielleicht die nötigen Rechte nicht gesetzt?
Fhem 5.8 auf Raspi 3, HMLAN und 868MHz CUL mit einigen Komponenten, Z-Wave Rollladenaktoren, Tablet UI, 433 MHz CUL mit Baumarktsteckdosen und Temp Sensoren, Amazon Echo, Echo Dot, 2x SONOS  play1, 1x SONOS Connect AMP,  presence, HUE, Lightify

Offline Neuhier

  • Full Member
  • ***
  • Beiträge: 415
Antw:Keine Icons mehr im WebIF
« Antwort #2 am: 05 September 2017, 23:41:58 »
Der Ordner ./www/images hat die Rechte 755 inclusive Unterordner.
Dachte auch, daß es daran liegen könnte, ist aber nicht der Fall.


Hier hat geholfen:
Pfad komplett entfernen - Restart - Pfad neu eingegeben - Restart
Jetzt ist on.png und off.png wieder in der Übersicht, die Windrosen noch immer nicht.

Kann es sein, daß die nur im Smartphone sichtbar sind?
Wäre eine Erklärung.
« Letzte Änderung: 05 September 2017, 23:56:10 von Neuhier »

 

decade-submarginal