Autor Thema: Mehrere TFA 30.3215 Außensensoren funken auf das gleiche Device  (Gelesen 487 mal)

Offline the_noltens

  • New Member
  • *
  • Beiträge: 26
Hallo zusammen,
ich bin noch recht neu mit FHEM unterwegs und bin hier gerade am Verzweifeln. Ich habe mir drei Außensensoren von TFA gekauft.
Also in den ersten die Batterien eingelegt und das Ding fängt an zu funken und via autocreate als Gerät TCM9700_144 auch angelegt.
Jetzt habe ich im zweiten Sensor die Batterien eingelegt, aber hier wurde kein neues Gerät angelegt. Ich habe festgestellt, dass der zweite Sender, den ich durch den Kanal unterscheiden kann, auf das gleiche Gerät sendet.
Hier der Auszug aus dem EventMonitor:
017-09-07 23:41:40 CUL_TCM97001 DR.Aussensensor channel: 1
2017-09-07 23:41:40 CUL_TCM97001 DR.Aussensensor temperature: 23.3
2017-09-07 23:41:40 CUL_TCM97001 DR.Aussensensor humidity: 59
2017-09-07 23:41:40 CUL_TCM97001 DR.Aussensensor T: 23.3 H: 59
2017-09-07 23:41:45 CUL_TCM97001 DR.Aussensensor channel: 0
2017-09-07 23:41:45 CUL_TCM97001 DR.Aussensensor temperature: 14.5
2017-09-07 23:41:45 CUL_TCM97001 DR.Aussensensor humidity: 75
2017-09-07 23:41:45 CUL_TCM97001 DR.Aussensensor T: 14.5 H: 75

Hier das Device:
Internals:
   CFGFN
   CHANGED
   CODE       CUL_TCM97001_144
   CUL2_MSGCNT 7318
   CUL2_RAWMSG s90800904B8DD;  512: 8528
   CUL2_TIME  2017-09-07 23:53:25
   DEF        CUL_TCM97001_144
   LASTInputDev CUL2
   MSGCNT     7318
   NAME       DR.Aussensensor
   NR         1260
   RSSI       -91.5
   STATE      T: 14.4 H: 75
   TYPE       CUL_TCM97001
   lastH      0
   lastT      1504821205
   Helper:
     DBLOG:
       battery:
         DBLogging:
           TIME       1504455113.94599
           VALUE      ok
       channel:
         DBLogging:
           TIME       1504820505.05607
           VALUE      0
       humidity:
         DBLogging:
           TIME       1504820905.04306
           VALUE      75
       mode:
         DBLogging:
           TIME       1504242179.57707
           VALUE      normal
       state:
         DBLogging:
           TIME       1504821055.03863
           VALUE      T: 14.4 H: 75
       temperature:
         DBLogging:
           TIME       1504821055.03863
           VALUE      14.4
   READINGS:
     2017-09-03 18:11:53   battery         ok
     2017-09-07 23:41:45   channel         0
     2017-09-07 23:53:25   humidity        75
     2017-09-01 07:02:59   mode            normal
     2017-09-07 23:53:25   state           T: 14.4 H: 75
     2017-09-07 23:53:25   temperature     14.4
Attributes:
   alias      WetterAussensensor
   event-min-interval .*:300
   event-on-change-reading .*
   group      Wetter
   icon       temperature_humidity
   model      Prologue
Was muss ich tun, damit die Sensoren als separate Geräte angelegt werden?
Ich habe die Suchmaschinen schon gequält, finde aber nichts passendes?

Offline amenomade

  • Hero Member
  • *****
  • Beiträge: 2033
Antw:Mehrere TFA 30.3215 Außensensoren funken auf das gleiche Device
« Antwort #1 am: 08 September 2017, 02:52:19 »
Wenn beide Geräte die gleiche ersten zwei HEX Werte in den Packeten schicken, sehe ich keine einfache Lösung, da

Zitat von: CommandREF
Die empfangenen Sensoren werden automatisch angelegt.
Die ID der angelgten Sensoren sind die ersten zwei HEX Werte des empfangenen Paketes in dezimaler Schreibweise.

Zitat
CUL2_RAWMSG s90800904B8DD;
x90 = 144 => CUL_TCM97001_144

Vielleicht hilft dieses Thread: https://forum.fhem.de/index.php?topic=43704.0. Hab nicht im Code geschaut.
FHEM 5.8 Pi 3, EchoDot, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, und HM Komponenten

F:"Schatz? Mach aus bitte"
M: "Alexa? Licht aus"-"Ich bin mir leider nicht sicher"  M:"Alexa? aus Licht"-"Das weiss ich leider nicht" M:"Alexa? Schalte...
F: "Drück mal auf den blöden Knopf!

Offline the_noltens

  • New Member
  • *
  • Beiträge: 26
Antw:Mehrere TFA 30.3215 Außensensoren funken auf das gleiche Device
« Antwort #2 am: 10 September 2017, 21:57:05 »
Gibt es das wirklich, dass alle drei Sensoren mit den gleichen Hex-Werten senden? Ist das bei anderen Aussensensoren auch so?

Online mahowi

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 865
Antw:Mehrere TFA 30.3215 Außensensoren funken auf das gleiche Device
« Antwort #3 am: 11 September 2017, 05:10:57 »
Es kann sein, daß die Sensoren eine feste ID haben und sich nur einzeln nutzen lassen. So welche hatte ich auch schon. Lässt sich auch mit dem TFA-Support klären, die antworten in der Regel recht flott.
 
CUBe (MAX): HT, FK | CUBe (SlowRF): ESA2000WZ
JeeLink: LaCrosse | nanoCUL433: Smartwares SHS-51001-EU, EM1000GZ
ZME_UZB1: GreenWave PowerNode, Popp Thermostat | SIGNALDuino: HE877, X10 MS14A, Revolt NC-5462,  IT Steckdosen + PIR
tado° | Milight | HUE, Lightify | SmarterCoffee

Offline chris1284

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3647
Antw:Mehrere TFA 30.3215 Außensensoren funken auf das gleiche Device
« Antwort #4 am: 11 September 2017, 06:26:27 »
einfach mal bei einem sensor die batterien raus und schauen ob er dann eine neu id generiert beim wieder einlegen. hatte auch mal 6 ähnliche sensoren und musste um allen eindeutige ids zu verpassen mehrmals die batterien neu einlegen
#HP Proliant MicroServer Gen8: FHEM, SAMBA, PLEX
#CCU2 + HMLAN: Heizung, Schalter, Sensoren, Remotes
#nanoCUL868: lacrossmode für Außensensor
#culCUBE868,signalduino,nanoCUL433: die lauschen nur

Offline the_noltens

  • New Member
  • *
  • Beiträge: 26
Antw:Mehrere TFA 30.3215 Außensensoren funken auf das gleiche Device
« Antwort #5 am: 11 September 2017, 22:33:29 »
einfach mal bei einem sensor die batterien raus und schauen ob er dann eine neu id generiert beim wieder einlegen. hatte auch mal 6 ähnliche sensoren und musste um allen eindeutige ids zu verpassen mehrmals die batterien neu einlegen
Das mit dem Batterien rausnehmen habe ich schon probiert. Klappt leider nicht.
Ich werde die Dinger zurückschicken und mir welche mit Display holen. Dann kann ich die Temperatur und Luftfeuchtigkeit gleich vom Gerät ablesen.
Danke für eure Hilfe.