Autor Thema: (mal wieder...) Devolo MT2650 (Danfoss LC13)  (Gelesen 966 mal)

Offline Aut0mat0r

  • Newbie
  • Beiträge: 2
(mal wieder...) Devolo MT2650 (Danfoss LC13)
« am: 30 Oktober 2017, 14:41:25 »
Hallo zusammen,

zunächst einmal ein großes Kompliment an die Entwickler von FHEM, sowie die großartige Community :-)
Ihr kennt mich zwar noch nicht (erster Beitrag), aber ich verfolge dieses Forum schon längere Zeit, momentan hauptsächlich wegen meines Problemes mit einem Devolo MT2650 Heizungsthermostat (Danfoss LC13).

Wie bereits bei einigen anderen auch erhalte ich nach einer Inkludierung des Thermostats nach ca. 1-2 Std. auf fast allen Thermostaten den Fehler "E5".

Ich habe schon so gut wie alle Foren-Threads durchsucht und alle Tipps berherzigt und versucht. Erkennbar war hierbei auch, dass das Problem ca. Anfang / Mitte 2016 mit einem FHEM-Update anscheinend (vorrübergehend) gelöst wurde ? Zumindestens hatte in diesem Zeitraum keiner mehr neue Threads eröffnet... Oder ich habe sie nicht gefunden ;-)

Okay... Also folgendes habe ich bereits versucht:

1. Akkus am Thermostat herausnehmen, erneut einsetzen und unmittelbar, als ersten Command das Wakeup-Intervall angepasst (set ZWave_Thermostat_Kueche wakeupInterval 300 1), um wie in der Bedienungsanleitung gefordert ein korrektes Routing zu setzen --> Ergebnis: Fehler E5

2. Verwendung des at-Befehles zum regelmäßigen Abholen der bspw. Battery-Eigenschaft alle 30 Minuten (defmod ZWave_Fix_Danfoss_LC13_ConnectionLost_Bug_GetWakeup at +*00:30 get ZWave_Thermostat.* wakeupInterval ;;;; get ZWave_Thermostat.* battery ;;;; get ZWave_Thermostat.* setpoint), um aktiv das Gerät abzufragen --> Ergebnis: Fehler E5

3. Anpassung der Prozesspriorität von perl / fhem (renice) um auszuschließen, dass ggf. Timing-Probleme auftreten. Auf dem Host-System laufen noch ein paar andere, regelmäßige Tasks, die ab und zu eine hohe CPU-Last für kurze Momente erzeugen. --> Ergebnis: Fehler E5

4. Verwendung der Option "useMultiCmd" (attr ZWave_Thermostat_Kueche useMultiCmd 1), wie in der Bedienungsanleitung des Devices gefordert --> Ergebnis: Fehler E5

5. Exkludieren und Inkludieren eines Test-Thermostats --> Ergebnis: Fehler E5

6. Ich habe auch vereinzelt schon damit rumprobiert, mittels eines DOIF immer einen wakeupNoMoreInformation an das Device zu senden, sobald dieses einen Mucks von sich gibt. Das hatte aber leider ebenfalls nicht funktioniert... E5 (([ZWave_THERMOSTAT_23:wakeup]) (get ZWave_THERMOSTAT_23 battery,set ZWave_THERMOSTAT_23 wakeupNoMoreInformation))


Auffällig ist:
1. Wenn der Fehler E5 im Display steht, reported das Thermostat weiterhin die Werte Battery / Temperatur / ccsOverride usw... Allerdings OHNE eine anschließende Wakeup-Notification, welche eine Bereitschaft des Gerätes zu FHEM signalisiert

2. Wenn der Fehler E5 im Display steht kann dieser vereinzelt durch Drücken der "Wärmer" + "Kälter" - Buttons aufgehoben werden, d.h. eine Zeit lang scheint das Thermostat wieder normal zu laufen, bis dann erneut ein E5 erscheint. Es werden auch Befehle angenommen...

3. Andere Geräte (zwei Aaeon Multisensoren + Fibaro Wall Plug + Fibaro Binary Sensor) funktionieren ohne Probleme und liefern regelmäßig eine Wakeup-Notification + Werte. Hier sind keine Ausfälle zu finden.

Frage:
Gibt es noch weitere Möglichkeiten, die ich ausprobieren könnte?
Ich bin so langsam echt am verzweifeln und möchte ungern meine ca. 13 Thermostate demontieren müssen :-(

Gerne stelle ich auch entsprechende Logfiles / Konfigurationen bereit. Bitte sagt mir hier am besten, was genau benötigt wird, da mir das "Debugging" und die damit verbundenen Informationen noch nicht so geläufig sind :-)

Verwendete FHEM-Version:
Latest Revision: 15350

File                Rev   Last Change

fhem.pl             15294 2017-10-20 06:40:24Z rudolfkoenig
96_allowed.pm       14888 2017-08-13 12:07:12Z rudolfkoenig
90_at.pm            14995 2017-09-03 14:23:14Z rudolfkoenig
98_autocreate.pm    15038 2017-09-10 10:00:18Z rudolfkoenig
95_Dashboard.pm     12251 2016-10-03 09:45:43Z talkabout
93_DbLog.pm         15297 2017-10-20 20:59:52Z DS_Starter
98_DOIF.pm          14790 2017-07-26 10:27:41Z Damian
98_dummy.pm         12700 2016-12-02 16:49:42Z rudolfkoenig
91_eventTypes.pm    14888 2017-08-13 12:07:12Z rudolfkoenig
01_FHEMWEB.pm       15328 2017-10-27 10:51:17Z rudolfkoenig
92_FileLog.pm       14888 2017-08-13 12:07:12Z rudolfkoenig
98_logProxy.pm      13399 2017-02-12 13:00:43Z justme1968
98_monitoring.pm    15160 2017-10-01 10:17:12Z igami
91_notify.pm        14888 2017-08-13 12:07:12Z rudolfkoenig
33_readingsGroup.pm 15100 2017-09-19 21:21:27Z justme1968
99_SUNRISE_EL.pm    14888 2017-08-13 12:07:12Z rudolfkoenig
98_SVG.pm           14888 2017-08-13 12:07:12Z rudolfkoenig
98_telnet.pm        15006 2017-09-05 09:37:33Z rudolfkoenig
99_Utils.pm         13259 2017-01-28 17:39:39Z rudolfkoenig
98_version.pm       15140 2017-09-26 09:20:09Z markusbloch
59_Weather.pm       12559 2016-11-13 08:54:54Z borisneubert
98_weblink.pm       14888 2017-08-13 12:07:12Z rudolfkoenig
98_XmlList.pm       13128 2017-01-17 21:40:09Z rudolfkoenig
10_ZWave.pm         15295 2017-10-20 07:03:57Z rudolfkoenig
00_ZWDongle.pm      15181 2017-10-03 10:33:02Z rudolfkoenig

Blocking.pm         15200 2017-10-05 08:27:30Z rudolfkoenig
DevIo.pm            14933 2017-08-20 14:21:58Z rudolfkoenig
HttpUtils.pm        15284 2017-10-18 19:46:13Z rudolfkoenig
myUtilsTemplate.pm   7570 2015-01-14 18:31:44Z rudolfkoenig
RTypes.pm           10476 2016-01-12 21:03:33Z borisneubert
SetExtensions.pm    12935 2017-01-02 19:51:46Z rudolfkoenig
TcpServerUtils.pm   14862 2017-08-07 15:16:03Z rudolfkoenig
YahooWeatherAPI.pm  12465 2016-10-29 09:01:31Z borisneubert
ZWLib.pm            12651 2016-11-25 15:12:14Z rudolfkoenig

fhemweb.js                 15228 2017-10-10 17:34:56Z rudolfkoenig
fhemweb_readingsGroup.js   15189 2017-10-03 17:53:27Z justme1968
svg.js                     13579 2017-03-02 12:39:59Z rudolfkoenig

Vielen Dank schon jetzt im Voraus und Gruß,
Wolfgang aka Aut0mat0r

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 19335
Antw:(mal wieder...) Devolo MT2650 (Danfoss LC13)
« Antwort #1 am: 30 Oktober 2017, 18:42:56 »
Zitat
Erkennbar war hierbei auch, dass das Problem ca. Anfang / Mitte 2016 mit einem FHEM-Update anscheinend (vorrübergehend) gelöst wurde ? Zumindestens hatte in diesem Zeitraum keiner mehr neue Threads eröffnet... Oder ich habe sie nicht gefunden ;-)

Oder man hat einfach entnervt aufgegeben :)

1: Falls die Inklusion geklappt hat, dann sollte der ZWave Controller mit dem Thermostat reden koennen => Verstehe den Grund fuer diese Aktion nicht
2: Eine "Massenabfrage" von 13 Thermostaten mit jeweils 3 Befehlen ist eher kontraproduktiv, ja nach Topologie sind da mind. 156 Funktelegramme unterwegs, wenn Routing Knoten dazwischen sind, dann deutlich mehr. Ich wuerde zunaechst mit einem Geraet testen, ob das hilft, und wenn ja, versuchen auf eine Abfrage zu reduzieren. Danach die Geraete einzeln mit Verzoegerung abfragen.
4. useMultiCmd kann die Funklast reduzieren, indem es mehrere Befehle zum gleichen Knoten zusammenfasst. Kann man machen, wenn man bei Punkt 2. was erreicht hat, und die Reduzierung auf einem Befehl schiefgegangen ist.
6. Das hat zur Folge: falls das Geraet nicht wach ist, ist es egal, und wenn es wach ist, wird es schlafengelegt. Wuerde mich wundern, wenn das der Zauberwort ist, um E5 zu vermeiden.

Ich wuerde eine "Devolo-kompatible" Software besorgen, und den per Usb-Sniffer 2-3 Stunden lang protokollieren. Ja, mir ist es bewusst, dass es aufwendig ist, aber sonst haetten wir ja schon eine Loesung :)

Offline tomspatz

  • Sr. Member
  • ****
  • Beiträge: 505
Antw:(mal wieder...) Devolo MT2650 (Danfoss LC13)
« Antwort #2 am: 30 Oktober 2017, 19:07:35 »
@Wolfgang
Du schreibst
Zitat
Akkus am Thermostat herausnehmen, erneut einsetzen

Schon mal mit Batterien probiert?
Ohne klugzuscheissern aber das macht schon einen Unterschied.

LG
Tom

Offline Aut0mat0r

  • Newbie
  • Beiträge: 2
Antw:(mal wieder...) Devolo MT2650 (Danfoss LC13)
« Antwort #3 am: 04 November 2017, 12:13:28 »
Hallo zusammen,

vielen Dank für die Rückmeldungen.

@rudolfkoenig:
zu #1: Die Re-Inklusion hatte ich nur deshalb versucht, weil ich zuerst dachte, dass sich das Thermostat irgendwie "aufgehangen" hat und ggf. einfach nur spinnt. Mehr war da nicht dahinter ;-)
zu #2: Ich werde im Laufe des Wochenendes mal ein paar Thermostate außer Betrieb nehmen und prüfen, wie sich das Netz dann insgesamt verhält. In der Tat habe ich ganz vergessen, dass hier noch ein Aaeon Repeater für das OG installiert und inkludiert ist. Ich habe aktuell überhaupt keine Erfahrungen, wie viele Funk-Telegramme für ein Netzwerk zu viel oder genau richtig sind. Hast Du da ggf. ein paar Richtwerte, oder eine Doku, wo man das nachlesen könnte? + Ich bin davon ausgegangen, dass ZWave ja immer mit Bestätigungen arbeitet, d.h. wenn zwei Telegramme "kollidieren" sollten, dann würde ja theoretisch versucht werden, dieses erneut abzusetzen... Hmmm....
zu #6: Ja, Du hast recht. Im Nachhinein war das keine gute Idee und hat die Devices dann teilweise zu schnell schlafen gelegt. Aber es war ein Versuch... In der Not probiert man alles und der Winter kommt ja näher.

@tomspatz:
Danke für den Hinweis, werde ich versuchen :-) Ich müsste irgendwo sogar noch ein paar Akkus haben.

Ich melde mich nochmal, sobald ich mit weniger Devices ein paar Test-Zyklen machen konnte.

Bis dahin VG und ein schönes Wochenende!

Gruß,
Wolfgang

Offline Hash99

  • New Member
  • *
  • Beiträge: 17
Antw:(mal wieder...) Devolo MT2650 (Danfoss LC13)
« Antwort #4 am: 23 Mai 2018, 13:07:44 »
Hi Wolfgang,

leider hast Du das Thema nicht mehr upgedated. Konntest Du das Problem lösen? Für ein kurzes Statement wäre ich dankbar.
Gruß
Helmut