Autor Thema: SCC mit aktueller a-culfw "out of the box" flashen?  (Gelesen 102 mal)

Offline M_I_B

  • Sr. Member
  • ****
  • Beiträge: 727
  • ... Biker essen keinen Honig; die kauen Bienen!
SCC mit aktueller a-culfw "out of the box" flashen?
« am: 07 Dezember 2017, 10:03:23 »
Morgähn ...

Ich habe derzeit zwei SCC auf einem RPi2b am laufen (IT, HM), angesteuert per VCCU vom Server via LAN; auf dem "Funk-PI" selber läuft kein FHEM (wozu auch), sondern stumpf Debian light headless in der aktuellen Version. Die SCC hatte ich seinerzeit mit der a-culfw geflasht (schon ne Weile her).

Im Zusammenhang mit dem Erhalt von 10 MAX-ECO-Tastern habe ich mir nun einen dritten SCC bestellt, der die Tage aufschlagen sollte. Dort würde ich auch gerne die aktuelle a-culfw drauf bringen, das aber gerne "out of the box", also unabhängig von FHEM, dem RPi und Debian. Am liebsten wäre mir eine Option, den per serieller Schnittstelle an meinen PC zu pappen und dann die Firmware drauf zu bügeln. Das aktuelle Archiv (1.26.01.272) liegt hier vor...

Frage 1:
Wie stellt man so was an? Wenn ich mich recht erinnere, haben die SCC sogar eine (unbestückte) Schnittstelle/ICP zu einem Programmer?!? Könnte man die dafür hernehmen? Und wenn ja, welches Environment benötige ich dazu (unter WIN7x64)?

Frage 2:
Ich kann mich leider nicht mehr daran erinnern, wie ich seinerzeit die a-culfw auf die SCC bekommen habe. Auch ein intensives Stöbern im Forum und im Wiki hat mich da nicht weiter gebracht; es scheint keine entsprechende Anleitung für Dummy's zu geben? Wenn doch, wo denn?
Oder war es einfach stumpf damit getan, die Taste zu drücken und in der Shell/SSH die Flash.sh auszuführen?

DLzG
Micha

Offline M_I_B

  • Sr. Member
  • ****
  • Beiträge: 727
  • ... Biker essen keinen Honig; die kauen Bienen!
Antw:SCC mit aktueller a-culfw "out of the box" flashen?
« Antwort #1 am: 07 Dezember 2017, 22:36:06 »
... ich muss noch mal dranhängen ...
Ich habe mal geschaut, welcher SCC welche FW drauf hat. Der SCC1 für IT hat "a-cul 1.21.00.69", der SCC2 für HM hat "cul 1.65" drauf.
Nun wollte ich quasi als Übung mal die beiden SCC's auf den gleichen, aktuellen Softwarestand bringen, was in diesem Fall wohl "a-culfw_1.26.01.272" wäre ? Zumindest habe ich mir dieses Archiv herunter geladen und den Ordner SCC auf den "Funk- PI" kopiert.

Jetzt hadere ich aber etwas mit der Vorgehensweise...

Gelesen habe ich, das ich aus FHEM heraus dem jeweiligen SCC ein "set SCCx raw B01" senden kann, um den in den Modus zum Flashen zu bringen. Oder habe ich das falsch verstanden? Denn wenn ich diesen Befehl absetze, passiert ... nix. Das System tut so, als wenn es gar nix tut...

Naja, kann ja sein, das dieses Verhalten in dem Fall normal ist, dachte ich mir zumindest, bin in die Konsole des Funk-PI's gegangen, in das Verzeichnis mit der neuen FW und habe mal stumpf die flash.sh gestartet. Aber so scheint das nicht zu klappen. Ich erhalte dann folgende Fehlermeldung:

root@sh-rpi-2b:~ # cd /opt/SCC/
root@sh-rpi-2b:/opt/SCC # ls -l
insgesamt 84
-rwxrw-r-- 1 root root  1997 Sep 18 20:29 flash.sh
-rwxrw-r-- 1 root root    72 Sep 18 20:29 README
-rwxrw-r-- 1 root root 77602 Sep 18 20:29 SCC.hex
root@sh-rpi-2b:/opt/SCC # ./flash.sh
-------------------------------------------------------------
This program flash the cul device with new firmware.
Please change the device into the bootloader
-------------------------------------------------------------
Please insert the port for your device [default /dev/ttyAMA0]:

The device will now be flashed
KEEP THE MICRO BUTTON PRESSED AT DESIRED EXTENSION
Continue (y/n)?y

calling radio frontends bootloader ...

Call now avrdude -patmega1284p -cavr109 -P/dev/ttyAMA0 -b38400 -Uflash:w:./SCC.hex:i
./flash.sh: Zeile 75: 11789 Ungültiger Maschinenbefehl   ${PROGRAMMER} -p${MCU} -cavr109 -P${port} -b${BAUD} -Uflash:w:./${FLASH_FILE}:i

Ok, geht also nicht, aber was will mir die Fehlermeldung eigentlich sagen? Soll ich die so interpretieren, das er avrdude nicht finden konnte? Oder was meint diese fehlermeldung sont? Kann mich mal wer auflären bitte?

PS: Wenn ich stumpf avrdude ohne was aufrufe, erhalte ich ebenfalls die Meldung "Ungültiger Maschinenbefehl" ?!?
« Letzte Änderung: 07 Dezember 2017, 22:40:51 von M_I_B »
DLzG
Micha

 

decade-submarginal