Autor Thema: Lightify funktioniert nicht  (Gelesen 165 mal)

Offline martin-h

  • New Member
  • *
  • Beiträge: 7
Lightify funktioniert nicht
« am: 07 Dezember 2017, 10:20:56 »
Wohl eher eine Anfängefrage, ggf. bitte verschieben..

Hat sich in Bezug auf Lightify was verändert? Vor Jahren lief es problemlos, jetzt nicht mehr: "Cannot load module LIGHTIFYstatefile: Please define lightify first", habe ich aber gemacht, IP stimmt:
define lightify LIGHTIFY 192.168.1.10

CUNO an einem E4200 mit DD-Wrt, optware (Perl 5.8.8.,kann das Probleme geben allgemein?)
« Letzte Änderung: 09 Dezember 2017, 14:33:24 von martin-h »

Offline dev0

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3015
    • _.:|:._
Antw:Lightify nicht sichtbar
« Antwort #1 am: 07 Dezember 2017, 15:05:48 »
Wohl.eher eine Anfängefrage, ggf. bitte verschieben?
Das kannst, darfst und sollst Du selbst. Button links unten.

Hat sich in Bezuf auf Lightify was verändert? Vor Jahren lief es problemlos, jetzt nicht mehr: "Cannot load module
War es vor Jahren noch nicht so, dass man ins Log schaut, ob dort Warnungen/Fehler zu entdecken sind?

CUNO an einem E4200 mit DD-Wrt, optware (Perl 5.8.8.,kann das Probleme geben allgemein?)
Ob Du mit einer 12 Jahren alten Perl Version glücklich wirst?

Offline martin-h

  • New Member
  • *
  • Beiträge: 7
Antw:Lightify nicht sichtbar
« Antwort #2 am: 09 Dezember 2017, 11:46:08 »
log:
2017.12.06 17:59:11 1: reload: Error:Modul 30_LIGHTIFY deactivated:
 Global symbol "$model" requires explicit package name at FHEM/Color.pm line 466, <$fh> line 13.
....
Unmatched right curly bracket at FHEM/Color.pm line 510, at end of line
FHEM/Color.pm has too many errors.
Compilation failed in require at ./FHEM/30_LIGHTIFY.pm line 9, <$fh> line 13.
BEGIN failed--compilation aborted at ./FHEM/30_LIGHTIFY.pm line 9, <$fh> line 13.

Offline dev0

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3015
    • _.:|:._
Antw:Lightify nicht sichtbar
« Antwort #3 am: 09 Dezember 2017, 13:12:26 »
Deine FHEM Installation ist auf dem aktuellen Stand? Update ausgeführt?

Offline martin-h

  • New Member
  • *
  • Beiträge: 7
Antw:Lightify nicht sichtbar
« Antwort #4 am: 09 Dezember 2017, 13:17:43 »
Ja..
Da die fhem.cfg eben uralt wart, habe ich vorsichtshalber alles, was mit lightify zu tun hat, rausgelöscht und neu initialisiert, kein Erfolg.
Ausserdem ist mir unklar, ob dafür nun stattdessen das HueBridge-Modul genommen werden soll/muss.
(falls es wirklich mit dem alten Perl zu tun haben sollte, wäre es für mich halt nicht so einfach, eine aktuellere Version zu finden, die doch wohl auch passend kompiliert werden müsste (bei ipkg ist das die "aktuellste")
« Letzte Änderung: 09 Dezember 2017, 14:33:49 von martin-h »

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 17003
Antw:Lightify funktioniert nicht
« Antwort #5 am: 10 Dezember 2017, 22:29:03 »
am LIGHTIFY modul hat sich zuletzt am 30.03.2016 etwas geändert. die zeilennummern deiner log ausgabe passt nicht zu dieser version.

Color verwendet in der nähe zwar den // operator den es in sehr alten perl versionen nicht gibt, das ist aber auch 'schon immer' so.

im übrigen ist ipkg scheinbar veraltet nicht mehr maintained. schau dir mal opkg an. dir pakete dort sind sehr viel aktueller.
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH