Autor Thema: Neu: 77_SMAEM - Modul für SMA Energie Meter. Alternative zum Sunny Home Manager.  (Gelesen 122796 mal)

Offline 300P

  • Full Member
  • ***
  • Beiträge: 128
Hallo Dersch,

schon FHEM "restart" mit anschliessendem zusätzlichem "reset" im Modul SMAEM versucht ? ;)

Gruß
300 P
FHEM 6.0 - Raspberry Pi 3 / Pi 4 - VControl300 mit VITOVALOR 300P - SMAEM - SMAInverter - Robonect - allergy -  DbLog/DbRep -MariaDB auf QNAP - HTTPMOD Stromzähler Discovergy - Modbus ser+TCP - ModbusSDM630M - SolarForecast

Offline DS_Starter

  • Developer
  • Hero Member
  • ****
  • Beiträge: 7358
Hi,

ich tippe auf ein Problem mit dem Netzwerkanschluß/Port.
Dersch hat geschrieben sein FHEM funktioniert nicht mehr, heißt nicht nur SMAEM ist betroffen (wenn er es so meint).
Vllt. das mal checken.

Grüße,
Heiko
ESXi 6.5 @NUC6i5SYH mit FHEM auf Debian 10, DbLog/DbRep mit MariaDB auf VM
Maintainer: SSCam, SSChatBot, SSCal, SSFile, DbLog/DbRep, Log2Syslog, SolarForecast,Watches, Dashboard
Kaffeekasse: https://www.paypal.me/HMaaz
Contrib: https://svn.fhem.de/trac/browser/trunk/fhem/contrib/DS_Starter

Offline Dersch

  • Sr. Member
  • ****
  • Beiträge: 532
Hi, ja ich glaub es lag nicht am SMAEM Modul. Ich habe es zwar aus einem Backup überschrieben und nach einem Reboot des Servers lief es wieder aber ich denke das ist auch eher ein HW Problem gewesen. Es fing mitten in der Nacht an und das SMAEM Modul wurde zwischen Backup und Vorfall gar nicht geupdated.

Jedenfalls läuft es wieder auch wenn die Ursache nicht so ganz klar ist.

Grüße

Offline ClausL

  • Jr. Member
  • **
  • Beiträge: 59
Hallo,

im Log meines HM2 habe ich die folgenden Meldung gefunden: 01.10.2021 00:26:57   Home Manager 2 453   Update auf Version 2.07.5.R erfolgreich

Allerdings erst, nachdem mir nach einem FHEM Update heute diese Meldung

SMAEM SMA_Energymeter - Buffer length 58 is not usual. May be your meter has been updated with a new firmware.

aufgefallen ist und ich nach Lesen von etlichen Beiträgen hier auf die Spur des Problems kam. Vorher habe ich mit Restore eine Sicherung wieder eingespielt, was nicht half. Trotz der Fehlermeldung im Log von FHEM scheint ansonsten alles normal zu laufen. Muss ich mir nun Sorgen machen oder nur damit leben, dass das Log etwas voller wird ;-).

Muss mich hier wohl berichtigen. Anscheinend gibt es seitdem Probleme mit der Energiebilanz. Die Wechselrichter aktualisieren die Daten nur noch sporadisch bzw. nur nach manueller Aufforderung. In den offiziellen Updates finde ich noch nichts. Kann ich da selber mit meine (un)gesundem Halbwissen was dran drehen?

Viele Grüße, Claus
« Letzte Änderung: 05 Oktober 2021, 17:15:50 von ClausL »

Offline ClausL

  • Jr. Member
  • **
  • Beiträge: 59
Hallo,

eines habe ich schon herausgefunden. Der triviale Ansatz, das Ergebnis der Versionsprüfung einfach unabhängig von der Pufferlänge zu setzen, funktioniert nicht. Da hagelt es im Log Fehlermeldungen zum Modul. Da müssen wohl die Experten ran.

Viele Grüße, Claus

Offline Elektron

  • Full Member
  • ***
  • Beiträge: 133
Hallo Claus,

Hier der Links zu den Release Notes.
https://www.sma.de/produkte/monitoring-control/sunny-home-manager-20.html

Da findet sich der Hinweis, dass die neue Version WebConnect 1.5 unterstützt.

Keine Ahnung ob das die Ursache ist, aber vielleicht hilft der Hinweis.

Viele Grüße Michael

Offline ClausL

  • Jr. Member
  • **
  • Beiträge: 59
Hallo Michael

vielen Dank für den Hinweis, aber das hat mit dem Fehler nichts zu tun. Der Fehler kommt daher, dass im Modul geprüft wird, welche Länge die gesendeten Daten haben. Danach wird dann entschieden, ob ein HM oder ein EM (muss alte Technik sein) verbaut ist. Wenn die Pufferlänge nicht zu den 2 bisher bekannten Werten passt, wird die Meldung ins Log geschrieben und die weitere Verarbeitung an dieser Stelle abgebrochen. Daher werden die Readings des HM nicht mehr gelesen. Und da die Module für die Wechselrichter auf Veränderungen der Readings vom HM warten, werden auch da die Daten nicht mehr automatisch gelesen. Womit die Energiebilanz nicht mehr läuft. Und da (bei mir) die Solarwettervorhersage auch auf die Wechselrichtermodule der Energiebilanz angewiesen ist, läuft auch da nicht mehr viel.

Mein Versuch, das Prüfungsergebnis einfach unabhängig von der Pufferlänge vorzugeben, ist gescheitert, weil die Pufferlänge noch an anderen Stellen genutzt wird. Und soweit reichen meine Kenntnisse in Perl nicht, als das ich das lösen könnte.

Wenn WebConnect die einzige Neuerung sein sollte, ist das wohl der Versuch von SMA, die eigene Anwendung stabiler zum Laufen zu bringen. Wäre ja mal an der Zeit, hat aber in diesem Falle nicht funktioniert. ;-)

Viele Grüße, Claus

Offline ClausL

  • Jr. Member
  • **
  • Beiträge: 59
Hallo,

ein Teil meines Problems hat sich von selber gelöst. Die Readings in der Energiebilanz laufen nun schon den 2. Tag wieder. Bleiben nur noch die Einträge im Log und evtl. noch weitere Effekte, die mich entweder nicht betreffen, oder die ich noch nicht gefunden habe. ;-)

Viele Grüße, Claus

 

decade-submarginal