Autor Thema: deconz push api (offiziell)  (Gelesen 5517 mal)

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 3470
  • NIVEAu ist keine Creme...
Antw:deconz push api (offiziell)
« Antwort #30 am: 29 Dezember 2017, 21:56:50 »
Hallo Chi-Tai,

vielen Dank!

Allerdings hab ich auch ein neues RaspBee Modul inkl. neuem PI und nun statt Jessie auch Stretch (also alles parallel neu ;)  ), was "merkt" sich denn die HUE-Lampe bzw. was "sagt" ihr, dass das "ihre" Bridge ist?
Steht das auch in den Config-Dateien?

Die "neue HUEBridge" muss ich dann neu in fhem einbinden?
Oder steht der "Verbindungs-Key" auch in den Config-Dateien?

Oder ich schau einfach mal rein was drin steht ;)

Allerdings so viele Lampen habe ich ja (noch) nicht, da kann ich auch von vorne anfangen... ;)
Habe ich wieder ein "sauberes" System... :)

Gruß, Joachim
« Letzte Änderung: 29 Dezember 2017, 21:59:21 von MadMax-FHEM »
FHEM 5.8 Pi 3: HM-CFG-USB, 40x HM, ZWave-USB, 5x ZWave, EnOcean-PI, 3x EnOcean, DashButtons, CO2, ESP-Multisensor, FireTV, NanoLeaf
FHEM 5.8 PI 2: HM-CFG-USB, 23x HM, ZWave-USB, 3x ZWave, EnOcean-PI, 3x EnOcean, CO2, KODI, ha-bridge
FHEM 5.8 PI 3 (Test): HM-MOD-PCB, Alexa (alexa-fhem), Google Home

Offline ct

  • Jr. Member
  • **
  • Beiträge: 50
Antw:deconz push api (offiziell)
« Antwort #31 am: 29 Dezember 2017, 22:05:55 »
Hallo Joachim,

was "merkt" sich denn die HUE-Lampe bzw. was "sagt" ihr, dass das "ihre" Bridge ist?
Steht das auch in den Config-Dateien?
Die Config-Dateien enthalten die Konfiguration des gesamten ZigBee Netzwerkes inkl. Gerätekonfig in deconz. Allerdings identifizieren sich die Geräte mit MAC-Adressen und dein neues RaspBee könnte aufgrund der neuen MAC-Adresse nicht mehr Teil des Netzwerkes sein..
Wäre allerdings hilfreich zu wissen ob bzw. dass es nicht funktioniert...
(Vielleicht "rekonfiguriert" deconz das Netzwerk von selbst, da ja offensichtlich das Gateway zum Netzwerk anders ist...)

Die "neue HUEBridge" muss ich dann neu in fhem einbinden?
Oder steht der "Verbindungs-Key" auch in den Config-Dateien?
Der ist auch Teil der Konfiguration.

Oder ich schau einfach mal rein was drin steht ;)
Das kann haarig werden hehe.. die zcl ist binär aber auch ganz aufschlussreich..

Grüße,
  Chi-Tai
« Letzte Änderung: 29 Dezember 2017, 22:07:32 von ct »

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 17719
Antw:deconz push api (offiziell)
« Antwort #32 am: 29 Dezember 2017, 22:09:02 »
ich glaube beim umstellen auf eine neue bridge ist es immer das beste vorher zu versuchen die neue bridge ins alte netz zu bekommen. zumindest bei der hue bridge geht das ziemlich gut mit einer living colors fernbedienung. und danach die alte bridge einfach zurück zu setzen. dadurch musst du die ganzen birnen nicht neu anlernen.
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline ct

  • Jr. Member
  • **
  • Beiträge: 50
Antw:deconz push api (offiziell)
« Antwort #33 am: 29 Dezember 2017, 22:11:31 »
ach ja, ganz wichtig. Die Dateiberechtigungen anpassen, sonst mag deconz nicht.

sudo chown -R newuser ~/.local/share/data/dresden-elektronik
sudo chmod -R u+rwx ~/.local/share/data/dresden-elektronik

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 3470
  • NIVEAu ist keine Creme...
Antw:deconz push api (offiziell)
« Antwort #34 am: 29 Dezember 2017, 23:49:19 »
Hi Chi-Tai, Andre,

vielen Dank!

Jetzt werde ich erst mal die neue "deCONZ-Bridge" ins Testsystem aufnehmen und da dann mal die Lightify integrieren, die noch "über" ist...
...und dann den "neuen" deCONZ-PI auf den Stand bringen, damit dann alle Funktionen die der "alte" deCONZ-PI hat auch zur Verfügung stehen...

Und dann werde ich sehen wie ich das nächstes Jahr dann mache ;)

Gruß, Joachim
FHEM 5.8 Pi 3: HM-CFG-USB, 40x HM, ZWave-USB, 5x ZWave, EnOcean-PI, 3x EnOcean, DashButtons, CO2, ESP-Multisensor, FireTV, NanoLeaf
FHEM 5.8 PI 2: HM-CFG-USB, 23x HM, ZWave-USB, 3x ZWave, EnOcean-PI, 3x EnOcean, CO2, KODI, ha-bridge
FHEM 5.8 PI 3 (Test): HM-MOD-PCB, Alexa (alexa-fhem), Google Home

Offline sash583

  • Newbie
  • Beiträge: 1
Antw:deconz push api (offiziell)
« Antwort #35 am: 01 Januar 2018, 14:28:52 »
Hi,

bin relativ neu hier und habe inzwischen eine Tradfri Lampe und Schalter in deconz eingebunden. Die Lampe lässt sich auch per fhem schalten, aber der Tradfri-Taster läuft nicht. Egal ob mit oder ohne Intervall, ich bekomme keine Rückmeldungen vom Taster. Bei state steht initialized. Ich habe fhem geupdated, reicht das um die deconz push api zu nutzen?

Grüße

Sascha

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 3470
  • NIVEAu ist keine Creme...
Antw:deconz push api (offiziell)
« Antwort #36 am: 02 Januar 2018, 14:14:38 »
Hi Chi-Tai, Andre,

vielen Dank!

Jetzt werde ich erst mal die neue "deCONZ-Bridge" ins Testsystem aufnehmen und da dann mal die Lightify integrieren, die noch "über" ist...
...und dann den "neuen" deCONZ-PI auf den Stand bringen, damit dann alle Funktionen die der "alte" deCONZ-PI hat auch zur Verfügung stehen...

Und dann werde ich sehen wie ich das nächstes Jahr dann mache ;)

Gruß, Joachim

So ich hab den Test jetzt abgekürzt ;)

Ich hab einfach mal die HUE-Iris (da das momentan die einzige HUE ist, die ich echt nutze) von der bestehenden RaspBee-Hue-Bridge (deCONZ 2.04.35) "abgelernt" (Touchlink) -> funktioniert.

Dann an neue Bridge (deCONZ 2.04.99) angelernt und entsprechend benamst -> funktioniert.

Dann auf dem Testsystem die alte Bridge, Groups und Devices "gelöscht" (gut nur auskommentiert, sicher ist mal sicher)...

Neue Bridge angelegt laut Wiki (https://wiki.fhem.de/wiki/Hue): define RaspBee HUEBridge 192.168.1.90
Dann "den Knopf gedrückt", also: "Unlock Gateway", damit ging das Modul dann von pairing auf paired...
...und ich dachte: passt. Also "save config" und set RaspBee autocreate
Dann wurden zwar Devices angelegt aber irgendwie "eigenartig":


Zu Beginn die "No route to host" war als ich meine alte Bridge "abgedreht" hatte, ist also "ok" ;)

2018.01.02 11:50:19 2: RaspBee: http request failed: 192.168.1.93: No route to host
2018.01.02 11:50:19 2: RaspBee: http request failed: 192.168.1.93: No route to host
2018.01.02 11:50:19 2: RaspBee: http request failed: 192.168.1.93: No route to host

...


2018.01.02 12:13:16 1: HUEBridge_HTTP_Request http://192.168.1.90/api: Select timeout/error:
2018.01.02 12:13:16 3: HUEBridge_Call: failed, retrying
2018.01.02 12:13:20 1: HUEBridge_HTTP_Request http://192.168.1.90/api: Select timeout/error:
2018.01.02 12:13:20 3: HUEBridge_Call: failed, retrying
2018.01.02 12:13:20 3: HUEBridge_Call: failed
2018.01.02 12:13:24 1: HUEBridge_HTTP_Request http://192.168.1.90/api/328bae7616f3065c1901cfef2fe41bd8/config: Select timeout/error:
2018.01.02 12:13:24 3: HUEBridge_Call: failed, retrying
2018.01.02 12:13:28 1: HUEBridge_HTTP_Request http://192.168.1.90/api/328bae7616f3065c1901cfef2fe41bd8/config: Select timeout/error:
2018.01.02 12:13:28 3: HUEBridge_Call: failed, retrying
2018.01.02 12:13:28 3: HUEBridge_Call: failed
2018.01.02 12:13:28 2: HUEBridge_OpenDev: got empty config
2018.01.02 12:13:28 1: Perfmon: possible freeze starting at 12:13:13, delay is 15.537
2018.01.02 12:13:28 2: HarmonyHub: disconnect
2018.01.02 12:13:30 3: HarmonyHub: connected
2018.01.02 12:13:32 3: HarmonyHub: new config
2018.01.02 12:14:09 3: RaspBee_HUEDeviceerror: I/O device is RaspBee
2018.01.02 12:14:09 1: PERL WARNING: Use of uninitialized value in concatenation (.) or string at ./FHEM/30_HUEBridge.pm line 1094.
2018.01.02 12:14:09 3: RaspBee_HUEGroup0: I/O device is RaspBee
2018.01.02 12:14:10 3: RaspBee_HUEGrouperror: I/O device is RaspBee
2018.01.02 12:14:10 1: PERL WARNING: Use of uninitialized value in concatenation (.) or string at ./FHEM/30_HUEBridge.pm line 1126.
2018.01.02 12:14:10 2: RaspBee: autocreated 3 devices
2018.01.02 12:14:10 3: unauthorized user
2018.01.02 12:14:10 2: RaspBee: message for unknow type received: lights/Gerror
2018.01.02 12:14:10 3: unauthorized user
2018.01.02 12:14:10 2: RaspBee_HUEGroup0: got wrong status message for RaspBee_HUEGroup0: $VAR1 = [
          {
            'error' => {
                         'description' => 'unauthorized user',
                         'address' => 'api/328bae7616f3065c1901cfef2fe41bd8/groups/0',
                         'type' => 1
                       }
          }
        ];

2018.01.02 12:14:10 3: unauthorized user
2018.01.02 12:14:10 2: RaspBee: message for unknow type received: lights/error
2018.01.02 12:16:46 0: Server shutdown


Dann dachte ich ich starte mal neu...

2018.01.02 12:17:00 3: RaspBee_HUEDeviceerror: I/O device is RaspBee
2018.01.02 12:17:00 3: RaspBee_HUEGroup0: I/O device is RaspBee
2018.01.02 12:17:00 3: RaspBee_HUEGrouperror: I/O device is RaspBee

...

2018.01.02 12:17:10 3: unauthorized user
2018.01.02 12:17:10 2: RaspBee: message for unknow type received: lights/error
2018.01.02 12:17:10 3: unauthorized user
2018.01.02 12:17:10 2: RaspBee_HUEGroup0: got wrong status message for RaspBee_HUEGroup0: $VAR1 = [
          {
            'error' => {
                         'type' => 1,
                         'description' => 'unauthorized user',
                         'address' => 'api/328bae7616f3065c1901cfef2fe41bd8/groups/0'
                       }
          }
        ];

2018.01.02 12:17:10 3: unauthorized user
2018.01.02 12:17:10 2: RaspBee: message for unknow type received: lights/Gerror
2018.01.02 12:18:10 0: Server shutdown

Hat aber auch nichts geändert...
(ach ja ein key-Attribut war vorhanden und gesetzt [und nat. gespeichert])

Dann hab ich irgendwann das Attribut gelöscht und von vorne (bin mir nicht sicher, ob [genau] der Logteil dazu gehört) und dann ging es...

2018.01.02 12:18:24 3: TestWebAPI: port 8088 opened
2018.01.02 12:18:24 3: RaspBee_HUEDeviceerror: I/O device is RaspBee
2018.01.02 12:18:24 3: RaspBee_HUEGroup0: I/O device is RaspBee
2018.01.02 12:18:24 3: RaspBee_HUEGrouperror: I/O device is RaspBee
2018.01.02 12:18:24 1: Including ./log/fhem.save

...

2018.01.02 12:18:24 3: TestWebAPI: port 8088 opened
2018.01.02 12:18:24 3: RaspBee_HUEDeviceerror: I/O device is RaspBee
2018.01.02 12:18:24 3: RaspBee_HUEGroup0: I/O device is RaspBee
2018.01.02 12:18:24 3: RaspBee_HUEGrouperror: I/O device is RaspBee
2018.01.02 12:18:24 1: Including ./log/fhem.save

...

2018.01.02 12:18:35 3: unauthorized user
2018.01.02 12:18:35 2: RaspBee: message for unknow type received: lights/error
2018.01.02 12:18:35 3: unauthorized user
2018.01.02 12:18:35 2: RaspBee_HUEGroup0: got wrong status message for RaspBee_HUEGroup0: $VAR1 = [
          {
            'error' => {
                         'description' => 'unauthorized user',
                         'type' => 1,
                         'address' => 'api/328bae7616f3065c1901cfef2fe41bd8/groups/0'
                       }
          }
        ];

2018.01.02 12:18:35 3: unauthorized user
2018.01.02 12:18:35 2: RaspBee: message for unknow type received: lights/Gerror
2018.01.02 12:19:06 3: RaspBee: websocket opened to 192.168.1.90:443
2018.01.02 12:19:06 2: RaspBee: message for unknow group received: RaspBee-G1
2018.01.02 12:19:06 2: RaspBee: message for unknow device received: RaspBee-1
2018.01.02 12:19:06 1: HTTP/1.1 101 Switching Protocols
Upgrade: websocket
Connection: Upgrade
Sec-WebSocket-Accept: krQ31zzlyuQB1Z4qJzOnW34A2IY=
Server: deconz
Access-Control-Allow-Credentials: false
Access-Control-Allow-Methods: GET
Access-Control-Allow-Headers: content-type
Access-Control-Allow-Origin: *
Date: Tue, 02 Jan 2018 11:19:06 GMT


2018.01.02 12:19:06 3: RaspBee: websocket: Switching Protocols ok
2018.01.02 12:20:06 2: RaspBee: message for unknow device received: RaspBee-1
2018.01.02 12:21:06 2: RaspBee: message for unknow device received: RaspBee-1
2018.01.02 12:21:06 3: HUEDevice1: I/O device is RaspBee
2018.01.02 12:21:07 3: HUEGroup0: I/O device is RaspBee
2018.01.02 12:21:07 3: HUEGroup1: I/O device is RaspBee
2018.01.02 12:21:07 2: RaspBee: autocreated 3 devices
2018.01.02 12:25:06 3: RaspBee: websocket opened to 192.168.1.90:443
2018.01.02 12:25:06 1: HTTP/1.1 101 Switching Protocols
Upgrade: websocket
Connection: Upgrade
Sec-WebSocket-Accept: krQ31zzlyuQB1Z4qJzOnW34A2IY=
Server: deconz
Access-Control-Allow-Credentials: false
Access-Control-Allow-Methods: GET
Access-Control-Allow-Headers: content-type
Access-Control-Allow-Origin: *
Date: Tue, 02 Jan 2018 11:25:06 GMT


2018.01.02 12:25:06 3: RaspBee: websocket: Switching Protocols ok

...

2018.01.02 12:33:37 3: RaspBee: websocket opened to 192.168.1.90:443
2018.01.02 12:33:37 1: HTTP/1.1 101 Switching Protocols
Upgrade: websocket
Connection: Upgrade
Sec-WebSocket-Accept: krQ31zzlyuQB1Z4qJzOnW34A2IY=
Server: deconz
Access-Control-Allow-Credentials: false
Access-Control-Allow-Methods: GET
Access-Control-Allow-Headers: content-type
Access-Control-Allow-Origin: *
Date: Tue, 02 Jan 2018 11:33:37 GMT


2018.01.02 12:33:37 3: RaspBee: websocket: Switching Protocols ok
2018.01.02 12:33:53 0: Server shutdown
2018.01.02 12:33:56 2: Perfmon: ready to watch out for delays greater than one second
2018.01.02 12:33:56 1: Including fhem.cfg
2018.01.02 12:33:56 3: telnetPort: port 7072 opened
2018.01.02 12:33:56 3: WEB: port 8083 opened
2018.01.02 12:33:56 2: eventTypes: loaded 1982 events from ./log/eventTypes.txt
2018.01.02 12:33:56 3: HM_UART device closed
2018.01.02 12:33:56 3: Opening HM_UART device /dev/ttyAMA0
2018.01.02 12:33:56 3: Setting HM_UART serial parameters to 115200,8,N,1
2018.01.02 12:33:56 3: HM_UART device opened
2018.01.02 12:33:57 3: HUEGroup0: I/O device is RaspBee
2018.01.02 12:33:57 3: HUEGroup1: I/O device is RaspBee
2018.01.02 12:33:58 3: HUEDevice1: I/O device is RaspBee


Allerdings hab ich immer noch solche Dinge im Log:

2018.01.02 13:10:08 3: RaspBee: websocket opened to 192.168.1.90:443
2018.01.02 13:10:08 1: HTTP/1.1 101 Switching Protocols
Upgrade: websocket
Connection: Upgrade
Sec-WebSocket-Accept: krQ31zzlyuQB1Z4qJzOnW34A2IY=
Server: deconz
Access-Control-Allow-Credentials: false
Access-Control-Allow-Methods: GET
Access-Control-Allow-Headers: content-type
Access-Control-Allow-Origin: *
Date: Tue, 02 Jan 2018 12:10:08 GMT


2018.01.02 13:10:08 3: RaspBee: websocket: Switching Protocols ok
2018.01.02 13:14:11 1: Perfmon: possible freeze starting at 13:14:10, delay is 1.166
2018.01.02 13:16:08 3: RaspBee: websocket opened to 192.168.1.90:443
2018.01.02 13:16:08 1: HTTP/1.1 101 Switching Protocols
Upgrade: websocket
Connection: Upgrade
Sec-WebSocket-Accept: krQ31zzlyuQB1Z4qJzOnW34A2IY=
Server: deconz
Access-Control-Allow-Credentials: false
Access-Control-Allow-Methods: GET
Access-Control-Allow-Headers: content-type
Access-Control-Allow-Origin: *
Date: Tue, 02 Jan 2018 12:16:08 GMT


2018.01.02 13:16:08 3: RaspBee: websocket: Switching Protocols ok
2018.01.02 13:22:08 3: RaspBee: websocket opened to 192.168.1.90:443
2018.01.02 13:22:08 1: HTTP/1.1 101 Switching Protocols
Upgrade: websocket
Connection: Upgrade
Sec-WebSocket-Accept: krQ31zzlyuQB1Z4qJzOnW34A2IY=
Server: deconz
Access-Control-Allow-Credentials: false
Access-Control-Allow-Methods: GET
Access-Control-Allow-Headers: content-type
Access-Control-Allow-Origin: *
Date: Tue, 02 Jan 2018 12:22:08 GMT


2018.01.02 13:22:08 3: RaspBee: websocket: Switching Protocols ok
2018.01.02 13:28:08 3: RaspBee: websocket opened to 192.168.1.90:443
2018.01.02 13:28:08 1: HTTP/1.1 101 Switching Protocols
Upgrade: websocket
Connection: Upgrade
Sec-WebSocket-Accept: krQ31zzlyuQB1Z4qJzOnW34A2IY=
Server: deconz
Access-Control-Allow-Credentials: false
Access-Control-Allow-Methods: GET
Access-Control-Allow-Headers: content-type
Access-Control-Allow-Origin: *
Date: Tue, 02 Jan 2018 12:28:08 GMT


2018.01.02 13:28:08 3: RaspBee: websocket: Switching Protocols ok
2018.01.02 13:34:08 3: RaspBee: websocket opened to 192.168.1.90:443
2018.01.02 13:34:08 1: HTTP/1.1 101 Switching Protocols
Upgrade: websocket
Connection: Upgrade
Sec-WebSocket-Accept: krQ31zzlyuQB1Z4qJzOnW34A2IY=
Server: deconz
Access-Control-Allow-Credentials: false
Access-Control-Allow-Methods: GET
Access-Control-Allow-Headers: content-type
Access-Control-Allow-Origin: *
Date: Tue, 02 Jan 2018 12:34:08 GMT


2018.01.02 13:34:08 3: RaspBee: websocket: Switching Protocols ok

Beim Define hatte ich keinen Port angegeben (wie im Wiki)...
Letztes Mal (alte Bridge) hatte ich beim Define einen Port 80 mitgegeben...

define RaspBee HUEBridge 192.168.1.93:80
Sollte ich einen Port angeben?
Ist das (trotzdem) ok so?
Oder was muss/müsste ich für https tun?

EDIT: also ich hab jetzt mal den Port auch hier gesetzt... Kamen mir zu oft die Meldungen...


Aber auf jeden Fall läuft es und die Rückmeldung, selbst wenn ich über Wireless-Light-Control schalte kommt sofort...
...gut ich habe jetzt keinen Vergleich zu vorher...

Das nur als Rückmeldung!
Ansosten wie immer: vielen Dank!
Läuft (bislang) prima mit der neuen Bridge!


Auf dem Hauptsystem war es ähnlich, nicht ganz so hakelig, da ich ja schon wusste, dass was zu tun ist.
Aber auch da klappte es (gefühlt) erst als ich das key-Attribut gelöscht neu gestartet habe und parallel (gleichzeitig) den "Unlock Gateway" gedrückt hatte...

Gruß, Joachim
« Letzte Änderung: 02 Januar 2018, 14:59:41 von MadMax-FHEM »
FHEM 5.8 Pi 3: HM-CFG-USB, 40x HM, ZWave-USB, 5x ZWave, EnOcean-PI, 3x EnOcean, DashButtons, CO2, ESP-Multisensor, FireTV, NanoLeaf
FHEM 5.8 PI 2: HM-CFG-USB, 23x HM, ZWave-USB, 3x ZWave, EnOcean-PI, 3x EnOcean, CO2, KODI, ha-bridge
FHEM 5.8 PI 3 (Test): HM-MOD-PCB, Alexa (alexa-fhem), Google Home

Offline Teamdrachen

  • Jr. Member
  • **
  • Beiträge: 60
Antw:deconz push api (offiziell)
« Antwort #37 am: 03 Januar 2018, 09:41:24 »
Die 6 minütigen Logs hab ich trotz ''Port  und Verbose 1 auch

2018.01.03 09:24:32 1: HTTP/1.1 101 Switching Protocols
Upgrade: websocket
Connection: Upgrade
Sec-WebSocket-Accept: =
Server: deconz
Access-Control-Allow-Credentials: false
Access-Control-Allow-Methods: GET
Access-Control-Allow-Headers: content-type
Access-Control-Allow-Origin: *
Date: Wed, 03 Jan 2018 08:24:32 GMT


2018.01.03 09:30:32 1: HTTP/1.1 101 Switching Protocols
Upgrade: websocket
Connection: Upgrade
Sec-WebSocket-Accept: =
Server: deconz
Access-Control-Allow-Credentials: false
Access-Control-Allow-Methods: GET
Access-Control-Allow-Headers: content-type
Access-Control-Allow-Origin: *
Date: Wed, 03 Jan 2018 08:30:32 GMT


2018.01.03 09:36:32 1: HTTP/1.1 101 Switching Protocols
Upgrade: websocket
Connection: Upgrade
Sec-WebSocket-Accept: =
Server: deconz
Access-Control-Allow-Credentials: false
Access-Control-Allow-Methods: GET
Access-Control-Allow-Headers: content-type
Access-Control-Allow-Origin: *
Date: Wed, 03 Jan 2018 08:36:32 GMT

Ansonsten läuft das System mit 2.04.97 recht stabil

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 3470
  • NIVEAu ist keine Creme...
Antw:deconz push api (offiziell)
« Antwort #38 am: 03 Januar 2018, 11:10:56 »
Stimmt, Porteintrag hat bei mir auch nicht geholfen...

Ansonsten: läuft...

Gruß, Joachim
FHEM 5.8 Pi 3: HM-CFG-USB, 40x HM, ZWave-USB, 5x ZWave, EnOcean-PI, 3x EnOcean, DashButtons, CO2, ESP-Multisensor, FireTV, NanoLeaf
FHEM 5.8 PI 2: HM-CFG-USB, 23x HM, ZWave-USB, 3x ZWave, EnOcean-PI, 3x EnOcean, CO2, KODI, ha-bridge
FHEM 5.8 PI 3 (Test): HM-MOD-PCB, Alexa (alexa-fhem), Google Home

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 17719
Antw:deconz push api (offiziell)
« Antwort #39 am: 03 Januar 2018, 11:26:57 »
da sind noch zwei log nachrichten übrig geblieben. die sollten ab morgen weg sein.
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 3470
  • NIVEAu ist keine Creme...
Antw:deconz push api (offiziell)
« Antwort #40 am: 03 Januar 2018, 11:29:25 »
Hi Andre,

vielen Dank!

Trotzdem kurz (noch mal gefragt): Port angeben oder nicht oder egal?

EDIT: weiß grad nicht mehr warum ich bei meiner "alten" Definition den Port mit drin hatte... Hat sich da was im Wiki geändert? Mache es einfach wie beschrieben und nehm den Port wieder raus... ;)

Gruß, Joachim
« Letzte Änderung: 03 Januar 2018, 11:33:59 von MadMax-FHEM »
FHEM 5.8 Pi 3: HM-CFG-USB, 40x HM, ZWave-USB, 5x ZWave, EnOcean-PI, 3x EnOcean, DashButtons, CO2, ESP-Multisensor, FireTV, NanoLeaf
FHEM 5.8 PI 2: HM-CFG-USB, 23x HM, ZWave-USB, 3x ZWave, EnOcean-PI, 3x EnOcean, CO2, KODI, ha-bridge
FHEM 5.8 PI 3 (Test): HM-MOD-PCB, Alexa (alexa-fhem), Google Home

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 17719
Antw:deconz push api (offiziell)
« Antwort #41 am: 03 Januar 2018, 11:57:38 »
den port mit anzugeben geht. ist aber nicht nötig wenn es eine standard installation auf port 80 ist.
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline ct

  • Jr. Member
  • **
  • Beiträge: 50
Antw:deconz push api (offiziell)
« Antwort #42 am: 04 Januar 2018, 02:25:57 »
Hallo Sascha,

Ich habe fhem geupdated, reicht das um die deconz push api zu nutzen?
Sind die Bedingungen, die in den ersten Posts genannt wurden, bei dir erfüllt?
Welche deconz-version wird verwendet?
Auf was für einem System läuft deconz (RPi, Ubuntu, Debian, Windows)?
Was sagen die Logs der Bridge in fhem (am besten mit verbose 5)?
Ein paar Angaben mehr und mögliche Hilfestellung wäre wesentlich leichter.

Grüße,
  ct

Offline sinus61

  • Full Member
  • ***
  • Beiträge: 319
Antw:deconz push api (offiziell)
« Antwort #43 am: 11 Januar 2018, 20:31:38 »
aber der Tradfri-Taster läuft nicht. Egal ob mit oder ohne Intervall, ich bekomme keine Rückmeldungen vom Taster. Bei state steht initialized.

Also der Tradfri Schalter läuft im Prinzip bei mir. In deconz wird der ja als Gruppe eingebunden und in FHEM dann ebenfalls so angelegt. Aber dann kann man den als sensor anlegen, es wird dann im state ein 4-stelliger code wie unten beschrieben angezeigt (etwas anders als auf Seite 1).

Problem beim Tradfri Schalter: Er hat ja keine On und Off Taste sondern eine Toggle Taste, damit gibt es niemals einen off state (400x). Er bleibt eigentlich immer auf 1002 stehen oder eben auf einem dim code.

Für Dim-Switches wird ein 4-stelliger code mit folgender Bedeutung gepushed:
1000 - Toggle
2000 - dim up
3000 - dim down
4000 - Left
5000 - Right
xxx1 - press hold
xxx3 - press hold released
xxx2 - press released

Left und Right haben aber direkt anscheinend keine Funktion mehr. Über FHEM und ein notify kann man den Tasten aber ja eine Funktion geben. Damit ist der Tradfri Taster ja eine wirklich günstige Lösung.
« Letzte Änderung: 12 Januar 2018, 17:29:48 von sinus61 »

Offline LordVoodoo

  • Jr. Member
  • **
  • Beiträge: 57
Antw:deconz push api (offiziell)
« Antwort #44 am: 15 Januar 2018, 08:40:12 »
Hallo zusammen,

kürzlich habe ich gesehen, dass es auch Stromzwischenstecker gibt, die eine Strommessung erlauben und ZigBee-Standard sind, aufgefallen sind mir:


Vor allem der schlanke GWA1526 und das Smart Cable haben es mir angetan, habe häufig das Problem, dass die Zwischenstecker benachbarte Stromplätze sperren oder Schraänke etwas zuweit im Raum stehen.

Sind schon Erfahrungen bekannt mit dem Auslesen des Stromverbrauches via DeConz / Philips Hue Bridge?

Viele Grüße.