Autor Thema: SDM630M mit USR-TCP232-410 funktioniert nicht  (Gelesen 606 mal)

Offline Burny4600

  • Hero Member
  • *****
  • Beiträge: 1450
SDM630M mit USR-TCP232-410 funktioniert nicht
« am: 29 Dezember 2017, 19:26:22 »
Hat jemand den SDM630M Zähler mit einem USR-TCP232-410 TCP Server im Einsatz?
Ich schaffe keine funktionsfähige Verbindung zwischen diesen Geräten.
SDM630M: 9600,8,N,1 und RS485 ID 1
USR-TCP232-410 TCP Server: 9600,8,N,1 und RS485 ID 10, IP 192.168.17.245, Port 26
LIST
Internals:
   CFGFN      /media/hdd/fhem/mycfg/schnittstellen_rasp01.cfg
   DEF        192.168.17.245:26
   DeviceName 192.168.17.245:26
   FD         165
   NAME       MBS
   NR         1104
   NTFY_ORDER 50-MBS
   PARTIAL   
   STATE      timeout
   TYPE       ModbusTCPServer
   statistics 138 / 807 / 3299 / 9684
   READINGS:
     2017-12-29 18:59:25   state           opened
   RQUEUE:
     B
B
     T
T
     >
>
     �
�
     8
8
     d
d
     <
<
   helper:
     delayNextRead 0
     delayNextWrite 0
     fc         4
     hd_tr_id   66
     hd_unit_id 0
     lastFrame  SimpleWrite [00 42 00 00 00 06] 0A 04 00 42 00 02
     lastSimpleWrite B
B
     last_fc    4
     last_hd_tr_id 52
     state      active
     statistics:
       bytesIn    3299
       bytesOut   9684
       pktIn      138
       pktOut     807
Attributes:
   alias      ModBus Server
   devStateIcon ok:lan_rs485@0CFB0C disconnected:lan_rs485@E50005 opened:lan_rs485@yellow
   group      Schnittstellen LAN
   icon       lan_rs485
   pollInterval 0.5
   queueDelay 20
   room       _RxTx
   timeout    3
   verbose    1
Aus irgendeinem Grund werden keine vernüftigen Daten übermittelt obwohl unter statistics Änderungen ersichtlich sind.
Mfg Chris

Raspberry Pi 2/2+/3/3+ / Betriebssystem: Jessie Stretch Lite
Schnittstellen: RFXtrx433E (Oregon) / SIGNALduino / nanoCUL 868MHz (FS20), nanoCUL 433 MHz (IT), LAN, ser2net, FHEM2FEHEM
Devices: S.USV, APC-USV, FS20, IT, WMR200, TEK603, YouLess, Resol VBUS & DL2, Fronius Datalogger Web 2

Offline Burny4600

  • Hero Member
  • *****
  • Beiträge: 1450
Antw:SDM630M mit USR-TCP232-410 funktioniert nicht
« Antwort #1 am: 02 Januar 2018, 15:42:37 »
Hat wirklich niemand einen ModbusServer mit einem USR-TCP232-410 im Einsatz?
Seit geraumer Zeit funktioniert diese Schnittstelle von FHEM nicht mehr.
Der USR-TCP232-410 ist jedenfalls überprüft worden und in Ordnung.
Hat sich im letzten Jahr irgendetwas an dem ModbusServer geändert weil die Daten nicht verarbeitet werden?
2018.01.02 20:15:19.666 1 : ModbusTCPServer_Parse: bad frame, sent: SimpleWrite [00 EE 00 00 00 06] 0A 04 00 EE 00 02
2018.01.02 20:15:19.668 1 : ModbusTCPServer_Parse: bad frame, received: [00 EE 00 00 00 07] 01 04 00 E0 00 02 70 00 EE 00 00 00 08 01 04 04 40 1F C7 55 4D
2018.01.02 20:15:20.527 1 : ModbusTCPServer_Parse: bad frame, sent: SimpleWrite [00 EE 00 00 00 06] 0A 04 00 EE 00 02
2018.01.02 20:15:20.529 1 : ModbusTCPServer_Parse: bad frame, received: [00 EE 00 00 00 07] 01 04 00 6A 00 02 51 00 EE 00 00 00 08 01 04 04 41 B2 A8 A4 31
« Letzte Änderung: 02 Januar 2018, 20:20:07 von Burny4600 »
Mfg Chris

Raspberry Pi 2/2+/3/3+ / Betriebssystem: Jessie Stretch Lite
Schnittstellen: RFXtrx433E (Oregon) / SIGNALduino / nanoCUL 868MHz (FS20), nanoCUL 433 MHz (IT), LAN, ser2net, FHEM2FEHEM
Devices: S.USV, APC-USV, FS20, IT, WMR200, TEK603, YouLess, Resol VBUS & DL2, Fronius Datalogger Web 2

Offline satprofi

  • Hero Member
  • *****
  • Beiträge: 1275
Antw:SDM630M mit USR-TCP232-410 funktioniert nicht
« Antwort #2 am: 04 Februar 2018, 10:17:34 »
Das hat bei mir noch nie funktioniert.
Bin zurück auf modbus

gruss
-----------------------------------------------------------------------
Raspberry - Fhem 5.7 CUL 868, FS20, NetIO230 CUL 433, REV, Unitec, FLS u. ELRO Funksteckdosen
HMLAN, HM-CC-RT-DN,Homematic Actoren,LD382A,Telegram