CUL > Hard- und Firmware

cul update aus fhem

(1/2) > >>

The-Holgi:
Hallo,
habe versucht mittels

--- Code: ---CULflash CUL0 CUL_V3
--- Ende Code ---

ein firmware update zu machen. Hat so leider nicht geklappt, im Logfile steht

--- Code: ---CULflash dfu-programmer: no device present
--- Ende Code ---
Woran könnte das liegen?

Gruss Holgi

Otto123:
Hallo Holgi,

na daran, dass der dfu-programmer fehlt :)

Siehe z.b: hier -> https://heinz-otto.blogspot.de/2016/02/cul-stick-flashen.html

Gruß Otto

The-Holgi:
Hallo Otto,
danke für die Hilfe, es lag an den fehlenden Rechten. Hier nochmal die erforderlichen Schritte, vielleicht kann das ja mal jemand gebrauchen.
Zunächst über telnet den dfu-programmer installieren.

--- Code: ---sudo apt-get install dfu-programmer
--- Ende Code ---
dann für fhem ausführbar machen ( da hatte ich nicht dran gedacht )

--- Code: ---sudo chmod u+s /usr/bin/dfu-programmer 
--- Ende Code ---
Nun kann man über das fhem webinterface mit der eingabe von

--- Code: ---CULflash CUL0 CUL_V3
--- Ende Code ---

(CUL0 ist der Name des Cul für den das update durchgeführt werden soll also gegebenen falls anpassen)
das update durchführen. Wenn der Cul vorher schon in fhem initialisiert war ist es auch nicht nötig den Microtaster beim einstecken des Cul zu betätigen.

Gruss Holgi

Wasserwerk33:
Hallo

vielleicht schaut ja noch wer zu.
Bin so vorgegangen wie es in dem Link steht und wie es der letzte beitrag zeigt. Bekomme aber leider die selbe meldung wie oben.


--- Code: ---Probing ZWDongle device serial0
  wrong answer
Probing ZWDongle device serial1
  wrong answer
Probing CUL device ttyACM1
cannot open the device
Probing CUL device ttyACM2
ttyACM2 is already used by the fhem device ZWDongle_2
Probing CUL device ttyAMA0
  wrong answer
Probing TCM_ESP3 device ttyAMA0
  wrong answer
Probing ZWDongle device ttyAMA0
  wrong answer
Probing SIGNALDuino device ttyAMA0
  wrong answer
Probing MYSENSORS device ttyAMA0
  wrong answer
Probing ArduCounter device ttyAMA0
  wrong answer
Probing ElsnerWS device ttyAMA0
  wrong answer
Probing FRM device ttyAMA0
  wrong answer
Probing CUL device ttyS0
  wrong answer
Probing TCM_ESP3 device ttyUSB0
ttyUSB0 is already used by the fhem device myCUL
Probing TCM_ESP3 device ttyUSB1
ttyUSB1 is already used by the fhem device myJeeLink
--- Ende Code ---

würde gerne diesen Updaten was trage ich da genau nun ein??

--- Code: ---Probing TCM_ESP3 device ttyUSB0
ttyUSB0 is already used by the fhem device myCUL
--- Ende Code ---

ween ich CULflash myCUL CUL_V3  eingebe sagt er mir das er das gerät nicht findet.
habe es auch schon so probiert CULflash TCM_ESP3 CUL_V3  kamm die selbe meldung.

Danke für eure Hilfe.

Beta-User:
The-Holgi hat einen "Modem"-CUL (mit eigener serieller Schnittstelle auf dem ATMega), du einen mit USB-Seriell-Wandler (vermutlich ein Nano-Klon). Du musst daher ein anderes Programm zum flashen nutzen, also nicht dfu-programmer, sondern avrdude.

Navigation

[0] Themen-Index

[#] Nächste Seite

Zur normalen Ansicht wechseln