Autor Thema: Fehlermeldung 10_ZWave.pm beim Neustart  (Gelesen 423 mal)

Offline ToKa

  • Full Member
  • ***
  • Beiträge: 299
Fehlermeldung 10_ZWave.pm beim Neustart
« am: 12 Januar 2018, 18:18:00 »
Hallo zusammen,

nach einem Neustart von fhem ist mir im Log eine Fehlermeldung von 10_ZWave.pm aufgefallen:

2018.01.12 18:11:26 1: PERL WARNING: Use of uninitialized value in string eq at ./FHEM/10_ZWave.pm line 2711, <FH> line 731.
2018.01.12 18:11:26 1: PERL WARNING: Use of uninitialized value in string eq at ./FHEM/10_ZWave.pm line 2717, <FH> line 731.

Vielleicht nicht schlimm, aber dennoch irritierend.

Beste Grüße
Torsten
RaspberryPi3 mit RaZberry2
Fibaro: FGWPE/F-101 Switch & FIBARO System FGWPE/F Wall Plug Gen5, FGSD002 Smoke Sensor
GreenWave: PowerNode 1 port
EUROtronic: SPIRIT Wall Radiator Thermostat Valve Control
Zipato Bulb 2

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 18297
Antw:Fehlermeldung 10_ZWave.pm beim Neustart
« Antwort #1 am: 12 Januar 2018, 22:51:31 »
Der Eintrag in fhem_zwave_deviceconfig.xml.gz fuer eurotronic/eur_spirit.xml ist kaputt, die Zeile
<Value genre="config" instance="1" index="8" value="0" label="Measured Temperature offset" units="" size="1" min="-50" max="128" >enthaelt kein type=

Offline krikan

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 5800
Antw:Fehlermeldung 10_ZWave.pm beim Neustart
« Antwort #2 am: 13 Januar 2018, 07:50:39 »
Der Eintrag in fhem_zwave_deviceconfig.xml.gz fuer eurotronic/eur_spirit.xml ist kaputt, die Zeile
<Value genre="config" instance="1" index="8" value="0" label="Measured Temperature offset" units="" size="1" min="-50" max="128" >enthaelt kein type=
Danke fürs Suchen und Finden.  :)
Werde ich in den naechsten Tagen anpassen.
Wenn ein Spirit-User eine getestete Anpassung hat, dann kann er die gerne hier posten.

Offline krikan

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 5800
Antw:Fehlermeldung 10_ZWave.pm beim Neustart
« Antwort #3 am: 15 Januar 2018, 18:23:41 »
Habe eine Aenderung eingecheckt; hoffe es funtioniert.

Offline ToKa

  • Full Member
  • ***
  • Beiträge: 299
Antw:Fehlermeldung 10_ZWave.pm beim Neustart
« Antwort #4 am: 17 Januar 2018, 19:34:02 »
Hallo Christian,

ja die Fehlermeldung ist weg...

Beste Grüße
Torsten
RaspberryPi3 mit RaZberry2
Fibaro: FGWPE/F-101 Switch & FIBARO System FGWPE/F Wall Plug Gen5, FGSD002 Smoke Sensor
GreenWave: PowerNode 1 port
EUROtronic: SPIRIT Wall Radiator Thermostat Valve Control
Zipato Bulb 2

 

decade-submarginal