Autor Thema: 1-wire bus am Firmata Device liefert kein device am Port  (Gelesen 2519 mal)

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Hi,
habe einen Arduino Mega mit ConfugurableFirmata V_2_06 per Ethernet mit dem Fhemserver (auf Raspi) verbunden. Die Verbindung steht auch sauber.

Internals:
   CFGFN      FHEM/arduino.cfg
   CONNECTS   1
   DEF        3030 global
   DeviceName 3030
   FD         31
   NAME       Arduino_03
   NOTIFYDEV  global
   NR         116
   NTFY_ORDER 50-Arduino_03
   PORT       3030
   STATE      Initialized
   TYPE       FRM
   analog_pins 54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69
   analog_resolutions 54:10,55:10,56:10,57:10,58:10,59:10,60:10,61:10,62:10,63:10,64:10,65:10,66:10,67:10,68:10,69:10
   encoder_pins 2,3,18,19,20,21
   encoder_resolutions 2:28,3:28,18:28,19:28,20:28,21:28
   firmware   ConfigurableFirmataHB02.ino
   firmware_version V_2_06
   i2c_pins   20,21
   input_pins 2,3,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69
   onewire_pins 2,3,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69
   output_pins 2,3,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69
   protocol_version V_2_06
   pwm_pins   2,3,5,6,7,8,9,10,11,12,13,44,45,46
   pwm_resolutions 2:8,3:8,5:8,6:8,7:8,8:8,9:8,10:8,11:8,12:8,13:8,44:8,45:8,46:8
   Helper:
     DBLOG:
       state:
         myDbLog:
           TIME       1515783028.63968
           VALUE      Initialized
   READINGS:
     2018-01-12 19:50:28   state           Initialized
   SERIAL:
   SocketDevice:
     BUF       
     DeviceName 3030
     FD         37
     NAME       Arduino_03_192.168.0.51_49168
     NR         386
     PEER       192.168.0.51
     PORT       49168
     SNAME      Arduino_03
     SSL       
     STATE      Connected
     TEMPORARY  1
     TYPE       FRM
Attributes:
   icon       it_server
   room       Arduino

nun habe ich versuch an Pin 22 einen 1-wire bus zu connecten, leider zieht Fhem jedoch via OWX kein device vom 1wire Bus.

Internals:
   ALARMED    0
   ASYNCHRONOUS 0
   CFGFN      FHEM/arduino.cfg
   DEF        Arduino_03:22
   DeviceName Arduino_03:22
   FRM_OWX_CORRELATIONID 0
   HWDEVICE   Arduino_03
   INITDONE   1
   INTERFACE  firmata
   IODev      Arduino_03
   NAME       Ard03_1W_02
   NR         159
   PARTIAL   
   PIN        22
   PRESENT    1
   ROM_ID     FF
   STATE      Initialized
   TYPE       OWX
   interval   300
   timeout    2
   version    7.05
   DEVHASH:
     Ard03_1W_02 Busmaster
   DEVS:
   FRM_OWX_REPLIES:
   READINGS:
     2018-01-12 19:25:38   state           error initializing: pin 22
Attributes:
   room       Arduino

Logfile:2018.01.12 19:50:59 1: OWX_Init called for bus Ard03_1W_02 with interface state Initialized, now going for detect
2018.01.12 19:51:04 1: OWX_Discover: 1-Wire devices found on bus Ard03_1W_02 ()

wie kann ich die Ursache eingrenzen oder optimaler Weise auch beheben?
FHEM + UniPi + Arduino = gute Lösung

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 450
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #1 am: 12 Januar 2018, 21:08:27 »
Sieht die Verkabelung in etwa so aus?

Gruß Jens
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #2 am: 12 Januar 2018, 21:14:52 »
in etwa, die Verkabelung ist zwar am Mega und auf Grund von 5 cm Leitungslänge benötige ich den Pullup nicht, aber sie Stimmt, habs nachgemessen, Spannung und Ground kommen an.
FHEM + UniPi + Arduino = gute Lösung

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 450
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #3 am: 12 Januar 2018, 21:19:43 »
Probier's mal mit.  ;)
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #4 am: 12 Januar 2018, 21:26:56 »
hab ich,

gleiches Ergebniss 2018.01.12 21:26:13 1: OWX_Discover: 1-Wire devices found on bus Ard03_1W_02 ()
FHEM + UniPi + Arduino = gute Lösung

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #5 am: 13 Januar 2018, 13:27:29 »
habe heute im Log gefunden:
2018.01.13 13:22:47 1: Error: >Arduino_03:22< has no TYPE, but following keys: ><
kann das mit der Ursache zusammenhängen?
FHEM + UniPi + Arduino = gute Lösung

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 450
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #6 am: 13 Januar 2018, 14:48:50 »
Hallo devien,

also muss der Fehler weiter eingegrenzt werden. Hast du "update" und "shutdown restart" ausgeführt? Sind die Module aktuell? Was sagt "version"? Wie ist das Schaltbild? Welche 1-wire-devices verwendest du?

Gruß Jens
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #7 am: 13 Januar 2018, 17:35:10 »
Hallo devien,

also muss der Fehler weiter eingegrenzt werden. Hast du "update" und "shutdown restart" ausgeführt? Sind die Module aktuell? Was sagt "version"? Wie ist das Schaltbild? Welche 1-wire-devices verwendest du?

Gruß Jens
update ist aktuell, natürlich schutdown restart bereits gemacht - > keine Auswirkung
 version:
Latest Revision: 15863

File                  Rev   Last Change

fhem.pl               15842 2018-01-10 21:07:52Z rudolfkoenig
96_allowed.pm         15709 2017-12-27 15:03:48Z rudolfkoenig
90_at.pm              15795 2018-01-05 20:46:21Z rudolfkoenig
98_autocreate.pm      15620 2017-12-16 18:10:36Z rudolfkoenig
93_DbLog.pm           15851 2018-01-11 22:22:44Z DS_Starter
98_DOIF.pm            15751 2018-01-02 11:03:10Z Damian
98_dummy.pm           12700 2016-12-02 16:49:42Z rudolfkoenig
91_eventTypes.pm      14888 2017-08-13 12:07:12Z rudolfkoenig
01_FHEMWEB.pm         15850 2018-01-11 22:04:01Z rudolfkoenig
92_FileLog.pm         15628 2017-12-17 12:01:30Z rudolfkoenig
95_FLOORPLAN.pm       13735 2017-03-19 12:43:53Z UliM
10_FRM.pm             15794 2018-01-05 19:14:58Z jensb
20_FRM_AD.pm          15770 2018-01-03 19:06:32Z jensb
20_FRM_OUT.pm         15771 2018-01-03 19:12:25Z jensb
20_FRM_PWM.pm         15772 2018-01-03 19:27:23Z jensb
52_I2C_MCP23008.pm    13602 2017-03-05 01:39:01Z klausw
52_I2C_MCP342x.pm     13424 2017-02-16 22:06:16Z klausw
No Id found for 99_myFloorplanList.pm
91_notify.pm          15795 2018-01-05 20:46:21Z rudolfkoenig
11_OWDevice.pm        14523 2017-06-16 05:15:56Z neubert
10_OWServer.pm        15589 2017-12-11 11:58:29Z neubert
00_OWX.pm             15392 2017-11-05 06:46:46Z phenning
11_OWX_FRM.pm         15392 2017-11-05 06:46:46Z phenning
98_ping.pm            10939 2016-02-25 22:30:46Z mattwire
33_readingsGroup.pm   15100 2017-09-19 21:21:27Z justme1968
00_RPII2C.pm          15021 2017-09-06 19:48:55Z klausw
51_RPI_GPIO.pm        15821 2018-01-07 21:36:43Z klausw
99_SUNRISE_EL.pm      15572 2017-12-08 22:18:13Z rudolfkoenig
98_SVG.pm             15863 2018-01-12 21:32:18Z rudolfkoenig
42_SYSMON.pm          15378 2017-11-01 20:36:57Z hexenmeister
32_SYSSTAT.pm         10567 2016-01-18 21:34:09Z justme1968
50_TelegramBot.pm     15652 2017-12-20 11:29:39Z viegener
98_telnet.pm          15676 2017-12-23 19:33:43Z rudolfkoenig
99_Utils.pm           15713 2017-12-28 11:01:02Z rudolfkoenig
98_version.pm         15140 2017-09-26 09:20:09Z markusbloch
59_Weather.pm         12559 2016-11-13 08:54:54Z borisneubert
98_weblink.pm         14888 2017-08-13 12:07:12Z rudolfkoenig

No Id found for Base.pm
Blocking.pm           15412 2017-11-09 14:34:29Z rudolfkoenig
Color.pm              11159 2016-03-30 16:08:06Z justme1968
No Id found for Constants.pm
DevIo.pm              14933 2017-08-20 14:21:58Z rudolfkoenig
GPUtils.pm             6653 2014-10-02 11:59:37Z ntruchsess
HttpUtils.pm          15631 2017-12-17 12:33:03Z rudolfkoenig
myUtilsTemplate.pm     7570 2015-01-14 18:31:44Z rudolfkoenig
myUtilsTemplate.pm     7570 2015-01-14 18:31:44Z rudolfkoenig
myUtilsTemplate.pm     7570 2015-01-14 18:31:44Z rudolfkoenig
# $Id: OWNet.pm,v 1.24 2013/02/02 11:41:28 alfille Exp $
No Id found for Platform.pm
No Id found for Protocol.pm
RTypes.pm             10476 2016-01-12 21:03:33Z borisneubert
SetExtensions.pm      12935 2017-01-02 19:51:46Z rudolfkoenig
TcpServerUtils.pm     15707 2017-12-27 14:41:21Z rudolfkoenig
TimeSeries.pm         10907 2016-02-21 17:38:02Z borisneubert
YahooWeatherAPI.pm    15742 2018-01-01 07:55:55Z neubert

doif.js                    15546 2017-12-03 09:57:42Z Ellert
fhemweb.js                 15850 2018-01-11 22:04:01Z rudolfkoenig
fhemweb_readingsGroup.js   15189 2017-10-03 17:53:27Z justme1968

das Schaltbild ist klassisch (am arduino, siehe vorige Antworten)

Angeschlossen ist ein U1WTVS von SEDtronic https://www.unipi.technology/sedtronic-1-wire-sensor-p67?categoryId=3

getestet und funktional ist er auch, hatte ihn (und weitere welche ich bereits alternativ am arduino ausprobiert hab) zuvor bereits am Unipi funktional getestet gehabt.
FHEM + UniPi + Arduino = gute Lösung

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #8 am: 13 Januar 2018, 18:45:27 »
nachdem mir offenbar unbekannt verursacht der fhem Prozess abgestürzt ist habe ich ihn neu gestartet und im Log tauchte folgende Meldung auf:

pin '22' is not configured for mode 'ONEWIRE' at FHEM/lib/Device/Firmata/Platform.pm line 779.
FHEM + UniPi + Arduino = gute Lösung

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 450
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #9 am: 13 Januar 2018, 19:27:41 »
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #10 am: 13 Januar 2018, 19:58:50 »
Gegen den Absturz gibt es ein Patch: https://forum.fhem.de/index.php/topic,82020.msg740801.html#msg740801
wie setze ich das patch ein?, ich würde eben die original 11_OQX_FRM.pm umbenennen und gegen den Patch ersetzen, aber bin mir nicht sicher das das der korrekte weg ist.
der Dateigröße nach muss ich das patch wohl eher der original Datei anhängen oder?

EDIT: habs gefunden / herrausgefunden, zwichen den @ stehen die Zeilennummern wo der jwl. code gegen den im Patch jeweils ausgetausch werden muss. Das wird wohl etwas dauern, ich frickel das mal rein.

davon ab, ich glaub nicht das der Patch auch mein 1-w erkennungsproblem löst :(
« Letzte Änderung: 13 Januar 2018, 20:19:27 von devien »
FHEM + UniPi + Arduino = gute Lösung

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #11 am: 13 Januar 2018, 20:50:01 »
hab den Absturzpatch erfolgreich eingefügt.

Wie erwartet hat die jedoch die Problematik das die 1 Wire Interfaces nicht erkannt werden nicht gebessert.
FHEM + UniPi + Arduino = gute Lösung

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 450
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #12 am: 13 Januar 2018, 21:18:40 »
Habe eben deinen Link angesehen. Keine Ahnung, ob der Kombisensor überhaupt unterstützt wird. pah kann dir da sicher Auskunft geben. Vorerst empfehle ich eine DS18b20 o.a. zu versuchen.

Gruß Jens
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #13 am: 13 Januar 2018, 21:48:02 »
Habe eben deinen Link angesehen. Keine Ahnung, ob der Kombisensor überhaupt unterstützt wird. pah kann dir da sicher Auskunft geben. Vorerst empfehle ich eine DS18b20 o.a. zu versuchen.

Gruß Jens
der Sensor basiert auf einem 1w Batteriesensor, funktioniert wie gesagt am Fehm server selbst (unipi+raspberry).
habe auch einen 18b20 getestet, gleiches Ergebniss leider.

habe zum Test ob ich evtl. den Pin trotz Pinout falsch identifiziert hab, als FRM_OUT steuert der Arduino problemlos eine Relaiscard an. Der Pin und Ansteuerung über TCP/P funktioieren, es muss bei mir also wohl doch irgendwo am OWX hängen...

Hab auch getestet das device mal umzubennenen (ziffern raus) leider auch kein Positiver Effekt.
FHEM + UniPi + Arduino = gute Lösung

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 450
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #14 am: 13 Januar 2018, 22:31:21 »
Hast du es mal an einem Port unter 20 versucht?
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #15 am: 13 Januar 2018, 22:57:56 »
Hast du es mal an einem Port unter 20 versucht?
nein hab ich noch nicht, da ich mir die Kommunikations Ports in Reserver halten möchte (eigentlich) theoretisch nurtzt das ethernet schield nur die Pins 10-13, 14 bis 21 sollten also frei sein, aber es ist nicht mein Wunsch die unteren Ports zu nutzen, testen kann ichs aber mal.
FHEM + UniPi + Arduino = gute Lösung

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #16 am: 14 Januar 2018, 10:44:35 »
so, nun habe ich es an PINs 19 - 21 versucht, unterhalb von 21 scheint es zu funktionieren.

Internals:
   ALARMED    0
   ASYNCHRONOUS 0
   CFGFN      FHEM/arduino.cfg
   DEF        Arduino_03:20
   DeviceName Arduino_03:20
   FRM_OWX_CORRELATIONID 0
   HWDEVICE   Arduino_03
   INITDONE   1
   INTERFACE  firmata
   IODev      Arduino_03
   NAME       Ard03_1W_bb
   NR         169
   PARTIAL   
   PIN        20
   PRESENT    1
   ROM_ID     FF
   STATE      Initialized
   TYPE       OWX
   interval   300
   timeout    2
   version    7.05
   DEVHASH:
     Ard03_1W_bb Busmaster
     OWX_26_728E06020000 26.728E06020000.B8
   DEVS:
     26.728E06020000.B8
   FRM_OWX_REPLIES:
Attributes:
   room       Arduino

und
Internals:
   ALARMED    0
   ASYNCHRONOUS 0
   CFGFN      FHEM/arduino.cfg
   DEF        Arduino_03:21
   DeviceName Arduino_03:21
   FRM_OWX_CORRELATIONID 6
   FRM_OWX_CURRDEV 26.7A8F06020000.D4
   HWDEVICE   Arduino_03
   INITDONE   1
   INTERFACE  firmata
   IODev      Arduino_03
   NAME       Ard03_1W_cc
   NR         171
   PARTIAL   
   PIN        21
   PRESENT    1
   ROM_ID     FF
   STATE      Initialized
   TYPE       OWX
   interval   300
   timeout    2
   version    7.05
   DEVHASH:
     Ard03_1W_cc Busmaster
     OWX_26_7A8F06020000 26.7A8F06020000.D4
   DEVS:
     26.7A8F06020000.D4
   FRM_OWX_REPLIES:
     26.7A8F06020000.D4 ���������
   FRM_OWX_REQUESTS:
     0:
       device     26.7A8F06020000.D4
       command:
         id         0
         read       0.01
         select:
           crc        212
           family     38
           identity:
             122
             143
             6
             2
             0
             0
         write:
           180
     1:
       device     26.7A8F06020000.D4
       command:
         id         1
         read       0.02
         select:
           crc        212
           family     38
           identity:
             122
             143
             6
             2
             0
             0
         write:
           184
           0
     3:
       device     26.7A8F06020000.D4
       command:
         id         3
         read       0.01
         select:
           crc        212
           family     38
           identity:
             122
             143
             6
             2
             0
             0
         write:
           180
     4:
       device     26.7A8F06020000.D4
       command:
         id         4
         read       0.02
         select:
           crc        212
           family     38
           identity:
             122
             143
             6
             2
             0
             0
         write:
           184
           0
Attributes:
   room       Arduino

man sieht aber auch hier einen Unterschied zwischen den beiden PINS welcher offenbar im LOG angezeigt wird:
2018.01.14 10:39:05 1: OWXMULTI_BinValues:  OWX_26_7A8F06020000: conversion not complete or data invalid in context ds2438.getvdd 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff
Nun bleiben mir also 2 Fragen,
1. warum funktioniert es nur unterhalb von PIN21?
2. kann ich die Fehlermeldung im Log beheben?
FHEM + UniPi + Arduino = gute Lösung

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 450
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #17 am: 14 Januar 2018, 11:48:06 »
Geht doch. :)
Die Begrenzung der möglichen PINs muss sich mal ein Entwickler ausgedacht haben...
Zitat
2018.01.13 13:22:47 1: Error: >Arduino_03:22< has no TYPE, but following keys: ><
kannst du ignorieren.
Zitat
2018.01.14 10:39:05 1: OWXMULTI_BinValues:  OWX_26_7A8F06020000: conversion not complete or data invalid in context ds2438.getvdd 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff
ist vermutlich ein Kontaktfehler.

Gruß Jens
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #18 am: 14 Januar 2018, 13:34:22 »
Geht doch. :)
Die Begrenzung der möglichen PINs muss sich mal ein Entwickler ausgedacht haben
eine begrenzung und trotzdem werden die höheren PINs im Arduino device als 1 wire Ports angezeigt?
das scheint mir etwas inkonsequent
...kannst du ignorieren.ist vermutlich ein Kontaktfehler.
ein Kontaktfehler beim Physikalischen Anschluss?
FHEM + UniPi + Arduino = gute Lösung

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 450
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #19 am: 14 Januar 2018, 13:50:33 »
Ja und Ja.  8)
« Letzte Änderung: 14 Januar 2018, 14:20:04 von dirigent »
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #20 am: 14 Januar 2018, 16:02:15 »
hm, nun krieg ich meine Sensoren zwar angezeigt, aber die Einstufung als OWMulti ist unproduktiv.

Leider raucht mir FHEM jedes mal ab wenn ich die Sensoren als OWDevice definiere und

Internals:
   ALARMED    0
   ASYNCHRONOUS 0
   CFGFN      FHEM/arduino.cfg
   DEF        Arduino_03:20
   DeviceName Arduino_03:20
   FRM_OWX_CORRELATIONID 0
   HWDEVICE   Arduino_03
   INITDONE   1
   INTERFACE  firmata
   IODev      Arduino_03
   NAME       Ard03_1W_bb
   NR         167
   PARTIAL   
   PIN        20
   PRESENT    1
   ROM_ID     FF
   STATE      Initialized
   TYPE       OWX
   interval   300
   timeout    2
   version    7.05
   DEVHASH:
     Ard03_1W_bb Busmaster
   DEVS:
   FRM_OWX_REPLIES:
Attributes:
   room       Arduino
[/code]
als IODevice setze...

die letzte Meldung im Log vorm Absturz lautet dann immer:2018.01.14 15:35:42 1: PERL WARNING: Use of uninitialized value in string ne at ./FHEM/10_OWServer.pm line 387.
2018.01.14 15:35:42 1: PERL WARNING: Use of uninitialized value in pattern match (m//) at ./FHEM/10_OWServer.pm line 400.
2018.01.14 15:35:51 1: PERL WARNING: Use of uninitialized value in subroutine entry at ./FHEM/11_OWDevice.pm line 448.
Undefined subroutine &main:: called at ./FHEM/11_OWDevice.pm line 448.

FHEM + UniPi + Arduino = gute Lösung

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 450
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #21 am: 14 Januar 2018, 18:28:02 »
Das liegt wohl daran, dass OWDevice zu OWServer gehört, du aber OWX nutzt.
Zitat
Definiert ein 1-Wire- Gerät. 1-Wire- Geräte werden anhand ihrer Adresse <address> definiert. Diese wird durch den zuvor eingerichteten OWServer bereitgestellt.

Gruß Jens
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #22 am: 14 Januar 2018, 18:55:17 »
Das liegt wohl daran, dass OWDevice zu OWServer gehört, du aber OWX nutzt.
Gruß Jens
klingt plausibel, aber da ich den Arduino über FRM angebunden hab kann ich nur OWX nehmen, welche alternative bleibt mir wenn OWMulti mir nicht mal die Temperatur vom Device ausgibt?

bzw wie komme ich zumindest an owg_val herran?

Internals:
   ASYNC      0
   CFGFN      FHEM/arduino.cfg
   DEF        DS2438 7A8F06020000
   ERRCOUNT   26
   ERRSTATE   1
   INTERVAL   300
   IODev      Ard_drei_bb
   NAME       OWX_26_7A8F06020000
   NOTIFYDEV  global
   NR         169
   NTFY_ORDER 50-OWX_26_7A8F06020000
   OW_FAMILY  26
   OW_ID      7A8F06020000
   PRESENT    0
   ROM_ID     26.7A8F06020000.D4
   STATE      initialized
   TYPE       OWMULTI
   Helper:
     DBLOG:
       state:
         myDbLog:
           TIME       1515944689.27011
           VALUE      initialized
   READINGS:
     2018-01-14 16:44:49   state           initialized
   owg_val:
     -0.00390625
     10.23
     10.23
     0.249755859375
Attributes:
   IODev      Ard_drei_bb
   model      DS2438
   room       OWX
« Letzte Änderung: 14 Januar 2018, 18:57:42 von devien »
FHEM + UniPi + Arduino = gute Lösung

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 450
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #23 am: 14 Januar 2018, 19:48:48 »
Es gibt eine neue modifizierte 11_OWX_FRM.pmhttps://forum.fhem.de/index.php/topic,81104.msg748728.html#msg748728.
Lösche mal alle relevanten Einträge zu FRM, OWX und OWMulti aus der fhem.save und starte fhem neu. So konnte man OWTherm zum plaudern überreden.

Gruß Jens
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #24 am: 15 Januar 2018, 09:31:16 »
hm,
OW Therm bietet mir aber höhstens die Chance die Temperaturwerte der Sensoren zu bekommen, VAD und VIS hingegen kriege ich darüber nicht. Ich nehme an das ich via OW Multi die Sensoren paralel abgefragt bekomme, eine doppelte Definition der Sensoren verursacht mir jedoch ein gewisses unbehagen.
Ich hege den Gedanken mir evt einen DS2482-100 an den Arduino zu hängen, aber kann ich damit dann per OW Server auf diesen zugreifen?
FHEM + UniPi + Arduino = gute Lösung

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5484
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #25 am: 15 Januar 2018, 10:05:06 »
Äh - wieso das denn ? Der DS2438 hat ein ganz anderes Kommunikationsprotokoll als ein DS18B20 (und Ähnliche).

Entweder OWTHERM, ODER OWMULTI.

LG

pah

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #26 am: 15 Januar 2018, 10:09:52 »
Äh - wieso das denn ? Der DS2438 hat ein ganz anderes Kommunikationsprotokoll als ein DS18B20 (und Ähnliche).

Entweder OWTHERM, ODER OWMULTI.

LG

pah
Weil OW Multi mir bei diesem Sensor nicht die Werte ausgibt die ich benötige (was OW Device zuvor jedoch am Raspberri selbst problemlos gemacht hat).
ganz zu schweigen das OWMulti mir ständig 2018.01.14 21:10:19 1: OWXMULTI_BinValues:  OWX_26_7A8F06020000: conversion not complete or data invalid in context ds2438.getvdd 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff beschert, obgleich ich die Verkabelung mehrfach auf sauberkeit geprüft und auch die Sensoren ausgetauscht habe.
FHEM + UniPi + Arduino = gute Lösung

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5484
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #27 am: 15 Januar 2018, 10:26:11 »
Kann nicht sein - wenn Mist empfangen wird, wird eben kein Wert berechnet.

Und die Vorstellung, dass man dann eben einfach OWTHERM an Stelle von OWMULTI verwendet, ist absurd.

Bei mir werkeln übrigens 8 verschiedene DS2438 mit OWMULTI ganz problemlos vor sich hin.

LG

pah

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #28 am: 15 Januar 2018, 10:35:56 »
Kann nicht sein - wenn Mist empfangen wird, wird eben kein Wert berechnet.

Und die Vorstellung, dass man dann eben einfach OWTHERM an Stelle von OWMULTI verwendet, ist absurd.

Bei mir werkeln übrigens 8 verschiedene DS2438 mit OWMULTI ganz problemlos vor sich hin.

LG

pah

ja, wie schon beschrieben würde mir OWTherm nicht zusagen wenn ich die beiden anderen Messwerte meiner Sensoren dadurch verliere.
habe bei mir https://www.unipi.technology/sedtronic-1-wire-sensor-p67?categoryId=3 im Einsatz, auf OWMulti geben die Internals:
   ASYNC      0
   CFGFN      FHEM/arduino.cfg
   DEF        DS2438 7A8F06020000
   ERRCOUNT   26
   ERRSTATE   1
   INTERVAL   300
   IODev      Ard_drei_bb
   NAME       OWX_26_7A8F06020000
   NOTIFYDEV  global
   NR         169
   NTFY_ORDER 50-OWX_26_7A8F06020000
   OW_FAMILY  26
   OW_ID      7A8F06020000
   PRESENT    0
   ROM_ID     26.7A8F06020000.D4
   STATE      initialized
   TYPE       OWMULTI
   Helper:
     DBLOG:
       state:
         myDbLog:
           TIME       1515944689.27011
           VALUE      initialized
   READINGS:
     2018-01-14 16:44:49   state           initialized
   owg_val:
     -0.00390625
     10.23
     10.23
     0.249755859375
Attributes:
   IODev      Ard_drei_bb
   model      DS2438
   room       OWX
aus. ich nehme einfach mal an das " owg_val"  2 der Werte ausgibt die ich benötige, nur eben nicht die Temperatur.....
FHEM + UniPi + Arduino = gute Lösung

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5484
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #29 am: 15 Januar 2018, 15:45:57 »
Rede ich chinesisch, oder wie ? Mit OWTHERM kann man keine DS2438 abfragen.

pah

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 450
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #30 am: 15 Januar 2018, 16:36:51 »
Sorry, wenn ich mit meinem missverständlichen Beitrag für Stress gesorgt habe. Es sollte kein OWTherm definiert werden, sondern es handelte sich um ein Beispiel.
Lösche alle Devices, welche die OWID 7A8F06020000 haben und führe folgende Kommandos aus:
setreading Ard_drei_bb state Initialized
get Ard_drei_bb devices
get OWX_26_7A8F06020000 reading
get OWX_26_7A8F06020000 temperature

Gruß Jens
« Letzte Änderung: 15 Januar 2018, 18:37:27 von dirigent »
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5484
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #31 am: 16 Januar 2018, 07:15:42 »
Zitat
setreading Ard_drei_bb state Initialized

Warum das denn ? Das sollte man niemals von Hand machen, sondern dem Modul überlassen. Sonst sind unerwünschte Effekte nicht auszuschließen.

LG

pah

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #32 am: 16 Januar 2018, 11:01:19 »
Warum das denn ? Das sollte man niemals von Hand machen, sondern dem Modul überlassen. Sonst sind unerwünschte Effekte nicht auszuschließen.

LG

pah
das habe ich nicht per Hand gemacht, das kam selbsständig, da hatte ich kein doing drann.
Ich entnehme jedoch deiner Entrüstung das das nicht so sein sollte?
FHEM + UniPi + Arduino = gute Lösung

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 450
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #33 am: 16 Januar 2018, 17:16:12 »
Hallo pah,

der Grund ist hier beschrieben.
https://forum.fhem.de/index.php/topic,81815.msg749243.html#msg749243

Gruß Jens
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5484
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #34 am: 16 Januar 2018, 17:42:29 »
Wäre ja nett gewesen, wenn man mir das mitgeteilt hätte - ich kann nicht jeden Thread lesen.

LG

pah

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 450
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5484
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #36 am: 16 Januar 2018, 19:17:59 »
Daneben.

Das eine war, wenn ich mich recht erinnere, eine gewünschte Option - und hier geht es um die Behebung eines allgemeinen Problems.

pah

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 450
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #37 am: 16 Januar 2018, 19:24:59 »
Wenn nach einem Update das System abstürzt und der Wunsch nach Wiederherstellung der Lauffähigkeit von fhem eine Option ist, magst du Recht haben. Die Frage nach dem ehemals unterstützten DS2482 ist weiterhin offen. ;)
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #38 am: 16 Januar 2018, 21:22:48 »
wähhhh

ich komme kaum noch mit, Glaube aber ich hab es halbwegs erfasst.
- die Letzten Posts betreffen mein Problem offenbar nicht direkt
- setreading Ard_drei_bb state Initialized <- ist offenbar nicht falsch

bleibt noch die Frage ob es möglich wäre mit einem  DS2482-100 am Arduino OWServer zu nutzen anstelle von OWX?
FHEM + UniPi + Arduino = gute Lösung

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #39 am: 16 Januar 2018, 22:04:04 »
Sorry, wenn ich mit meinem missverständlichen Beitrag für Stress gesorgt habe. Es sollte kein OWTherm definiert werden, sondern es handelte sich um ein Beispiel.
Lösche alle Devices, welche die OWID 7A8F06020000 haben und führe folgende Kommandos aus:
setreading Ard_drei_bb state Initialized
get Ard_drei_bb devices
get OWX_26_7A8F06020000 reading
get OWX_26_7A8F06020000 temperature

Gruß Jens
hat leider nicht funktioniert, es wird keine Temperatur ausgegeben....
FHEM + UniPi + Arduino = gute Lösung

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5484
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #40 am: 17 Januar 2018, 06:00:38 »
Zitat
ehemals unterstützten DS2482
Von mir nicht

LG

pah

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 450
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #41 am: 17 Januar 2018, 18:12:30 »
@pah
Ok, es geht ja auch ohne.

@devien
Ganz schön stur. Poste noch mal alle Infos (Sketch, FRM-und OWX-Device inkl. LOG5, Schaltplan). Irgendwo muss ein Fehler sein. Das Ganze nur mit einem DS18b20.

Gruß Jens
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #42 am: 31 Januar 2018, 12:46:01 »
Hey, hatte das nochmal mit nem 18b20 getestet, gab wieder kein Anderes Ergebiss leider.
Bin aus Zeitkritischen Gründen dann dazu übergegangen anstelle des Arduinos einen ungenutzten Raspberry pi 1b fix per fhem2fhem hinzupacken und diesen mit nem 2428-800 zu koppeln, 1 wire übernimmt der nun zuverlässig.

Der Arduino steuert derweil per FRM Out meine 16er Relaiskarte für die Stellmotoren meines Heizkreisverteilers an, das schafft er ohne zu murren, evtl. belege ich demnächst noch die PWM fähigen Ports für die RGB LED Streifen als Beleuchtung. Soll soweit reichen.

Danke für eure Unterstützung.
FHEM + UniPi + Arduino = gute Lösung

 

decade-submarginal