Autor Thema: 1-wire bus am Firmata Device liefert kein device am Port  (Gelesen 2926 mal)

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 483
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #30 am: 15 Januar 2018, 16:36:51 »
Sorry, wenn ich mit meinem missverständlichen Beitrag für Stress gesorgt habe. Es sollte kein OWTherm definiert werden, sondern es handelte sich um ein Beispiel.
Lösche alle Devices, welche die OWID 7A8F06020000 haben und führe folgende Kommandos aus:
setreading Ard_drei_bb state Initialized
get Ard_drei_bb devices
get OWX_26_7A8F06020000 reading
get OWX_26_7A8F06020000 temperature

Gruß Jens
« Letzte Änderung: 15 Januar 2018, 18:37:27 von dirigent »
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5731
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #31 am: 16 Januar 2018, 07:15:42 »
Zitat
setreading Ard_drei_bb state Initialized

Warum das denn ? Das sollte man niemals von Hand machen, sondern dem Modul überlassen. Sonst sind unerwünschte Effekte nicht auszuschließen.

LG

pah

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #32 am: 16 Januar 2018, 11:01:19 »
Warum das denn ? Das sollte man niemals von Hand machen, sondern dem Modul überlassen. Sonst sind unerwünschte Effekte nicht auszuschließen.

LG

pah
das habe ich nicht per Hand gemacht, das kam selbsständig, da hatte ich kein doing drann.
Ich entnehme jedoch deiner Entrüstung das das nicht so sein sollte?
FHEM + UniPi + Arduino = gute Lösung

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 483
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #33 am: 16 Januar 2018, 17:16:12 »
Hallo pah,

der Grund ist hier beschrieben.
https://forum.fhem.de/index.php/topic,81815.msg749243.html#msg749243

Gruß Jens
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5731
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #34 am: 16 Januar 2018, 17:42:29 »
Wäre ja nett gewesen, wenn man mir das mitgeteilt hätte - ich kann nicht jeden Thread lesen.

LG

pah

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 483
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5731
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #36 am: 16 Januar 2018, 19:17:59 »
Daneben.

Das eine war, wenn ich mich recht erinnere, eine gewünschte Option - und hier geht es um die Behebung eines allgemeinen Problems.

pah

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 483
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #37 am: 16 Januar 2018, 19:24:59 »
Wenn nach einem Update das System abstürzt und der Wunsch nach Wiederherstellung der Lauffähigkeit von fhem eine Option ist, magst du Recht haben. Die Frage nach dem ehemals unterstützten DS2482 ist weiterhin offen. ;)
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #38 am: 16 Januar 2018, 21:22:48 »
wähhhh

ich komme kaum noch mit, Glaube aber ich hab es halbwegs erfasst.
- die Letzten Posts betreffen mein Problem offenbar nicht direkt
- setreading Ard_drei_bb state Initialized <- ist offenbar nicht falsch

bleibt noch die Frage ob es möglich wäre mit einem  DS2482-100 am Arduino OWServer zu nutzen anstelle von OWX?
FHEM + UniPi + Arduino = gute Lösung

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #39 am: 16 Januar 2018, 22:04:04 »
Sorry, wenn ich mit meinem missverständlichen Beitrag für Stress gesorgt habe. Es sollte kein OWTherm definiert werden, sondern es handelte sich um ein Beispiel.
Lösche alle Devices, welche die OWID 7A8F06020000 haben und führe folgende Kommandos aus:
setreading Ard_drei_bb state Initialized
get Ard_drei_bb devices
get OWX_26_7A8F06020000 reading
get OWX_26_7A8F06020000 temperature

Gruß Jens
hat leider nicht funktioniert, es wird keine Temperatur ausgegeben....
FHEM + UniPi + Arduino = gute Lösung

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5731
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #40 am: 17 Januar 2018, 06:00:38 »
Zitat
ehemals unterstützten DS2482
Von mir nicht

LG

pah

Offline dirigent

  • Full Member
  • ***
  • Beiträge: 483
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #41 am: 17 Januar 2018, 18:12:30 »
@pah
Ok, es geht ja auch ohne.

@devien
Ganz schön stur. Poste noch mal alle Infos (Sketch, FRM-und OWX-Device inkl. LOG5, Schaltplan). Irgendwo muss ein Fehler sein. Das Ganze nur mit einem DS18b20.

Gruß Jens
Debian auf APU2C4, HM-CFG-USB2, SIGNALduino, HM-ES-PMSw1-Pl, AB440S, AB440R, TFA 30.3121, TFA 30.3125, ITS-150, PIR-5000, configurable Firmata USB & LAN, 1-wire: DS-18B20, DS-18S20, DS-2408, DS-2413, diverse I2C-Komponenten

Offline devien

  • Full Member
  • ***
  • Beiträge: 131
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:1-wire bus am Firmata Device liefert kein device am Port
« Antwort #42 am: 31 Januar 2018, 12:46:01 »
Hey, hatte das nochmal mit nem 18b20 getestet, gab wieder kein Anderes Ergebiss leider.
Bin aus Zeitkritischen Gründen dann dazu übergegangen anstelle des Arduinos einen ungenutzten Raspberry pi 1b fix per fhem2fhem hinzupacken und diesen mit nem 2428-800 zu koppeln, 1 wire übernimmt der nun zuverlässig.

Der Arduino steuert derweil per FRM Out meine 16er Relaiskarte für die Stellmotoren meines Heizkreisverteilers an, das schafft er ohne zu murren, evtl. belege ich demnächst noch die PWM fähigen Ports für die RGB LED Streifen als Beleuchtung. Soll soweit reichen.

Danke für eure Unterstützung.
FHEM + UniPi + Arduino = gute Lösung

 

decade-submarginal