Autor Thema: structure Problem nach Update 13.1.2018  (Gelesen 984 mal)

Offline DeeSPe

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3693
  • Wer anderen eine Bratwurst brät...
structure Problem nach Update 13.1.2018
« am: 13 Januar 2018, 09:10:42 »
Seit dem heutigen Update habe ich Probleme mit structure wo vorher keine waren.

structure(s) mit nur einem Gerät zeigen keine set Befehle mehr an und zeigen auch den falschen Status.

Hintergrund:
Ich habe für jeden Raum ein structure für alle Lichter des Raums um diese generisch ansprechen zu können.
In zwei Räumen gibt es aber jeweils nur ein Licht.

Gruß
Dan
FHEM 5.8, Brix, VIVO mini, RPi3, Debian Jessie, ZME_UZB1
HM-CFG-LAN, HM-MOD-UART-WIFI, HUE, HarmonyHub, JeeLink, CO20
Hyperion auf RPi Zero W, Sonos, viel Z-Wave und HM
alles per HomeKit steuerbar
MAINTAINER: 22_HOMEMODE, 98_Hyperion, 98_FileLogConvert

Offline rolf

  • Jr. Member
  • **
  • Beiträge: 66
Antw:structure Problem nach Update 13.1.2018
« Antwort #1 am: 13 Januar 2018, 14:02:44 »
Habe gerade auch FHEM aktualisiert und jetzt auch Probleme mit meinen structures - d.h. habe mehrere Strukturen um den Status von mehreren Devices zusammenzufassen und die Aktualisierung der Strukturen funktioniert nach dem Update nicht mehr. Nach Restore ist bei mir jetzt alles wieder OK.
System 1: Intel NUC (ubuntu 16.04.3 lts) mit diversen Homematic-Komponenten + CUNO mit Uniroll/Hoermann + RFXTRX mit TFA + EnOcean mit Eltako + Alexa + Harmony + per HMCCU gekoppelter PI3-Raspberrymatic mit HM-IP-Komponenten
System 2: PI2-Raspberry (Jessie) + Signalduino mit Somfy/RTS

Offline binford6000

  • Full Member
  • ***
  • Beiträge: 353
Antw:structure Problem nach Update 13.1.2018
« Antwort #2 am: 13 Januar 2018, 15:09:59 »
Halo ihr beiden,
ich habe auch heute morgen aktualisiert und auch wie Dan Strukturen mit nur einem device und auch kaskadierende Strukturen.
Nur bei mir funktioniert alles wie gewohnt.

VG Sebastian
FHEM 5.8 auf RPi3(enocean), RPi1(CUL) u. ODROID-C2
IT, EnOcean, HUE + INNR + Nanoleaf Aurora, AmazonDASH, GTAG, SONOS, ENIGMA2, YAMAHA_AVR, KODI, WINCONNECT, AMADNG,  IPCAM
alexa-fhem, homebridge, TelegramBot mit msgDialog, livetracking, XiaomiFlowerSens

Offline juemuc

  • Full Member
  • ***
  • Beiträge: 243
Antw:structure Problem nach Update 13.1.2018
« Antwort #3 am: 13 Januar 2018, 16:44:16 »
Hallo zusammen,

ich habe nach dem update auch keine Probleme. Alles wie vorher.

Viele Grüße
Jürgen
3x Sonos Play 1, 1x Sonos Playbar + Sub, 1 Sonos-One
Fritzbox 7490 mit 4x Dect 200 und 3 Dect-ULE-Thermostate, HM Klingelsensor HM-Sen-DB-PCB, HM Fensterkontakte und HM Funkmodul HM-MOD-RPI-PCB
Amazon Echo Dot

Raspi3 mit 32GB und akt. Raspberry

Offline WarLord

  • Jr. Member
  • **
  • Beiträge: 50
Antw:structure Problem nach Update 13.1.2018
« Antwort #4 am: 13 Januar 2018, 17:47:16 »
hab nun gerade mitbekommen das meine structuren nicht mehr funktionieren nach dem update.
Der state ändert sich zwar in FHEM aber es wird nichts geschalten.
Einzeln kann ich die Geräte der Structuren ohne Probleme schalten
FHEM auf RaspberryPi B+
HMLAN Adapter + Div HM Komponenten

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 18651
Antw:structure Problem nach Update 13.1.2018
« Antwort #5 am: 13 Januar 2018, 18:07:52 »
Ich stelle mit erstaunen fest, dass man mir die Faehigkeiten eines Gedankenlesers oder gar Gottes zumutet, anders kann ich es mir nicht erklaeren, wieso keiner versucht es mir an konkreten Beispielen zu zeigen, was nicht geht.

Ich habe gestern structure erweitert, dass es dynamisch auf devspec Definitionen reagiert, d.h. ein
Zitat
define s structure s TYPE=dummy
wird auch nachtraeglich definierte dummies erfassen.
Ich habe das getestet so gut ich es konnte, ohne sichtbare Probleme, siehe diesen Beitrag.

Ich habe jetzt wieder etliche Tests gemacht mit einem konkreten Mitglied, mit zwei oder mit devspec, set  mit einem Argument oder mehreren, mir reverse oder nicht, und habe keine weiteren Ideen. Wer also nur jammern will, der darf es weiterhin, wenn ich helfen soll, dann brauche ich konkrete Beispiele.
Zustimmung Zustimmung x 1 Liste anzeigen

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 18651
Antw:structure Problem nach Update 13.1.2018
« Antwort #6 am: 13 Januar 2018, 18:23:11 »
Ich habe ein Problem gefixt, evtl. ist das, was hier beschrieben wurde.
Details siehe https://forum.fhem.de/index.php/topic,82604.msg748065.html#msg748065

Offline rolf

  • Jr. Member
  • **
  • Beiträge: 66
Antw:structure Problem nach Update 13.1.2018
« Antwort #7 am: 14 Januar 2018, 11:44:57 »
Habe FHEM gerade nochmal aktualisiert - mit der aktuellen Version von structure klappt wieder alles wunderbar.
Sorry das ich mir nicht die Zeit genommen hatte mehr fundierte Details zu liefern.
System 1: Intel NUC (ubuntu 16.04.3 lts) mit diversen Homematic-Komponenten + CUNO mit Uniroll/Hoermann + RFXTRX mit TFA + EnOcean mit Eltako + Alexa + Harmony + per HMCCU gekoppelter PI3-Raspberrymatic mit HM-IP-Komponenten
System 2: PI2-Raspberry (Jessie) + Signalduino mit Somfy/RTS

Offline DeeSPe

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3693
  • Wer anderen eine Bratwurst brät...
Antw:structure Problem nach Update 13.1.2018
« Antwort #8 am: 14 Januar 2018, 13:41:54 »
Hab auch gerade aktualisiert und kurz getestet. Scheint wieder wie vorher zu funktionieren.

Danke Rudi.

Gruß
Dan
FHEM 5.8, Brix, VIVO mini, RPi3, Debian Jessie, ZME_UZB1
HM-CFG-LAN, HM-MOD-UART-WIFI, HUE, HarmonyHub, JeeLink, CO20
Hyperion auf RPi Zero W, Sonos, viel Z-Wave und HM
alles per HomeKit steuerbar
MAINTAINER: 22_HOMEMODE, 98_Hyperion, 98_FileLogConvert

Offline softwear

  • New Member
  • *
  • Beiträge: 13
Antw:structure Problem nach Update 13.1.2018
« Antwort #9 am: 15 Januar 2018, 13:44:16 »
Gerade aktualisiert und ganz fhem crasht:
Can't use an undefined value as an ARRAY reference at ./FHEM/98_structure.pm line 398.Neue Datei gegen die alte ausgetauscht und fhem startet.

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 18651
Antw:structure Problem nach Update 13.1.2018
« Antwort #10 am: 15 Januar 2018, 13:50:02 »
Rufst du set mit einem structure auf waehrend des Initialisierens?

Offline softwear

  • New Member
  • *
  • Beiträge: 13
Antw:structure Problem nach Update 13.1.2018
« Antwort #11 am: 15 Januar 2018, 14:12:29 »
Das tut fhem inmitten der ActionDetector-Zuordnungen. Es soll offensichtlich folgender Switch gesetzt werden (bei funktionierendem Ablauf haben wir genau an der Stelle des Fehlers die beschriebenen SETs):

2018.01.15 13:33:10 3: CUL_HM set HM_266FF3_Sw_03 on
2018.01.15 13:33:10 3: CUL_HM set HM_266FF3_Sw_01 on
2018.01.15 13:33:10 3: CUL_HM set HM_266FF3_Sw_02 on
2018.01.15 13:33:10 3: CUL_HM set HM_266FF3_Sw_04 on

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 18651
Antw:structure Problem nach Update 13.1.2018
« Antwort #12 am: 15 Januar 2018, 14:35:14 »
Ich habe ein Patch eingespielt, was die Warnung vermeiden sollte.

Offline softwear

  • New Member
  • *
  • Beiträge: 13
Antw:structure Problem nach Update 13.1.2018
« Antwort #13 am: 15 Januar 2018, 15:37:29 »
funktioniert leider nicht. Ist auch nicht einfach nur eine Warnung. Die Initialisierung kommt bis zur angezeigten Stelle des Fehlers und fhem crasht unwiderbringlich.
Hier die letzten Zeilen der Log:

2018.01.15 15:34:18 1: Including ./log/fhem.save
2018.01.15 15:34:19 3: Device bad_THSensor added to ActionDetector with 000:10 time
2018.01.15 15:34:19 3: Device bib_THSensor added to ActionDetector with 000:10 time
2018.01.15 15:34:19 3: Device gar_nord_THSensor added to ActionDetector with 000:10 time
2018.01.15 15:34:19 3: Device k_THSensor added to ActionDetector with 000:10 time
Can't use an undefined value as an ARRAY reference at ./FHEM/98_structure.pm line 398.

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 18651
Antw:structure Problem nach Update 13.1.2018
« Antwort #14 am: 15 Januar 2018, 15:52:09 »
Kannst du bitte mit version pruefen, dass du Version 15900 hast?

 

decade-submarginal