Autor Thema: [gelöst] HM-LC-SW1-FM Missing / ResponseTimeout / keinPairen  (Gelesen 1383 mal)

Andre0909

  • Gast
Versuche seit Stunden den genannten Actor einzubinden aber bekomme es nicht hin. Der aktor ist in einer Gartenlampe zwischengeschaltet und bekommt Dauerstrom. Angelernt habe ich mit

set CUL866 hmPairSerial NEQ1656533
Daraufhin wird das Device erstellt aber es passiert dann nix mehr. Kein schalten geht. Mehrfaches Wiederholen des Pairings mit der korrekten Serial führt zu keinem erfolg :(

Hier ein List:

Internals:
   .triggerUsed 1
   CFGFN
   CUL866_MSGCNT 1
   CUL866_RAWMSG A1A01800050AFCAF143212800044E45513136353635333310010100::-80:CUL866
   CUL866_RSSI -80
   CUL866_TIME 2018-01-17 17:25:56
   DEF        50AFCA
   IODev      CUL866
   LASTInputDev CUL866
   MSGCNT     1
   NAME       HM_50AFCA
   NOTIFYDEV  global
   NR         747
   STATE      RESPONSE TIMEOUT:RegisterRead
   TYPE       CUL_HM
   hmPairSerial NEQ1656533
   lastMsg    No:01 - t:00 s:50AFCA d:F14321 2800044E45513136353635333310010100
   protCmdDel 13
   protLastRcv 2018-01-17 17:25:56
   protResnd  15 last_at:2018-01-17 17:46:49
   protResndFail 5 last_at:2018-01-17 17:46:54
   protSnd    6 last_at:2018-01-17 17:46:34
   protState  CMDs_done_Errors:1
   rssi_at_CUL866 max:-80 avg:-80 cnt:1 lst:-80 min:-80
   Readings:
     2018-01-17 17:25:56   .D-devInfo      010100
     2018-01-17 17:25:56   .D-stc          10
     2018-01-17 17:25:56   .protLastRcv    2018-01-17 17:25:56
     2018-01-17 17:25:56   D-firmware      2.8
     2018-01-17 17:25:56   D-serialNr      NEQ1656533
     2018-01-17 17:46:54   state           RESPONSE TIMEOUT:RegisterRead
     Regl_00.:
       VAL
   Helper:
     HM_CMDNR   27
     cSnd       01F1432150AFCA00040000000000,01F1432150AFCA00040000000000
     getCfgList all
     getCfgListNo ,3
     mId        0004
     rxType     1
     Expert:
       def        1
       det        0
       raw        1
       tpl        0
     Io:
       newChn     +50AFCA,00,00,00
       nextSend   1516206357.01943
       prefIO
       rxt        0
       vccu
       p:
         50AFCA
         00
         00
         00
     Mrssi:
       mNo        01
       Io:
         CUL866     -78
     Prt:
       bErr       0
       sProc      0
     Q:
       qReqConf
       qReqStat   00
     Role:
       chn        1
       dev        1
       prs        1
     Rssi:
       At_cul866:
         avg        -80
         cnt        1
         lst        -80
         max        -80
         min        -80
     Tmpl:
Attributes:
   IODev      CUL866
   autoReadReg 4_reqStatus
   expert     2_raw
   firmware   2.8
   model      HM-LC-SW1-FM
   room       CUL_HM
   serialNr   NEQ1656533
   subType    switch
   webCmd     statusRequest:toggle:on:off

Jmd eine Idee was hier ffalsch läuft? Nutze diverse Homematic Sensoren für Fenster, Bewegungsmelder etc. Alles läuft über den CUL und es ab nie Pairing Probleme. Allerdings wurde hier auch nie mit hmPairSerial gepairt. Mehrfaches Getconfig bringt leider auch nüx
« Letzte Änderung: 21 Januar 2018, 11:35:11 von Andre0909 »

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 8516
  • NIVEAu ist keine Creme...
Antw: HM-LC-SW1-FM Missing / ResponseTimeout / keinPairen
« Antwort #1 am: 17 Januar 2018, 18:46:02 »
Vielleicht hilft das:

https://forum.fhem.de/index.php/topic,63240.0/all.html

Und wenn nicht evtl. mal (steht aber auch im, im Link verlinkten Wiki ;)  bei Problembehebung) bzgl. Spezial-FW für CUL mit Timestamp suchen und diese verwenden...

Gruß, Joachim
FHEM PI3B+ Buster: HM-CFG-USB, 40x HM, ZWave-USB, 6x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, KODI, alexa-fhem, ...
FHEM PI2 Stretch: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, KODI, ha-bridge, ...
FHEM PI3 Buster (Test)
FHEM PI3 Stretch (Test)

Andre0909

  • Gast
Antw: HM-LC-SW1-FM Missing / ResponseTimeout / keinPairen
« Antwort #2 am: 17 Januar 2018, 19:14:10 »
Vielleicht hilft das:

https://forum.fhem.de/index.php/topic,63240.0/all.html

Und wenn nicht evtl. mal (steht aber auch im, im Link verlinkten Wiki ;)  bei Problembehebung) bzgl. Spezial-FW für CUL mit Timestamp suchen und diese verwenden...

Gruß, Joachim

also erneutes pairen
clear msgEvents
getConfig
nochmal hmPairSerial

waren allesamt nicht erfolgreich :( Ich kriege einfach kein Pairing mit dem Mistding. Ich schaue mir mal das mit Timestamp an...gesagt getan. Da raff ich leider gar nix. Habe auch Angst mit einer FW Aktualisierung mir hier alles zu zerschiessen. Ich habe ja gut 8 Homematic Devices ohne Probleme gepaired :(((
« Letzte Änderung: 17 Januar 2018, 19:17:41 von Andre0909 »

Offline martinp876

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 10862
Antw: HM-LC-SW1-FM Missing / ResponseTimeout / keinPairen
« Antwort #3 am: 17 Januar 2018, 20:37:22 »
Fhem versucht mit dem Device zu reden.
Die cul da ohne timestamp ist instabil, auch bei dir. Wenn doch es besser weißt musst du damit umgehen.
Offensichtlich wird die Antwort des Device nicht empfangen,  wahrscheinlich weil fhem zu spät sendet. Also timestamp nutzen, oder weiter auf gut Glück funken.

Andre0909

  • Gast
Antw: HM-LC-SW1-FM Missing / ResponseTimeout / keinPairen
« Antwort #4 am: 17 Januar 2018, 22:37:56 »
Ich hab ja nur gesagt das ich mich nicht traue weil ich es nicht ganz kapiere. Muss ich alle Devices z.b neu anlernen? Was sind die Konsequenzen des Updates


Gesendet von iPhone mit Tapatalk

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 8516
  • NIVEAu ist keine Creme...
Antw: HM-LC-SW1-FM Missing / ResponseTimeout / keinPairen
« Antwort #5 am: 17 Januar 2018, 22:48:14 »
Du musst nicht neu anlernen (sofern du nicht an der HMID rumdrehst ;)  ).

Also grob folgendes (sollte aber im Timestamp-Thread im ersten Post auch alles [genauer] stehen):

CUL mit passender FW flashen.
Für diverse Varianten sind HEX-Files im Download.
Flash-Anleitungen gibt es einige (auch fhem Wiki denke ich).

Dann die enthaltenen FHEM-Module nach /opt/fhem/FHEM kopieren, bei Standardinstallation (vorher die dort vorhandenen besser mal sichern / beispielsweise mittels backup).
Gegebenenfalls Rechte anpassen.

Dann fhem shutdown.

Dann in der fhem.cfg (ja ausnahmsweise / andere Variante: CUL löschen [vorher das define "merken"! V.a. HMID!] und neu als TS_CUL definieren) CUL durch TS_CUL (also "einfach" nur im Define den "TYP" ändern) ersetzen (sollte ja nur einmal [pro CUL] vorhanden sein).

fhem starten (sudo service fhem start / PI booten / ...)

Das sollte es dann gewesen sein.

Bzw. die getauschten FHEM-Module noch vom Update ausschließen (excludeFromUpdate), da die sonst beim nächsten update wieder überschrieben würden...

Wenn du vorher ein backup von fhem machst kann eigentlich nix groß schief gehen, bzw. wenn, dann halt das backup wieder zurückspielen (und den CUL wieder mit Original-FW flashen)...

Gruß, Joachim
« Letzte Änderung: 17 Januar 2018, 22:52:15 von MadMax-FHEM »
FHEM PI3B+ Buster: HM-CFG-USB, 40x HM, ZWave-USB, 6x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, KODI, alexa-fhem, ...
FHEM PI2 Stretch: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, KODI, ha-bridge, ...
FHEM PI3 Buster (Test)
FHEM PI3 Stretch (Test)

Offline Pfriemler

  • Hero Member
  • *****
  • Beiträge: 3732
  • geht nich gips nich
Antw: HM-LC-SW1-FM Missing / ResponseTimeout / keinPairen
« Antwort #6 am: 18 Januar 2018, 09:57:58 »
Abgesehen davon, dass die TS_CUL nicht grundlos den Aufwand Wert ist ...

Ich erweitere hin und wieder meinen Gerätezoo und nutze bevorzugt hmPairSerial, weil ich den Code direkt abscannen  kann (mit USB-Barcodereader). Mir kommen aber regelmäßig Geräte unter, die sich - trotz HMUART - hartnäckig dem Pairen verweigern und beim ersten hmPairForSeconds da sind. Dazu gehörte auch das Schwestermodell HM-LC-Sw2-FM.
« Letzte Änderung: 19 Januar 2018, 01:22:41 von Pfriemler »
"Änd're nie in fhem.cfg, denn das tut hier allen weh!" *** Wheezy@Raspi(3), HMWLAN+HMUART, CUL868(SlowRF) für FHT+KS+FS20, miniCUL433, Rademacher DuoFern *** "... kaum macht man es richtig, funktioniert es ..."
Zustimmung Zustimmung x 1 Liste anzeigen

Andre0909

  • Gast
Antw: HM-LC-SW1-FM Missing / ResponseTimeout / keinPairen
« Antwort #7 am: 18 Januar 2018, 19:51:45 »
Abgesehen davon, dass die TS_CUL nicht grundlos den Aufwand Wert ist ...

Ich erweitere hin und wieder meinen Gerätezoo und nutze bevorzugt hmPairSerial, weil ich den Code direkt abspannen kann. Mir kommen aber regelmäßig Geräte unter, die sich - trotz HMUART - hartnäckig dem Pairen verweigern und beim ersten hmPairForSeconds da sind. Dazu gehörte auch das Schwestermodell HM-LC-Sw2-FM.

Danke werde es nochmal mit nem Taster anlernen versuchen und mich egal ob es klappt oder nicht danach mit der Firmware beschäfttigen. Danke an alle für de Anleitungen hier

Andre0909

  • Gast
Antw: HM-LC-SW1-FM Missing / ResponseTimeout / keinPairen
« Antwort #8 am: 20 Januar 2018, 14:41:50 »
Wollte nur Bescheid geben: mit Taster direkt am Aktor ging es mit hmPairForSec in 1 sekunde... !