Autor Thema: Steuerung für eine Zentrale Lüftungsanlage (KWL Kontrollierte Wohnraumlüftung)  (Gelesen 2073 mal)

Offline Starsurfer

  • Full Member
  • ***
  • Beiträge: 170
    • Projekt-Heimwerken
Die Masseleitung habe ich mittlerweile schon getrennt und für Lüfter und Temperatur Sensoren jeweils eine eigene Masseleitung.
Die Anschlüsse sollten so sein, kann ich aber erst heute Abend nachschauen.
Wegen Kondensator muss ich Mal in meine bastelkiste schauen.
Zotak Zbox + LaCrosseGateway + CURL 433 + 868 + HM-MOD-RPI-PCB WLAN + ConBee + Migateway
HomeMatic HM-CC-RT-DN - Sonoff Tasmota
LaCrosse TX29DTH - PCA301 - Intertechno IT1500
Arduino Mega - MQTT - Pluggit 300

Offline Starsurfer

  • Full Member
  • ***
  • Beiträge: 170
    • Projekt-Heimwerken
So ich glaube ich habe zumindest ein Fehler gefunden gehabt. Irgendwie muss beim loten die Brücke der Masseleitung an den Optokopplern zu heiß geworden sein und hat mit den Widerständen eine Gemeinschaft gebildet. Hat aber auch nichts gebracht, Tachowerte waren trotzdem zu hoch. Ich habe mit verschiedenen Kondensatoren versucht, hat auch alles nichts geholfen.
Ich habe es dann mal mit einem 10K Ohm Widerstand zwischen 10V und Tacho ausprobiert, hatte ich irgendwo gelesen und siehe da, die Tachowerte scheinen jetzt zu stimmen und sind wesentlich stabiler.
Momentan läuft die Kalibrierung durch, diesmal auch hörbar.
Zotak Zbox + LaCrosseGateway + CURL 433 + 868 + HM-MOD-RPI-PCB WLAN + ConBee + Migateway
HomeMatic HM-CC-RT-DN - Sonoff Tasmota
LaCrosse TX29DTH - PCA301 - Intertechno IT1500
Arduino Mega - MQTT - Pluggit 300

Offline Starsurfer

  • Full Member
  • ***
  • Beiträge: 170
    • Projekt-Heimwerken
Ok ich gebe gleich auf, irgendwas passt da immer noch nicht.
Stufe 1: circa 1900/U
Stufe 2: circa 2500/U
Stufe 3: circa 2800/U

Läuft Momentan mit d15/set/kwl/fans/calculatespeed -m PROP
Die Drehzahlen sind bei PID aber ungefähr gleich.

Auch eine Eingabe von:
root@cubietruck:~# mosquitto_pub -t d15/set/kwl/fan1/standardspeed -m 1250
root@cubietruck:~# mosquitto_pub -t d15/set/kwl/fan2/standardspeed -m 1250
scheint keine Auswirkung zu haben.

Stufe 1 finde ich definitiv zu hoch. Kann ich die Drehzahlen auch irgendwie manuell hinterlegen?
Z.B
Stufe 1: 1200
Stufe 2: 1600
Stufe 3: 3000

Wie sind den die originalen Drehzahlen?
Zotak Zbox + LaCrosseGateway + CURL 433 + 868 + HM-MOD-RPI-PCB WLAN + ConBee + Migateway
HomeMatic HM-CC-RT-DN - Sonoff Tasmota
LaCrosse TX29DTH - PCA301 - Intertechno IT1500
Arduino Mega - MQTT - Pluggit 300

Offline SvenJust

  • Full Member
  • ***
  • Beiträge: 319
Es ist schwer konkret zu helfen, da so wenig von Deinem aktuellen Aufbau bekannt ist, liste doch bitte kurz die aktuellen Aufbau auf und mach doch bitte ein/mehrere Fotos.

Besonderes Interesse: LAN-Shield (welches), Display (welches), Relais-Shield (welches), Netzteil (welches, Name, Spannung, Strom), verbundene Sensoren (welche). Wie werden der Arduino und wie die anderen Komponenten mit Strom versorgt? Welches Eingangsspannung soll das Netzteil liefern und welche Spannung misst du mit und ohne Belastung/Schaltung am Netzteil? Welchen Strom misst du auf der Niedervoltschiene bei der Versorgung der ganzen Komponenten?

Ich meine mich zu erinnern, dass Du kein Oszilloskop hast? Falls doch, wie sieht das Tachosignal aus?

Du kannst alle Drehzahlen im Programmcode einstellen, siehe folgende Zeilen https://github.com/svenjust/room-ventilation-system/blob/cee5d365790ac40b58ebf9f962971649728e9288/Sourcecode/KWLctl/KWLctl.ino#L124
Nach dem Einstellen von neuen Werten muss ein FactoryReset ausgeführt werden, dazu in der Zeile https://github.com/svenjust/room-ventilation-system/blob/cee5d365790ac40b58ebf9f962971649728e9288/Sourcecode/KWLctl/KWLctl.ino#L139 true einstellen oder per mqtt Befehl senden: mosquitto_pub -t d15/set/kwl/resetAll_IKNOWWHATIMDOING -m YES

Die Originaldrehzahlen sind 1550 für beide Lüfter, bei mir sind 1450 für L1 und 1100 für L2, steht aber auch im genannten Code.

VG Sven
FTUI, Banana PI/SSD, CUL CC1101, HMLAN, 10x HM-LC-Bl1PBU-FM, HM-LC-Sw4-WM (KWL Pluggit P300), HM-WDS30-OT2-SM (Sonnensensor), HM-Sec-SCo, LW-12 Wifi LED, CUL Selbstbau nanoCUL 433 (IT), Arduino (S0-Stromverbrauch), OW DS2480 (OWX_ASYNC) 8x DS18B20, MQTT (Fröling P4), MYSENSORS (Roto Rollläden)

Offline Starsurfer

  • Full Member
  • ***
  • Beiträge: 170
    • Projekt-Heimwerken
Danke, habe das jetzt noch einmal in der von dir genannten Reihenfolge gemacht und jetzt habe ich die Drehzahlen, wie ich sie haben möchte :-)
Mir war nicht bewußt, das ich diese Zeile dafür anpassen muss:
double   defStandardKwlModeFactor[defStandardModeCnt] = {0, 0.4, 1, 1.3};
Die Komponenten sind die gleichen wie bei dir, nur ist mein Lan Shield blau.
Wie gesagt, jetzt funktioniert es so wie ich möchte.
Zotak Zbox + LaCrosseGateway + CURL 433 + 868 + HM-MOD-RPI-PCB WLAN + ConBee + Migateway
HomeMatic HM-CC-RT-DN - Sonoff Tasmota
LaCrosse TX29DTH - PCA301 - Intertechno IT1500
Arduino Mega - MQTT - Pluggit 300

Offline SvenJust

  • Full Member
  • ***
  • Beiträge: 319
Es gab Fehler beim Schalten des Sommer-Bypasses, diese sind in der jetzt online stehenden Version V0.15 korrigiert, https://github.com/svenjust/room-ventilation-system/commit/c62b2b7321b782e56975dd1c9e47d99340bfef82

VG Sven
FTUI, Banana PI/SSD, CUL CC1101, HMLAN, 10x HM-LC-Bl1PBU-FM, HM-LC-Sw4-WM (KWL Pluggit P300), HM-WDS30-OT2-SM (Sonnensensor), HM-Sec-SCo, LW-12 Wifi LED, CUL Selbstbau nanoCUL 433 (IT), Arduino (S0-Stromverbrauch), OW DS2480 (OWX_ASYNC) 8x DS18B20, MQTT (Fröling P4), MYSENSORS (Roto Rollläden)
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline kabelschnürschuh

  • New Member
  • *
  • Beiträge: 3
Hallo Sven,
vorab erstmal vielen Dank für tolle Arbeit!

Ich bin gerade dabei, deine Steuerung für meine Avent P300 nachzubauen, da sich dort ebenfalls die Platine verabschiedet hat. Die Schaltung habe ich mittlerweile größtenteils begriffen.
Was mir jetzt noch Fragen aufwirft, ist die Beschaltung der Relais für die Lüfter bzw Bypass:
Bei meinen Relais (4fach Relaiskarte) habe ich im ungeschalteten Zustand Durchgang vom mittleren zum 'rechten' Anschluß. Sobald das Relais geschaltet ist, vom mittleren zum 'linken' Anschluß. D.h. wenn ich es wie auf deinem Schaltplan verkabele, habe ich in keinem Schaltzustand  Durchgang vom 'Bypass-Power-Relais' über die Brücke zum 'Bypass-Richtungs-Relais'

Ich bitte leihweise um eine Kneifzange, um das Brett von meinem Kopf zu entfernen, danke
bg Hauke
« Letzte Änderung: 10 April 2018, 18:25:12 von kabelschnürschuh »

Offline SvenJust

  • Full Member
  • ***
  • Beiträge: 319
Hallo Hauke!

Hallo Sven,
vorab erstmal vielen Dank für tolle Arbeit!
Danke.

Bei meinen Relais (4fach Relaiskarte) habe ich im ungeschalteten Zustand Durchgang vom mittleren zum 'rechten' Anschluß. Sobald das Relais geschaltet ist, vom mittleren zum 'linken' Anschluß.

Für das Bypass-Power-Relais führst Du die 230V-AC-Spannung über den mittleren Anschluss zu. Den linken Anschluss (Bypass-Power-Relais) verbindest Du mit dem mittleren Anschluss des Richtungsrelais. Der linke Anschluss des Richtungsrelais steuert dann Bypass-Zu, der rechte Anschluss Bypass-Auf.

Viel Spaß und viel Erfolg.

Viele Grüße
Sven
FTUI, Banana PI/SSD, CUL CC1101, HMLAN, 10x HM-LC-Bl1PBU-FM, HM-LC-Sw4-WM (KWL Pluggit P300), HM-WDS30-OT2-SM (Sonnensensor), HM-Sec-SCo, LW-12 Wifi LED, CUL Selbstbau nanoCUL 433 (IT), Arduino (S0-Stromverbrauch), OW DS2480 (OWX_ASYNC) 8x DS18B20, MQTT (Fröling P4), MYSENSORS (Roto Rollläden)

Offline kabelschnürschuh

  • New Member
  • *
  • Beiträge: 3
Vielen Dank! Hatte es mir fast schon so gedacht. Allerdings scheint der Bypassmotor ebenfalls den Geist aufgegeben zu haben: Kein Pieps sagt das Ding. Beschaltung laut Datenblatt (http://www.belimo.ch/pdf/d/CM230-L_datasheet_de-ch.pdf) ist korrekt, Spannung liegt an. Mit folgendem Testprogramm tat sich nichts.

const int bypasspower = 40;
const int bypassdir = 41;
const int fan1 = 42;
const int fan2 = 43;

#define RELAY_ON   LOW
#define RELAY_OFF  HIGH
#include <SPI.h>
void setup() {
  pinMode(bypasspower, OUTPUT); // Den PWM PIN "relaisPin" als Ausgangssignal setzen.
  pinMode(bypassdir, OUTPUT);
  pinMode(fan1, OUTPUT);
  pinMode(fan2, OUTPUT);


 Serial.begin(57600);
 while (!Serial) {
    ; // wait for serial port to connect. Needed for native USB port only
  }
 
}
void loop() {
  digitalWrite(bypasspower, RELAY_OFF);
  digitalWrite(bypassdir, RELAY_OFF);
  digitalWrite(fan1, RELAY_OFF);
  digitalWrite(fan2, RELAY_OFF);
  delay(5000);
 
  digitalWrite(bypasspower, RELAY_ON);
  delay(500);
  Serial.println("Bypass Power: ON");
  // Serial.println(RELAY_ON);
  digitalWrite(bypassdir, RELAY_ON);
  Serial.println("Bypass Direction: CLOSE");
  delay(50000);
 
  digitalWrite(bypassdir, RELAY_OFF);
  Serial.println("Bypass Direction: OPEN");
  delay(50000);
 
  digitalWrite(bypasspower, RELAY_OFF);
  Serial.println("Bypass Power: OFF");
  delay(2000);
 
  digitalWrite(fan1, RELAY_ON);
  Serial.println("Fan 1: ON");
  delay(500);
  digitalWrite(fan1, RELAY_OFF);
  Serial.println("Fan 1: OFF");
  delay(1000);
 
  digitalWrite(fan2, RELAY_ON);
  Serial.println("Fan 2: ON");
  delay(500);
  digitalWrite(fan2, RELAY_OFF);
  Serial.println("Fan 2: OFF");
  delay(1000);
}

Neuer Motor ist bestellt (70€), Bezugsquelle verlinke ich bei Bedarf gerne nach.

Offline Starsurfer

  • Full Member
  • ***
  • Beiträge: 170
    • Projekt-Heimwerken
Moin,
wollte mal kurz eine Rückmeldung geben.
Habe die Steuerung jetzt seid knapp 5 Wochen im realen Einsatz und was soll ich sagen, sie läuft 1A.
Danke noch einmal Sven, für deine tolle Arbeit :-)

Momentan habe ich die Bypassklappe noch nicht eingebaut und wir hatten ja jetzt schon ein paar ordentlich warme Tage und die Erhitzung des Hauses hält sich in Grenzen.
Eventuell werde ich die Anlage bei über 24 Grad Zuluft, die Anlage ausschalte, mal sehen.
Ansonsten alles Top
Zotak Zbox + LaCrosseGateway + CURL 433 + 868 + HM-MOD-RPI-PCB WLAN + ConBee + Migateway
HomeMatic HM-CC-RT-DN - Sonoff Tasmota
LaCrosse TX29DTH - PCA301 - Intertechno IT1500
Arduino Mega - MQTT - Pluggit 300

Offline SvenJust

  • Full Member
  • ***
  • Beiträge: 319
Habe die Steuerung jetzt seid knapp 5 Wochen im realen Einsatz und was soll ich sagen, sie läuft 1A.

Hallo Sascha,

danke für die Rückmeldung, freut mich zu hören, dass es so problemlos funktioniert.

VG Sven
FTUI, Banana PI/SSD, CUL CC1101, HMLAN, 10x HM-LC-Bl1PBU-FM, HM-LC-Sw4-WM (KWL Pluggit P300), HM-WDS30-OT2-SM (Sonnensensor), HM-Sec-SCo, LW-12 Wifi LED, CUL Selbstbau nanoCUL 433 (IT), Arduino (S0-Stromverbrauch), OW DS2480 (OWX_ASYNC) 8x DS18B20, MQTT (Fröling P4), MYSENSORS (Roto Rollläden)

Offline kabelschnürschuh

  • New Member
  • *
  • Beiträge: 3
Hi,
auch von mir nochmal meinen herzlichsten Dank an alle Mitwirkenden!
Der neue Bypass-Motor ist eingebaut und die Steuerung des "Avenduinos 300" insgesamt funktioniert 1A! Von meiner, mit dem Dachrinnenlötkolben geklöppelten, Lochrasterplatine V1.0 stelle ich bald nochmal ein paar Fotos rein... aber erst wenn die ordentlich gebastelte V2.0 fertig ist. ;-)

Die Steuerung habe ich noch insofern angepasst, dass ich den TFT- und DAC-Teil rausgenommen habe, da ich kein TFT habe und nicht vorhabe ein Vorheizregister einzubauen, also reichen da die Optokoppler. Die Anzeige und Steuerung läuft bei mir über Raspberry und OpenHAB.

lg
Hauke

Offline SvenJust

  • Full Member
  • ***
  • Beiträge: 319
Hallo Hauke!

Lochrasterplatine V1.0 stelle ich bald nochmal ein paar Fotos rein... aber erst wenn die ordentlich gebastelte V2.0 fertig ist. ;-)
Bilder sind immer klasse und erleichtern anderen Nutzern den Zugang zum Nachbau.


Die Steuerung habe ich noch insofern angepasst, dass ich den TFT- und DAC-Teil rausgenommen habe, da ich kein TFT habe und nicht vorhabe ein Vorheizregister einzubauen, also reichen da die Optokoppler.
Sehr gut, die Steuerung auf dem Arduino ist auch entsprechend entwickelt worden, so dass die Steuerung auch ohne TFT-Display und DAC funktioniert.

Die Anzeige und Steuerung läuft bei mir über Raspberry und OpenHAB.
 

Die Visualisierung mittels OpenHAB hört sich interessant an. Falls Du in dem OpenHAB-Forum etwas dazu gezeigt hast, wäre der Link interessant.

VG Sven
« Letzte Änderung: 07 Mai 2018, 13:41:18 von SvenJust »
FTUI, Banana PI/SSD, CUL CC1101, HMLAN, 10x HM-LC-Bl1PBU-FM, HM-LC-Sw4-WM (KWL Pluggit P300), HM-WDS30-OT2-SM (Sonnensensor), HM-Sec-SCo, LW-12 Wifi LED, CUL Selbstbau nanoCUL 433 (IT), Arduino (S0-Stromverbrauch), OW DS2480 (OWX_ASYNC) 8x DS18B20, MQTT (Fröling P4), MYSENSORS (Roto Rollläden)

Offline arnoldluk

  • Newbie
  • Beiträge: 1
Hallo Sven,

Vorab, danke für die tolle Steuerung die du hier entwickelt hast.

Habe mir eine gebrauchte Helios KWL 300 gekauft die ich bei mir installieren möchte.
Da ich die Anlage auch über FHEM steuern möchte habe ich mich entschieden deine Steuerung dafür einzusetzten.
Habe deine Steuerung aufgebaut, und es funktioniert soweit auch alles super. Anbindung an FHEM über MQTT funtioniert auch.
Habe auch einen VOC Sensor TGS2600 mit angeschlossen, Auf dem Touchscreen bekomme ich den Wert angezeigt, wird aber nicht über MQTT gepublisht.
Im sourcecode mqtt_send.ino ist TOPICKwlVOCAbluft nicht vorhanden.
Habe ich da ein Denkfehler oder muss ich da noch was einstellen damit ich den VOC Wert über MQTT übermittelt bekomme?

Danke!
LG Arnold



Offline SvenJust

  • Full Member
  • ***
  • Beiträge: 319
Hallo Arnold!

Vorab, danke für die tolle Steuerung die du hier entwickelt hast.
Danke,  :)

Habe auch einen VOC Sensor TGS2600 mit angeschlossen, Auf dem Touchscreen bekomme ich den Wert angezeigt, wird aber nicht über MQTT gepublisht.

Das Publishen des VOC Wertes ist in der Tat in der Version https://github.com/svenjust/room-ventilation-system/commit/c62b2b7321b782e56975dd1c9e47d99340bfef82 nicht implementiert, ich habe es bei mir lokal aber ergänzt und werde den Code heute Abend am Gerät testen und die Änderungen bei github hochladen. Ich melde mich dann hier nochmals...

Danke für die Rückmeldung.

Viele Grüße
Sven
FTUI, Banana PI/SSD, CUL CC1101, HMLAN, 10x HM-LC-Bl1PBU-FM, HM-LC-Sw4-WM (KWL Pluggit P300), HM-WDS30-OT2-SM (Sonnensensor), HM-Sec-SCo, LW-12 Wifi LED, CUL Selbstbau nanoCUL 433 (IT), Arduino (S0-Stromverbrauch), OW DS2480 (OWX_ASYNC) 8x DS18B20, MQTT (Fröling P4), MYSENSORS (Roto Rollläden)