Autor Thema: SIGNALESP: Firm- und Hardware für SIGNALduino direkt auf ESP8266 oder ESP32  (Gelesen 11324 mal)

Offline Bennemannc

  • Hero Member
  • *****
  • Beiträge: 2726
Hallo,

kann man die Quellen von der rc4 irgendwo runter laden ? Wenn ja wo?

Gruß Christoph
Cubietruck, Fhem 5.8
CC-RT-DN|LC-SW2-FM|RC-12|RC-19|LC-SW4-BA-PCB|LCp-SW1-BA-PCB|ES-PMSw1-Pl|LC-Bl1PBU-FM|PBI-4-FM|CC-VD|CC-TC|SEC-SC(2)|RC-KEY3-B|LC-Sw1PBU-FM|PB-2-FM|WDS100-C6-O|WDC7000|LC-Bl1-FM
Module: Dewpoint,FB_Callmonitor,HCS,Panstamp,at,notify,THRESHOLD,average,DOIF

Offline Sidey

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2091
Ja, hier:

https://github.com/RFD-FHEM/SIGNALESP/tree/dev-cc1101-cb?files=1

Gesendet von meinem XT1650 mit Tapatalk

Signalduino, HMLan, Raspberry Pi, Mysensors, ArduinoSensor

Offline SabineT

  • Full Member
  • ***
  • Beiträge: 188
gibt es jetzt eigentlich ein funktionierendes Binary für den ESP32 + CC1101?
Offenbar gibt es da nichts :(

Offline stefanru

  • Full Member
  • ***
  • Beiträge: 408
Habe es manuell eingetragen.

Irgendwie seltsam.

Gruß,
Stefan

Offline OppiM

  • New Member
  • *
  • Beiträge: 29
Hi,

ich hab mir jetzt auch mal einen SIGNALESP zusammengebaut, der auch direkt funktioniert hat. Nur mit einem Sender gibt es Probleme, er wird zwar empfangen, aber die Nachricht nicht weiter verarbeitet:
2018.02.14 09:00:05 4 : mySignaldunio/msg READ: Mc;LL=-2590;LH=3278;SL=-1128;SH=1788;D=EDDFBF8D;C=1463;L=32;R=33;
Ein parallel laufender Signaldunio empfängt und verarbeitet die Nachricht:
2018.02.14 09:00:04 4 : mySignaldunio/msg READ: MC;LL=-2653;LH=3204;SL=-1199;SH=1733;D=EDDFBF8D;C=1464;L=32;R=36;
2018.02.14 09:00:04 4 : mySignaldunio: Found manchester Protocol id 18 clock 1464 RSSI -56 -> OSV1
2018.02.14 09:00:04 5 : mySignaldunio: extracted data 00010010001000000100000001110010 (bin)
2018.02.14 09:00:04 4 : mySignaldunio: OSV1 input data: 00010010001000000100000001110010
2018.02.14 09:00:04 4 : mySignaldunio: OSV1 protocol id (18) translated to RFXSensor format
2018.02.14 09:00:04 4 : mySignaldunio: converted to hex: (500A4D2008402000002100)
2018.02.14 09:00:04 5 : mySignaldunio Dispatch: 500A4D2008402000002100, test ungleich: disabled
2018.02.14 09:00:04 5 : mySignaldunio Dispatch: 500A4D2008402000002100, -56 dB, dispatch
2018.02.14 09:00:04 5 : mySignaldunio: dispatch 500A4D2008402000002100
2018.02.14 09:00:04 5 : OREGON: decoding delay=29 hex=500A4D2008402000002100
2018.02.14 09:00:04 5 : OREGON: sensor_id=0a4d BitsMsg=80 Bits=80
2018.02.14 09:00:04 5 : OREGON: checksum2 = 33 berechnet: 33
2018.02.14 09:00:04 4 : THR128_08_2 decoded Oregon: T: 20.4 BAT: ok

Der einzige Unterschied, den ich sehe, ist das beim SIGNALESP Mc steht während beim Signaldunio MC steht.

SIGNALESP version: V 3.3.1-rc3 SIGNALESP cc1101 868MHz - compiled at Jan 24 2018 21:48:34
Signaldunio version: V 3.3.1-dev SIGNALduino cc1101 - compiled at Jan 12 2017 20:49:02

Kann ich da beim Zusammenbau was falsch gemacht haben?

Gruß,
Michael

Offline Sidey

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2091
Hallo Oppim,

Du hast keinen Fehler beim Zusammenbau gemacht.

Das liegt an Änderungen in der Firmware.
Auf dem ESP verwendest Du eine aktuellere als auf dem Arduino.

Wenn Du die Entwicklungs Version des Moduls installierst, dann sollte der Sensor korrekt demoduliert werden.

update all https://raw.githubusercontent.com/RFD-FHEM/RFFHEM/dev-r33/controls_signalduino.txt

Gesendet von meinem XT1650 mit Tapatalk

Signalduino, HMLan, Raspberry Pi, Mysensors, ArduinoSensor

Offline OppiM

  • New Member
  • *
  • Beiträge: 29
Hi Sidey,

klappt!

Danke,
Michael

Offline raiderxxl

  • Full Member
  • ***
  • Beiträge: 114
Ich ich muss auch bei jedem Neustart WLAN neu verbinden (RC3)...
Von Hand eingetragen einmal mit Scan einmal ohne Scan...
RC3
Grüßle

Pascal
FHEM VM Ubuntu-Server auf Intel® NUC-Kit NUC6i5SYH ESXi 6.5
FHEM auf Raspberry2 OSMC Hyperion und TTS
FHEM auf ACER Aspire easyStore Ubuntu-Server
Homematic,TradfriHub und Lampen,WIFILight,Fritzbox,FritzDECT,NanoCul433,IT Steckdosen,Diverse Nachbar-Sensoren,
ESP_Signalduino,ESPEasy,Amad,HarmonyHub,

Offline Bennemannc

  • Hero Member
  • *****
  • Beiträge: 2726
Hallo,

das mit dem Autoverbinden ist ja auch nicht wirklich einfach. In meinen Augen gibt es 4 Möglichkeiten.
1) das verbinden mit bekannter SSID und Passwort mit fester IP
2) das verbinden mit bekannter SSID und Passwort
3) WPS
4) die Weboberfläche zum verbinden, also der eigene AP
Was ich mich frage - in welcher Reihenfolge sollten die Möglichkeiten durchlaufen werden? Gerade das mit fester IP ist so ein Problem, weil,da ja immer ein Wert drin steht. Mann müsste also vorher bestimmen ob der Wert auch sinnvoll ist. Wenn alles auf 0.0.0.0 steht, könnte man das verbinden mir fester IP weglassen. Ich würde vorschlagen, das in dieser Reihenfolge zu durchlaufen - also von 1 nach 4.

Gruß Christoph
Cubietruck, Fhem 5.8
CC-RT-DN|LC-SW2-FM|RC-12|RC-19|LC-SW4-BA-PCB|LCp-SW1-BA-PCB|ES-PMSw1-Pl|LC-Bl1PBU-FM|PBI-4-FM|CC-VD|CC-TC|SEC-SC(2)|RC-KEY3-B|LC-Sw1PBU-FM|PB-2-FM|WDS100-C6-O|WDC7000|LC-Bl1-FM
Module: Dewpoint,FB_Callmonitor,HCS,Panstamp,at,notify,THRESHOLD,average,DOIF

Offline Sidey

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2091
Ich habe mich damit etwas beschäftigt.

Es ist nicht so einfach die drei Optionen unter einen Hut zu bringen:

WPS mit DHCP
Manuelle SSID Auswahl mit DHCP
Manuelle SSID Auswahl mit statischer Adresse.

Der Aktuelle Stand im Repo deckt alle drei Optionen ab.
Zuerst wird aber immer der eigene AP Modus für 60 Sekunden gestartet.
In dieser Zeit kann man Konfigurationen ändern.

WPS wird jetzt erst gemacht, wenn zu keiner vorhandene SSID eine Verbindung hergestellt werden kann.

Aktuell ist noch selbst compilieren angesagt :)

Grüße Sidey

Gesendet von meinem XT1650 mit Tapatalk

Signalduino, HMLan, Raspberry Pi, Mysensors, ArduinoSensor

Offline BlackStone

  • Full Member
  • ***
  • Beiträge: 188
Könnte mir jemand die aktuelle als binary zur Verfügung stellen?
Ich habe von locutus den D1 Mini cc1101 Schild.
Aus irgend einem Grund schmiert die ide bei mir mal wieder ab.
Und die binary vom Thread Anfang bekomm ich komischer weise nicht ins wlan. Config über 4.1 versucht aufzurufen kommt keine password abfrage ´espconfigˋ o.ä.
Ja habe mit dem ap eine Verbindung aufgebaut.

Danke schon mal.



Gesendet von iPad mit Tapatalk
« Letzte Änderung: 17 Februar 2018, 12:24:10 von BlackStone »

Offline brezel

  • New Member
  • *
  • Beiträge: 7
Hallo,

also bei mir werden beim rc3 und rc4 jede Menge MS und MC Telegramme empfangen aber da scheints mit dem Hideki Protokoll irgendwie Probleme zu geben weil meine Devices mit diesen Versionen nicht atualisiert werden.

Also ich hänge mal die Compilierte rc4 hier mit an.

Grüße

Offline BlackStone

  • Full Member
  • ***
  • Beiträge: 188
Supi, geflasht und nu läuft der kleine. mal schaun wie er sich jetzt verhält.
 8)

Offline Bennemannc

  • Hero Member
  • *****
  • Beiträge: 2726
Hallo,

wo kann man den die static IP eingeben? Bei mir kommt nur des Feld wo ich static oder dhcp eingeben kann. Dabei ist es egal ob ich auf die Seite mit Scan oder ohne gehe.
Wenn ich versuche das selber zu compilieren bekomme ich immer eine Fehlermeldung.
Arduino: 1.8.5 (Linux), Board: "WeMos D1 R2 & mini, 80 MHz, 4M (1M SPIFFS), v2 Prebuilt (MSS=536), Disabled, None, 921600"

/home/christoph/Downloads/SIGNALESP-dev-cc1101-cb/SIGNALESP/SIGNALESP.ino: In function 'void setup()':
SIGNALESP:378: error: 'class SignalDetectorClass' has no member named 'setStreamCallback'
  musterDec.setStreamCallback(writeCallback);
            ^
exit status 1
'class SignalDetectorClass' has no member named 'setStreamCallback'


Gruß Christoph
« Letzte Änderung: 19 Februar 2018, 13:29:16 von Bennemannc »
Cubietruck, Fhem 5.8
CC-RT-DN|LC-SW2-FM|RC-12|RC-19|LC-SW4-BA-PCB|LCp-SW1-BA-PCB|ES-PMSw1-Pl|LC-Bl1PBU-FM|PBI-4-FM|CC-VD|CC-TC|SEC-SC(2)|RC-KEY3-B|LC-Sw1PBU-FM|PB-2-FM|WDS100-C6-O|WDC7000|LC-Bl1-FM
Module: Dewpoint,FB_Callmonitor,HCS,Panstamp,at,notify,THRESHOLD,average,DOIF

Offline habeIchVergessen

  • Sr. Member
  • ****
  • Beiträge: 695
hattest du in der Vergangenheit die Sourcen unter src/_micro-api/libraries in das library-Verzeichnis der Arduino IDE (unter Windows %USERPROFILE%\Documents\Arduino\libraries) kopiert?
Wenn ja, dann musst du diese aktualisieren. Dann sollte auch das Kompilieren klappen.

 

decade-submarginal