Autor Thema: SIGNALESP: Firm- und Hardware für SIGNALduino direkt auf ESP8266 oder ESP32  (Gelesen 46633 mal)

Offline HomeAuto_User

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 962
Hallo Marko,
Hallo, guten Morgen,

ich habe 2 Fhem System am Laufen:
1. Fhem auf einem Raspberry 2
2. Fhem in einer Proxmox VM

Fhem 2 ist ein Klon von Fhem 1. Sie sind nicht verbunden, jedes System arbeitet selbstständig.

Auf der 1. Instanz habe ich den SignalESP seit ca. einem Jahr eingebunden und nutze ihn zum Schalten von IT Geräten/ 433 Mhz 192.168.1.42:23.
Auf der 2. Instanz wurde er durch das Klonen 1 : 1 eingebunden. Allerdings steht er auf disconnected. Setze ich ihn auf „reset“ ist er kurz online (opened für 1–2 Minuten) und ist dann wieder weg.

Hat jemand einen Tipp für mich, warum es hier geht und dort nicht? Alle anderen Geräte wurden im Klon übernommen und konnten 1 : 1 verwendet werden.

Viele Grüße
Marko
verstehe ich es richtig, du greifst zur selben Zeit aus 2 FHEM Instanzen auf den ESP?

Das Problem wird sein, das zur selben Zeit auf den ESP zugegriffen wird. Ich habe das Verhalten nachgestellt.
Wenn ich das 2. System auf den ESP einrichte, so öffnet er sich kurz und schließt sich wieder.
Ernst nachdem ich ein System wieder vom ESP trenne, so ist dieser auch Empfangsbereit.

Ob es schon jemals zur selben Zeit funktionierte weiß ich nicht aber würde ich bezweifeln.

MfG
"Developer" heißt nicht, das man alles wissen kann!
- FHEM v5.9 | Rasberry PI 3
- radino CC1101 433Mhz (SIGNALduino)| - radino CC1101 868Mhz (CUL) | nano 433Mhz (SIGNALduino) - Sensoren: purer Dschungel querbeet

Offline marko67

  • Full Member
  • ***
  • Beiträge: 129
Hallo Marko, verstehe ich es richtig, du greifst zur selben Zeit aus 2 FHEM Instanzen auf den ESP?

Das Problem wird sein, das zur selben Zeit auf den ESP zugegriffen wird. Ich habe das Verhalten nachgestellt.
Wenn ich das 2. System auf den ESP einrichte, so öffnet er sich kurz und schließt sich wieder.
Ernst nachdem ich ein System wieder vom ESP trenne, so ist dieser auch Empfangsbereit.

Ob es schon jemals zur selben Zeit funktionierte weiß ich nicht aber würde ich bezweifeln.

MfG

Hallo,

das ist richtig. Ich habe 2 Fhem Instanzen. Die eine ist mehr eine Test Instanz. Die andere ist produktiv.
Die Frage ist wohl beantwortet, dass es nicht geht von beiden darauf zuzugreifen.

Dann möchte ich aber gerne eine weitere Frage stellen:

Da unser Haus sehr verwinkelt ist, möchte ich einen 2. 433er Cul einsetzen. Wie kann ich das umsetzen? Die Empfänger kennen und empfangen ja nur 1 IO Devices.


Ein schönes Wochenende

Marko

Offline HomeAuto_User

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 962
Hallo Marko,

Da unser Haus sehr verwinkelt ist, möchte ich einen 2. 433er Cul einsetzen. Wie kann ich das umsetzen? Die Empfänger kennen und empfangen ja nur 1 IO Devices.

den Devices ist es egal. Wenn ein Device von 2 Sendern angesteuert wird, so registriert es beim Empfang beide. Beim senden kommt dann das Device zum Zuge welches im IODev eingetragen ist.

Ist deine Frage damit beantwortet?

Liebe Grüße


Gesendet von iPhone mit Tapatalk Pro
"Developer" heißt nicht, das man alles wissen kann!
- FHEM v5.9 | Rasberry PI 3
- radino CC1101 433Mhz (SIGNALduino)| - radino CC1101 868Mhz (CUL) | nano 433Mhz (SIGNALduino) - Sensoren: purer Dschungel querbeet

Offline marko67

  • Full Member
  • ***
  • Beiträge: 129
Hallo Marko,

den Devices ist es egal. Wenn ein Device von 2 Sendern angesteuert wird, so registriert es beim Empfang beide. Beim senden kommt dann das Device zum Zuge welches im IODev eingetragen ist.

Ist deine Frage damit beantwortet?

Liebe Grüße


Gesendet von iPhone mit Tapatalk Pro

Ehrlich Gesagt  ..... nein.

Meine Steckdose z.B. hat den Code : 0FF00F000F FF F0 als IODev: signalESP.433.

Internals:
   00         f0
   CFGFN      /opt/fhem/FHEM/SchalterIT.cfg
   DEF        0FF00F000F FF F0
   FUUID      5d5087aa-f33f-c6c6-8177-ef56554d4ee05640
   IODev      signalESP.433
   NAME       FS.EG.DeckenliFlur
   NR         995
   STATE      off
   TYPE       IT
   XMIT       0ff00f000f
   XMITdimdown 00
   XMITdimup  00
   XMITon     ff
   .attraggr:
   .attrminint:
   CODE:
     1          0ff00f000f
   READINGS:
     2019-11-22 19:14:46   protocol        V1
     2020-02-16 17:44:35   state           off
Attributes:
   IODev      signalESP.433
   ITclock    350
   devStateIcon on:light_ceiling@yellow off:light_ceiling@red
   icon       light_ceiling
   room       IT
   userattr   lightSceneParamsToSave lightSceneRestoreOnlyIfChanged:1,0
   webCmd     on:off:on-for-timer 300

Wie mache ich nun Bekannt machen, dass wenn ich on/off sende das über signalESP.433 UND signalESP1.433 geschehen soll?

Marko

Offline HomeAuto_User

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 962
Wie mache ich nun Bekannt machen, dass wenn ich on/off sende das über signalESP.433 UND signalESP1.433 geschehen soll?

Ein senden von 2 IODevs zur selben Zeit geht nicht. In das Attribut IODev kann nur ein Wert eingetragen werden.


Gesendet von iPhone mit Tapatalk Pro
"Developer" heißt nicht, das man alles wissen kann!
- FHEM v5.9 | Rasberry PI 3
- radino CC1101 433Mhz (SIGNALduino)| - radino CC1101 868Mhz (CUL) | nano 433Mhz (SIGNALduino) - Sensoren: purer Dschungel querbeet

Offline sash.sc

  • Hero Member
  • *****
  • Beiträge: 1753


]

Wie mache ich nun Bekannt machen, dass wenn ich on/off sende das über signalESP.433 UND signalESP1.433 geschehen soll?

Marko

Ich habe als erstes IODev einen cul.
Da kannst du das Attribut sendpool setzen. Ein Liste von weiteren Gateways du du dort hinterlegen kannst, auf denen dann die Befehle abgesetzt werden.

Das gleiche würde ich mir auch für den Signalduino wünschen.

Frei nach dem Motto, wenn auf dem 1.gesendet wird dann auch bitte auf den 2. Oder 3. Signalduino



Gesendet von meinem MI 9 mit Tapatalk

Raspi 2 Buster Lite; LaCrosse; HomeMatic; ESP8622 ;nanoCUL a-fw (433 & 868 MHz); MapleCUL; ZigBee
WLANduino 433&868 ; Shellys; MQTT2