Autor Thema: SIGNALESP: Firm- und Hardware für SIGNALduino direkt auf ESP8266 oder ESP32  (Gelesen 118507 mal)

Offline dadoc

  • Sr. Member
  • ****
  • Beiträge: 941
Du kannst erst mal testen ob überhaupt was empfangen wird.
Gibts bei Dir in der Nähe auch 433MHz slowrf (ASK/OOK) Sensoren?
An SlowRF habe ich wohl nur FS20-Sender, aber die haben halt nicht 433MHz. Ich probiere es aber mal, vielleicht funkt es ja in der Nachbarschaft? Einfach rfmode auf SlowRF_ccFactoryReset setzen? Oder bedeutet der Name, dass man vorher einen Factory Reset machen muss?
Standort 1: FS20 mit CUL und FHEM auf Raspi. HM-Komponenten (Heizung, Rollladen, Schalter). HM IP über Raspimatic (testweise)
Standort 2: Homematic (Wired) über CCU2 und PocketHome HD
3 x Raspi3 mit piCorePlayer/Kodi für Multiroom Audio (+ Tablets/iPeng/iPods

Offline Ralf9

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4401
Mit rfmode auf SlowRF_ccFactoryReset wird mit dem raw Befehl e ein ccFactoryReset durchgeführt,
wenn Du dann die Frequenz auf 868.35 änderst, solltest Du die FS20 Sender empfangen können, evtl musst Du die cc1101_bwidth erhöhen

Du kannst mit get ccconf die Einstellungen anschauen
« Letzte Änderung: 21 September 2022, 23:33:36 von Ralf9 »
FHEM auf Cubietruck mit Igor-Image, SSD und  hmland + HM-CFG-USB-2,  HMUARTLGW Lan,   HM-LC-Bl1PBU-FM, HM-CC-RT-DN, HM-SEC-SC-2, HM-MOD-Re-8, HM-MOD-Em-8
HM-Wired:  HMW_IO_12_FM, HMW_Sen_SC_12_DR, Selbstbau IO-Module HBW_IO_SW
Maple-SIGNALduino, WH3080,  Hideki, Id 7

Offline dadoc

  • Sr. Member
  • ****
  • Beiträge: 941
Scheint zu empfangen:
21 23:38:42 SIGNALduino mkduino UNKNOWNCODE 810c04xx0909a0012B447E007701
2022-09-21 23:38:42 FS20 Dimmer_03 dimup
2022-09-21 23:38:42 SIGNALduino mkduino UNKNOWNCODE 810b04f70101a0011c112d0013
2022-09-
Standort 1: FS20 mit CUL und FHEM auf Raspi. HM-Komponenten (Heizung, Rollladen, Schalter). HM IP über Raspimatic (testweise)
Standort 2: Homematic (Wired) über CCU2 und PocketHome HD
3 x Raspi3 mit piCorePlayer/Kodi für Multiroom Audio (+ Tablets/iPeng/iPods

Offline dadoc

  • Sr. Member
  • ****
  • Beiträge: 941
Allerdings schießt es mir jetzt das gesamte fhem ab, sobald ich einen fs20-Befehl absetze…
Standort 1: FS20 mit CUL und FHEM auf Raspi. HM-Komponenten (Heizung, Rollladen, Schalter). HM IP über Raspimatic (testweise)
Standort 2: Homematic (Wired) über CCU2 und PocketHome HD
3 x Raspi3 mit piCorePlayer/Kodi für Multiroom Audio (+ Tablets/iPeng/iPods

Offline Ralf9

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4401
ja das passt
2022.09.21 23:46:03 4: sduinoD/msg get dispatch: 810b04f70101a0011c112d0013
2022.09.21 23:46:03 5: sduinoD: dispatch 810b04f70101a0011c112d0013
2022.09.21 23:46:03 3: FS20 Unknown device 1c11 (12411212), Button 2d (1342) Code 13 (dimup), please define it

Es kann evtl sein, daß Du ein 868MHz Modul hast wo die Frequenz nicht ganz stimmt.
Bei FSK muss die Frequenz genauer passen als bei slowrf

Du kannst mal beim rfmode WH24 versuchen die Frequenz um ca 0.3 in 0.05 Schritten zu ändern

FHEM auf Cubietruck mit Igor-Image, SSD und  hmland + HM-CFG-USB-2,  HMUARTLGW Lan,   HM-LC-Bl1PBU-FM, HM-CC-RT-DN, HM-SEC-SC-2, HM-MOD-Re-8, HM-MOD-Em-8
HM-Wired:  HMW_IO_12_FM, HMW_Sen_SC_12_DR, Selbstbau IO-Module HBW_IO_SW
Maple-SIGNALduino, WH3080,  Hideki, Id 7

Offline dadoc

  • Sr. Member
  • ****
  • Beiträge: 941
Mit dem Jeelink funktioniert es ja (nur) bei 868.345. Darauf habe ich jetzt den sduino gesetzt. Nun kommen readings wie
LASTDMSG 810c04xx0909a00155450000A600Oder RAWMSG MU;P0=-640;P1=-9354;P2=-31382;P3=198;P4=-419;P5=553;P6=-1454;P7=367;CP=7;R=8;D=345674747474747474747474747450745074507450745074745074747450745050747474747474747474507450747450507474747474747474747474745074745050747450717474747474747474747474745074507450745074507474507474745074505074747474747474747450745074745050747474747474747474747474507474505074745072;e;Mich verwirren auch die abweichenden Frequenzangaben:
cc1101_config freq:868.345MHz bWidth:812KHz rAmpl:33dB sens:8dB (DataRate:17257.69Baud)
2022-09-22 00:13:11
cc1101_config_ext
Modulation:2-FSK (SYNC_MODE:16/16 + carrier-sense above threshold) DEVIATN:88.867kHz
2022-09-22 00:13:11
cmdBank
B: b=1 freq:868.350MHz bWidth:812KHz rAmpl:33dB sens:8dB (DataRate:17257.69Baud) [boffs=0100]

   N=6 ccmode=3 sync=2DD4 Modulati
Standort 1: FS20 mit CUL und FHEM auf Raspi. HM-Komponenten (Heizung, Rollladen, Schalter). HM IP über Raspimatic (testweise)
Standort 2: Homematic (Wired) über CCU2 und PocketHome HD
3 x Raspi3 mit piCorePlayer/Kodi für Multiroom Audio (+ Tablets/iPeng/iPods

Offline Ralf9

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4401
Zitat
2022.09.22 00:34:23 5 : sduinoD: dispatch 810c04xx0909a00155450000A600
2022.09.22 00:34:23 3 : FHT Unknown device 5545, please define it
Hast Du auch FHT?

Wenn Du solche Nachrichten empfängst, dann ist der rfmode slowrf noch aktiv

Wenn Du bei slowrf erst nach erhöhen der bwidth was empfängst, dann ist dies ein Hinweis, daß Du ein fehlerhaftes cc1101 Modul hast wo die Frequenz nicht passt.

Bei FSK solltest Du die bwidth nicht erhöhen
« Letzte Änderung: 22 September 2022, 00:57:43 von Ralf9 »
FHEM auf Cubietruck mit Igor-Image, SSD und  hmland + HM-CFG-USB-2,  HMUARTLGW Lan,   HM-LC-Bl1PBU-FM, HM-CC-RT-DN, HM-SEC-SC-2, HM-MOD-Re-8, HM-MOD-Em-8
HM-Wired:  HMW_IO_12_FM, HMW_Sen_SC_12_DR, Selbstbau IO-Module HBW_IO_SW
Maple-SIGNALduino, WH3080,  Hideki, Id 7

Offline dadoc

  • Sr. Member
  • ****
  • Beiträge: 941
Hast Du auch FHT?
Die Nachbarwohnung hat welche. Aber woher kommt das Zitat, mit Uhrzeit 00:34? Ich hatte ja vorher geposted und auch keine (für mich erkennbaren) FHT-Messages bekommen.
Zitat
Wenn Du solche Nachrichten empfängst, dann ist der rfmode slowrf noch aktiv
D.h. der geht nicht weg, wenn man einen anderen rfmode wählt?
Standort 1: FS20 mit CUL und FHEM auf Raspi. HM-Komponenten (Heizung, Rollladen, Schalter). HM IP über Raspimatic (testweise)
Standort 2: Homematic (Wired) über CCU2 und PocketHome HD
3 x Raspi3 mit piCorePlayer/Kodi für Multiroom Audio (+ Tablets/iPeng/iPods

Offline Ralf9

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4401
Zitat
Die Nachbarwohnung hat welche. Aber woher kommt das Zitat, mit Uhrzeit 00:34?
Ich hab bei mir ein dummy sduino definiert und kann es damit mit Deinen Nachrichten simulieren.

Wenn der wh24 rfmode aktiv ist, dann empfängst Du kein slowrf mehr, Du kannst es mit "get ccconf" und "get CmdBank" kontrollieren
FHEM auf Cubietruck mit Igor-Image, SSD und  hmland + HM-CFG-USB-2,  HMUARTLGW Lan,   HM-LC-Bl1PBU-FM, HM-CC-RT-DN, HM-SEC-SC-2, HM-MOD-Re-8, HM-MOD-Em-8
HM-Wired:  HMW_IO_12_FM, HMW_Sen_SC_12_DR, Selbstbau IO-Module HBW_IO_SW
Maple-SIGNALduino, WH3080,  Hideki, Id 7

Offline dadoc

  • Sr. Member
  • ****
  • Beiträge: 941
Moin,
ich denke, FSK ist aktiv:
ccconf: freq:868.345MHz bWidth:812KHz rAmpl:33dB sens:8dB (DataRate:17257.69Baud)

Modulation:2-FSK (SYNC_MODE:16/16 + carrier-sense above threshold) DEVIATN:88.867kHz
cmdBank:
B: b=0 freq:868.345MHz bWidth:812KHz rAmpl:33dB sens:8dB (DataRate:17257.69Baud) [boffs=0000]

   N=6 ccmode=3 sync=2DD4 Modulation:2-FSK (SYNC_MODE:16/16 + carrier-sense above threshold) DEVIATN:88.867kHz
Standort 1: FS20 mit CUL und FHEM auf Raspi. HM-Komponenten (Heizung, Rollladen, Schalter). HM IP über Raspimatic (testweise)
Standort 2: Homematic (Wired) über CCU2 und PocketHome HD
3 x Raspi3 mit piCorePlayer/Kodi für Multiroom Audio (+ Tablets/iPeng/iPods

Offline dadoc

  • Sr. Member
  • ****
  • Beiträge: 941
Zitat
WH24_WH25 - 868.300 MHz, Datarate: 17.241 kbps (LaCrosse)  - SYNC  = 2DD4,  bWidth = 203KHz, DataRate = 17257.69Baud, DEVIATN = 88.867kHz,  20 byte in RX, ccN=0,  ccmode=4
get sduino raw CW0001,0246,0304,042D,05D4,06FF,0700,0802,0D21,0E65,0F6A,1089,115C,1206,1322,14F8,1556,1700,1818,1916,1B43,1C68,1D91,2211,23E9,242A,2500,2611,3D00,3E04,4057,4148,4232,4334,4457,4548,4632,4735
ist doch noch aktuell/korrekt?
Und als Vorgehen:
1. Reset mit e
2. Bank 0 selektieren
3. CREB
4. Dann obigen Code per get raw… übertragen
5. Dann LaCrossePairForSec z.B. auf 120

Dann müsste nach meinem Verständnis ein LC device per autocreate angelegt werden.
Welche Version des LaCross-Moduls sollte es denn sein? Da kursieren ja auch verschiedene.
Standort 1: FS20 mit CUL und FHEM auf Raspi. HM-Komponenten (Heizung, Rollladen, Schalter). HM IP über Raspimatic (testweise)
Standort 2: Homematic (Wired) über CCU2 und PocketHome HD
3 x Raspi3 mit piCorePlayer/Kodi für Multiroom Audio (+ Tablets/iPeng/iPods

Offline Ralf9

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4401
Nein reset ist nicht jedes mal notwendig.
Es reicht wenn du die neue config mir get RAW CW... oder einfacher mit set rfmode wh24... überzrägst.
Mit CREB wird die Bank Zuordnung wieder gelöscht.

Für den WH24 benötigst du meine Version vom 14_SDWS modul
FHEM auf Cubietruck mit Igor-Image, SSD und  hmland + HM-CFG-USB-2,  HMUARTLGW Lan,   HM-LC-Bl1PBU-FM, HM-CC-RT-DN, HM-SEC-SC-2, HM-MOD-Re-8, HM-MOD-Em-8
HM-Wired:  HMW_IO_12_FM, HMW_Sen_SC_12_DR, Selbstbau IO-Module HBW_IO_SW
Maple-SIGNALduino, WH3080,  Hideki, Id 7

Offline dadoc

  • Sr. Member
  • ****
  • Beiträge: 941
oder einfacher mit set rfmode wh24... überzrägst.
Ah ok, danke. Bei mir erscheint im set rfmode Dropdown allerdings kein wh24.
Standort 1: FS20 mit CUL und FHEM auf Raspi. HM-Komponenten (Heizung, Rollladen, Schalter). HM IP über Raspimatic (testweise)
Standort 2: Homematic (Wired) über CCU2 und PocketHome HD
3 x Raspi3 mit piCorePlayer/Kodi für Multiroom Audio (+ Tablets/iPeng/iPods

Offline Ralf9

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4401
Dann hast du evtl nicht sie aktuelle dev Version von meinem 00_Signalduino Modul installiert
FHEM auf Cubietruck mit Igor-Image, SSD und  hmland + HM-CFG-USB-2,  HMUARTLGW Lan,   HM-LC-Bl1PBU-FM, HM-CC-RT-DN, HM-SEC-SC-2, HM-MOD-Re-8, HM-MOD-Em-8
HM-Wired:  HMW_IO_12_FM, HMW_Sen_SC_12_DR, Selbstbau IO-Module HBW_IO_SW
Maple-SIGNALduino, WH3080,  Hideki, Id 7

Offline dadoc

  • Sr. Member
  • ****
  • Beiträge: 941
Für den WH24 benötigst du meine Version vom 14_SDWS modul
Ah, danke, war mir nicht bewusst.
Zitat
Dann hast du evtl nicht sie aktuelle dev Version von meinem 00_Signalduino Modul installiert
Dito.
Jetzt ist beides drin; ich habe mal attr debug gesetzt. Lt. Log wurde jetzt anscheinend einmal etwas empfangen:
2022.09.22 11:23:46 1: DEBUG>mkduino: incoming message: (MN;D=0000000000008C81C000000020200000000007FC;R=219;)
2022.09.22 11:23:46 1: DEBUG>mkduino: extracted  data 0000000000008C81C000000020200000000007FC
2022.09.22 11:23:46 1: DEBUG>mkduino: extracted RSSI 219
Muss ich denn für das SD_WS auch LaCrossePairForSec setzen? So oder so scheinen aber keine weiteren Daten reinzukommen bzw. es werden keine Devices angelegt. Werde, sobald ich Zeit habe, nochmal mit der Frequenz spielen.
Sorry für die vielen Fragen, aber das ist für mich alles noch ein wenig verwirrend... und danke für Deine Unterstützung
Standort 1: FS20 mit CUL und FHEM auf Raspi. HM-Komponenten (Heizung, Rollladen, Schalter). HM IP über Raspimatic (testweise)
Standort 2: Homematic (Wired) über CCU2 und PocketHome HD
3 x Raspi3 mit piCorePlayer/Kodi für Multiroom Audio (+ Tablets/iPeng/iPods

 

decade-submarginal