Autor Thema: [Erledigt] Perl Fehler nach FHEM Update  (Gelesen 499 mal)

Offline gamelive1207

  • New Member
  • *
  • Beiträge: 27
[Erledigt] Perl Fehler nach FHEM Update
« am: 27 Januar 2018, 21:39:18 »
Hallo alle zusammen,

ich habe heute mal wieder ein FHEM Update gemacht, jetzt funktioniert Fhem aber nicht mehr.

Es gibt wohl ein Fehler bei Perl.
pi@home-fhem:~ $ systemctl status fhem.service
● fhem.service - LSB: FHEM server
   Loaded: loaded (/etc/init.d/fhem; generated; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2018-01-27 21:21:28 CET; 16min ago
     Docs: man:systemd-sysv-generator(8)

Jan 27 21:21:28 home-fhem fhem[520]: Compilation failed in require at /usr/lib/arm-linux-gnueabihf/perl/5.24/IO/Handl
Jan 27 21:21:28 home-fhem fhem[520]: BEGIN failed--compilation aborted at /usr/lib/arm-linux-gnueabihf/perl/5.24/IO/H
Jan 27 21:21:28 home-fhem fhem[520]: Compilation failed in require at /usr/lib/arm-linux-gnueabihf/perl/5.24/IO/Socke
Jan 27 21:21:28 home-fhem fhem[520]: BEGIN failed--compilation aborted at /usr/lib/arm-linux-gnueabihf/perl/5.24/IO/S
Jan 27 21:21:28 home-fhem fhem[520]: Compilation failed in require at fhem.pl line 36.
Jan 27 21:21:28 home-fhem fhem[520]: BEGIN failed--compilation aborted at fhem.pl line 36.
Jan 27 21:21:28 home-fhem systemd[1]: fhem.service: Control process exited, code=exited status=255
Jan 27 21:21:28 home-fhem systemd[1]: Failed to start LSB: FHEM server.
Jan 27 21:21:28 home-fhem systemd[1]: fhem.service: Unit entered failed state.
Jan 27 21:21:28 home-fhem systemd[1]: fhem.service: Failed with result 'exit-code'.

Fehler beim Installieren von Updates oder auch Fhem:
Reading package lists... Done
Building dependency tree
Reading state information... Done
fhem is already the newest version (5.8).
0 upgraded, 0 newly installed, 0 to remove and 26 not upgraded.
16 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
debconf: Perl may be unconfigured (Unrecognized character \xF2; marked by <-- HERE after  DynaLoade<-- HERE near column 18 at /usr/share/perl/5.24/XSLoader.pm line 10.
Compilation failed in require at /usr/lib/arm-linux-gnueabihf/perl/5.24/IO.pm line 5.
BEGIN failed--compilation aborted at /usr/lib/arm-linux-gnueabihf/perl/5.24/IO.pm line 5.
Compilation failed in require at /usr/lib/arm-linux-gnueabihf/perl/5.24/IO/Handle.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/arm-linux-gnueabihf/perl/5.24/IO/Handle.pm line 9.
Compilation failed in require at /usr/lib/arm-linux-gnueabihf/perl/5.24/IO/Seekable.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/arm-linux-gnueabihf/perl/5.24/IO/Seekable.pm line 9.
Compilation failed in require at /usr/lib/arm-linux-gnueabihf/perl/5.24/IO/File.pm line 11.
BEGIN failed--compilation aborted at /usr/lib/arm-linux-gnueabihf/perl/5.24/IO/File.pm line 11.
Compilation failed in require at /usr/share/perl/5.24/FileHandle.pm line 9.
Compilation failed in require at (eval 1) line 3.
BEGIN failed--compilation aborted at (eval 1) line 3.
) -- aborting
Setting up sensible-utils (0.0.9+deb9u1) ...
Unrecognized character \xF2; marked by <-- HERE after  DynaLoade<-- HERE near column 18 at /usr/share/perl/5.24/XSLoader.pm line 10.
Compilation failed in require at /usr/lib/arm-linux-gnueabihf/perl/5.24/File/Glob.pm line 6.
Compilation failed in require at /usr/sbin/update-mime line 75.
BEGIN failed--compilation aborted at /usr/sbin/update-mime line 75.
dpkg: error processing package sensible-utils (--configure):
 subprocess installed post-installation script returned error exit status 255
Errors were encountered while processing:
 sensible-utils
E: Sub-process /usr/bin/dpkg returned an error code (1)

Kann mir da jemand Helfen?

Danke
« Letzte Änderung: 28 Januar 2018, 09:52:34 von gamelive1207 »

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 18560
Antw:Perl Fehler nach FHEM Update
« Antwort #1 am: 27 Januar 2018, 22:14:46 »
Fuer mich klingt das so, als ob die Festplatte kaputt waere.
Zeile 36 in fhem.pl versucht die Systembibliothek IO::Socket zu laden, und das geht wohl nicht.

Btw. FHEM update macht man mW innerhalb von FHEM mit dem update Befehl, und nicht mit apt.

Offline gamelive1207

  • New Member
  • *
  • Beiträge: 27
Antw:Perl Fehler nach FHEM Update
« Antwort #2 am: 28 Januar 2018, 09:52:01 »
Update von Fhem habe ich auch über das Webinterface gemacht.

Wie auch immer, ich habe jetzt einfach mal den Strom gezogen und jetzt geht wieder.
Ein Reboot hat gestern asber nicht geholfen.

Werde aber mal jetzt erstmal ein Backup von der SD-Karte machen und eine neue kaufen.

Danke

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 4131
Antw:[Erledigt] Perl Fehler nach FHEM Update
« Antwort #3 am: 28 Januar 2018, 16:57:57 »
Ist eigentlich das System aktuell? Würde darauf Tippen, das Teile des Systems nicht aktuallisiert wurden. Bzw. Module per cpan installiert?
- Bitte um Input für Output
- When there is a Shell, there is a Way

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html