Autor Thema: [Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM  (Gelesen 33123 mal)

Offline LuGu

  • New Member
  • *
  • Beiträge: 6
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #390 am: 30 September 2018, 18:58:19 »
Ich hatte keine Probleme. Bei meinen (neuen) Osram Smart+ Plugs reichte es sogar das Pairing zu starten und den Plug dann in die Steckdose zu stecken. Wurde dann direkt erkannt und funktioniert auch einwandfrei. Wurde auch korrekt als "Repeater" erkannt, also kann dadurch dann auch die Reichweite erhöht werden (so sollte es zumindest sein).

Woran erkenne ich, dass er auch als Repeater erkannt wurde?
HMLAN mit diversen Komponenten (soll abgelöst werden)
FHEM mit RPi3 (Visu über FTUI)
HMCCU: Schnittstelle CCU2 - FHEM (soll Einzug halten)

Offline Blauhorn

  • New Member
  • *
  • Beiträge: 38
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #391 am: 01 Oktober 2018, 09:26:20 »
Hallo nochmal,

...
Heute morgen kamen dann keine Signale mehr von den Sensoren durch.
Die Bridge steht im fhem auf offline.
Neustart des gesamten Systems brachte keinen Erfolg.
...

nachdem ich dieses WE einen Familienkrieg riskiert habe, indem ich mehrere Stunden suchte und probierte, konnte ich mein Zigbee-Netzwerk gestern nachmittag wieder reanimieren. Hier nun die kurze Story:


Mit dem Aufruf
sudo systemctl status zigbee2mqtt.service -l

konnte ich ermitteln, dass der Fehler im zigbee-sheperd liegt, der nicht mehr mit dem Stick sprechen wollte.
Dazu gibt es hier https://github.com/Koenkk/zigbee2mqtt einige issues.
Die erschlagende Lösung ist ein neu flashen des Sticks. Der eigentliche Erfolg bei der Lösung ist, dass ich dort auch eine Möglichkeit ausgegraben habe, den cc2531 ohne CC-Debugger über USB/UART zu flashen. Die Firmware auf dem Stick hat einen bootloader eingebaut, der ermöglicht, mit einem serial boot tool neue Firmware aufzuspielen. Jedoch nicht das normale Hex-File, sondern ein spezielles bin-file, das die serial bootloader-firmware unterstützt.
Hier sehr genau beschrieben: https://github.com/Koenkk/zigbee2mqtt/issues/320

Nun ist alles wieder gut.

Gruß vom Blauhorn
1xBananaPi; 1x FB7490; 1xCUL433; 1xCUL868; 1xHMUART; HM-LC-Sw4-DR, Sonoff*, LEDController, MySensors

Offline mark79

  • Full Member
  • ***
  • Beiträge: 346
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #392 am: 01 Oktober 2018, 19:41:49 »
Ja Zigbee reagiert dann gar nicht mehr und habe gerade erst damit begonnen als nur "ein" Sensor zur Zeit.

Es fällt auch immer zu unterschiedlichen Zeiten aus, einmal war es erst nacht 4 Tagen Gestern erst hat es gerade mal 12std. durch gehalten.

Gibt es irgendwo ein log den man mal einsehen kann?

Mfg Steffen

Mhh das ist komisch und hatte ich so noch nie und auch noch nicht von gelesen.

Ein log sollte in /opt/zigbee2mqtt/data liegen, man kann in der configuration auch noch ein ausführlicheres Debug Log einstellen:
https://github.com/Koenkk/zigbee2mqtt/wiki/How-to-debug


Viele Grüße
Mark
Rock64 4GB mit Debian Strech, FHEM im LXC, Sonoff Switches/Touch, HM Thermostate, HMUART/Zigbee2MQTT@MapleCUN, ESP RGBWW Wifi Controller, ESP8266 Door Sensor/Briefkastenwächter, BT CSL Stick, BT iTags, DashButtons, Alexa, FireTV, RPi2 mit Kodi, Xiaomi Vacuum v1/GW/Smarthome Komponenten

Offline Byte09

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 818
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #393 am: 03 Oktober 2018, 14:30:25 »
Guten Morgen Zusammen,

tolle Arbeit, Danke!! =)

Ich habe ein Problem, habe es soweit am laufen, dass wenn ich "npm start" in der Console sage, dass es funktioniert.

Wenn ich dann aber "systemctl status zigbee2mqtt.service" eingebe, dann bekomme ich folgende Ausgaben:

root@raspberrypi:/opt/zigbee2mqtt# systemctl status zigbee2mqtt.service
● zigbee2mqtt.service - zigbee2mqtt
   Loaded: loaded (/etc/systemd/system/zigbee2mqtt.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Sun 2018-07-08 03:51:39 CEST; 63ms ago
  Process: 26530 ExecStart=/usr/bin/npm start (code=exited, status=1/FAILURE)
 Main PID: 26530 (code=exited, status=1/FAILURE)

Jul 08 03:51:39 raspberrypi systemd[1]: zigbee2mqtt.service: Failed with result 'exit-code'.

root@raspberrypi:/opt/zigbee2mqtt# systemctl status zigbee2mqtt.service
● zigbee2mqtt.service - zigbee2mqtt
   Loaded: loaded (/etc/systemd/system/zigbee2mqtt.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2018-07-08 03:51:39 CEST; 1s ago
 Main PID: 26559 (npm)
   CGroup: /system.slice/zigbee2mqtt.service
           ├─26559 npm
           ├─26569 sh -c node index.js
           └─26570 node index.js

Jul 08 03:51:39 raspberrypi systemd[1]: Started zigbee2mqtt.
Jul 08 03:51:41 raspberrypi npm[26559]: > zigbee2mqtt@0.1.0 start /opt/zigbee2mqtt
Jul 08 03:51:41 raspberrypi npm[26559]: > node index.js

Es scheint dann immer neuzustarten und einen Fehler zu haben.
An FHEM wird auch nichts mehr geschickt.

Ich habe mich an folgende Anleitung gehalten:
https://github.com/Koenkk/zigbee2mqtt/wiki/Running-the-bridge

Ich hoffe ihr könnt mir helfen.
Grüße
Gear

hie gear,

ich habe seit heute morgen das gleiche problem. kannst du mir sagen , wie du es in den griff bekommen hast ?

gruss Byte09
Fhem 5.7, 3*RPi2, Harmony, Hyperion, HM-CFG-LAN, Signalduino, SignalESP, NanoCul
MAINTAINER: 98_Siro, 98_MSwitch

Offline Byte09

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 818
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #394 am: 03 Oktober 2018, 17:44:12 »
Hi zusammen,

vor lauter verzweiflung habe ich die gesamte bridge jetzt auf einem zweiten pi installiert.
eigenartiger weise habe ich dort genau das gleiche verhalten , wie im post drüber auf dem ersten raspi .

da jetzt die hälfte meiner sensoren 'steht' habe ich ein echtes problem .

mit npm start lässt es sich starten , start über systemctl führt zu folgendem :
Okt 03 17:41:52 raspberrypi systemd[1]: zigbee2mqtt.service holdoff time over, scheduling restart.
Okt 03 17:41:52 raspberrypi systemd[1]: Stopping zigbee2mqtt...
Okt 03 17:41:52 raspberrypi systemd[1]: Starting zigbee2mqtt...
Okt 03 17:41:52 raspberrypi systemd[1]: Started zigbee2mqtt.
Okt 03 17:42:00 raspberrypi npm[1568]: > zigbee2mqtt@0.1.6 start /opt/zigbee2mqtt
Okt 03 17:42:00 raspberrypi npm[1568]: > node index.js
Okt 03 17:42:06 raspberrypi npm[1568]: fs.js:885
Okt 03 17:42:06 raspberrypi npm[1568]: return binding.mkdir(pathModule._makeLong(path),
Okt 03 17:42:06 raspberrypi npm[1568]: ^
Okt 03 17:42:06 raspberrypi npm[1568]: Error: EACCES: permission denied, mkdir '/opt/zigbee2mqtt/data/log/2018-10-03.17-42-06'
Okt 03 17:42:06 raspberrypi npm[1568]: at Object.fs.mkdirSync (fs.js:885:18)
Okt 03 17:42:06 raspberrypi npm[1568]: at mkdirSyncRecursive (/opt/zigbee2mqtt/node_modules/mkdir-recursive/index.js:199:16)
Okt 03 17:42:06 raspberrypi npm[1568]: at mkdirSyncRecursive (/opt/zigbee2mqtt/node_modules/mkdir-recursive/index.js:197:12)
Okt 03 17:42:06 raspberrypi npm[1568]: at mkdirSyncRecursive (/opt/zigbee2mqtt/node_modules/mkdir-recursive/index.js:197:12)
Okt 03 17:42:06 raspberrypi npm[1568]: at mkdirSyncRecursive (/opt/zigbee2mqtt/node_modules/mkdir-recursive/index.js:197:12)
Okt 03 17:42:06 raspberrypi npm[1568]: at mkdirSyncRecursive (/opt/zigbee2mqtt/node_modules/mkdir-recursive/index.js:197:12)
Okt 03 17:42:06 raspberrypi npm[1568]: at Object.mkdirSync (/opt/zigbee2mqtt/node_modules/mkdir-recursive/index.js:82:10)
Okt 03 17:42:06 raspberrypi npm[1568]: at Object.<anonymous> (/opt/zigbee2mqtt/lib/util/logger.js:17:4)
Okt 03 17:42:06 raspberrypi npm[1568]: at Module._compile (module.js:653:30)
Okt 03 17:42:06 raspberrypi npm[1568]: at Object.Module._extensions..js (module.js:664:10)
Okt 03 17:42:06 raspberrypi npm[1568]: npm ERR! code ELIFECYCLE
Okt 03 17:42:06 raspberrypi npm[1568]: npm ERR! errno 1
Okt 03 17:42:06 raspberrypi npm[1568]: npm ERR! zigbee2mqtt@0.1.6 start: `node index.js`
Okt 03 17:42:06 raspberrypi npm[1568]: npm ERR! Exit status 1
Okt 03 17:42:06 raspberrypi npm[1568]: npm ERR!
Okt 03 17:42:06 raspberrypi npm[1568]: npm ERR! Failed at the zigbee2mqtt@0.1.6 start script.
Okt 03 17:42:06 raspberrypi npm[1568]: npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
Okt 03 17:42:07 raspberrypi npm[1568]: npm ERR! A complete log of this run can be found in:
Okt 03 17:42:07 raspberrypi npm[1568]: npm ERR!     /home/pi/.npm/_logs/2018-10-03T15_42_06_993Z-debug.log
Okt 03 17:42:07 raspberrypi systemd[1]: zigbee2mqtt.service: main process exited, code=exited, status=1/FAILURE
Okt 03 17:42:07 raspberrypi systemd[1]: Unit zigbee2mqtt.service entered failed state.
Okt 03 17:42:07 raspberrypi systemd[1]: zigbee2mqtt.service holdoff time over, scheduling restart.
Okt 03 17:42:07 raspberrypi systemd[1]: Stopping zigbee2mqtt...
Okt 03 17:42:07 raspberrypi systemd[1]: Starting zigbee2mqtt...
Okt 03 17:42:07 raspberrypi systemd[1]: Started zigbee2mqtt.

 ............... bräuchte hier dringend hilfe .

danke und gruss Byte09


edit: auf dem zweiten pi hane ich es nun hinbekommen , war ein rechteproblem , was ich nicht gesehen habe. Aber das Problem auf dem erstem Pi ist mir ein nachwievor ein Rätsel ?!

« Letzte Änderung: 03 Oktober 2018, 18:15:55 von Byte09 »
Fhem 5.7, 3*RPi2, Harmony, Hyperion, HM-CFG-LAN, Signalduino, SignalESP, NanoCul
MAINTAINER: 98_Siro, 98_MSwitch

Offline Diggewuff

  • Jr. Member
  • **
  • Beiträge: 82
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #395 am: 04 Oktober 2018, 05:21:07 »
Der Batterie status eines meiner Aqara Temperatur Sensoren wird mir schon bei knapp 80% als low ausgegeben...
Lässt sich der schwellwert dazu irgendwo anpassen?
Internals:
   CFGFN     
   DEF        WSDCGQ11LM 0x00158d00022c9d06 XiaomiTHP_5
   FRIENDLYNAME XiaomiTHP_5
   IODev      MQTT
   MODEL      WSDCGQ11LM
   NAME       FL_XiaomiTHP
   NOTIFYDEV  WSDCGQ11LM 0x00158d00022c9d06 XiaomiTHP_5
   NR         210
   SID        0x00158d00022c9d06
   STATE      21.24 °C, 52.36 %, 1018.69 kPa, condensing at 13.2 °C, Battery: 78.33 %
   TYPE       XiaomiMQTTDevice
   Helper:
     DBLOG:
       battery_level:
         DBLogging:
           TIME       1538616093.32211
           VALUE      78.33
       humidity:
         DBLogging:
           TIME       1538622696.48017
           VALUE      52.36
       linkquality:
         DBLogging:
           TIME       1538622696.46382
           VALUE      94
       pressure:
         DBLogging:
           TIME       1538622696.48017
           VALUE      1018.69
       temperature:
         DBLogging:
           TIME       1538622696.48017
           VALUE      21.24
       voltage:
         DBLogging:
           TIME       1538616093.32211
           VALUE      2935
   READINGS:
     2018-10-04 05:11:36   battery         low
     2018-10-04 05:11:36   battery_level   78.33
     2018-09-23 21:50:43   dewpoint        13.2
     2018-10-04 05:11:36   humidity        52.36
     2018-10-04 05:11:36   linkquality     94
     2018-10-04 05:11:36   pressure        1018.69
     2018-10-04 05:11:36   temperature     21.24
     2018-10-04 05:11:36   transmission-state incoming publish received
     2018-10-04 05:11:36   voltage         2935
   message_ids:
   subscribe:
     zigbee2mqtt/XiaomiTHP_5
     xiaomi/0x00158d00022c9d06/#
   subscribeExpr:
     ^zigbee2mqtt\/XiaomiTHP_5$
     ^xiaomi\/0x00158d00022c9d06.*$
   subscribeQos:
     xiaomi/0x00158d00022c9d06/# 0
     zigbee2mqtt/XiaomiTHP_5 0
Attributes:
   DbLogExclude .*
   DbLogInclude temperature,humidity,pressure,dewpoint,linkquality,voltage,battery_level
   IODev      MQTT
   event-on-change-reading .*
   group      Klima
   icon       temp_temperature
   room       08_Flur,25_Heizung,XiaomiMQTTDevice
   stateFormat temperature °C, humidity %, pressure kPa, condensing at dewpoint °C, Battery: battery_level %

Offline mark79

  • Full Member
  • ***
  • Beiträge: 346
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #396 am: 07 Oktober 2018, 21:35:03 »
Hi zusammen,

vor lauter verzweiflung habe ich die gesamte bridge jetzt auf einem zweiten pi installiert.
eigenartiger weise habe ich dort genau das gleiche verhalten , wie im post drüber auf dem ersten raspi .

da jetzt die hälfte meiner sensoren 'steht' habe ich ein echtes problem .

mit npm start lässt es sich starten , start über systemctl führt zu folgendem :
Okt 03 17:41:52 raspberrypi systemd[1]: zigbee2mqtt.service holdoff time over, scheduling restart.
Okt 03 17:41:52 raspberrypi systemd[1]: Stopping zigbee2mqtt...
Okt 03 17:41:52 raspberrypi systemd[1]: Starting zigbee2mqtt...
Okt 03 17:41:52 raspberrypi systemd[1]: Started zigbee2mqtt.
Okt 03 17:42:00 raspberrypi npm[1568]: > zigbee2mqtt@0.1.6 start /opt/zigbee2mqtt
Okt 03 17:42:00 raspberrypi npm[1568]: > node index.js
Okt 03 17:42:06 raspberrypi npm[1568]: fs.js:885
Okt 03 17:42:06 raspberrypi npm[1568]: return binding.mkdir(pathModule._makeLong(path),
Okt 03 17:42:06 raspberrypi npm[1568]: ^
Okt 03 17:42:06 raspberrypi npm[1568]: Error: EACCES: permission denied, mkdir '/opt/zigbee2mqtt/data/log/2018-10-03.17-42-06'
Okt 03 17:42:06 raspberrypi npm[1568]: at Object.fs.mkdirSync (fs.js:885:18)
Okt 03 17:42:06 raspberrypi npm[1568]: at mkdirSyncRecursive (/opt/zigbee2mqtt/node_modules/mkdir-recursive/index.js:199:16)
Okt 03 17:42:06 raspberrypi npm[1568]: at mkdirSyncRecursive (/opt/zigbee2mqtt/node_modules/mkdir-recursive/index.js:197:12)
Okt 03 17:42:06 raspberrypi npm[1568]: at mkdirSyncRecursive (/opt/zigbee2mqtt/node_modules/mkdir-recursive/index.js:197:12)
Okt 03 17:42:06 raspberrypi npm[1568]: at mkdirSyncRecursive (/opt/zigbee2mqtt/node_modules/mkdir-recursive/index.js:197:12)
Okt 03 17:42:06 raspberrypi npm[1568]: at mkdirSyncRecursive (/opt/zigbee2mqtt/node_modules/mkdir-recursive/index.js:197:12)
Okt 03 17:42:06 raspberrypi npm[1568]: at Object.mkdirSync (/opt/zigbee2mqtt/node_modules/mkdir-recursive/index.js:82:10)
Okt 03 17:42:06 raspberrypi npm[1568]: at Object.<anonymous> (/opt/zigbee2mqtt/lib/util/logger.js:17:4)
Okt 03 17:42:06 raspberrypi npm[1568]: at Module._compile (module.js:653:30)
Okt 03 17:42:06 raspberrypi npm[1568]: at Object.Module._extensions..js (module.js:664:10)
Okt 03 17:42:06 raspberrypi npm[1568]: npm ERR! code ELIFECYCLE
Okt 03 17:42:06 raspberrypi npm[1568]: npm ERR! errno 1
Okt 03 17:42:06 raspberrypi npm[1568]: npm ERR! zigbee2mqtt@0.1.6 start: `node index.js`
Okt 03 17:42:06 raspberrypi npm[1568]: npm ERR! Exit status 1
Okt 03 17:42:06 raspberrypi npm[1568]: npm ERR!
Okt 03 17:42:06 raspberrypi npm[1568]: npm ERR! Failed at the zigbee2mqtt@0.1.6 start script.
Okt 03 17:42:06 raspberrypi npm[1568]: npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
Okt 03 17:42:07 raspberrypi npm[1568]: npm ERR! A complete log of this run can be found in:
Okt 03 17:42:07 raspberrypi npm[1568]: npm ERR!     /home/pi/.npm/_logs/2018-10-03T15_42_06_993Z-debug.log
Okt 03 17:42:07 raspberrypi systemd[1]: zigbee2mqtt.service: main process exited, code=exited, status=1/FAILURE
Okt 03 17:42:07 raspberrypi systemd[1]: Unit zigbee2mqtt.service entered failed state.
Okt 03 17:42:07 raspberrypi systemd[1]: zigbee2mqtt.service holdoff time over, scheduling restart.
Okt 03 17:42:07 raspberrypi systemd[1]: Stopping zigbee2mqtt...
Okt 03 17:42:07 raspberrypi systemd[1]: Starting zigbee2mqtt...
Okt 03 17:42:07 raspberrypi systemd[1]: Started zigbee2mqtt.

 ............... bräuchte hier dringend hilfe .

danke und gruss Byte09


edit: auf dem zweiten pi hane ich es nun hinbekommen , war ein rechteproblem , was ich nicht gesehen habe. Aber das Problem auf dem erstem Pi ist mir ein nachwievor ein Rätsel ?!

Hi Byte,

das sieht aus wie ein rechte Problem: Error: EACCES: permission denied, mkdir '/opt/zigbee2mqtt/data/log/2018-10-03.17-42-06
Mach mal ein:
chown username /opt/zigbee2mqtt -R
Alternativ den Dienst als root laufen lassen :)


Viele Grüße
Mark
Rock64 4GB mit Debian Strech, FHEM im LXC, Sonoff Switches/Touch, HM Thermostate, HMUART/Zigbee2MQTT@MapleCUN, ESP RGBWW Wifi Controller, ESP8266 Door Sensor/Briefkastenwächter, BT CSL Stick, BT iTags, DashButtons, Alexa, FireTV, RPi2 mit Kodi, Xiaomi Vacuum v1/GW/Smarthome Komponenten

Offline sash.sc

  • Hero Member
  • *****
  • Beiträge: 1362
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #397 am: 10 Oktober 2018, 16:20:49 »
Hallo zusammen.

habe heute das Modul in betrieb genommen. installation hat alles soweit funktioniert, die Statusmeldung passen auch.
Wenn ich das Modul in FHEM definieren will, schmier FHEm komplett ab.

Hier die letzten Meldung.

2018.10.10 16:10:23 3: No I/O device found for xBridge
2018.10.10 16:10:23 1: client device hash no IODev provided
Undefined subroutine &XiaomiMQTT::DEVICE::send_publish called at ./FHEM/72_XiaomiMQTTDevice.pm line 381.


Kann es sein, dass es damit zusammen hängt, dass ich keinen externen MQTT Broker am laufen habe?
ich benutze nur MQTT2, also FHEM als MQTT Server.

Gruß und Danke
Sascha
Raspi 2 ; LaCrosse; HomeMatic; 1x TX 29 als Lichtsensor umgebaut;
ESP8622 ;nanoCUL a-fw (433 & 868 MHz); miniCULwlan;
WLANduino 433&868 ; WlanCul

Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 3984
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #398 am: 10 Oktober 2018, 16:28:19 »
Dann kannst du es auch ohne das Modul direkt als MQTT2_DEVICE anlegen lassen, siehe wiki-Praxisbeiträge. Oder eben ein MQTT-Gerät an MQTT2 dranhängen und dann erst das Xiaomi...-Gerät darüber füttern. Dann eine ID per attr an das MQTT-Gerät setzen.
Server: HP-T5740 mit Debian stretch (i386) + aktuellem FHEM | ConfigDB | VCCU mit einiger HM-Hardware | MySensors seriell (2.3.1-beta@RS485, div. konkrete Hardware, u.a. einige DS18B20) | Milight@ESP-GW@MQTT2 | zigbee2mqtt@MQTT2 | SIGNALduino | MapleCUN

Offline Spaltenputzer

  • New Member
  • *
  • Beiträge: 11
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #399 am: 14 Oktober 2018, 11:25:41 »
Hab mir mal was gebastelt um die ganze Hardware zu verstauen.

Offline Badflex

  • Full Member
  • ***
  • Beiträge: 433
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #400 am: 14 Oktober 2018, 12:17:23 »
Machst du das auch in Serie?
Könnte auch sowas GEBRAUCHEN :)

Kann man mittlerweile auch die RGB Farben bei den Ikea Lampen über MQTT ändern ?
« Letzte Änderung: 14 Oktober 2018, 12:26:46 von Badflex »
Raspberry Pi, CUL868(SlowRF), FB 7490, SmartVisu, fast nur HomeMatic wenig FS20, Netatmo

Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 3984
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #401 am: 14 Oktober 2018, 12:56:11 »
Das mit "RGB" sollte gehen,  allerdings würde ich eher darauf tippen, das man keinen Hue-Wert in das json packen muss.
Reicht der FTDI zur Versorgung? Würde eher  einen CP2102 da sehen...
 
« Letzte Änderung: 14 Oktober 2018, 12:58:03 von Beta-User »
Server: HP-T5740 mit Debian stretch (i386) + aktuellem FHEM | ConfigDB | VCCU mit einiger HM-Hardware | MySensors seriell (2.3.1-beta@RS485, div. konkrete Hardware, u.a. einige DS18B20) | Milight@ESP-GW@MQTT2 | zigbee2mqtt@MQTT2 | SIGNALduino | MapleCUN

Offline Spaltenputzer

  • New Member
  • *
  • Beiträge: 11
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #402 am: 14 Oktober 2018, 13:39:29 »
Den FTDI hab ich gewählt da er eine eindeutige ID hat.
Läuft auch ohne Probleme.
Platinen hab ich nochmal ein wenig modifiziert und neu bestellt.
In Serie mache ich die nicht würde aber die Platine schon abgeben.


Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 3984
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #403 am: 14 Oktober 2018, 14:31:17 »
Die CP2102 kann man auch individualisieren. Müsste im wiki stehen.
Server: HP-T5740 mit Debian stretch (i386) + aktuellem FHEM | ConfigDB | VCCU mit einiger HM-Hardware | MySensors seriell (2.3.1-beta@RS485, div. konkrete Hardware, u.a. einige DS18B20) | Milight@ESP-GW@MQTT2 | zigbee2mqtt@MQTT2 | SIGNALduino | MapleCUN

Offline kennymc.c

  • Full Member
  • ***
  • Beiträge: 106
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #404 am: 14 Oktober 2018, 20:21:18 »
Hat hier schon mal jemand Update Probleme mit den runden Temperatursensoren gehabt? Bei mir scheint einer von insgesamt 3 Sensoren nach einiger Zeit keine neuen Werte mehr zu liefern. Wenn ich allerdings die Batterie einmal raus und wieder rein nehme, funktioniert es wieder für ein paar Tage. Der Sensor selbst schein auch vor dem Wechsel auf einen Knopfdruck mit der LED zu reagieren, deshalb gehe ich erstmal von einem Empfangsproblem aus. In ZigBee2MQTT tauchen im Log auch keine neuen Werte auf, der Debug Modus sieht auch nicht verdächtigt aus. Seltsamerweise werden mit aber nach dem Aus und Einschalten direkt wieder aktuelle Werte angezeigt. Kann es sein, dass die Sensoren bei konstant schlechter Signalqualität in eine Art Deep Sleep schalten? Ich habe noch einen anderen Sensor etwas weiter entfernt, der aber nich solche Probleme zeigt.