Autor Thema: [Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM  (Gelesen 49798 mal)

Offline mark79

  • Full Member
  • ***
  • Beiträge: 476
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #555 am: 18 November 2018, 18:05:50 »
Erstmal schönen Dank, dass du das so gut mit mir durchgehst :) ich warte dann doch lieber bis Montag, weil ich mosquitto garnicht installiert habe ::) oder brauche ich das nicht dafür?
Gerngeschehen. :) Wenn du den MQTT2_SERVER hast, dann brauchst du nur den Clienten für die Console zu installieren, also apt-get install mosquitto-clients

Ich habe das heute hier ausprobiert mit MQTT2_CLIENT, weil ich darauf umsteigen will und wie es ausschaut, fehlt bei Fhem noch was, das er die angeforderten Daten in ein Bild umwandelt und zwar das hier:
mosquitto_sub -h localhost -C 1 -t zigbee2mqtt/bridge/networkmap/graphviz | sfdp -Tpng >/tmp/network_map.png
Das scheint wohl noch nicht implementiert worden zu sein.

Den Befehl müsstest du also selber in der SSH Console ausführen und danach im Fhem zigbee_mqtt Device wie im Wiki den network_map graphviz Befehl absetzen.
Rock64 4GB mit Debian Strech, FHEM im LXC, Sonoff Switches/Touch, HM Thermostate, HMUART/Zigbee2MQTT@MapleCUN, ESP RGBWW Wifi Controller, ESP8266 Door Sensor/Briefkastenwächter, BT CSL Stick, BT iTags, DashButtons, Alexa, FireTV, RPi2 mit Kodi, Xiaomi Vacuum v1/Smarthome Komponenten

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 19523
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #556 am: 18 November 2018, 21:37:02 »
Zitat
fehlt bei Fhem noch was, das er die angeforderten Daten in ein Bild umwandelt
Eine aehnliche Visualisierung gibt es im ZWDongle Modul fuer die ZWave Geraete, das koennte man (theoretisch, nach Anpassung) auch hier verwenden.

Offline rohlande

  • Jr. Member
  • **
  • Beiträge: 72
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #557 am: 19 November 2018, 20:45:52 »
Guten Morgen,

eine (vielleicht) blöde Frage... auf meinem Brix mit Debian läuft node 6.xx, da ich u.a. auch die Homebridge nutze und die mit node 8.xx nicht läuft (zumindest habe ich bislang keinen Weg gefunden). Würde gerne das System hier nutzen, Stick ist da und startklar, zum Testen habe ich 2 Temp/Hum Sensoren von Xioami bestellt. Krux ist aber - unter node 6.xx bekomme ich Koenkk nicht ans laufen, das benötigt wiederum node 8.xx.

Nen Raspi habe ich noch da, aber an sich fände ich es unglücklich nur für das Gateway einen Raspi 24/7 zu betreiben. Hatte jemand hier schon mal ein ähnliches "Problem" und eine Idee/Lösung für mich?

Bin für jeden Tip dankbar,

Grüße Tedious

Hallo Tedious,

kann ich nicht nachvollziehen. Hatte heute genau das umgesetzt. Debian auf dem FHEM / Mosquitto / Homebridge / zigbee2mqtt / Mysql / Plexmediaserver / läuft. Ich hatte zwar Probleme nach der zigbee2mqtt Installation und npm aber das lag nur an den Rechten des users.

node --version == v8.12.0

Nach dem Upgrade auf V8 musste ich ja nachmal bauen aber das ging wie gesagt alles als die Rechte auch gepasst haben.
Vielleicht hilfts weiter.

Vg Denny
my perl5 (revision 5 version 24 subversion 1)
fhem.pl 15766 2018-01-03
EspEasy / HMLan / Hue / Sonos / Jeelink / NanoCul433 / Homebridge / CUL 868 / Telegram / MQTT - Tasmota / SML Energiezähler / AMAD

Offline rohlande

  • Jr. Member
  • **
  • Beiträge: 72
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #558 am: 19 November 2018, 21:28:57 »
Gerngeschehen. :) Wenn du den MQTT2_SERVER hast, dann brauchst du nur den Clienten für die Console zu installieren, also apt-get install mosquitto-clients

Ich habe das heute hier ausprobiert mit MQTT2_CLIENT, weil ich darauf umsteigen will und wie es ausschaut, fehlt bei Fhem noch was, das er die angeforderten Daten in ein Bild umwandelt und zwar das hier:
mosquitto_sub -h localhost -C 1 -t zigbee2mqtt/bridge/networkmap/graphviz | sfdp -Tpng >/tmp/network_map.png
Das scheint wohl noch nicht implementiert worden zu sein.

Den Befehl müsstest du also selber in der SSH Console ausführen und danach im Fhem zigbee_mqtt Device wie im Wiki den network_map graphviz Befehl absetzen.

funktioniert wie beschrieben mit beiden Terminal:

Terminal 1:
mosquitto_sub -h localhost -C 1 -t zigbee2mqtt/bridge/networkmap/graphviz | sfdp -Tpng >/tmp/network_map.png
Terminal 2:
mosquitto_pub -h localhost -t zigbee2mqtt/bridge/networkmap -m graphviz
die [display -] Version funktioniert nicht.

Vielen Dank. Schönes Werkzeug um zu sehen was wirklich los ist. Habe es übrigens mit MQTTfx nochmals gecheckt.
Parallel sieht man dort auch die Angaben ob die jeweiligen Devices "online" sind und was für eine "linkquality" vorhanden ist.

digraph G {
node[shape=record];
  "0x00124b0012022e95" [label="{0x00124b0012022e95|Coordinator|No model information available|online}"];
  "0x00158d00022885a4" [label="{0x00158d00022885a4|EndDevice|Xiaomi Aqara temperature, humidity and pressure sensor (WSDCGQ11LM)|online}"];
  "0x00158d00022885a4" -> "0x00124b0012022e95" [label="1"]
  "0x00158d00023a0ab4" [label="{0x00158d00023a0ab4|EndDevice|Xiaomi MiJia temperature & humidity sensor  (WSDCGQ01LM)|online}"];
  "0x00158d00023a0ab4" -> "0x00124b0012022e95" [label="1"]
  "0x00158d0001f28adc" [label="{0x00158d0001f28adc|EndDevice|Xiaomi Aqara temperature, humidity and pressure sensor (WSDCGQ11LM)|online}"];
  "0x00158d0001f28adc" -> "0x00124b0012022e95" [label="38"]
}

label == linkquality

VG denny
my perl5 (revision 5 version 24 subversion 1)
fhem.pl 15766 2018-01-03
EspEasy / HMLan / Hue / Sonos / Jeelink / NanoCul433 / Homebridge / CUL 868 / Telegram / MQTT - Tasmota / SML Energiezähler / AMAD

Offline n._markus

  • New Member
  • *
  • Beiträge: 5
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #559 am: 20 November 2018, 19:18:46 »
Hallo zusammen,
ich versuche seit Tagen erfolglos einen CC2530 in FHEM einzubinden.

Sobald ich
node index.jseintippe erscheint folgende Meldung:
pi@raspberrypi:~ $ cd xiaomi-zb2mqtt
pi@raspberrypi:~/xiaomi-zb2mqtt $ node index.js
                Zigbee2mqtt requires node version >=8.11 10, you are running v8.                                                      12.0!

  zigbee2mqtt:info 2018-11-20 18:31:28 Logging to directory: '/home/pi/xiaomi-zb                                                      2mqtt/data/log/2018-11-20.18-31-28'
  zigbee2mqtt:info 2018-11-20 18:31:29 Starting zigbee2mqtt version 0.2.0 (commi                                                      t #b0d3c2f)
  zigbee2mqtt:info 2018-11-20 18:31:29 Starting zigbee-shepherd
  zigbee2mqtt:info 2018-11-20 18:31:32 Error while starting zigbee-shepherd, att                                                      emping to fix... (takes 60 seconds)
  zigbee2mqtt:info 2018-11-20 18:32:32 Starting zigbee-shepherd
  zigbee2mqtt:error 2018-11-20 18:32:35 Error while starting zigbee-shepherd!
  zigbee2mqtt:error 2018-11-20 18:32:35 Press the reset button on the stick (the                                                       one closest to the USB) and start again
  zigbee2mqtt:error 2018-11-20 18:32:35 Failed to start
        {"message":"request timeout","stack":"Error: request timeout\n    at CcZ                                                      np.<anonymous> (/home/pi/xiaomi-zb2mqtt/node_modules/cc-znp/lib/ccznp.js:255:22)                                                      \n    at Object.onceWrapper (events.js:315:30)\n    at emitOne (events.js:116:13                                                      )\n    at CcZnp.emit (events.js:211:7)\n    at Timeout.<anonymous> (/home/pi/xia                                                      omi-zb2mqtt/node_modules/cc-znp/lib/ccznp.js:234:18)\n    at ontimeout (timers.j                                                      s:498:11)\n    at tryOnTimeout (timers.js:323:5)\n    at Timer.listOnTimeout (ti                                                      mers.js:290:5)"}
^C  zigbee2mqtt:error 2018-11-20 18:32:42 Not connected to MQTT server!
  zigbee2mqtt:error 2018-11-20 18:32:42 Cannot send message: topic: 'zigbee2mqtt                                                      /bridge/state', payload: 'offline
  zigbee2mqtt:info 2018-11-20 18:32:42 zigbee-shepherd stopped

Meine configuration.yaml sieht mittlerweile so aus:
# Home Assistant integration (MQTT discovery)
homeassistant: false

# allow new devices to join
permit_join: true

# MQTT settings
mqtt:
  # MQTT base topic for zigbee2mqtt MQTT messages
  base_topic: zigbee2mqtt
  # MQTT server URL
  server: 'mqtt://192.168.178.18'
  # MQTT server authentication, uncomment if required:
  # user: my_user
  # password: my_password



# Serial settings
serial:
  # Location of CC2531 USB sniffer
  port: /dev/serial/by-id/usb-Silicon_Labs_CP2104_USB_to_UART_Bridge_Controller_017D2963-if00-port0
  baudrate: 11520
advanced:
  rtscts:  false

Hat hier evtl. Jemand einen Tipp für mich?

Offline mark79

  • Full Member
  • ***
  • Beiträge: 476
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #560 am: 20 November 2018, 20:01:01 »
Hallo,

der findet den Zigbee Adapter nicht, deswegen startet der Dient nicht.
Bist du dir sicher das der Pfad so richtig ist: /dev/serial/by-id/usb-Silicon_Labs_CP2104_USB_to_UART_Bridge_Controller_017D2963-if00-port0 ?
Und der Zigbee Adapter richtig geflasht ist, mit der richtigen Firmware von hier: https://github.com/Koenkk/Z-Stack-firmware/tree/master/coordinator

Wenn es ein CC2530 ist, musst du noch P02 auf GND dauerhaft kurzschließen und mal probieren TX / RX zu vertauschen.

Dann gibt es noch eine Fehlermeldung bzgl. MQTT Server. Hast du einen installiert?
Wenn nein, würde ich dir den MQTT2_SERVER empfehlen: https://wiki.fhem.de/wiki/MQTT2-Module_-_Praxisbeispiele#Installation_von_zigbee2mqtt


Viele Grüße
Mark


Hat hier evtl. Jemand einen Tipp für mich?
Rock64 4GB mit Debian Strech, FHEM im LXC, Sonoff Switches/Touch, HM Thermostate, HMUART/Zigbee2MQTT@MapleCUN, ESP RGBWW Wifi Controller, ESP8266 Door Sensor/Briefkastenwächter, BT CSL Stick, BT iTags, DashButtons, Alexa, FireTV, RPi2 mit Kodi, Xiaomi Vacuum v1/Smarthome Komponenten

Offline n._markus

  • New Member
  • *
  • Beiträge: 5
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #561 am: 20 November 2018, 20:12:03 »
Danke schonmal für die schnelle Antwort!

Zitat
Und der Zigbee Adapter richtig geflasht ist, mit der richtigen Firmware von hier

Ich weiß ehrlich gesagt gar nicht welche Firmware auf dem Adapter ist. Ich hatte ihn allerdings schon in IOBroker integriert und da lief er problemlos.

Zitat
Wenn es ein CC2530 ist, musst du noch P02 auf GND
P20 und Ground sind mitteinander verbunden.

Zitat
Dann gibt es noch eine Fehlermeldung bzgl. MQTT Server. Hast du einen installiert?
MQTT sollte eigentlich laufen. Ich habe Sonoff Pow´s in FHEM integriert. Da funktioniert alles.

Offline mark79

  • Full Member
  • ***
  • Beiträge: 476
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #562 am: 20 November 2018, 20:40:43 »
Wenn der /dev Pfad stimmt und er vorher lief, dann weiß ich auch nicht wirklich weiter.
Vielleicht fehlende Zugriffsrechte auf das Zigbee /dev.. Device, je nachdem mit welchem User du Zigbee2mqtt startest.. Du kannst probeweise das als root starten.

Was aber noch komisch ist, das er wegen der node Version bei dir meckert:
Zigbee2mqtt requires node version >=8.11 10, you are running v8.12.0!
Vielleicht mal eine Version tiefer gehen, also Node Version 8.11.X.
Ich habe auf meinen Testsystem folgende Version installiert:
root@raspberrypi:/opt/zigbee2mqtt# node -v
v8.11.2
root@raspberrypi:/opt/zigbee2mqtt# npm -v
6.2.0

So sieht der Start bei mir aus:
root@raspberrypi:/opt/zigbee2mqtt# node index.js
2018-11-20 20:32:53 DEBUG Using zigbee-shepherd with settings: '{"net":{"panId":6754,"channelList":[14]},"dbPath":"/opt/zigbee2mqtt/data/database.db","sp":{"baudrate":115200,"rtscts":true}}'
2018-11-20 20:32:54 INFO Starting zigbee2mqtt version 0.1.2 (commit #7dd1c75)
2018-11-20 20:32:54 INFO Starting zigbee-shepherd
2018-11-20 20:32:57 INFO zigbee-shepherd started
2018-11-20 20:32:57 DEBUG zigbee-shepherd info: {"enabled":true,"net":{"state":"Coordinator","channel":14,"panId":
2018-11-20 20:32:57 INFO Currently 2 devices are joined:
2018-11-20 20:32:57 INFO 0x00158d0002006aa6 (0x00158d0002006aa6): RTCGQ11LM - Xiaomi Aqara human body movement and illuminance sensor (EndDevice)
2018-11-20 20:32:57 INFO 0x00158d000248682c (0x00158d000248682c): MFKZQ01LM - Xiaomi Mi smart home cube (EndDevice)
2018-11-20 20:32:57 WARN `permit_join` set to  `true` in configuration.yaml.
2018-11-20 20:32:57 WARN Allowing new devices to join.
2018-11-20 20:32:57 WARN Set `permit_join` to `false` once you joined all devices.
2018-11-20 20:32:57 INFO Zigbee: allowing new devices to join.
2018-11-20 20:32:57 INFO Connecting to MQTT server at mqtt://localhost:1883
2018-11-20 20:32:57 DEBUG Using MQTT client ID: 'zigbee'
« Letzte Änderung: 20 November 2018, 20:43:29 von mark79 »
Rock64 4GB mit Debian Strech, FHEM im LXC, Sonoff Switches/Touch, HM Thermostate, HMUART/Zigbee2MQTT@MapleCUN, ESP RGBWW Wifi Controller, ESP8266 Door Sensor/Briefkastenwächter, BT CSL Stick, BT iTags, DashButtons, Alexa, FireTV, RPi2 mit Kodi, Xiaomi Vacuum v1/Smarthome Komponenten

Offline n._markus

  • New Member
  • *
  • Beiträge: 5
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #563 am: 20 November 2018, 20:44:45 »
Ich habe gerade die Lösung aus der Facebook-Gruppe erhalten.
Die Pins 4 und 6 benötigen auch die Verbindung zu GND. Danach hat es sofort geklappt.

Danke trotzdem für die schnelle Hilfe!

Offline mark79

  • Full Member
  • ***
  • Beiträge: 476
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #564 am: 20 November 2018, 20:51:54 »
Dann ist aber komisch, das es vorher mit IOBroker so lief.. ist ja der selbe Dienst (Zigbee2mqtt).
Aber gut das es jetzt geht... :)
Rock64 4GB mit Debian Strech, FHEM im LXC, Sonoff Switches/Touch, HM Thermostate, HMUART/Zigbee2MQTT@MapleCUN, ESP RGBWW Wifi Controller, ESP8266 Door Sensor/Briefkastenwächter, BT CSL Stick, BT iTags, DashButtons, Alexa, FireTV, RPi2 mit Kodi, Xiaomi Vacuum v1/Smarthome Komponenten

Offline n._markus

  • New Member
  • *
  • Beiträge: 5
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #565 am: 20 November 2018, 21:08:02 »
Zitat
Dann ist aber komisch, das es vorher mit IOBroker so lief.. ist ja der selbe Dienst (Zigbee2mqtt).
Aber gut das es jetzt geht.
Das kann ich mir auch nicht erklären. Ich habe aber zwei von diesen Modulen. Bei beiden war das gleiche Symptom.

Offline mark79

  • Full Member
  • ***
  • Beiträge: 476
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #566 am: 20 November 2018, 22:56:39 »
Ja oder der Zigbee Adapter hat rumgezickt, das habe ich auch schon ein paar mal gehabt.

Mit der neuen Firmware, braucht man angeblich die Brücken nicht mehr zu setzen.
So habe ich das in den Github Issues gelesen, selbst getestet aber noch nicht.

Ich würde dir empfehlen, auf die neue FW zu wechseln. Weil dort einige Verbesserungen eingeflossen sind.
Die Firmware von PTVO z.B., hat bei mir Probleme, mit nicht mehr antworteten Motion Sensoren bereitet.
Wenn du z.B. jetzt alles pairst und später Probleme bekommst und die FW neu flashst, darfst du alles neu pairen, ist ne Heiden arbeit. Oder den Alufolientrick ausprobieren. :D
Rock64 4GB mit Debian Strech, FHEM im LXC, Sonoff Switches/Touch, HM Thermostate, HMUART/Zigbee2MQTT@MapleCUN, ESP RGBWW Wifi Controller, ESP8266 Door Sensor/Briefkastenwächter, BT CSL Stick, BT iTags, DashButtons, Alexa, FireTV, RPi2 mit Kodi, Xiaomi Vacuum v1/Smarthome Komponenten

Offline tavoc

  • New Member
  • *
  • Beiträge: 4
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #567 am: 21 November 2018, 09:05:47 »
Guten Morgen,

ich bin mit Zigbee/FHEM etc  ganz am Anfang. Ich habe mir aufgrund der beschränkten Reichweite des CC2531  Sticks hier aus dem Forum 2 OSram Smart Plugs geholt und diese versucht einzubinden.
Die Plugs tauchen per autocreate in FHEM auf, jedoch sind diese nicht schaltbar. Muss ich hier noch was ändern?
Wenn ich den Geräten das hier mitgebe: "devStateIcon ON:on:OFF OFF:off:ON", dann erscheint zwar das Lampensymbol, und in MQTT wird auch was gemacht, aber ich erhalte keine Rückmeldung, ist das normal? Kann man den Status auslesen, per getconfig oder ähnliches?

Und noch eine Frage: Sollten sich die Sensoren (Xiaomi Wassersensoren) nicht selbstständig am Router anmelden, wenn das Netz da besser ist? habe nämlich das Problem, dass diese nach einiger Zeit nicht mehr Messwerte schicken (und so ist das leider unzuverlässig).


Offline Tedious

  • Hero Member
  • *****
  • Beiträge: 1160
  • Indocti discant et ament meminisse periti
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #568 am: 21 November 2018, 09:17:33 »
Von mir auch guten Morgen,

ich hab eine Frage zum Thema Reichweite... ich nutze einen CC2531 als Coordinator an einem Brix, zum testen habe 2 Aquara Temp/Hum Sensoren. So weit, so gut. Aufgrund der dürftigen Reichweite habe ich mir einen als Router geflashten CC2530 beschafft. Selbiger kommuniziert mit mosquitto (sehe ich auf Konsole) und ist auch in FHEM angelegt. Problem: Wenn ich ihn einen Raum weiter platziere habe ich eine linkquality von 23. Platziere ich jetzt die beiden Sensoren in der Nähe des Routers passiert - nix. Eine hat eine linkquality von 13, der Andere von 15. Daraus schließe ich dass die Devices nicht mit dem Router kommunizieren, denn selbst wenn der Router eine schlechte Verbindung hat sollten doch die Devices wenn sie via Router laufen eine gute Verbindung (zum Router) aufweisen. Muss man irgendeinen Parameter setzen den ich überlesen habe? Kann man auf der Konsole irgendwie testen welchen Weg das Signal nimmt? So ist das irgendwie unschick...

Grüße Tedious
FHEM auf Brix N3150/4GB/500GB mit 4xMapleCUN (433,3x868) und Jeelink, HUE, MiLight, Max! und SonOff, Alexa mit HABridge, Kleinkram...

Offline Tabularasa

  • Full Member
  • ***
  • Beiträge: 176
Antw:[Neues Modul] Xiaomi Smart Home ohne Gateway direkt an FHEM
« Antwort #569 am: 21 November 2018, 20:40:38 »
Gerngeschehen. :) Wenn du den MQTT2_SERVER hast, dann brauchst du nur den Clienten für die Console zu installieren, also apt-get install mosquitto-clients

Ich habe das heute hier ausprobiert mit MQTT2_CLIENT, weil ich darauf umsteigen will und wie es ausschaut, fehlt bei Fhem noch was, das er die angeforderten Daten in ein Bild umwandelt und zwar das hier:
mosquitto_sub -h localhost -C 1 -t zigbee2mqtt/bridge/networkmap/graphviz | sfdp -Tpng >/tmp/network_map.png
Das scheint wohl noch nicht implementiert worden zu sein.

Den Befehl müsstest du also selber in der SSH Console ausführen und danach im Fhem zigbee_mqtt Device wie im Wiki den network_map graphviz Befehl absetzen.

Hallo mark79, @ all

Heute bin ich endlich dazu gekommen es mal auszuprobieren. Gleich vorweg mal die Ausgangssituation.
Ausgangspost https://forum.fhem.de/index.php/topic,84790.msg859149.html#msg859149
Coordinator im Keller (****3e6)
Fensterkontakt im WZ (****bb6)
Tempsensor1 im WZ am Ofen (****450)
Tempsensor2 ist mobil (****627)
Router im WZ (****cea)

in map0 ist der Router aus, Tempsensor2 liegt neben dem Coordinator.

in map1 ist der Router im WZ an, Tempsensor2 liegt neben dem Coordinator.(was schon komisch ist, Tempsensor1 und Fensterkontakt sind dem Router näher und im selben Raum, jedoch wird nur Tempsensor2 mit Router verbunden)

in map2 ist der Tempsensor2 neben dem Router, aber innerhalb der Reichweite des Coordinators

in map3 ist der Tempsensor2 in der Küche 4m neben dem Router jedoch außerhalb vom Coordinator.

So nun zu der Frage ;D

ab map3 sendet Tempsensor2 keine Werte mehr, also muss der Router ja entweder das Signal nicht weiter senden oder der Sensor war nie mit ihm verbunden.

Ich hoffe es ist einigermaßen verständlich und nicht zu umfangreich um durchzusteigen und mir zu helfen ;)
« Letzte Änderung: 21 November 2018, 20:47:16 von Tabularasa »