Autor Thema: CUL und irox  (Gelesen 644 mal)

Offline rcaspar

  • New Member
  • *
  • Beiträge: 22
CUL und irox
« am: 24 Februar 2018, 09:54:13 »
Liebe alle

Ich versuche an meinem Pi3 einen nanoCUL mit einem irox Temp/Hum Sensor in Betrieb zu nehmen.

Nach einigen Anläufen und Wik/Forum Hilfen (danke allen) läuft der CUL nun scheinbar, nur mit dem Empfang der Daten tue ich mich noch etwas schwer...
Liegt wohl daran, dass ich ein absoluter Neuling bin, sowohl mit CUL auls auch mit FHEM

Ich habe einen CUL wie folgt definiert:

define CUL_433 CUL /dev/serial/by-id/usb-1a86_USB2.0-Serial-if00-port0@38400 1234
set CUL_433 raw X05
attr CUL_433 rfmode SlowRF




Danach hatte ich "plötzlich" ein automatisch generiertes Element:

defmod CUL_WS_8 CUL_WS 8
attr CUL_WS_8 room CUL_WS


Dies beinhaltet ein Filelog, welches aber leer bleibt...


Im CUL_433 Element sehe ich eine rawmsg mit folgenden Werten:

2018-02-24_09:17:16 CUL_433 UNKNOWNCODE p 8  544 1984  528 3920  1  3 4 9B0CFFF0
2018-02-24_09:17:16 CUL_433 UNKNOWNCODE p 8  528 2000  544 3696  1  2 1 9B0C80
2018-02-24_09:41:30 CUL_433 UNKNOWNCODE p 6   96  224  752  112  1  2 0 FFFF
2018-02-24_09:41:38 CUL_433 UNKNOWNCODE p 8  480 2032  496 3968  1  4 4 9B0CFFFFA0
2018-02-24_09:41:38 CUL_433 UNKNOWNCODE p 8  496 2016  480 3920  1  4 4 9B0CFFFFA0
2018-02-24_09:41:38 CUL_433 UNKNOWNCODE p 8  496 2016  496 3952  1  4 4 9B0CFFFFA0
2018-02-24_09:42:11 CUL_433 UNKNOWNCODE p 8  496 2016  480 3952  1  4 4 9B0CFFFFA0
2018-02-24_09:42:11 CUL_433 UNKNOWNCODE p 8  432 2064  464 3984  1  4 4 9B0CFFFFA0

Nun weiss ich leider nicht mehr weiter und habe auch nichts dazu gefunden - wie bringe ich nun die gewünschten Daten aus diesen Strings?

Merci für die Nachhilfe eines Newbies ;)

René

Offline KölnSolar

  • Hero Member
  • *****
  • Beiträge: 2798
Antw:CUL und irox
« Antwort #1 am: 24 Februar 2018, 14:44:27 »
slowRF musst Du nicht extra setzen ist default.
Wieso X05 ?  :-\ Standard ist X21.

Und dann mal den event monitor beobachten  ;)
RPi3/2 Stretch-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-CUL868-FS20A4-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty-Boop-EchoDot

Offline rcaspar

  • New Member
  • *
  • Beiträge: 22
Antw:CUL und irox
« Antwort #2 am: 24 Februar 2018, 18:20:51 »
Merci für den Tipp

Habe SlowRF und X05 gelöscht.

Allerdings sehe ich im Event Log keine weiteren Daten ausser:

2018-02-24 18:16:18 CUL CUL_433 ccconf: freq:433.920MHz bWidth:325KHz rAmpl:42dB sens:4dB
2018-02-24 18:16:45 Global global DELETEATTR CUL_433 rfmode
2018-02-24 18:16:53 CUL CUL_433 cmds:  A B C E e F f G h i K k l M m R T t U V W X x Y Z z
2018-02-24 18:16:53 CUL CUL_433 Initialized
2018-02-24 18:16:53 CUL CUL_433 CONNECTED

danach kommt nix mehr ins log obwohl der irox 10 cm daneben steht und regelmässig sendet...

Offline KölnSolar

  • Hero Member
  • *****
  • Beiträge: 2798
Antw:CUL und irox
« Antwort #3 am: 24 Februar 2018, 19:26:15 »
Dann funkt der vermutlich mit einem der culfw/aculfw unbekannten Protokoll u. wurde nur "versehentlich" erkannt.

Du kannst die bwidth auf 464 erhöhen. Und nochmal Debuggingmodus(X67 und dann wieder zurück auf X21).
RPi3/2 Stretch-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-CUL868-FS20A4-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty-Boop-EchoDot

Offline rcaspar

  • New Member
  • *
  • Beiträge: 22
Antw:CUL und irox
« Antwort #4 am: 25 Februar 2018, 09:05:10 »
Zuerst mal danke für deine Inputs.

Allerdings werde ich aus dem Teil noch nicht schlau...  :(

Ich habe die bWith mal auf 464KHz gesetzt (mit und ohne X67), allerdings empfing der nanoCUL dannach nichts mehr - oder zumindest sah ich im Log nichts.

Danach wieder retour und mit X67 folgendes Bild im Log:

2018-02-25 08:53:49 CUL CUL_433 cmds:  A B C E e F f G h i K k l M m R T t U V W X x Y Z z
2018-02-25 08:53:49 CUL CUL_433 Initialized
2018-02-25 08:53:49 CUL CUL_433 CONNECTED
2018-02-25 08:54:45 CUL CUL_433 raw X67
2018-02-25 08:54:45 CUL CUL_433 UNKNOWNCODE p 8  512 1968  528 3856  1  3 5 E4 9B423FF8
2018-02-25 08:56:24 CUL CUL_433 UNKNOWNCODE p 8  496 1984  512 3952  1  4 4 E4 9B423FFFA0
2018-02-25 08:56:53 CUL CUL_433 UNKNOWNCODE p 9  496  944  496  496  1  2 4 D7 3FFBF0
2018-02-25 08:56:57 CUL CUL_433 UNKNOWNCODE p 8  480 1968  464 3984  1  4 4 E4 9B423FFFA0
2018-02-25 08:56:57 CUL CUL_433 UNKNOWNCODE p 8  512 1968  480 3968  1  4 4 E5 9B423FFFA0
2018-02-25 08:57:30 CUL CUL_433 UNKNOWNCODE p 8  496 1968  480 3968  1  4 3 E5 9B407FFF40
2018-02-25 08:57:30 CUL CUL_433 UNKNOWNCODE p 8  512 1952  480 3968  1  4 4 E5 9B423FFFA0
2018-02-25 08:57:30 CUL CUL_433 UNKNOWNCODE p 8  512 1968  496 3936  1  4 4 E6 9B423FFFA0
2018-02-25 08:58:03 CUL CUL_433 UNKNOWNCODE p 8  512 1936  512 3920  1  4 3 E6 9B423FFF40
2018-02-25 08:58:36 CUL CUL_433 UNKNOWNCODE p 8  544 1952  560 3888  1  4 3 E3 9B427FFF40
2018-02-25 09:00:15 CUL CUL_433 UNKNOWNCODE p 8  512 1936  528 3920  1  4 4 E3 9B423FFFA0


ALso - zumindest für mich - keine neuen Infos.

Die EInträge scheinen auch zeitlich willkürlich, resp. nur manchmal mit der Sende-LED des Sensors im Zusammenhang.

Der Sensor selbst zeigt 21.1, resp nach einieger Zeit 21,2 und immer 39% an.

 

Offline KölnSolar

  • Hero Member
  • *****
  • Beiträge: 2798
Antw:CUL und irox
« Antwort #5 am: 25 Februar 2018, 12:28:43 »
Zitat
Ich habe die bWith mal auf 464KHz gesetzt (mit und ohne X67), allerdings empfing der nanoCUL dannach nichts mehr - oder zumindest sah ich im Log nichts.
Wundert mich, aber wird schon so sein.

Und mit verbose 5 beim CUL kommt nichts im Log ? Was steht im internal RAWMSG des CUL ? Bei P8 hätte ich erwartet, dass ggfs. eine Fehlermeldung aus dem TCM97001-Modul kommt.  :-\ Bin aber nicht der Temp-/Hygro-Spezi.
RPi3/2 Stretch-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-CUL868-FS20A4-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty-Boop-EchoDot

Offline rcaspar

  • New Member
  • *
  • Beiträge: 22
Antw:CUL und irox
« Antwort #6 am: 25 Februar 2018, 13:06:18 »
Habe den nanoCUL nun nochmals mit a-culfw geflashed
Nun empfange ich mehr Sensoren als ich selbst besitze...

Unter anderem meinen Irox HTS33 als Hediki.
Alle Attribute werden einwandfrei decodiert - Temp, Hum, Batteriestatus, Comfort-level, Channel - so wie man sich das vorstellt ;)

Merci für deine HInts, diese haben mich auf "den richtigen Weg" gebracht.

René
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline rerohu

  • Newbie
  • Beiträge: 1
Antw:CUL und irox
« Antwort #7 am: 14 April 2018, 17:49:44 »
Hallo rcaspar

Ich habe eine nanoCUL mit a-culfw V 1.26.02. Ich möchte auch einen IROX HTS33 einbinden, aber ich bekomme nur folgende Meldungen im Log:

2018.04.14 14:49:20 3: nanoCUL: Unknown code P12#75D7BA4A80BF13EE, help me!
2018.04.14 15:19:06 3: nanoCUL: Unknown code P12#75D7BACA83BF6E9E, help me!
2018.04.14 15:31:38 3: nanoCUL: Unknown code P12#75D7BA4A82BFEEA90F, help me!
2018.04.14 16:38:13 3: nanoCUL: Unknown code P12#75D7BA8A8EBF11090F, help me!
2018.04.14 17:00:56 3: nanoCUL: Unknown code P12#75D7BA4A70BF116E, help me!
2018.04.14 17:07:59 3: nanoCUL: Unknown code P12#75A6A572F415901577, help me!

Mit X67 bekomme ich
2018.04.14 17:29:33 3: set nanoCUL raw X67
2018.04.14 17:29:56 3: nanoCUL: Unknown code p11   32  640   48   96   48 1520  17  1  2 1   160 12720     0 D8 EA9B80, help me!
2018.04.14 17:30:20 3: nanoCUL: Unknown code p 8   32 2960   32   96   32 2352  24  1  3 0   160  7504     0 D9 F9A1F4, help me!
2018.04.14 17:30:28 3: nanoCUL: Unknown code p11   32  976  128  128   48  336  18  1  2 2   192  5472     0 D8 D8BA80, help me!
2018.04.14 17:30:45 3: nanoCUL: Unknown code p11  208  448   32 2864   16  784  25  1  3 1   160  3712     0 DA 0AD40000, help me!
2018.04.14 17:30:48 3: nanoCUL: Unknown code p11  400   96  448  528  448 1008  60  1  7 4   288 10560     0 3B 5608008040409020, help me!
2018.04.14 17:30:52 3: nanoCUL: Unknown code p11   32 2016   48 2000   48  800  21  1  2 5   192  3328     0 D8 F880C0, help me!

Wie konntest Du den HTS33 einbinden?

Vielen Dank für einen Tipp

Offline rcaspar

  • New Member
  • *
  • Beiträge: 22
Antw:CUL und irox
« Antwort #8 am: 19 Mai 2018, 16:50:13 »
Hi rerohu

Ja das ich dir leider nicht "straight forward" erklären, da es bei mir auch ein ausprobieren war.
Habe allerding jetzt eine neue Installation und war am Anfang auch am verzweifeln, aber nun geht's.

Ich habe einen nanoCUL mit folgender FW:
V 1.26.02 a-culfw Build: 275 (2018-02-07_20-27-53) nanoCUL433 (F-Band: 433MHz)

und ccconf gibt folgende Settings retour:
freq:433.920MHz bWidth:325KHz rAmpl:42dB sens:4dB

Das Device habe ich folgendermassen definiert:
define CUL_433 CUL /dev/ttyUSB0@38400 1234
Danach hatte ich unter den Clients den "Hideki" noch nicht, diesen benötigt es.
Als ich den Raspi neu gestartet habe, war er auch noch nicht da. Danach den Sensor neben den Empfänger gelegt und gewartet...

Nach einiger Zeit habe ich im Event Monitor einen Eintrag zu Hideki gesehen, mehr nicht. Nun hat der CUL den Hideki CLient gelistet.
Wieder etwas warten und FHEM zeigt eine Config Speicherung als anstehend an - wieso ist auf dem GUI nicht ersichtlich - also Config geschrieben.

Wieder eine Zeit später (wenige Minuten...) ist eine neues Hideki Device da - diese nun noch nach Wunsch konfigurieren - fertig ;)

Hoffe dir geholfen zu haben

René


Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 1859
  • Es begann alles so klein ;-)
Antw:CUL und irox
« Antwort #9 am: 19 Mai 2018, 17:23:53 »
Hi,

a) Ich würde in der Def des CUL statt /dev/ttyUSB?@[Baudrate] über die Angabe des USB-Pfades gehen (z.B. /dev/serial/by-path/irgendwas@[Baudrate], irgendwas steht unter „ls -la /dev/serial/by-path“ vor dem /dev/ttyUSB? Eintrag
b) Ich denke die Protokolle hängen tatsächlich davon ab, welche Module FHEM schon geladen hat. Dies bedeutet, dass erst nach dem Finden des ersten Hidecki Senders (zwei Funkpakete mit gleicher ID innerhalb 2 Minuten) das Protokoll in der Liste auftaucht
c) Wenn man beim config speichern auf das rote Fragezeichen tippt, bekommt man erklärt warum!

Gruß Arnd


Gesendet von iPhone mit Tapatalk
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

 

decade-submarginal