Autor Thema: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was  (Gelesen 2044 mal)

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
                                                   

Moin an alle,

Ich benötige mal Eure Hilfe.
Nachdem mein Testsystem mit kleinen Anpassungen für 1-Wire auf einem
Windows XP-Rechner sauber funktionierte, habe ich gewagt, FHEM auf die
Fritzbox zu bringen.

- die Fritzbox ist eine 7570_HN (Alice IAD 7570)
- das System ist ein fertiges Toolboxflex-Image für die 7570_HN
--> Alice IAD
ZD-tbflex2.0_7570_04.91-freetz-devel-9394M.en_20120922-094324.image +
external
--> http://www.zebradem.com/49753-7570-images
- das FHEM-Paket kommt ebenfalls vom Zebradem-Board
--> http://www.zebradem.com/65206-fhem-tbflex-addon-support-thread-3
- updatefhem wurde durchgeführt, und die letzten 1-Wire Dateien aus > fhem
> trunk
> fhem
> contrib
> 1-Wire
- der 1-Wire Adapter ist ein LinkUSB aus dem Fuchs Shop (FTDI-Chip)
- nach dem starten von FHEM kommt folgende Fehlermeldung
--> 2012.09.23 08:48:13 3: Opening 1wire device /dev/ttyUSB0
      2012.09.23 08:48:13 3: Setting 1wire baudrate to 9600
      2012.09.23 08:48:13 3: 1wire device opened
      2012.09.23 08:48:13 1: OWX: Serial device /dev/ttyUSB0 defined
      2012.09.23 08:48:14 1: serial ( von mir zur Fehlersuche in OWX.pm
eingetragen)
      2012.09.23 08:48:14 1: Device::SerialPort=HASH(0xa92ba8) ( von mir
zur Fehlersuche in OWX.pm eingetragen)
      2012.09.23 08:48:14 1: OWX: 1-Wire bus 1wire: interface not found,
answer was
      2012.09.23 08:48:14 1: OWX: 1-Wire bus 1wire: interface not found,
answer was
      2012.09.23 08:48:15 1: OWX: 1-Wire bus 1wire: interface not found,
answer was
      2012.09.23 08:48:15 1: OWX: 1-Wire bus 1wire: interface not found,
answer was
      2012.09.23 08:48:16 1: OWX: 1-Wire bus 1wire: interface not detected,
answer was

Mein 2. Adapter, ein USB zu Serial Noname mit PL2303-Chip und einem
selbstgestricken Modul für meine Lüftungsanlage rennt sauber durch. (
Log-Auszug)
--> 2012.09.23 12:55:45 3: Opening WHR962 device /dev/ttyUSB0
      2012.09.23 12:55:46 3: Setting WHR962 baudrate to 9600
      2012.09.23 12:55:46 3: WHR962 device opened 2012.09.23 12:55:47 1:
Including ./log/fhem.save
      2012.09.23 12:55:47 0: Server started (version Fhem 5.2
(DEVELOPMENT), $Id: fhem.pl 1719
      2012-07-11 14:46:37Z rudolfkoenig $, pid 10836)
      2012.09.23 12:55:47 3: WHR_KomfortTemperatur: 22.5

Und jetzt komme ich nicht mehr weiter.

Wer kann mir helfen?
Wenn noch weitere Infos gebraucht werden, bescheid sagen.

Gruß Joachim

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Guest

  • Gast
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #1 am: 24 September 2012, 07:56:08 »
Originally posted by: <email address deleted>

Das Modul OWX sendet eine binäre Initialisierungssequenz an das Interface
und erwartet einen Rückgabewert.
Anhand dessen entscheidet es sich, um welchen Adapter es sich handelt.
Insgesamt werden dafür 5 Versuche unternommen, jeweils im Absgtand von 1
Sekunde. Wie man oben sieht, kommt bei keinem der Versuche etwas zurück.

Ich selbst habe keinen LinkUSB zur Verfügung, kann also nicht testen,
welchen Wert dieser liefern müsste.

Folgende Vorschläge:
1. Auf dem Windows-System nachsehen, welche Antworten der LinkUSB liefert.
2. Nachsehen, ob der LinkUSB tatsächlich auf dem ttyUSB0 sitzt. Denn das
zweite Protokoll oben besagt, dass dort der PL2303 sitzt. Das würde dann
bedeuten, dass die Konfiguration des Systems nicht stimmt.

LG

pah


--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #2 am: 24 September 2012, 08:45:45 »
                                                   

Guten Morgen Prof. Dr. Peter A. Henning,

Werde das heute abend mal testen, welche Initialierungssequenz der LinkUsb
sendet, hast Du einen Tipp, an welcher Stelle ich ein Log5 in der OWX.pm
einfügen muß?

Ja, der LinkUSB sitzt auf ttyUSB0, habe die Adapter nacheinander
ausprobiert, um hier Fehler auszuschließen. Er wird sauber initialisiert,
und mit dmesg wird angezeigt, daß er auf /dev/ttyUSB0 sitzt.

Danke ersteinmal für die Hilfe.

gruß Joachim

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #3 am: 24 September 2012, 21:18:33 »
                                                   






Rückmeldung an alle,

nachdem ich mit Hilfe des Zebradem-Boards das Toolboxpaket FHEM angepasst
habe, rennt jetzt auch 1-Wire auf meiner Fritzbox.
Das ist jetzt nach Fehlerbeseitigung eine supereinfache und gut zu
administrierende Lösung, um FHEM auf der Fritzbox zu installieren (siehe
Anhänge).

@ pah,

nachgenauerem Ansehen von OWX.pm habe ich die debugging Einstellung
gefunden, aber so lernt man am besten. Danke auch für Deine Hilfe.

gruß Joachim

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Guest

  • Gast
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #4 am: 24 September 2012, 21:20:37 »
Originally posted by: <email address deleted>

Das nutzt leider nichts.
Denn in den Zeilen 487 - 525 des OWX-Moduls wird ja schon jeder unbekannte
Rückgabewert ausgeschrieben.

Man kann noch die globale Variable $owx_debug auf 3 setzen (am Anfang des
Moduls) - dann bekommt man wirklich tonnenweise Information darüber, was
herausgeht und was hereinkommt.

Im vorliegenden Fall scheint aber gar nichts zurückzukommen. Kann es sein,
dass die Device Permissions nicht stimmen ?

LG

pah

 

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #5 am: 24 September 2012, 21:36:35 »
                                                   

@ pah,

Ich hatte doch geschrieben, es läuft jetzt alles, der Fehler lag im
FHEM-Paket der Toolbox.
Den Fehler habe ich mit Hilfe von FS79 aus dem Zebradem-Board beseitigt,
und jetzt läuft alles.
Jetzt kann ich mich wieder meinem Modul für die Lüftungsanlage zuwenden.

Danke und Gruß

Joachim

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Guest

  • Gast
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #6 am: 25 September 2012, 05:45:13 »
Originally posted by: <email address deleted>

Posts haben sich überschnitten.

Erklärt aber noch nicht, woran es genau lag "FS79 aus dem Zebradem-Board"
sollt ebitt eetwas genauer erklärt werden.

pah

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #7 am: 25 September 2012, 07:36:50 »
                                                   

Guten Morgen Professor,

hier nocheimal die etwas genauere Erklährung.

Auf dem Zebradem-Board gibt es für die meisten Fritz-Boxen fertig
kompilierte Images.
Unter anderem auch als Toolboxflex-Image.
Das Toolboxflex-Image hat den Vorteil, dass ohne neukompilieren weitere
Module im laufenden Betrieb der Fritzbox nachgeladen werden können.
Ein Modul davon ist ein FHEM-Modul, das FHEM in die Oberfläche von Freetz
integriert (siehe meine angehängten Bilder von gestern).
Über dieses Modul konnte bis gestern nur das Kernelmodul Cdc-acm.ko
nachgeladen werden. Die beiden von mir benötigten Module hatte ich auf
einem anderen Weg nachgeladen, und dabei kam es scheinbar dem Problemen,
daß das ftdi_sio.ko zwar geladen wurde, aber durch einen anderen Dienst
blockiert wurde.
Durch die Hilfe von FS79, dem Entwickler des FHEM-Moduls sind nun auch
zusätzlich die Module ftdi_sio.ko und pl2303.ko im FHEM Modul anwähl und
startbar, weitere Module sind, wenn als Kernelmodul vorhanden ebenfalls in
die Oberfläche integrierbar.
Weitere Informationen zu Toolboxflex mußt Du Dir selbst anlesen, das würde
den Rahmen hier sprengen.
Alles in allem ist die Variante optimal für FHEM (siehe Bilder von gestern).

Ich hoffe, das reicht Dir als genauere Erklährung.

gruß Joachim


--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Guest

  • Gast
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #8 am: 25 September 2012, 20:48:25 »
Originally posted by: <email address deleted>

Ja, kann man zulassen...

LG

pah


--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3986
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #9 am: 02 Dezember 2012, 16:04:39 »
                                                   

ich mach den thread mal weiter da ich denselben Fehler habe.
Der LinkUSBi lief seit einem Monat problemlos.
Habe jetzt auf FHEM 5.3 gewechselt (deb neu eingespielt + update) und OWX
bekommt keine Antwort mehr vom LinkUSBi. (zwischendurch war kein Reboot
o.ä) Er ist aber definitiv auf /dev/ttyUSB0. So wie vorher auch. Ein
"lsusb" bestätigt das Vorhandensein.

Mit einem testweise angeschlossenen MP00202 vom polnischen Freund lief es
sofort. Auch ein Reboot brachte nix.

Ideen?

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #10 am: 02 Dezember 2012, 16:49:02 »
                                                   

Moin Tobias,

lese mal auf FHEM developers -->
https://groups.google.com/forum/?fromgroups=#!topic/fhem-developers/TS09mNWohxc

probiere die dort angehaengte 00_OWX.pm

die fhem.cfg auf folgende Einstellungen kontrollieren:
attr global mseclog
attr global verbose 3

in der 00_OWX.pm zeile 91/92 kontrollieren
#-- Debugging 0,1,2,3
my $owx_debug=3;

und dann FHEM shutdown, log leeren, save leeren und Neustart.
dann das log analysieren, ggf. hier posten. Die ersten 6 Minuten reichen.

gruss Joachim

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Guest

  • Gast
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #11 am: 02 Dezember 2012, 17:26:07 »
Originally posted by: <email address deleted>

Mit 5.3 sind tolle neue Mechanismen eingebaut worden, die z.B. die
Kommunikation zwischen CUNO und OWX, sagen wir mal, negativ beeinflussen...

Ist in Arbeit.

LG

pah

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3986
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #12 am: 03 Dezember 2012, 13:30:24 »
                                                   

Hm, alles gemacht, aber auch nach den 3x100 Schleifendurchläufen gibts
keine Antwort vom LinkUSBi :(


On Sunday, December 2, 2012 4:49:02 PM UTC+1, joachim herold wrote:
>
> Moin Tobias,
>
> lese mal auf FHEM developers -->
> https://groups.google.com/forum/?fromgroups=#!topic/fhem-developers/TS09mNWohxc
>
> probiere die dort angehaengte 00_OWX.pm
>
> die fhem.cfg auf folgende Einstellungen kontrollieren:
> attr global mseclog
> attr global verbose 3
>
> in der 00_OWX.pm zeile 91/92 kontrollieren
> #-- Debugging 0,1,2,3
> my $owx_debug=3;
>
> und dann FHEM shutdown, log leeren, save leeren und Neustart.
> dann das log analysieren, ggf. hier posten. Die ersten 6 Minuten reichen.
>
> gruss Joachim
>

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #13 am: 03 Dezember 2012, 13:41:35 »
                                                   

Dann liegt das Problem nicht in OWX, sonder davor.

Adapter, Kabel, etc. kaputt?
Ausprobieren unter Windows nit dem Programm von Dallas/Maxheim
Module nicht richtig geladen? Adpter nicht richtig erkannt?
dmesg | grep USB

gruss Joachim

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3986
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #14 am: 04 Dezember 2012, 06:40:26 »
                                                   

Irgendwie muss die Linkusbi einen Reset haben, oder er ist einfach nur
abgestürzt.
Adapter abgestöpselt, wieder dran und sofort lief er wieder. Mit dem ersten
Schleifendurchlauf.


On Monday, December 3, 2012 1:41:35 PM UTC+1, joachim herold wrote:
>
> Dann liegt das Problem nicht in OWX, sonder davor.
>
> Adapter, Kabel, etc. kaputt?
> Ausprobieren unter Windows nit dem Programm von Dallas/Maxheim
> Module nicht richtig geladen? Adpter nicht richtig erkannt?
> dmesg | grep USB
>
> gruss Joachim
>

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Guest

  • Gast
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #15 am: 04 Dezember 2012, 09:26:56 »
Originally posted by: <email address deleted>

Nun, dann ist ja alles in Butter...

Das kommt daher, dass man die Dinger zu schlau baut. Irgendwann stürzt Dir
morgens auch die Elektrozahnbürste ab...

LG

pah

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3986
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #16 am: 07 Dezember 2012, 21:50:28 »
                                                   

und schon wieder. Habe ein "shutdown restart" gemacht, und schon antwortet
der LinkUsbi wieder nicht.
Ich meine, kann doch nicht sein das man das Teil nur durch die
Holzhammermethode (Stecker ziehen) wieder zum kommunizieren überreden
kann... :(
Da arbeitet der 1wire Konverter vom polnischen Freund zuverlässiger...

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #17 am: 07 Dezember 2012, 21:52:59 »
                                                   

Moin Tobias, seit den Aenderungen im OWX-Modul rennt des Ding bei mir
super, und frage jetzt bitte nicht, wie oft ich schon ein Shutdown Restart
gemacht habe.

Gruss Joachim

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3986
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #18 am: 07 Dezember 2012, 22:02:22 »
                                                   

Auch wenn es ein paar Tage ohne unterbrechung durchgerannt ist?

On Friday, December 7, 2012 9:52:59 PM UTC+1, joachim herold wrote:
>
> Moin Tobias, seit den Aenderungen im OWX-Modul rennt des Ding bei mir
> super, und frage jetzt bitte nicht, wie oft ich schon ein Shutdown Restart
> gemacht habe.
>
> Gruss Joachim
>

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #19 am: 07 Dezember 2012, 22:04:41 »
                                                   

Rennt seit 2. Dezember mit diversen Shutdown, Shutdown Restart, Reboots der
Fritzbox

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3986
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #20 am: 07 Dezember 2012, 22:08:58 »
                                                   

was mir im dmesg aufgefallen ist, das der Adapter disconnected wurde und
gleich danach wieder connected wurde ... hmm....

usb 1-1.3: USB disconnect, address 4
ftdi_sio ttyUSB0: FTDI USB Serial Device converter now disconnected from
ttyUSB0
ftdi_sio 1-1.3:1.0: device disconnected
usb 1-1.3: new full speed USB device using orion-ehci and address 6
ftdi_sio 1-1.3:1.0: FTDI USB Serial Device converter detected
usb 1-1.3: Detected FT232RL
usb 1-1.3: Number of endpoints 2
usb 1-1.3: Endpoint 1 MaxPacketSize 64
usb 1-1.3: Endpoint 2 MaxPacketSize 64
usb 1-1.3: Setting MaxPacketSize 64
usb 1-1.3: FTDI USB Serial Device converter now attached to ttyUSB1

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #21 am: 07 Dezember 2012, 22:21:10 »
                                                   

Da kann ich Dir nicht wirklich bei helfen, aber irgendwo gab es mal einen
Tipp wo man einem USB-Adapter immer die gleiche Adresse ttyUSBx zuweisen
konnte.

Gruss Joachim

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3986
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #22 am: 07 Dezember 2012, 22:40:24 »
                                                   

mittels udev habe ich eine feste Adresse vergeben, aber das Problem besteht
nicht im Mount-Point sondern in der Nicht-Kommunikation... bin ich der
einzige mit dem Problem? Leider hab ich nur ein Exemplar des LinkUSBi.
Außer den Adapter mal an einen aktiven Hub zu hängen würde mir spontan auch
nichts einfallen.

On Friday, December 7, 2012 10:21:10 PM UTC+1, joachim herold wrote:
>
>
> Da kann ich Dir nicht wirklich bei helfen, aber irgendwo gab es mal einen
> Tipp wo man einem USB-Adapter immer die gleiche Adresse ttyUSBx zuweisen
> konnte.
>
> Gruss Joachim
>

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #23 am: 07 Dezember 2012, 23:00:24 »
                                                   

Aktiver Hub ist ne gute Idee, denn der Adapter versorgt ja auch den 1-Wire
Bus.
Haengt der Adapter an einem PC? oder an einer Fritzbox/Rapsberry?

Dann reicht die Spannung nicht aus.

Bei mir haengt auch ein aktiver Hub dazwischen.

Gruss Joachim

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3986
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #24 am: 07 Dezember 2012, 23:26:07 »
                                                   

hängt an einer Debianisierten Iomega Iconnect. Im 60m Bus hängen auch nur
10 DS2406 und 10 DS18B20. UNd der LinkUsbi stellt auch nur max 20mA bereit.

On Friday, December 7, 2012 11:00:24 PM UTC+1, joachim herold wrote:
>
> Aktiver Hub ist ne gute Idee, denn der Adapter versorgt ja auch den 1-Wire
> Bus.
> Haengt der Adapter an einem PC? oder an einer Fritzbox/Rapsberry?
>
> Dann reicht die Spannung nicht aus.
>
> Bei mir haengt auch ein aktiver Hub dazwischen.
>
> Gruss Joachim
>

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3986
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #25 am: 10 Dezember 2012, 19:44:57 »
                                                   

Hi,
ich habe mal den Fuchs-Shop angeschrieben mit u.a. Antwort:

> Hallo Herr Fuchs,
>
> kennen bzw wurde ihnen schon folgendes Verhalten berichtet?
>
> es kommt vor das, wenn der LinkUSBi neu initialisiert wird, die aktuelle
> ttyUSB* Verbindung unterbrochen und neu aufgebaut wird. Danach ist der
> LinkUSBi  nicht mehr ansprechbar.
> Zwar ist auch noch ein "picocom -b 9600 /dev/ttyUSB1" möglich, aber
> keine Reaktion zb. auf "\h" oder sonstige Befehle.
> Erst ein Ab- und erneutes Anstecken an den USBPort hilft damit der
> LinkUSBi wieder mit meiner Anwendung kommunizieren will.
>
> Haben Sie ev. einen Hinweis?

Sehr geehrter Herr Faust,

ich kenne dieses Verhalten. Es scheint an USB 2.0 zu liegen. Versuchen
Sie mal den LinkUSB über USB 1.1 anzusprechen, in dem Sie das USB 2.0
Modul entfernen.

# lsmod | grep ehci_hcd
ehci_hcd               29101  0
usbcore                99774  6
ftdi_sio,usbserial,usb_storage,uhci_hcd,ehci_hcd

# rmmod ehci_hcd


Mit freundlichem Gruß
Moritz Fuchs

Dummerweise sehe ich 1. das Modul nicht per lsmod und 2. kann ich es nicht
einfach wegnehmen da ich es anderweitig benötige.
Kann man (ev. per udev-regel) dem Device explizit eine USB 1.1 Conn
zuweisen?

root@Iconnect:~# lsmod
Module                  Size  Used by
ipv6                  233239  32
nfsd                  242637  11
exportfs                3084  1 nfsd
ftdi_sio               27204  1
usbserial              26516  3 ftdi_sio
mv_cesa                 9418  0

usb 1-1.3: new full speed USB device using orion-ehci and address 6
ftdi_sio 1-1.3:1.0: FTDI USB Serial Device converter detected
usb 1-1.3: Detected FT232RL
usb 1-1.3: Number of endpoints 2
usb 1-1.3: Endpoint 1 MaxPacketSize 64
usb 1-1.3: Endpoint 2 MaxPacketSize 64
usb 1-1.3: Setting MaxPacketSize 64
usb 1-1.3: FTDI USB Serial Device converter now attached to ttyUSB2



--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Guest

  • Gast
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #26 am: 10 Dezember 2012, 20:01:06 »
Originally posted by: <email address deleted>

Oha ...

Da muss ich selbst mal recherchieren - ist m.E. nicht so einfach, weil der
Adapter über USB signalisiert, dass er 2.0 kann. Man könnte aber einen Hub
dazwischen setzen, der nur 1.1 spricht.

LG

pah

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com