Autor Thema: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was  (Gelesen 2044 mal)

Guest

  • Gast
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #15 am: 04 Dezember 2012, 09:26:56 »
Originally posted by: <email address deleted>

Nun, dann ist ja alles in Butter...

Das kommt daher, dass man die Dinger zu schlau baut. Irgendwann stürzt Dir
morgens auch die Elektrozahnbürste ab...

LG

pah

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3986
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #16 am: 07 Dezember 2012, 21:50:28 »
                                                   

und schon wieder. Habe ein "shutdown restart" gemacht, und schon antwortet
der LinkUsbi wieder nicht.
Ich meine, kann doch nicht sein das man das Teil nur durch die
Holzhammermethode (Stecker ziehen) wieder zum kommunizieren überreden
kann... :(
Da arbeitet der 1wire Konverter vom polnischen Freund zuverlässiger...

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #17 am: 07 Dezember 2012, 21:52:59 »
                                                   

Moin Tobias, seit den Aenderungen im OWX-Modul rennt des Ding bei mir
super, und frage jetzt bitte nicht, wie oft ich schon ein Shutdown Restart
gemacht habe.

Gruss Joachim

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3986
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #18 am: 07 Dezember 2012, 22:02:22 »
                                                   

Auch wenn es ein paar Tage ohne unterbrechung durchgerannt ist?

On Friday, December 7, 2012 9:52:59 PM UTC+1, joachim herold wrote:
>
> Moin Tobias, seit den Aenderungen im OWX-Modul rennt des Ding bei mir
> super, und frage jetzt bitte nicht, wie oft ich schon ein Shutdown Restart
> gemacht habe.
>
> Gruss Joachim
>

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #19 am: 07 Dezember 2012, 22:04:41 »
                                                   

Rennt seit 2. Dezember mit diversen Shutdown, Shutdown Restart, Reboots der
Fritzbox

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3986
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #20 am: 07 Dezember 2012, 22:08:58 »
                                                   

was mir im dmesg aufgefallen ist, das der Adapter disconnected wurde und
gleich danach wieder connected wurde ... hmm....

usb 1-1.3: USB disconnect, address 4
ftdi_sio ttyUSB0: FTDI USB Serial Device converter now disconnected from
ttyUSB0
ftdi_sio 1-1.3:1.0: device disconnected
usb 1-1.3: new full speed USB device using orion-ehci and address 6
ftdi_sio 1-1.3:1.0: FTDI USB Serial Device converter detected
usb 1-1.3: Detected FT232RL
usb 1-1.3: Number of endpoints 2
usb 1-1.3: Endpoint 1 MaxPacketSize 64
usb 1-1.3: Endpoint 2 MaxPacketSize 64
usb 1-1.3: Setting MaxPacketSize 64
usb 1-1.3: FTDI USB Serial Device converter now attached to ttyUSB1

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #21 am: 07 Dezember 2012, 22:21:10 »
                                                   

Da kann ich Dir nicht wirklich bei helfen, aber irgendwo gab es mal einen
Tipp wo man einem USB-Adapter immer die gleiche Adresse ttyUSBx zuweisen
konnte.

Gruss Joachim

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3986
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #22 am: 07 Dezember 2012, 22:40:24 »
                                                   

mittels udev habe ich eine feste Adresse vergeben, aber das Problem besteht
nicht im Mount-Point sondern in der Nicht-Kommunikation... bin ich der
einzige mit dem Problem? Leider hab ich nur ein Exemplar des LinkUSBi.
Außer den Adapter mal an einen aktiven Hub zu hängen würde mir spontan auch
nichts einfallen.

On Friday, December 7, 2012 10:21:10 PM UTC+1, joachim herold wrote:
>
>
> Da kann ich Dir nicht wirklich bei helfen, aber irgendwo gab es mal einen
> Tipp wo man einem USB-Adapter immer die gleiche Adresse ttyUSBx zuweisen
> konnte.
>
> Gruss Joachim
>

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #23 am: 07 Dezember 2012, 23:00:24 »
                                                   

Aktiver Hub ist ne gute Idee, denn der Adapter versorgt ja auch den 1-Wire
Bus.
Haengt der Adapter an einem PC? oder an einer Fritzbox/Rapsberry?

Dann reicht die Spannung nicht aus.

Bei mir haengt auch ein aktiver Hub dazwischen.

Gruss Joachim

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3986
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #24 am: 07 Dezember 2012, 23:26:07 »
                                                   

hängt an einer Debianisierten Iomega Iconnect. Im 60m Bus hängen auch nur
10 DS2406 und 10 DS18B20. UNd der LinkUsbi stellt auch nur max 20mA bereit.

On Friday, December 7, 2012 11:00:24 PM UTC+1, joachim herold wrote:
>
> Aktiver Hub ist ne gute Idee, denn der Adapter versorgt ja auch den 1-Wire
> Bus.
> Haengt der Adapter an einem PC? oder an einer Fritzbox/Rapsberry?
>
> Dann reicht die Spannung nicht aus.
>
> Bei mir haengt auch ein aktiver Hub dazwischen.
>
> Gruss Joachim
>

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3986
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #25 am: 10 Dezember 2012, 19:44:57 »
                                                   

Hi,
ich habe mal den Fuchs-Shop angeschrieben mit u.a. Antwort:

> Hallo Herr Fuchs,
>
> kennen bzw wurde ihnen schon folgendes Verhalten berichtet?
>
> es kommt vor das, wenn der LinkUSBi neu initialisiert wird, die aktuelle
> ttyUSB* Verbindung unterbrochen und neu aufgebaut wird. Danach ist der
> LinkUSBi  nicht mehr ansprechbar.
> Zwar ist auch noch ein "picocom -b 9600 /dev/ttyUSB1" möglich, aber
> keine Reaktion zb. auf "\h" oder sonstige Befehle.
> Erst ein Ab- und erneutes Anstecken an den USBPort hilft damit der
> LinkUSBi wieder mit meiner Anwendung kommunizieren will.
>
> Haben Sie ev. einen Hinweis?

Sehr geehrter Herr Faust,

ich kenne dieses Verhalten. Es scheint an USB 2.0 zu liegen. Versuchen
Sie mal den LinkUSB über USB 1.1 anzusprechen, in dem Sie das USB 2.0
Modul entfernen.

# lsmod | grep ehci_hcd
ehci_hcd               29101  0
usbcore                99774  6
ftdi_sio,usbserial,usb_storage,uhci_hcd,ehci_hcd

# rmmod ehci_hcd


Mit freundlichem Gruß
Moritz Fuchs

Dummerweise sehe ich 1. das Modul nicht per lsmod und 2. kann ich es nicht
einfach wegnehmen da ich es anderweitig benötige.
Kann man (ev. per udev-regel) dem Device explizit eine USB 1.1 Conn
zuweisen?

root@Iconnect:~# lsmod
Module                  Size  Used by
ipv6                  233239  32
nfsd                  242637  11
exportfs                3084  1 nfsd
ftdi_sio               27204  1
usbserial              26516  3 ftdi_sio
mv_cesa                 9418  0

usb 1-1.3: new full speed USB device using orion-ehci and address 6
ftdi_sio 1-1.3:1.0: FTDI USB Serial Device converter detected
usb 1-1.3: Detected FT232RL
usb 1-1.3: Number of endpoints 2
usb 1-1.3: Endpoint 1 MaxPacketSize 64
usb 1-1.3: Endpoint 2 MaxPacketSize 64
usb 1-1.3: Setting MaxPacketSize 64
usb 1-1.3: FTDI USB Serial Device converter now attached to ttyUSB2



--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Guest

  • Gast
Re: 1-Wire OWX: 1-Wire bus 1wire: interface not found, answer was
« Antwort #26 am: 10 Dezember 2012, 20:01:06 »
Originally posted by: <email address deleted>

Oha ...

Da muss ich selbst mal recherchieren - ist m.E. nicht so einfach, weil der
Adapter über USB signalisiert, dass er 2.0 kann. Man könnte aber einen Hub
dazwischen setzen, der nur 1.1 spricht.

LG

pah

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com