Autor Thema: OWServer hängt nach Update  (Gelesen 2223 mal)

Offline Tommi ratlos

  • Jr. Member
  • **
  • Beiträge: 65
OWServer hängt nach Update
« am: 12 März 2018, 17:06:15 »
Hallo,

seit meinem heutigen Update hängt Fhem bei:

OWServer: Successfully connected to 192.168.115.2:4304.
Erst nach dem Zurückspielen der alten OWNet.pm läuft es wieder.

System Raspberry mit Debian Stretch, der Owserver läuft auf einer Fritzbox.

Gruß
Thomas
Pi 3 CUNX868 mit 433 Pigator.

Offline fhem-hm-knecht

  • Hero Member
  • *****
  • Beiträge: 1830
  • Fhem User seit 2010
Antw:OWServer hängt nach Update
« Antwort #1 am: 12 März 2018, 19:22:09 »
Zitat
der Owserver läuft auf einer Fritzbox
und welche Version hat der?
Hary


Banane (CT)   2x HM-Lan + WlanHMUART, Avr-net-io, 1Wire,

Offline 1of16

  • New Member
  • *
  • Beiträge: 33
Antw:OWServer hängt nach Update
« Antwort #2 am: 12 März 2018, 21:43:25 »
habe das gleiche Problem, siehe auch hier: https://forum.fhem.de/index.php/topic,85211.msg779802.html#msg779802

Grüße
FHEM 5.8 in einem Dockercontainer
VCCU mit 2x nanoCUL HM, HMUSB, HMLAN
2x nanoCUL 433MHz, 3x RPi3, Unifi-controller mit zwei APs für presence und Unifi-Video-Controller mit drei UVC
7x HM-CC-RT-DN, 9x HM-SEC-SCo, 2x HM-LC-Dim1TPBU-FM und div weitere HM-Geräte

Offline Tommi ratlos

  • Jr. Member
  • **
  • Beiträge: 65
Antw:OWServer hängt nach Update
« Antwort #3 am: 13 März 2018, 06:08:00 »
Hallo,

Owserver Version 2.7p32 libow 2.7p32

Gruß
Thomas
Pi 3 CUNX868 mit 433 Pigator.

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4155
Antw:OWServer hängt nach Update
« Antwort #4 am: 16 März 2018, 20:36:40 »
Hi,

lässt sich der owserver auf 3.1 aktualisieren?

Grüße
Boris
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline Tommi ratlos

  • Jr. Member
  • **
  • Beiträge: 65
Antw:OWServer hängt nach Update
« Antwort #5 am: 17 März 2018, 07:23:23 »
Hallo,

muss ich mal schauen, habe schon versucht eine freetz Version mit Owsever 3.2 zu bauen.
Zum Einspielen komme ich die nächste Zeit erst mal nicht, da ich unterwegs bin.

Gruß
Thomas
Pi 3 CUNX868 mit 433 Pigator.

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4155
Antw:OWServer hängt nach Update
« Antwort #6 am: 18 März 2018, 15:38:09 »
Hallo,

schau bitte mal, ob Dir diese Änderung hilft, die ich gerade gemacht habe:

https://forum.fhem.de/index.php/topic,85542.msg783045.html#msg783045

Viele Grüße
Boris
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline Tommi ratlos

  • Jr. Member
  • **
  • Beiträge: 65
Antw:OWServer hängt nach Update
« Antwort #7 am: 19 März 2018, 10:02:18 »
Hallo,

leider führt das zum Fehler

Can't locate lib/OWNet-3.1p5/OWNet.pm in @INC (you may need to install the lib::OWNet-3.1p5::OWNet module)
Welches Paket fehlt hier owfs? Macht das Sinn, da Fhem die Daten ja von einem "Externen" Owserver im Netz bezieht.


Gruß
Thomas
Pi 3 CUNX868 mit 433 Pigator.

Offline Dersch

  • Full Member
  • ***
  • Beiträge: 286
Antw:OWServer hängt nach Update
« Antwort #8 am: 19 März 2018, 10:40:05 »
Habe das auch grade:


Can't locate lib/OWNet-3.1p5/OWNet.pm in @INC (you may need to install the lib::OWNet-3.1p5::OWNet module) (@INC contains: . /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/x86_64-linux-gnu/perl5/5.24 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base ./FHEM ./FHEM/lib) at ./FHEM/10_OWServer.pm line 191, <$fh> line 1283.


Das letzte FHEM Update habe ich eben gemacht. Dort sollte also auch schon die Änderung von Dr. Boris Neubert mit drin sein.

owserver (3.1p5-1) unter Debian Stretch ist installiert.
« Letzte Änderung: 19 März 2018, 10:51:25 von Dersch »

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4155
Antw:OWServer hängt nach Update
« Antwort #9 am: 19 März 2018, 15:14:53 »
Hallo,

offensichtlich sind die Verzeichnisse unterhalb von lib nicht ins Repo gekommen. Ich bringe das heute Abend in Ordnung.

Wer es vorab ausprobieren will, legt unter FHEM/lib das Verzeichnis OWNet-3.1p5 an und schiebt die OWNet.pm aus lib dort hinein.

Viele Grüße
Boris
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline Dersch

  • Full Member
  • ***
  • Beiträge: 286
Antw:OWServer hängt nach Update
« Antwort #10 am: 19 März 2018, 15:37:00 »
Super! Läuft so.

Offline Tommi ratlos

  • Jr. Member
  • **
  • Beiträge: 65
Antw:OWServer hängt nach Update
« Antwort #11 am: 19 März 2018, 15:38:54 »
Hallo,

leider kein Erfolg, hänge jetzt wieder bei:
OWServer: Successfully connected to 192.168.115.2:4304.
Gruß
Thomas
Pi 3 CUNX868 mit 433 Pigator.

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4155
Antw:OWServer hängt nach Update
« Antwort #12 am: 19 März 2018, 16:20:40 »
leider kein Erfolg, hänge jetzt wieder bei:
OWServer: Successfully connected to 192.168.115.2:4304.

Schicke bitte mal alle Log-Zeilen vom OWServer-Start. Das sind die Zeilen, die mit OWServer beginnen, und die vor/nach der Fehlermeldung aus Deinem vorigen Beitrag kommen.

Außerdem kannst Du bitte mal probieren, lib/OWNet-2.7p32 anzulegen und die zugehörige OWNet.pm von hier (in den Tiefen des Archivs irgendwo unter net perl5 - habe das nicht mehr in Erinnerung):

https://sourceforge.net/projects/owfs/files/owfs/2.7p32/

dort hineinzukopieren. Ich entnehme einem Deiner vorigen Posts, dass Du 2.7p32 einsetzt. Nach dem Start sollte er diese Datei dann benutzen.

Viele Grüße
Boris
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline Tommi ratlos

  • Jr. Member
  • **
  • Beiträge: 65
Antw:OWServer hängt nach Update
« Antwort #13 am: 19 März 2018, 17:02:59 »
Hallo,

danke für die Mühe. Es gibt keine Fehlermeldungen, im Logfile ist die besagte Meldung, und dann Passiert nichts mehr.

Die Datei liegt unter /module/ownet/perl5/OWNet/lib/

Was mich stutzig macht  "OWNet version 3.1p5 loaded".

2018.03.19 15:19:23 3: OWServer: OWNet version 3.1p5 loaded.
2018.03.19 15:19:23 3: OWServer: Opening connection to OWServer 192.168.115.2:4304...
2018.03.19 15:19:23 3: OWServer: Successfully connected to 192.168.115.2:4304.


Gruß
Thomas
Pi 3 CUNX868 mit 433 Pigator.

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4155
Antw:OWServer hängt nach Update
« Antwort #14 am: 19 März 2018, 17:42:06 »
offensichtlich sind die Verzeichnisse unterhalb von lib nicht ins Repo gekommen. Ich bringe das heute Abend in Ordnung.

Erledigt. Die Verzeichnisse sollte morgen übers Update reinlaufen.
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline Tommi ratlos

  • Jr. Member
  • **
  • Beiträge: 65
Antw:OWServer hängt nach Update
« Antwort #15 am: 19 März 2018, 17:49:20 »
Hallo,

habe die Verzeichnisse lib/OWNet-2.7p32 und lib/OWNet-3.1p5 von Hand angelegt. Trotzdem wird die OWNet-3.1p5  verwendet.

Gruß
Thomas
Pi 3 CUNX868 mit 433 Pigator.

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4155
Antw:OWServer hängt nach Update
« Antwort #16 am: 19 März 2018, 17:49:58 »
Hallo Thomas,

Was mich stutzig macht  "OWNet version 3.1p5 loaded".

OWServer lädt zunächst OWNet 3.1p5, um sich mit dem Server zu verbinden und dessen Version abzufragen. Dann wird ggf. OWNet in der Version der Servers nachgeladen, wenn diese Version von OWNet installiert ist. Das Problem in Deiner Konfiguration ist, dass ein Zugriff mit OWNet 3.1p5 auf einen Server mit der Version 2.7p32 zum Hänger führt.

Vorschlag: Du installierst wie vorher beschrieben OWNet 2.7p32 passend zum Server. Dann änderst Du in 10_OWServer.pm die Version in Zeile 36 auf 2.7p32.

Dann bitte im Erfolgsfall oder Misserfolgsfall nochmal das Log posten.

Ich befürchte, ich muss das konfigurierbar machen :-(

Viele Grüße
Boris

Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline Tommi ratlos

  • Jr. Member
  • **
  • Beiträge: 65
Antw:OWServer hängt nach Update
« Antwort #17 am: 19 März 2018, 18:06:22 »
Hallo,

jetzt läuft es, ownet aus der restoreDir nach lib/OWNet-2.7p32 kopiert:

2018.03.19 18:02:06 3: OWServer: OWNet version 2.7p32 loaded.
2018.03.19 18:02:06 3: OWServer: Opening connection to OWServer 192.168.115.2:4304...
2018.03.19 18:02:06 3: OWServer: Successfully connected to 192.168.115.2:4304.
2018.03.19 18:02:08 3: OWServer: owserver version  found.


Gruß
Thomas
Pi 3 CUNX868 mit 433 Pigator.

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4155
Antw:OWServer hängt nach Update
« Antwort #18 am: 19 März 2018, 18:14:03 »
OK, Danke. Ich werde also eine Option anfügen, um die Serverversion vorgeben zu können. Der Benutzer muss dann aber dafür sorgen, dass die passende OWNet.pm vorhanden ist. Wie Du das getan hast.

Viele Grüße
Boris
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline Morgennebel

  • Sr. Member
  • ****
  • Beiträge: 973
  • Proud systemd-free zone
Antw:OWServer hängt nach Update
« Antwort #19 am: 19 März 2018, 18:58:29 »
Nach update und shutdown restart heute um 18:xx möchte mein FHEM nicht mehr.

Aus restoreDir/2018-03-19/FHEM die Datei 10_OWServer.pm wiederhergestellt. FHEM erzeugt nun 100% CPU Last und reagiert nimmer...

Die letzten Ausgaben im Logfile sind mehrere Minuten alt.

*SEUFZ*

Danke, -MN
Einziger Spender an FHEM e.V. mit Dauerauftrag seit >= 18 Monaten

FHEM: LattePanda x86 4/64GB
In-Use: STELLMOTOR, VALVES, PWM-PWMR, Xiaomi, Allergy, Proplanta, UWZ, MQTT, vThings, Homematic, Luftsensor.info, ESP8266, ESERA

Offline Morgennebel

  • Sr. Member
  • ****
  • Beiträge: 973
  • Proud systemd-free zone
Antw:OWServer hängt nach Update
« Antwort #20 am: 19 März 2018, 19:03:00 »
Tja.... Mit -d manuell gestartet ergibt sich:

2018.03.19 19:01:05 5: End notify loop for V_RadiatorenWohnzimmer
2018.03.19 19:01:05 4: configDB reading file: .//tempList.cfg
2018.03.19 19:01:05 3: RPi1Wire: Opening connection to OWServer 10.10.10.10:4303...
2018.03.19 19:01:05 3: RPi1Wire: Successfully connected to 10.10.10.10:4303.
2018.03.19 19:01:05 5: Starting notify loop for RPi1Wire, 1 event(s), first is CONNECTED
2018.03.19 19:01:05 4: dewpoint_notify: cmd_type=dewpoint devname=RPi1Wire dewname=dewpointToAllDeviceReadings, dev=RPi1Wire, dev_regex=.* temp_name=T hum_name=H
2018.03.19 19:01:05 5: dewpoint_notify: s='CONNECTED'
2018.03.19 19:01:05 5: dewpoint max_timediff=1
2018.03.19 19:01:05 5: RG_Battery: not on any display, ignoring notify
2018.03.19 19:01:05 5: End notify loop for RPi1Wire

Mein 1Wire hängt an einem zweitem PI mit IP 10.10.10.10.... Das scheint gar nicht zu gehen... Danach ist FHEM abgestürzt (100% CPU Last, keine weiteren Ausgaben im Logfile/Console).

Ciao, -MN
Einziger Spender an FHEM e.V. mit Dauerauftrag seit >= 18 Monaten

FHEM: LattePanda x86 4/64GB
In-Use: STELLMOTOR, VALVES, PWM-PWMR, Xiaomi, Allergy, Proplanta, UWZ, MQTT, vThings, Homematic, Luftsensor.info, ESP8266, ESERA

Offline Morgennebel

  • Sr. Member
  • ****
  • Beiträge: 973
  • Proud systemd-free zone
Antw:OWServer hängt nach Update
« Antwort #21 am: 19 März 2018, 19:14:15 »
Derzeit laufen diese 1-Wire Module:

==> 11_OWDevice.pm <==
# $Id: 11_OWDevice.pm 14523 2017-06-16 05:15:56Z neubert $

==> 11_OWX_CCC.pm <==
# $Id: 11_OWX_CCC.pm 15392 2017-11-05 06:46:46Z phenning $

==> 11_OWX_FRM.pm <==
# $Id: 11_OWX_FRM.pm 15978 2018-01-24 07:27:33Z phenning $

==> 11_OWX_SER.pm <==
# $Id: 11_OWX_SER.pm 15392 2017-11-05 06:46:46Z phenning $

==> 11_OWX_TCP.pm <==
# $Id: 11_OWX_TCP.pm 15392 2017-11-05 06:46:46Z phenning $

und

# $Id: 10_OWServer.pm 15589 2017-12-11 11:58:29Z neubert $

jedoch gleiches Verhalten... FHEM bleibt stehen...

Jedwede Hilfe gern erbeten...

Danke, -MN
Einziger Spender an FHEM e.V. mit Dauerauftrag seit >= 18 Monaten

FHEM: LattePanda x86 4/64GB
In-Use: STELLMOTOR, VALVES, PWM-PWMR, Xiaomi, Allergy, Proplanta, UWZ, MQTT, vThings, Homematic, Luftsensor.info, ESP8266, ESERA

Offline Tommi ratlos

  • Jr. Member
  • **
  • Beiträge: 65
Antw:OWServer hängt nach Update
« Antwort #22 am: 19 März 2018, 19:34:08 »
Hallo,

hast du die /lib/OWnet.pm auch wieder hergestellt?

Gruß
Thomas
Pi 3 CUNX868 mit 433 Pigator.

Offline Morgennebel

  • Sr. Member
  • ****
  • Beiträge: 973
  • Proud systemd-free zone
Antw:OWServer hängt nach Update
« Antwort #23 am: 19 März 2018, 20:18:43 »
Hi Thomas,


nein, die hatte ich übersehen...

Jetzt habe ich zurückgespielt:

root@fhem:/opt/fhem/FHEM# cp -v ../restoreDir/2018-03-19.ORIG/FHEM/11_OWX_* .
‘../restoreDir/2018-03-19.ORIG/FHEM/11_OWX_CCC.pm’ -> ‘./11_OWX_CCC.pm’
‘../restoreDir/2018-03-19.ORIG/FHEM/11_OWX_FRM.pm’ -> ‘./11_OWX_FRM.pm’
‘../restoreDir/2018-03-19.ORIG/FHEM/11_OWX_SER.pm’ -> ‘./11_OWX_SER.pm’
‘../restoreDir/2018-03-19.ORIG/FHEM/11_OWX_TCP.pm’ -> ‘./11_OWX_TCP.pm’
root@fhem:/opt/fhem/FHEM# cp -v ../restoreDir/2018-03-19.ORIG/FHEM/10_OWServer.pm .
‘../restoreDir/2018-03-19.ORIG/FHEM/10_OWServer.pm’ -> ‘./10_OWServer.pm’
root@fhem:/opt/fhem/FHEM# cp -v ../restoreDir/2018-03-19.ORIG/FHEM/lib/OWNet.pm lib/
‘../restoreDir/2018-03-19.ORIG/FHEM/lib/OWNet.pm’ -> ‘lib/OWNet.pm’
root@fhem:/opt/fhem/FHEM# sync

und alles läuft wieder. Puuuhh...

Mein Setup ist eindeutig zu kompliziert. Zu viel Software-Schichten und Treiber-Versionen. Hab mir jetzt einen ESERA Controller bestellt...

Danke für die Hilfe,

Ciao, -MN
Einziger Spender an FHEM e.V. mit Dauerauftrag seit >= 18 Monaten

FHEM: LattePanda x86 4/64GB
In-Use: STELLMOTOR, VALVES, PWM-PWMR, Xiaomi, Allergy, Proplanta, UWZ, MQTT, vThings, Homematic, Luftsensor.info, ESP8266, ESERA

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4155
Antw:OWServer hängt nach Update
« Antwort #24 am: 19 März 2018, 21:23:18 »
Hallo MN,

morgen kommt es wieder. Bitte sende das Log sowie eine Angabe zur owserver-Version, egal, ob es geht oder nicht.

Bitte obige Hinweise an Tommy Ratlos befolgen.

Viele Grüße
Boris
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline Omega

  • Full Member
  • ***
  • Beiträge: 481
Antw:OWServer hängt nach Update
« Antwort #25 am: 20 März 2018, 18:01:45 »
Hallo,

ich habe vorhin ein Update durchgeführt (ohne den thread vorher gesehen zu haben). Folgende Fehlermeldung:
Can't locate lib/OWNet-3.1p5/OWNet.pm in @INC (you may need to install the lib::OWNet-3.1p5::OWNet module) (@INC contains: . /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.20.2 /usr/local/share/perl/5.20.2 /usr/lib/x86_64-linux-gnu/perl5/5.20 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.20 /usr/share/perl/5.20 /usr/local/lib/site_perl ./FHEM) at ./FHEM/10_OWServer.pm line 191, <$fh> line 2920.
FHEM ist bei dieser Fehlermeldung im Startvorgang stehen geblieben.

Ich habe erst einmal einen kompletten Restore durchgeführt.

LG
Holger
NUC6i3SYH (FHEM 5.8 in VM)
Homematic: HMLAN, HMUSB, HM-Sec-SD, HM-CC-RT-DN, HM-TC-IT, ... + diverse weitere
LaCrosseGateway, ESPEasy
ZWave
Zustimmung Zustimmung x 1 Liste anzeigen

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4155
Antw:OWServer hängt nach Update
« Antwort #26 am: 20 März 2018, 20:06:55 »
Grunz. Habe gerade festgestellt, dass neue Verzeichnisse unter lib nicht automatisch per Update verteilt werden. Ich sehe zu, dass lib/OWNet-*/* per Update verteilt wird.
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline Sunny

  • Full Member
  • ***
  • Beiträge: 286
Antw:OWServer hängt nach Update
« Antwort #27 am: 21 März 2018, 06:30:09 »
Moin Boris,

ist das
Grunz... Ich sehe zu, dass lib/OWNet-*/* per Update verteilt wird.

auch der Grund für
<$fh> line 389. Can't locate lib/OWNet-3.1p5/OWNet.pm in @INC (you may need to install the lib::OWNet-3.1p5::OWNet module) (@INC contains: . /etc/perl /usr/local/lib/arm-linux-gnueabihf/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/arm-linux-gnueabihf/perl5/5.24 /usr/share/perl5 /usr/lib/arm-linux-gnueabihf/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/arm-linux-gnueabihf/perl-base /opt/fhem/FHEM) at /opt/fhem/FHEM/10_OWServer.pm line 191,?

Betreibe fhem auf Rpi mit IP:×.×.×.54 und owfs auf RPi (read only, ohne fhem) mit IP:x.x.x.80.
Beide auf aktuellem stretch.

Besten Dank
Sunny

PS: Von unterwegs gesendet, falls Du mehr Details benötigst kann ich die gerne nachliefern.
FHEM 5.8 (Wheezy:RPi2);(Jessie:Bpi,RpiB+'s,CeleronM,Odroid C1+)
AddonBoard|1-Wire USB|miniCUL|miniCUL868WLAN|HM-USB2
HM-(CC-RT-DN,SEC-SC-2,SEC-SCo);IT(-1500,LR-3500);DS18B20|DS2406;FB7390|FB7580|DECT200|Powerline546E|520E
Anfänger: Linux,FHEM+Pearl

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4155
Antw:OWServer hängt nach Update
« Antwort #28 am: 21 März 2018, 06:53:27 »
Ja.
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline Spartacus

  • Hero Member
  • *****
  • Beiträge: 1117
Antw:OWServer hängt nach Update
« Antwort #29 am: 21 März 2018, 20:32:45 »
Moin,
habe gerade dummerweise ein fhem Update gemacht und bei mir hängt der OWSERVER auch. Fhem startet gar nicht mehr!
Wie fixe ich das jetzt am Schnellsten? Oder gibt es noch keine Lösung per Update?

Can't locate lib/OWNet-3.1p5/OWNet.pm in @INC (@INC contains: . /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl ./FHEM) at ./FHEM/10_OWServer.pm line 191, <> line 10.Danke Euch!
Christian

« Letzte Änderung: 21 März 2018, 20:34:40 von Spartacus »
Fhem-System: 1 x raspberry PI Typ B, 1 x enOcean PI Typ B | Sonos: 5 x Play1, 2 x Play 3, ConnectAmp, SUB | Enocean: PTM210, FMS61NP, FAM14, 2 x FSR14-4x, FTS14-EM | LaCrosse: 2 x TX29D über Jeelink V3 | 1-Wire: 2 x DS18B20 über DS9490R | AVM: FB7390, Repeater 300E, 2 x MT-F

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4155
Antw:OWServer hängt nach Update
« Antwort #30 am: 21 März 2018, 20:36:41 »
Habe gerade ein Update eingecheckt. Warte noch auf Bestätigung, dass es morgen früh verteilt wird.

Soforthilfe:

Von hier 10_OWServer.pm und lib/OWNet-*.pm laden, in die FHEM-Konfiguration kopieren, und FHEM neu starten.

Bitte um Feedback, ob es gemacht wurde und wie es funktioniert. Details in einigen Minuten hier: https://forum.fhem.de/index.php/topic,85542.0.html

Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline Spartacus

  • Hero Member
  • *****
  • Beiträge: 1117
Antw:OWServer hängt nach Update
« Antwort #31 am: 21 März 2018, 21:03:46 »
Hi,
naja, der owserver sagt im Log zwar, dass er gestartet ist, un der fhem Prozess läuft auch wieder, aber ich komme nicht mehr auf das web Interface. Der Browser zeigt an "warten auf <hostnbame>" und versucht die Seite zu laden. Komisch ist auch, dass der letzte Eintrag im Log dieser ist:

2018.03.21 21:01:39 3: [UtilsHourCounter] Init Done with Version 1.0.1.0 - 10.12.2014 (john)
2018.03.21 21:01:39 1: Including fhem.cfg
2018.03.21 21:01:40 3: telnetPort: port 7072 opened
2018.03.21 21:01:42 3: WEB: port 8083 opened
2018.03.21 21:01:42 3: WEBphone: port 8084 opened
2018.03.21 21:01:42 3: WEBtablet: port 8085 opened
2018.03.21 21:01:43 2: eventTypes: loaded 168 events from ./log/eventTypes.txt
2018.03.21 21:01:43 1: Including Config/98-1-Wire.cfg
2018.03.21 21:01:43 3: 1W.OWServer: OWNet version 3.1p5 loaded.
2018.03.21 21:01:43 3: 1W.OWServer: Opening connection to OWServer localhost:4304...
2018.03.21 21:01:43 3: 1W.OWServer: Successfully connected to localhost:4304.

Irgendetwas ist kaputt gegangen.
Christian
Fhem-System: 1 x raspberry PI Typ B, 1 x enOcean PI Typ B | Sonos: 5 x Play1, 2 x Play 3, ConnectAmp, SUB | Enocean: PTM210, FMS61NP, FAM14, 2 x FSR14-4x, FTS14-EM | LaCrosse: 2 x TX29D über Jeelink V3 | 1-Wire: 2 x DS18B20 über DS9490R | AVM: FB7390, Repeater 300E, 2 x MT-F

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4155
Antw:OWServer hängt nach Update
« Antwort #32 am: 21 März 2018, 21:09:34 »
Hallo Christian,

hast Du den neuesten Beitrag hier gelesen? https://forum.fhem.de/index.php/topic,85542.0.html

Wenn Du Dich mit einem owserver in der Version 2.8p17 verbindest, soltest Du die Definition auf

define 1W.OWServer localhost:4304 2.8p17
erweitern, um einen Vorschlag für die richtige Version vom OWNet-Modul zu liefern.

Grüße
Boris
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline Spartacus

  • Hero Member
  • *****
  • Beiträge: 1117
Antw:OWServer hängt nach Update
« Antwort #33 am: 21 März 2018, 21:23:16 »
Hallo Boris,
puuh! Das war es! Ganz lieben Dank für diese superschnelle Unterstützung. Funzt jetzt wieder alles.

Also zusammengefasst:

- 10_OWServer.pm nach fhem laden
- lib/OWNet-*.pm nach FEHM/lib laden
- OWServer in der Konfig die gewünschte Version mitgeben (hier 2.8p17)

Danke Dir,
Christian
Fhem-System: 1 x raspberry PI Typ B, 1 x enOcean PI Typ B | Sonos: 5 x Play1, 2 x Play 3, ConnectAmp, SUB | Enocean: PTM210, FMS61NP, FAM14, 2 x FSR14-4x, FTS14-EM | LaCrosse: 2 x TX29D über Jeelink V3 | 1-Wire: 2 x DS18B20 über DS9490R | AVM: FB7390, Repeater 300E, 2 x MT-F

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4155
Antw:OWServer hängt nach Update
« Antwort #34 am: 21 März 2018, 21:37:51 »
Danke für die Rückmeldung. Freue mich, dass es funktioniert.

Viele Grüße
Boris
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline synaps-o-dan

  • Jr. Member
  • **
  • Beiträge: 71
Antw:OWServer hängt nach Update
« Antwort #35 am: 22 März 2018, 21:03:26 »
Hallo,
habe heute das Update von 10_OWServer.pm durchgeführt. Die 1wire devices hängen an einem separaten Raspberry Pi Zero. In der aktuellen Version (mit Fallunterscheidung der OWServer-Version) funzt alles. Die Version (3.1p5) wird in den beiden Internals des OWServer device korrekt erkannt & gesetzt. Beide Raspberrys laufen unter Stretch.
Grüße und Danke,
Daniel
fhem auf Raspberry Pi 3
5 x Set aus jew. 1x FHT80B + 1xFHT8V + 1x FHT80TF-2
HM: 1 x HM-ES-PMSw1-Pl, 2 x HM-LC-Sw1-FM, 2 x HM-LC-Sw1PBU-FM, 3 x HM-Sec-SD, 2 x HM-PB-2-WM55, 2 x HM-Sec-MDIR-2
3 x EM-1000 EM
Onewire: insgesamt 11 Onewire-Sensoren an einem LinkUSB Adapter

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4155
Antw:OWServer hängt nach Update
« Antwort #36 am: 22 März 2018, 21:22:25 »
In der aktuellen Version (mit Fallunterscheidung der OWServer-Version) funzt alles. Die Version (3.1p5) wird in den beiden Internals des OWServer device korrekt erkannt & gesetzt. Beide Raspberrys laufen unter Stretch.

Danke. Das freut mich.
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!