Autor Thema: Verbindung zwischen IP-Interface <=> KNX fhem Raspberry  (Gelesen 954 mal)

Offline knx_user

  • Newbie
  • Beiträge: 2
Hallo zusammen,

ich kämpfe seit einigen Wochen mit der Verbindung zwischen KNX und fhem. Bekomme das System nicht in den Status: "Active: active (running)"
Habe mich bei der Konfiguration an die Anleitung "https://wiki.fhem.de/wiki/Einrichten_knxd_mit_MDT_SCN-IP000.02" gehalten. Leider ohne Erfolg. Auch die Suche hier im Forum und im übrigen Netz brachte keine neuen Erkenntnisse.



Zur Info:
MDT-Interface: SCN-IP000.02          (KEIN ROUTER)

Raspberry 3 Model B:
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=raspbian
ID_LIKE=debian

Fehlermeldung:
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Sun 2018-03-11 18:51:10 CET; 4s ago
  Process: 725 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=2)
 Main PID: 725 (code=exited, status=2)

Mar 11 18:51:10 RASP_1 systemd[1]: knxd.service: Unit entered failed state.
Mar 11 18:51:10 RASP_1 systemd[1]: knxd.service: Failed with result 'exit-code'.

OPTS:
KNXD_OPTS="-e 1.0.240 -b ipt:192.168.2.45"
ipt = IP-Adresse des IP-Interface;
1.0.240 = Freie Adresse im KNX-Netzwerk;

Hoffe mit diesen Infos kann man was anfangen und mir vielleicht etwas auf die Sprünge helfen.



Offline Andi291

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1103
Antw:Verbindung zwischen IP-Interface <=> KNX fhem Raspberry
« Antwort #1 am: 18 März 2018, 14:21:51 »
Servus!

In einer der letzten Versionen wurde -E zum Pflichtparameter. Hat mich auch schon a bisserl Nevern gekostet.

Probier mal:

KNXD_OPTS="-E 1.0.240:5 -b ipt:192.168.2.45"
oder
KNXD_OPTS="-e 1.0.240 -E 1.0.241:5 -b ipt:192.168.2.45"

Grüße, Andi

Offline Andi291

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1103
Antw:Verbindung zwischen IP-Interface <=> KNX fhem Raspberry
« Antwort #2 am: 18 März 2018, 14:28:48 »
P.S.:
EInfach mal herantasten ohne den Service, also mit

sudo knxd -E 1.0.240:5 -b ipt:192.168.2.45

Offline mark_wff

  • Newbie
  • Beiträge: 2
Antw:Verbindung zwischen IP-Interface <=> KNX fhem Raspberry
« Antwort #3 am: 18 März 2018, 16:14:10 »
Hi,

ich habe genau das gleiche Problem.
Wenn ich versuche mich ranzutasten bekomme ich folgende Fehlermeldung:

sudo knxd -E 1.0.240:5 -b ipt:192.168.2.45
E00000055: [ 1:main] There is no KNX addr= in section 'main'.
F00000000: [ 1:main] Error setting up the KNX router.

Offline Andi291

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1103
Antw:Verbindung zwischen IP-Interface <=> KNX fhem Raspberry
« Antwort #4 am: 18 März 2018, 16:33:36 »
Nu ja, dann bitte:

sudo knxd -e 1.0.240 -E 1.0.241:4 -b ipt:192.168.2.45

Offline mark_wff

  • Newbie
  • Beiträge: 2
Antw:Verbindung zwischen IP-Interface <=> KNX fhem Raspberry
« Antwort #5 am: 18 März 2018, 16:43:36 »
Ersteinmal vielen Dank für die super schnelle Antwort.

Ich mach grade meine ersten Versuche mit knxd. Daher entschuldigt bitte
meine komplette Ahnungslosigkeit :D

Jetzt bekomme ich diese Fehlermeldung.

E00000055: [ 1:main] Only one connection in section 'main'.
F00000000: [ 1:main] Error setting up the KNX router.

Offline knx_user

  • Newbie
  • Beiträge: 2
Antw:Verbindung zwischen IP-Interface <=> KNX fhem Raspberry
« Antwort #6 am: 19 März 2018, 16:05:52 »
Hallo zusammen,

vielen Dank für die schnelle Antwort. Habe gestern noch bisschen getestet.

Ich dachte immer die KNX-Gruppenadresse mit Doppelpunkt (z.B. -E 1.0.240:5) ist nur für IP-ROUTER zulässig und führt bei einem IP-Interface wie ich es verwende zu einem Problem.
Was ich noch festgestellt habe, es gibt ein kleines Timing-Problem. (Habe ich in einem anderen Beitrag überlesen). Ich bekomme die gleichen Fehlermeldungen wie mark_wff. ABER: Wenn ich knxd.service & knxd.socket stoppe und manuell wieder nacheinander starte (mit einer BOSCH-Gedenkminute dazwischen) bekomme ich den Status "running", grün.
Ich schaue jetzt noch wie ich eine routine erstellen kann mit welcher ich nach einem Neustart das manuelle stoppen und anschließendem starten automatisieren kann.


Offline Andi291

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1103
Antw:Verbindung zwischen IP-Interface <=> KNX fhem Raspberry
« Antwort #7 am: 19 März 2018, 21:10:11 »
Na, das ist doch schonmal was...

Wenn's denn so geht:

sudo systemctl stop knxd.socket
sudo systemctl stop knxd.socket
sudo knxd <siehe oben>

Dann mittels KNXD_OPTS und sudo systemctl weiter machen.

Ein Tip - ggf. ist das Netzwerk noch nicht bereit, oder aber ein Socket blockiert sich.
Dazu einfach mal googlen...

Grüße, Andi

Offline tomconnect

  • New Member
  • *
  • Beiträge: 9
Antw:Verbindung zwischen IP-Interface <=> KNX fhem Raspberry
« Antwort #8 am: 10 November 2018, 23:35:16 »
Hallo,
mir geht es leider genauso.
Ich habe einen Raspberry mit ROT und knxd laufen und das klappt. (IP Gateway zu KNX)
Ich habe einen weiten Raspberry 3 mit fhem und möchte knxd zum laden bringen.
Das klappt nicht
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Sat 2018-11-10 23:27:04 CET; 6
  Process: 14307 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=2)
 Main PID: 14307 (code=exited, status=2)

Nov 10 23:27:04 smarthome systemd[1]: knxd.service: Unit entered failed state.
Nov 10 23:27:04 smarthome systemd[1]: knxd.service: Failed with result 'exit-code'.
Beziehungsweise beim herantasten mit

sudo knxd -e 0.0.2 -E 0.0.2:8 -b ipt:IP

E00000055: [ 1:main] There is no KNX addr= in section 'main'.
F00000000: [ 1:main] Error setting up the KNX router.


als Fehlermeldungen.
IP Adressen stimmen.

Was ist falsch, wie funktioniert es richtig.
Vielen Dank für Eure Hilfe.
Grüße
Tom

Offline tomconnect

  • New Member
  • *
  • Beiträge: 9
Antw:Verbindung zwischen IP-Interface <=> KNX fhem Raspberry
« Antwort #9 am: 11 November 2018, 19:33:36 »
Hat sich bei mir erledigt!
KNXD nochmal installiert und es lief.
Viele Grüße
Tom

 

decade-submarginal