Autor Thema: HDMI/DVI Problem  (Gelesen 1110 mal)

Offline dt2510

  • Full Member
  • ***
  • Beiträge: 431
HDMI/DVI Problem
« am: 29 März 2018, 16:48:51 »
Ich habe noch einen alten Flatscreen, der leider nur einen DVI Eingang und Cinch für das Tonsignal hat. Da das Gerät damals noch rund 4000€ gekostet hat, möchte ich es natürlich so lange wie möglich weiter verwenden.
Bisher hatte ich daran einen Raspberry mit HDMI auf DVI Kabel und analogem Ton angeschlossen - ohne Probleme. Um aber auch ein FireTV Stick zu verwenden habe ich mir einen HDMI Umschalter mit analogem Audio Ausgang besorgt (https://www.amazon.de/gp/product/B078H1VDY9/ref=oh_aui_detailpage_o04_s00?ie=UTF8&psc=1). Von dort geht es mit den gleichen Kabeln, die vorher am Raspberry waren, zum Fernseher. Um weiterhin Ton zu haben, muss ich auf dem Raspberry HDMI Audio aktivieren, da die Box das ja aktiv nach analog wandelt. Dummerweise verursacht jede Tonausgabe Bildstörungen. Zuerst hatte ich die Box in Verdacht, aber auch direkt am Raspberry habe ich das gleiche Problem. Deaktiviere ich HDMI Audio, ist alles ok.
Anscheinend sind die Pins, über die bei HDMI das Audio Signal läuft in irgendeiner Form auf dem DVI Stecker aufgelegt. Gibt es einen Adapter (passiv oder aktiv), der das Tonsignal vom HDMI Signal entfernt ?

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 10674
    • Otto's Technik Blog
Antw:HDMI/DVI Problem
« Antwort #1 am: 29 März 2018, 17:24:16 »
Hi,

aber eigentlich ist genau dies der Haupt Unterschied vom HDMI zu DVI -> es fehlt Ton.

Was für eine Version Pi ist das?

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,ET9200,Arduino nano,ESP8266

Offline dt2510

  • Full Member
  • ***
  • Beiträge: 431
Antw:HDMI/DVI Problem
« Antwort #2 am: 29 März 2018, 18:23:39 »
Dass DVI keinen Ton transportiert ist mir auch klar, deshalb ja analog. Sobald auf dem HDMI Ausgang aber Ton anliegt, wird das Bild gestört - egal ob Pi (hier ein 2er) oder anderer HDMI Zuspieler.

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 10674
    • Otto's Technik Blog
Antw:HDMI/DVI Problem
« Antwort #3 am: 29 März 2018, 18:29:29 »
Moment, jetzt sagst Du es liegt nicht am Pi?
Ich verstehe das Konstrukt jetzt gerade nicht. Ich dachte der Weg
Pi HDMI mit Ton -> Box -> Fernseher -> Bild gestört?
Irgendwas HDMI mit Ton -> Box -> Fernseher -> Bild ok?

Jetzt sagst Du es ist egal, dann ist es doch die Box?
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,ET9200,Arduino nano,ESP8266

Offline dt2510

  • Full Member
  • ***
  • Beiträge: 431
Antw:HDMI/DVI Problem
« Antwort #4 am: 29 März 2018, 18:32:20 »
Du hast oben nicht richtig gelesen ... aber egal. Nochmal:

- HDMI ohne Ton (Pi - kann ich sonst nirgends abschalten) egal ob Box oder direkt: ok
- HDMI mit Ton (am Pi aktiviert oder anderer Zuspieler) egal ob Box oder direkt: Bildfehler

Also stört der Ton über HDMI irgendwo das DVI Bildsignal

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 10674
    • Otto's Technik Blog
Antw:HDMI/DVI Problem
« Antwort #5 am: 29 März 2018, 18:52:10 »
Ok :) hatte ich wirklich auf den Pi bezogen.

Ich kenne DVI Ausgänge die liefern digitale und analoge Signale (ich dachte eigentlich nur Bild und nicht Ton) aber das sind getrennte Pins im Stecker.

Eigentlich ist doch die Ton Übertragung nicht separat, sondern im digitalen Datenstrom. Mit einem Adapter wird es nicht zu lösen sein.
HDMI sind doch meines Wissens einfach ein paar parallele Datenleitungen. Und DVI verwendet nicht alle, 3 von 4 möglichen bei HDMI? (dadurch geringere Datenrate in Summe)

Es gibt aber auch Systeme die haben zwar den DVI Stecker machen aber darüber Sonderlocken (Bei Grafikkarten weiß ich das). Offenbar macht Dein Flatscreen das. Hast Du da Unterlagen?

Tut mir leid, da habe ich keine zündende Idee.

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,ET9200,Arduino nano,ESP8266

Offline dt2510

  • Full Member
  • ***
  • Beiträge: 431
Antw:HDMI/DVI Problem
« Antwort #6 am: 29 März 2018, 18:54:19 »
Ich hab' mir auch mal die Pin Layouts angesehen, Audio ist da wohl wirklich im Datenstrom integriert und stört - bei einem passiven Kabel - das Bildsignal in meinem Fernseher.
Vielleicht sollte ich mal einen aktiven HDMI > DVI Konverter testen - sofern ich einen finde ...

Alternativ HDMI > VGA > HDMI/DVI ... dadurch ist das digitale Tonsignal definitiv eliminiert
« Letzte Änderung: 29 März 2018, 19:06:55 von dt2510 »

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 10674
    • Otto's Technik Blog
Antw:HDMI/DVI Problem
« Antwort #7 am: 29 März 2018, 19:21:52 »
och nöö  :o

Du hast jetzt einen HDMI DVI Adapter und HDMI Kabel? Oder ein Adapter Kabel?
Aktive HDMI DVI Konverter kenne ich nicht, weil eigentlich sind nur drei Datenleitungen (Adernpaare) und ein (flach gesagt) serieller Bus durchverbunden.
Du bräuchtest dann ja etwas was den Ton separiert und "löscht", das tut deine Box offenbar nicht.

Ich sehe das Problem eher im "speziellen" DVI Eingang Deines Flatscreen. Vielleicht wirst Du irgendwie damit bei der Suche fündig. Du sagst ja unterm Strich bei HDMI Ton am DVI Eingang gibt es Bildstörung. Die Zuspieler dürfen also keinen Ton "over HDMI" liefern. Das muss doch schon einer bemerkt haben.

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,ET9200,Arduino nano,ESP8266

Offline kroman

  • Jr. Member
  • **
  • Beiträge: 92
Antw:HDMI/DVI Problem
« Antwort #8 am: 29 März 2018, 20:15:59 »
Hab schon 2 Beträge gefunden, die auf diesen Adapter schwören:

https://www.amazon.com/dp/B00FCYKO8W?tag=tomsguide_forum_vgl-20

Nämlich:

http://www.tomsguide.com/answers/id-3499975/dvi-hdmi-firestick-sound.html
https://www.quora.com/How-do-I-connect-an-Amazon-Firestick-to-a-DVI-television

Wäre interessant zu erfahren, ob er bei dir auch funktioniert.
Kosten würd er ja nicht viel.

Ich denke jedenfalls, dass es an deinem Adpater liegt.
Kann wohl aber auch an deinem Fernseher liegen, DVI ist nicht gleich DVI meine ich gelesen zu haben.

Offline dt2510

  • Full Member
  • ***
  • Beiträge: 431
Antw:HDMI/DVI Problem
« Antwort #9 am: 29 März 2018, 23:50:21 »
Der Flatscreen ist ein Philips 37PF9986 aus dem Jahr 2005. Zu der Zeit gab es nicht mal das HD Ready oder FullHD Logo. Wer weiss was an diesem Anschluss DVI "Standard" ist ... von der Bauform ist er DVI-D.
Ich verwende ein handelsübliches HDMI auf DVI Kabel - lassen wir die Umschaltbox mal aussen vor. Sobald auf dem HDMI Signal Ton liegt kommt es zu Bildstörungen. Man müsste also tatsächlich den Ton eliminieren. Ich befürchte aber, dass dies wirklich im Datenstrom passieren muss. Ein Adaperkabel oder eine Adapterbox wird nicht reichen.
Der Weg HDMI auf VGA und dann wieder auf DVI oder HDMI (also Digital > Analog > Digital) ist vielleicht nicht optimal für das Bild, würde den Ton aber definitiv entfernen.

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 10674
    • Otto's Technik Blog
Antw:HDMI/DVI Problem
« Antwort #10 am: 31 März 2018, 16:28:17 »
Hi,

ich habe nochmal in deiner Bedienungsanleitung gelesen, Du hast einen DVI-I Eingang.
Ich habe auch noch diese ganz ansprechende Erklärung dazu gefunden -> https://www.e-und-p.de/download/164.pdf

Ich nehme an, Dein Fernseher geht wirklich davon aus, dass über einen DVI Single Link nur Bild kommt. Er kann mit dem enthaltenen Ton nichts anfangen, er stört ihn sogar. Du hast es ja praktisch nachgewiesen.

Es bleibt Dir nur die Wahl den Ton völlig separat zu verarbeiten. Das Problem ist ja sogar weniger der raspberry sondern Dein Fire TV Stick.

Vielleicht geht wirklich die Box von kroman.

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,ET9200,Arduino nano,ESP8266

Offline joschi2009

  • Full Member
  • ***
  • Beiträge: 331
Antw:HDMI/DVI Problem
« Antwort #11 am: 31 März 2018, 16:57:59 »
Hallo,

ich habe jetzt mal auf die Schnelle nach gebrauchten Angeboten für den Fernseher gegoogelt. Der 'Marktpreis' liegt wohl so um die 100 €.
So bitter wie das klingt, ich würde da keine großartigen Verrenkungen mehr machen und lieber das Geld für irgendwelche Adapter in einen neuen Fernseher investieren.

VG

joschi2009

Offline kroman

  • Jr. Member
  • **
  • Beiträge: 92
Antw:HDMI/DVI Problem
« Antwort #12 am: 01 April 2018, 00:43:50 »
Zitat
Vielleicht geht wirklich die Box von kroman.

Ich bilde mir ein, das waren am Donnerstag noch 5$ und das wäre auf jeden Fall einen Versuch wert gewesen.
Jetzt kostet das Teil wohl 55$, was sich mit dem Preis auf ebay deckt.
Komisch...

Jetzt schaut die Sache natürlich anders aus.

Gruß kroman

Offline dt2510

  • Full Member
  • ***
  • Beiträge: 431
Antw:HDMI/DVI Problem
« Antwort #13 am: 03 April 2018, 09:28:43 »
Hallo,

ich habe jetzt mal auf die Schnelle nach gebrauchten Angeboten für den Fernseher gegoogelt. Der 'Marktpreis' liegt wohl so um die 100 €.
So bitter wie das klingt, ich würde da keine großartigen Verrenkungen mehr machen und lieber das Geld für irgendwelche Adapter in einen neuen Fernseher investieren.

VG

joschi2009

Klar, das Teil ist 13 Jahre alt und praktisch nichts mehr wert (von der Auflösung von 1280x720 mit 2cm schwarzem Rand drumherum mal abgesehen ;) ) ... allerdings hab' ich damals 4000€ bezahlt und will das Teil so lange es funktioniert weiter nutzen...

 

decade-submarginal